Dln Namespace

Dln Namespace dln.net.dll
The Dln namespace contains types that allow usage of DLN-series adapters.
Classes
 | Class | Description
Public class | Connection |
Public class | Device | Device class describes generic fucntionality for DLN devices.
Public class | DeviceAddedEventArgs | The DeviceAddedEventArgs class contains event data for DeviceAddedEv event.
Public class | Library | Library class handles the main operations such as connection/disconnection to/from Dln Server, library version, opening handle to device and events handling.
Public class | ResultExtension |
Enumerations
 | Enumeration | Description
Public enumeration | Device Filter |
Public enumeration | Handle | Device handle
Public enumeration | HardwareType | HardwareType enumeration describes all possible DLN device types.
Public enumeration | Restriction | Restriction enumeration describes all possible restriction types.
Public enumeration | Result |


Connection Class

Connection Class dln.net.dll

[Missing <summary> documentation for "T:Dln.Connection"]

Inheritance Hierarchy
System Object
Dln Connection

Namespace: Dln
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public class Connection
public class Connection
Public Class Connection
Public Class Connection
public ref class Connection
public ref class Connection
The Connection type exposes the following members.
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Public method | IsConnected |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Connected |
 | DefaultPort |
Public property | Guid |
Public property | Host |
Public property | Port |
Top
Events
 | Name | Description
Public event | ConnectionLost |
Top
See Also
Reference
Dln Namespace


Connection Methods

Connection Methods dln.net.dll

The Connection type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Public method | IsConnected |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Connection Class
Dln Namespace


Connection.IsConnected Method

Connection IsConnected Method dln.net.dll

[Missing <summary> documentation for "M:Dln.Connection.IsConnected"]

Namespace: Dln
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public bool IsConnected()
public bool IsConnected()
Public Function IsConnected As Boolean
Public Function IsConnected As Boolean
public:
bool IsConnected()
public:
bool IsConnected()
Return Value
Type: Boolean
[Missing <returns> documentation for "M:Dln.Connection.IsConnected"]
See Also
Reference
Connection Class
Dln Namespace


Connection Properties

Connection Properties dln.net.dll

The Connection type exposes the following members.

Properties
 | Name | Description
Public property | Connected |
 | DefaultPort |
Public property | Guid |
Public property | Host |
Public property | Port |
Top
See Also

Reference

Connection Class
Dln Namespace


Connection.Connected Property

Connection Connected Property dln.net.dll

[Missing <summary> documentation for "P:Dln.Connection.Connected"]

Namespace: Dln
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public bool Connected { get; }
public bool Connected { get; }
Public ReadOnly Property Connected As Boolean
    Get
Public ReadOnly Property Connected As Boolean
    Get
public:
property bool Connected {
    bool get ();
}
public:
property bool Connected {
    bool get ();
}
Property Value
Type: Boolean
See Also
Reference
Connection Class
Dln Namespace


Connection.DefaultPort Property

Connection DefaultPort Property dln.net.dll

[Missing <summary> documentation for "P:Dln.Connection.DefaultPort"]

Namespace: Dln
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public static ushort DefaultPort { get; }
public static ushort DefaultPort { get; }
Public Shared ReadOnly Property DefaultPort As UShort
    Get
Public Shared ReadOnly Property DefaultPort As UShort
    Get
public:
static property unsigned short DefaultPort {
    unsigned short get ();
}
public:
static property unsigned short DefaultPort {
    unsigned short get ();
}
Property Value
Type: UInt16
See Also
Reference
Connection Class
Dln Namespace


Connection.Guid Property

Connection Guid Property dln.net.dll

[Missing <summary> documentation for "P:Dln.Connection.Guid"]

Namespace: Dln
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public Guid Guid { get; }
public Guid Guid { get; }
Public ReadOnly Property Guid As Guid
    Get
Public ReadOnly Property Guid As Guid
    Get
public:
property Guid Guid {
    Guid get ();
}
public:
property Guid Guid {
    Guid get ();
}
Property Value
Type: Guid
See Also
Reference
Connection Class
Dln Namespace


Connection.Host Property

Connection Host Property dln.net.dll

[Missing <summary> documentation for "P:Dln.Connection.Host"]

Namespace: Dln
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public string Host { get; }
public string Host { get; }
Public ReadOnly Property Host As String
    Get
Public ReadOnly Property Host As String
    Get
public:
property String^ Host {
    String^ get ();
}
public:
property String^ Host {
    String^ get ();
}
Property Value
Type: String
See Also
Reference
Connection Class
Dln Namespace


Connection.Port Property

Connection Port Property dln.net.dll

[Missing <summary> documentation for "P:Dln.Connection.Port"]

Namespace: Dln
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public ushort Port { get; }
public ushort Port { get; }
Public ReadOnly Property Port As UShort
    Get
Public ReadOnly Property Port As UShort
    Get
public:
property unsigned short Port {
    unsigned short get ();
}
public:
property unsigned short Port {
    unsigned short get ();
}
Property Value
Type: UInt16
See Also
Reference
Connection Class
Dln Namespace


Connection Events

Connection Events dln.net.dll

The Connection type exposes the following members.

Events
 | Name | Description
Public event | ConnectionLost |
Top
See Also

Reference

Connection Class
Dln Namespace


Connection.ConnectionLost Event

Connection ConnectionLost Event dln.net.dll

[Missing <summary> documentation for "E:Dln.Connection.ConnectionLost"]

Namespace: Dln
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public event EventHandler<EventArgs> ConnectionLost
public event EventHandler<EventArgs> ConnectionLost
Public Event ConnectionLost As EventHandler(Of EventArgs)
Public Event ConnectionLost As EventHandler(Of EventArgs)
public:
 event EventHandler<EventArgs^>^ ConnectionLost {
    void add (EventHandler<EventArgs^>^ value);
    void remove (EventHandler<EventArgs^>^ value);
}
public:
 event EventHandler<EventArgs^>^ ConnectionLost {
    void add (EventHandler<EventArgs^>^ value);
    void remove (EventHandler<EventArgs^>^ value);
}
Value
Type: System EventHandler  EventArgs
See Also
Reference
Connection Class
Dln Namespace


Device Class

Device Class dln.net.dll
Device class describes generic fucntionality for DLN devices.
Inheritance Hierarchy
System Object
Dln Device

Namespace: Dln
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public class Device
public class Device
Public Class Device
Public Class Device
public ref class Device
public ref class Device
The Device type exposes the following members.
Methods
 | Name | Description
 | Count | Count all conected DLN devices.
 | Count(Device Filter, HardwareType, UInt32, UInt32) | Count connected DLN devices by using filters.
Public method | Delay | Increase delays between transactions.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Device class destructor (Overrides Object Finalize .)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetSrvParams |
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Open | Open single connected device
 | Open(Int32) | Open device by device number
 | Open(UInt32) | Open device by device number
 | Open(Device Filter, UInt32, HardwareType, UInt32, UInt32) | Open DLN device by using filters.
 | OpenById | Open device by ID
 | OpenBySn | Open device by serial number
Public method | Restart | Restarts currently opened DLN-series device.
Public method | SetSrvParams |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Adc |
Public property | FirmwareVersion | Firmware version
Public property | Gpio |
Public property | Handle |
Public property | HardwareType | hardware type
Public property | HardwareVersion | Hardware version
Public property | I2cMaster |
Public property | I2cSlave |
Public property | ID |
Public property | Led |
Public property | LibraryVersion | Library version
Public property | PulseCounter |
Public property | Pwm |
Public property | ServerVersion | Server version
Public property | SN |
Public property | SpiFlash |
Public property | SpiMaster |
Public property | SpiSlave |
Public property | Uart |
Top
Events
 | Name | Description
Public event | DeviceRemoved |
Public event | DeviceRemovedThreadSafe |
Top
See Also
Reference
Dln Namespace


Device Methods

Device Methods dln.net.dll

The Device type exposes the following members.

Methods
 | Name | Description
 | Count | Count all conected DLN devices.
 | Count(Device Filter, HardwareType, UInt32, UInt32) | Count connected DLN devices by using filters.
Public method | Delay | Increase delays between transactions.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Device class destructor (Overrides Object Finalize .)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetSrvParams |
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Open | Open single connected device
 | Open(Int32) | Open device by device number
 | Open(UInt32) | Open device by device number
 | Open(Device Filter, UInt32, HardwareType, UInt32, UInt32) | Open DLN device by using filters.
 | OpenById | Open device by ID
 | OpenBySn | Open device by serial number
Public method | Restart | Restarts currently opened DLN-series device.
Public method | SetSrvParams |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Device Class
Dln Namespace


Device.Count Method

Device Count Method dln.net.dll
Overload List
Name | Description
Count | Count all conected DLN devices.
Count(Device Filter, HardwareType, UInt32, UInt32) | Count connected DLN devices by using filters.
Top
See Also

Reference

Device Class
Dln Namespace


Device.Count Method

Device Count Method dln.net.dll
Count all conected DLN devices.

Namespace: Dln
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public static uint Count()
public static uint Count()
Public Shared Function Count As UInteger
Public Shared Function Count As UInteger
public:
static unsigned int Count()
public:
static unsigned int Count()
Return Value
Type: UInt32
The quantity of all connected devices.
See Also
Reference
Device Class
Count Overload
Dln Namespace


Device.Count Method (Device.Filter, HardwareType, UInt32, UInt32)

Device Count Method (Device Filter, HardwareType, UInt32, UInt32) dln.net.dll
Count connected DLN devices by using filters.

Namespace: Dln
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public static uint Count(
    Device&#160;Filter filter,
    HardwareType hwType,
    uint sn,
    uint id
)
public static uint Count(
    Device..::..Filter filter,
    HardwareType hwType,
    uint sn,
    uint id
)
Public Shared Function Count (
    filter As Device&#160;Filter,
    hwType As HardwareType,
    sn As UInteger,
    id As UInteger
) As UInteger
Public Shared Function Count (
    filter As Device..::..Filter,
    hwType As HardwareType,
    sn As UInteger,
    id As UInteger
) As UInteger
public:
static unsigned int Count(
    Device&#160;Filter filter,
    HardwareType hwType,
    unsigned int sn,
    unsigned int id
)
public:
static unsigned int Count(
    Device..::..Filter filter,
    HardwareType hwType,
    unsigned int sn,
    unsigned int id
)
Parameters
filter
Type: Dln Device Filter
Filter to be applied. Use Filter enumeration.
hwType
Type: Dln HardwareType
hardware type
sn
Type: System UInt32
Serial number
id
Type: System UInt32
Device ID
Return Value
Type: UInt32
[Missing <returns> documentation for "M:Dln.Device.Count(Dln.Device.Filter,Dln.HardwareType,System.UInt32,System.UInt32)"]
See Also
Reference
Device Class
Count Overload
Dln Namespace


Device.Delay Method

Device Delay Method dln.net.dll
Increase delays between transactions.

Namespace: Dln
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public void Delay(
    int delay
)
public void Delay(
    int delay
)
Public Sub Delay (
    delay As Integer
)
Public Sub Delay (
    delay As Integer
)
public:
void Delay(
    int delay
)
public:
void Delay(
    int delay
)
Parameters
delay
Type: System Int32
Delay value.
See Also
Reference
Device Class
Dln Namespace


Device.Finalize Method

Device Finalize Method dln.net.dll
Device class destructor

Namespace: Dln
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
protected override void Finalize()
protected override void Finalize()
Protected Overrides Sub Finalize
Protected Overrides Sub Finalize
protected:
virtual void Finalize() override
protected:
virtual void Finalize() override
See Also
Reference
Device Class
Dln Namespace


Device.GetSrvParams Method

Device GetSrvParams Method dln.net.dll

[Missing <summary> documentation for "M:Dln.Device.GetSrvParams(System.Byte[]@,System.UInt16@,System.Byte[]@,System.Byte[]@,System.Byte[]@,System.Byte[]@,System.UInt16@)"]

Namespace: Dln
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public void GetSrvParams(
    out byte[] uuid,
    out ushort deviceHandle,
    out byte[] macAddress,
    out byte[] ipAddress,
    out byte[] subnetMask,
    out byte[] gatewayIp,
    out ushort port
)
public void GetSrvParams(
    out byte[] uuid,
    out ushort deviceHandle,
    out byte[] macAddress,
    out byte[] ipAddress,
    out byte[] subnetMask,
    out byte[] gatewayIp,
    out ushort port
)
Public Sub GetSrvParams (
    <OutAttribute> ByRef uuid As Byte(),
    <OutAttribute> ByRef deviceHandle As UShort,
    <OutAttribute> ByRef macAddress As Byte(),
    <OutAttribute> ByRef ipAddress As Byte(),
    <OutAttribute> ByRef subnetMask As Byte(),
    <OutAttribute> ByRef gatewayIp As Byte(),
    <OutAttribute> ByRef port As UShort
)
Public Sub GetSrvParams (
    <OutAttribute> ByRef uuid As Byte(),
    <OutAttribute> ByRef deviceHandle As UShort,
    <OutAttribute> ByRef macAddress As Byte(),
    <OutAttribute> ByRef ipAddress As Byte(),
    <OutAttribute> ByRef subnetMask As Byte(),
    <OutAttribute> ByRef gatewayIp As Byte(),
    <OutAttribute> ByRef port As UShort
)
public:
void GetSrvParams(
    [OutAttribute] array<unsigned char>^% uuid,
    [OutAttribute] unsigned short% deviceHandle,
    [OutAttribute] array<unsigned char>^% macAddress,
    [OutAttribute] array<unsigned char>^% ipAddress,
    [OutAttribute] array<unsigned char>^% subnetMask,
    [OutAttribute] array<unsigned char>^% gatewayIp,
    [OutAttribute] unsigned short% port
)
public:
void GetSrvParams(
    [OutAttribute] array<unsigned char>^% uuid,
    [OutAttribute] unsigned short% deviceHandle,
    [OutAttribute] array<unsigned char>^% macAddress,
    [OutAttribute] array<unsigned char>^% ipAddress,
    [OutAttribute] array<unsigned char>^% subnetMask,
    [OutAttribute] array<unsigned char>^% gatewayIp,
    [OutAttribute] unsigned short% port
)
Parameters
uuid
Type:  System Byte
[Missing <param name="uuid"/> documentation for "M:Dln.Device.GetSrvParams(System.Byte[]@,System.UInt16@,System.Byte[]@,System.Byte[]@,System.Byte[]@,System.Byte[]@,System.UInt16@)"]
deviceHandle
Type: System UInt16
[Missing <param name="deviceHandle"/> documentation for "M:Dln.Device.GetSrvParams(System.Byte[]@,System.UInt16@,System.Byte[]@,System.Byte[]@,System.Byte[]@,System.Byte[]@,System.UInt16@)"]
macAddress
Type:  System Byte
[Missing <param name="macAddress"/> documentation for "M:Dln.Device.GetSrvParams(System.Byte[]@,System.UInt16@,System.Byte[]@,System.Byte[]@,System.Byte[]@,System.Byte[]@,System.UInt16@)"]
ipAddress
Type:  System Byte
[Missing <param name="ipAddress"/> documentation for "M:Dln.Device.GetSrvParams(System.Byte[]@,System.UInt16@,System.Byte[]@,System.Byte[]@,System.Byte[]@,System.Byte[]@,System.UInt16@)"]
subnetMask
Type:  System Byte
[Missing <param name="subnetMask"/> documentation for "M:Dln.Device.GetSrvParams(System.Byte[]@,System.UInt16@,System.Byte[]@,System.Byte[]@,System.Byte[]@,System.Byte[]@,System.UInt16@)"]
gatewayIp
Type:  System Byte
[Missing <param name="gatewayIp"/> documentation for "M:Dln.Device.GetSrvParams(System.Byte[]@,System.UInt16@,System.Byte[]@,System.Byte[]@,System.Byte[]@,System.Byte[]@,System.UInt16@)"]
port
Type: System UInt16
[Missing <param name="port"/> documentation for "M:Dln.Device.GetSrvParams(System.Byte[]@,System.UInt16@,System.Byte[]@,System.Byte[]@,System.Byte[]@,System.Byte[]@,System.UInt16@)"]
See Also
Reference
Device Class
Dln Namespace


Device.Open Method

Device Open Method dln.net.dll
Overload List
Name | Description
Open | Open single connected device
Open(Int32) | Open device by device number
Open(UInt32) | Open device by device number
Open(Device Filter, UInt32, HardwareType, UInt32, UInt32) | Open DLN device by using filters.
Top
See Also

Reference

Device Class
Dln Namespace


Device.Open Method

Device Open Method dln.net.dll
Open single connected device

Namespace: Dln
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public static Device Open()
public static Device Open()
Public Shared Function Open As Device
Public Shared Function Open As Device
public:
static Device^ Open()
public:
static Device^ Open()
Return Value
Type: Device
New Device class object
See Also
Reference
Device Class
Open Overload
Dln Namespace


Device.Open Method (Int32)

Device Open Method (Int32) dln.net.dll
Open device by device number

Namespace: Dln
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public static Device Open(
    int number
)
public static Device Open(
    int number
)
Public Shared Function Open (
    number As Integer
) As Device
Public Shared Function Open (
    number As Integer
) As Device
public:
static Device^ Open(
    int number
)
public:
static Device^ Open(
    int number
)
Parameters
number
Type: System Int32
Device number, which is assigned when device is connected.
Return Value
Type: Device
New Device class object
See Also
Reference
Device Class
Open Overload
Dln Namespace


Device.Open Method (UInt32)

Device Open Method (UInt32) dln.net.dll
Open device by device number

Namespace: Dln
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public static Device Open(
    uint number
)
public static Device Open(
    uint number
)
Public Shared Function Open (
    number As UInteger
) As Device
Public Shared Function Open (
    number As UInteger
) As Device
public:
static Device^ Open(
    unsigned int number
)
public:
static Device^ Open(
    unsigned int number
)
Parameters
number
Type: System UInt32
Device number, which is assigned when device is connected.
Return Value
Type: Device
New Device class object
See Also
Reference
Device Class
Open Overload
Dln Namespace


Device.Open Method (Device.Filter, UInt32, HardwareType, UInt32, UInt32)

Device Open Method (Device Filter, UInt32, HardwareType, UInt32, UInt32) dln.net.dll
Open DLN device by using filters.

Namespace: Dln
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public static Device Open(
    Device&#160;Filter filter,
    uint number,
    HardwareType hwType,
    uint sn,
    uint id
)
public static Device Open(
    Device..::..Filter filter,
    uint number,
    HardwareType hwType,
    uint sn,
    uint id
)
Public Shared Function Open (
    filter As Device&#160;Filter,
    number As UInteger,
    hwType As HardwareType,
    sn As UInteger,
    id As UInteger
) As Device
Public Shared Function Open (
    filter As Device..::..Filter,
    number As UInteger,
    hwType As HardwareType,
    sn As UInteger,
    id As UInteger
) As Device
public:
static Device^ Open(
    Device&#160;Filter filter,
    unsigned int number,
    HardwareType hwType,
    unsigned int sn,
    unsigned int id
)
public:
static Device^ Open(
    Device..::..Filter filter,
    unsigned int number,
    HardwareType hwType,
    unsigned int sn,
    unsigned int id
)
Parameters
filter
Type: Dln Device Filter
Filter to be applied. Use Filter enumeration.
number
Type: System UInt32
Device number
hwType
Type: Dln HardwareType
Hardware type
sn
Type: System UInt32
Serial number
id
Type: System UInt32
ID number
Return Value
Type: Device
New Device class object
See Also
Reference
Device Class
Open Overload
Dln Namespace


Device.OpenById Method

Device OpenById Method dln.net.dll
Open device by ID

Namespace: Dln
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public static Device OpenById(
    uint id
)
public static Device OpenById(
    uint id
)
Public Shared Function OpenById (
    id As UInteger
) As Device
Public Shared Function OpenById (
    id As UInteger
) As Device
public:
static Device^ OpenById(
    unsigned int id
)
public:
static Device^ OpenById(
    unsigned int id
)
Parameters
id
Type: System UInt32
ID number
Return Value
Type: Device
New Device class object
See Also
Reference
Device Class
Dln Namespace


Device.OpenBySn Method

Device OpenBySn Method dln.net.dll
Open device by serial number

Namespace: Dln
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public static Device OpenBySn(
    uint sn
)
public static Device OpenBySn(
    uint sn
)
Public Shared Function OpenBySn (
    sn As UInteger
) As Device
Public Shared Function OpenBySn (
    sn As UInteger
) As Device
public:
static Device^ OpenBySn(
    unsigned int sn
)
public:
static Device^ OpenBySn(
    unsigned int sn
)
Parameters
sn
Type: System UInt32
Serial number
Return Value
Type: Device
New Device class object
See Also
Reference
Device Class
Dln Namespace


Device.Restart Method

Device Restart Method dln.net.dll
Restarts currently opened DLN-series device.

Namespace: Dln
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public void Restart()
public void Restart()
Public Sub Restart
Public Sub Restart
public:
void Restart()
public:
void Restart()
See Also
Reference
Device Class
Dln Namespace


Device.SetSrvParams Method

Device SetSrvParams Method dln.net.dll

[Missing <summary> documentation for "M:Dln.Device.SetSrvParams(System.Byte[],System.UInt16,System.Byte[],System.Byte[],System.Byte[],System.Byte[],System.UInt16)"]

Namespace: Dln
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public void SetSrvParams(
    byte[] uuid,
    ushort deviceHandle,
    byte[] macAddress,
    byte[] ipAddress,
    byte[] subnetMask,
    byte[] gatewayIp,
    ushort port
)
public void SetSrvParams(
    byte[] uuid,
    ushort deviceHandle,
    byte[] macAddress,
    byte[] ipAddress,
    byte[] subnetMask,
    byte[] gatewayIp,
    ushort port
)
Public Sub SetSrvParams (
    uuid As Byte(),
    deviceHandle As UShort,
    macAddress As Byte(),
    ipAddress As Byte(),
    subnetMask As Byte(),
    gatewayIp As Byte(),
    port As UShort
)
Public Sub SetSrvParams (
    uuid As Byte(),
    deviceHandle As UShort,
    macAddress As Byte(),
    ipAddress As Byte(),
    subnetMask As Byte(),
    gatewayIp As Byte(),
    port As UShort
)
public:
void SetSrvParams(
    array<unsigned char>^ uuid,
    unsigned short deviceHandle,
    array<unsigned char>^ macAddress,
    array<unsigned char>^ ipAddress,
    array<unsigned char>^ subnetMask,
    array<unsigned char>^ gatewayIp,
    unsigned short port
)
public:
void SetSrvParams(
    array<unsigned char>^ uuid,
    unsigned short deviceHandle,
    array<unsigned char>^ macAddress,
    array<unsigned char>^ ipAddress,
    array<unsigned char>^ subnetMask,
    array<unsigned char>^ gatewayIp,
    unsigned short port
)
Parameters
uuid
Type:  System Byte
[Missing <param name="uuid"/> documentation for "M:Dln.Device.SetSrvParams(System.Byte[],System.UInt16,System.Byte[],System.Byte[],System.Byte[],System.Byte[],System.UInt16)"]
deviceHandle
Type: System UInt16
[Missing <param name="deviceHandle"/> documentation for "M:Dln.Device.SetSrvParams(System.Byte[],System.UInt16,System.Byte[],System.Byte[],System.Byte[],System.Byte[],System.UInt16)"]
macAddress
Type:  System Byte
[Missing <param name="macAddress"/> documentation for "M:Dln.Device.SetSrvParams(System.Byte[],System.UInt16,System.Byte[],System.Byte[],System.Byte[],System.Byte[],System.UInt16)"]
ipAddress
Type:  System Byte
[Missing <param name="ipAddress"/> documentation for "M:Dln.Device.SetSrvParams(System.Byte[],System.UInt16,System.Byte[],System.Byte[],System.Byte[],System.Byte[],System.UInt16)"]
subnetMask
Type:  System Byte
[Missing <param name="subnetMask"/> documentation for "M:Dln.Device.SetSrvParams(System.Byte[],System.UInt16,System.Byte[],System.Byte[],System.Byte[],System.Byte[],System.UInt16)"]
gatewayIp
Type:  System Byte
[Missing <param name="gatewayIp"/> documentation for "M:Dln.Device.SetSrvParams(System.Byte[],System.UInt16,System.Byte[],System.Byte[],System.Byte[],System.Byte[],System.UInt16)"]
port
Type: System UInt16
[Missing <param name="port"/> documentation for "M:Dln.Device.SetSrvParams(System.Byte[],System.UInt16,System.Byte[],System.Byte[],System.Byte[],System.Byte[],System.UInt16)"]
See Also
Reference
Device Class
Dln Namespace


Device Properties

Device Properties dln.net.dll

The Device type exposes the following members.

Properties
 | Name | Description
Public property | Adc |
Public property | FirmwareVersion | Firmware version
Public property | Gpio |
Public property | Handle |
Public property | HardwareType | hardware type
Public property | HardwareVersion | Hardware version
Public property | I2cMaster |
Public property | I2cSlave |
Public property | ID |
Public property | Led |
Public property | LibraryVersion | Library version
Public property | PulseCounter |
Public property | Pwm |
Public property | ServerVersion | Server version
Public property | SN |
Public property | SpiFlash |
Public property | SpiMaster |
Public property | SpiSlave |
Public property | Uart |
Top
See Also

Reference

Device Class
Dln Namespace


Device.Adc Property

Device Adc Property dln.net.dll

[Missing <summary> documentation for "P:Dln.Device.Adc"]

Namespace: Dln
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public Module Adc { get; }
public Module Adc { get; }
Public ReadOnly Property Adc As Module
    Get
Public ReadOnly Property Adc As Module
    Get
public:
property Module^ Adc {
    Module^ get ();
}
public:
property Module^ Adc {
    Module^ get ();
}
Property Value
Type: Module
See Also
Reference
Device Class
Dln Namespace


Device.FirmwareVersion Property

Device FirmwareVersion Property dln.net.dll
Firmware version

Namespace: Dln
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public uint FirmwareVersion { get; }
public uint FirmwareVersion { get; }
Public ReadOnly Property FirmwareVersion As UInteger
    Get
Public ReadOnly Property FirmwareVersion As UInteger
    Get
public:
property unsigned int FirmwareVersion {
    unsigned int get ();
}
public:
property unsigned int FirmwareVersion {
    unsigned int get ();
}
Property Value
Type: UInt32
See Also
Reference
Device Class
Dln Namespace


Device.Gpio Property

Device Gpio Property dln.net.dll

[Missing <summary> documentation for "P:Dln.Device.Gpio"]

Namespace: Dln
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public Module Gpio { get; }
public Module Gpio { get; }
Public ReadOnly Property Gpio As Module
    Get
Public ReadOnly Property Gpio As Module
    Get
public:
property Module^ Gpio {
    Module^ get ();
}
public:
property Module^ Gpio {
    Module^ get ();
}
Property Value
Type: Module
See Also
Reference
Device Class
Dln Namespace


Device.Handle Property

Device Handle Property dln.net.dll

[Missing <summary> documentation for "P:Dln.Device.Handle"]

Namespace: Dln
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public Handle Handle { get; }
public Handle Handle { get; }
Public ReadOnly Property Handle As Handle
    Get
Public ReadOnly Property Handle As Handle
    Get
public:
property Handle Handle {
    Handle get ();
}
public:
property Handle Handle {
    Handle get ();
}
Property Value
Type: Handle
See Also
Reference
Device Class
Dln Namespace


Device.HardwareType Property

Device HardwareType Property dln.net.dll
hardware type

Namespace: Dln
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public HardwareType HardwareType { get; }
public HardwareType HardwareType { get; }
Public ReadOnly Property HardwareType As HardwareType
    Get
Public ReadOnly Property HardwareType As HardwareType
    Get
public:
property HardwareType HardwareType {
    HardwareType get ();
}
public:
property HardwareType HardwareType {
    HardwareType get ();
}
Property Value
Type: HardwareType
See Also
Reference
Device Class
Dln Namespace


Device.HardwareVersion Property

Device HardwareVersion Property dln.net.dll
Hardware version

Namespace: Dln
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public uint HardwareVersion { get; }
public uint HardwareVersion { get; }
Public ReadOnly Property HardwareVersion As UInteger
    Get
Public ReadOnly Property HardwareVersion As UInteger
    Get
public:
property unsigned int HardwareVersion {
    unsigned int get ();
}
public:
property unsigned int HardwareVersion {
    unsigned int get ();
}
Property Value
Type: UInt32
See Also
Reference
Device Class
Dln Namespace


Device.I2cMaster Property

Device I2cMaster Property dln.net.dll

[Missing <summary> documentation for "P:Dln.Device.I2cMaster"]

Namespace: Dln
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public Module I2cMaster { get; }
public Module I2cMaster { get; }
Public ReadOnly Property I2cMaster As Module
    Get
Public ReadOnly Property I2cMaster As Module
    Get
public:
property Module^ I2cMaster {
    Module^ get ();
}
public:
property Module^ I2cMaster {
    Module^ get ();
}
Property Value
Type: Module
See Also
Reference
Device Class
Dln Namespace


Device.I2cSlave Property

Device I2cSlave Property dln.net.dll

[Missing <summary> documentation for "P:Dln.Device.I2cSlave"]

Namespace: Dln
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public Module I2cSlave { get; }
public Module I2cSlave { get; }
Public ReadOnly Property I2cSlave As Module
    Get
Public ReadOnly Property I2cSlave As Module
    Get
public:
property Module^ I2cSlave {
    Module^ get ();
}
public:
property Module^ I2cSlave {
    Module^ get ();
}
Property Value
Type: Module
See Also
Reference
Device Class
Dln Namespace


Device.ID Property

Device ID Property dln.net.dll

[Missing <summary> documentation for "P:Dln.Device.ID"]

Namespace: Dln
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public uint ID { get; set; }
public uint ID { get; set; }
Public Property ID As UInteger
    Get
    Set
Public Property ID As UInteger
    Get
    Set
public:
property unsigned int ID {
    unsigned int get ();
    void set (unsigned int value);
}
public:
property unsigned int ID {
    unsigned int get ();
    void set (unsigned int value);
}
Property Value
Type: UInt32
See Also
Reference
Device Class
Dln Namespace


Device.Led Property

Device Led Property dln.net.dll

[Missing <summary> documentation for "P:Dln.Device.Led"]

Namespace: Dln
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public Module Led { get; }
public Module Led { get; }
Public ReadOnly Property Led As Module
    Get
Public ReadOnly Property Led As Module
    Get
public:
property Module^ Led {
    Module^ get ();
}
public:
property Module^ Led {
    Module^ get ();
}
Property Value
Type: Module
See Also
Reference
Device Class
Dln Namespace


Device.LibraryVersion Property

Device LibraryVersion Property dln.net.dll
Library version

Namespace: Dln
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public uint LibraryVersion { get; }
public uint LibraryVersion { get; }
Public ReadOnly Property LibraryVersion As UInteger
    Get
Public ReadOnly Property LibraryVersion As UInteger
    Get
public:
property unsigned int LibraryVersion {
    unsigned int get ();
}
public:
property unsigned int LibraryVersion {
    unsigned int get ();
}
Property Value
Type: UInt32
See Also
Reference
Device Class
Dln Namespace


Device.PulseCounter Property

Device PulseCounter Property dln.net.dll

[Missing <summary> documentation for "P:Dln.Device.PulseCounter"]

Namespace: Dln
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public Module PulseCounter { get; }
public Module PulseCounter { get; }
Public ReadOnly Property PulseCounter As Module
    Get
Public ReadOnly Property PulseCounter As Module
    Get
public:
property Module^ PulseCounter {
    Module^ get ();
}
public:
property Module^ PulseCounter {
    Module^ get ();
}
Property Value
Type: Module
See Also
Reference
Device Class
Dln Namespace


Device.Pwm Property

Device Pwm Property dln.net.dll

[Missing <summary> documentation for "P:Dln.Device.Pwm"]

Namespace: Dln
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public Module Pwm { get; }
public Module Pwm { get; }
Public ReadOnly Property Pwm As Module
    Get
Public ReadOnly Property Pwm As Module
    Get
public:
property Module^ Pwm {
    Module^ get ();
}
public:
property Module^ Pwm {
    Module^ get ();
}
Property Value
Type: Module
See Also
Reference
Device Class
Dln Namespace


Device.ServerVersion Property

Device ServerVersion Property dln.net.dll
Server version

Namespace: Dln
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public uint ServerVersion { get; }
public uint ServerVersion { get; }
Public ReadOnly Property ServerVersion As UInteger
    Get
Public ReadOnly Property ServerVersion As UInteger
    Get
public:
property unsigned int ServerVersion {
    unsigned int get ();
}
public:
property unsigned int ServerVersion {
    unsigned int get ();
}
Property Value
Type: UInt32
See Also
Reference
Device Class
Dln Namespace


Device.SN Property

Device SN Property dln.net.dll

[Missing <summary> documentation for "P:Dln.Device.SN"]

Namespace: Dln
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public uint SN { get; }
public uint SN { get; }
Public ReadOnly Property SN As UInteger
    Get
Public ReadOnly Property SN As UInteger
    Get
public:
property unsigned int SN {
    unsigned int get ();
}
public:
property unsigned int SN {
    unsigned int get ();
}
Property Value
Type: UInt32
See Also
Reference
Device Class
Dln Namespace


Device.SpiFlash Property

Device SpiFlash Property dln.net.dll

[Missing <summary> documentation for "P:Dln.Device.SpiFlash"]

Namespace: Dln
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public Module SpiFlash { get; }
public Module SpiFlash { get; }
Public ReadOnly Property SpiFlash As Module
    Get
Public ReadOnly Property SpiFlash As Module
    Get
public:
property Module^ SpiFlash {
    Module^ get ();
}
public:
property Module^ SpiFlash {
    Module^ get ();
}
Property Value
Type: Module
See Also
Reference
Device Class
Dln Namespace


Device.SpiMaster Property

Device SpiMaster Property dln.net.dll

[Missing <summary> documentation for "P:Dln.Device.SpiMaster"]

Namespace: Dln
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public Module SpiMaster { get; }
public Module SpiMaster { get; }
Public ReadOnly Property SpiMaster As Module
    Get
Public ReadOnly Property SpiMaster As Module
    Get
public:
property Module^ SpiMaster {
    Module^ get ();
}
public:
property Module^ SpiMaster {
    Module^ get ();
}
Property Value
Type: Module
See Also
Reference
Device Class
Dln Namespace


Device.SpiSlave Property

Device SpiSlave Property dln.net.dll

[Missing <summary> documentation for "P:Dln.Device.SpiSlave"]

Namespace: Dln
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public Module SpiSlave { get; }
public Module SpiSlave { get; }
Public ReadOnly Property SpiSlave As Module
    Get
Public ReadOnly Property SpiSlave As Module
    Get
public:
property Module^ SpiSlave {
    Module^ get ();
}
public:
property Module^ SpiSlave {
    Module^ get ();
}
Property Value
Type: Module
See Also
Reference
Device Class
Dln Namespace


Device.Uart Property

Device Uart Property dln.net.dll

[Missing <summary> documentation for "P:Dln.Device.Uart"]

Namespace: Dln
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public Module Uart { get; }
public Module Uart { get; }
Public ReadOnly Property Uart As Module
    Get
Public ReadOnly Property Uart As Module
    Get
public:
property Module^ Uart {
    Module^ get ();
}
public:
property Module^ Uart {
    Module^ get ();
}
Property Value
Type: Module
See Also
Reference
Device Class
Dln Namespace


Device Events

Device Events dln.net.dll

The Device type exposes the following members.

Events
 | Name | Description
Public event | DeviceRemoved |
Public event | DeviceRemovedThreadSafe |
Top
See Also

Reference

Device Class
Dln Namespace


Device.DeviceRemoved Event

Device DeviceRemoved Event dln.net.dll

[Missing <summary> documentation for "E:Dln.Device.DeviceRemoved"]

Namespace: Dln
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public event EventHandler<EventArgs> DeviceRemoved
public event EventHandler<EventArgs> DeviceRemoved
Public Event DeviceRemoved As EventHandler(Of EventArgs)
Public Event DeviceRemoved As EventHandler(Of EventArgs)
public:
 event EventHandler<EventArgs^>^ DeviceRemoved {
    void add (EventHandler<EventArgs^>^ value);
    void remove (EventHandler<EventArgs^>^ value);
}
public:
 event EventHandler<EventArgs^>^ DeviceRemoved {
    void add (EventHandler<EventArgs^>^ value);
    void remove (EventHandler<EventArgs^>^ value);
}
Value
Type: System EventHandler  EventArgs
See Also
Reference
Device Class
Dln Namespace


Device.DeviceRemovedThreadSafe Event

Device DeviceRemovedThreadSafe Event dln.net.dll

[Missing <summary> documentation for "E:Dln.Device.DeviceRemovedThreadSafe"]

Namespace: Dln
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public event EventHandler<EventArgs> DeviceRemovedThreadSafe
public event EventHandler<EventArgs> DeviceRemovedThreadSafe
Public Event DeviceRemovedThreadSafe As EventHandler(Of EventArgs)
Public Event DeviceRemovedThreadSafe As EventHandler(Of EventArgs)
public:
 event EventHandler<EventArgs^>^ DeviceRemovedThreadSafe {
    void add (EventHandler<EventArgs^>^ value);
    void remove (EventHandler<EventArgs^>^ value);
}
public:
 event EventHandler<EventArgs^>^ DeviceRemovedThreadSafe {
    void add (EventHandler<EventArgs^>^ value);
    void remove (EventHandler<EventArgs^>^ value);
}
Value
Type: System EventHandler  EventArgs
See Also
Reference
Device Class
Dln Namespace


Device.Filter Enumeration

Device Filter Enumeration dln.net.dll

[Missing <summary> documentation for "T:Dln.Device.Filter"]

Namespace: Dln
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
[FlagsAttribute]
public enum Filter
[FlagsAttribute]
public enum Filter
<FlagsAttribute>
Public Enumeration Filter
<FlagsAttribute>
Public Enumeration Filter
[FlagsAttribute]
public enum class Filter
[FlagsAttribute]
public enum class Filter
Members
Member name | Value | Description
None | 0 |
Number | 1 |
HardwareType | 2 |
Sn | 4 |
Id | 8 |
See Also
Reference
Dln Namespace


DeviceAddedEventArgs Class

DeviceAddedEventArgs Class dln.net.dll
The DeviceAddedEventArgs class contains event data for DeviceAddedEv event.
Inheritance Hierarchy
System Object
System EventArgs
Dln DeviceAddedEventArgs

Namespace: Dln
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public class DeviceAddedEventArgs : EventArgs
public class DeviceAddedEventArgs : EventArgs
Public Class DeviceAddedEventArgs
    Inherits EventArgs
Public Class DeviceAddedEventArgs
    Inherits EventArgs
public ref class DeviceAddedEventArgs : public EventArgs
public ref class DeviceAddedEventArgs : public EventArgs
The DeviceAddedEventArgs type exposes the following members.
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | HardwareType | Hardware type
Public property | ID | Device ID
Public property | SN | Serial number
Top
See Also
Reference
Dln Namespace


DeviceAddedEventArgs Methods

DeviceAddedEventArgs Methods dln.net.dll

The DeviceAddedEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DeviceAddedEventArgs Class
Dln Namespace


DeviceAddedEventArgs Properties

DeviceAddedEventArgs Properties dln.net.dll

The DeviceAddedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | HardwareType | Hardware type
Public property | ID | Device ID
Public property | SN | Serial number
Top
See Also

Reference

DeviceAddedEventArgs Class
Dln Namespace


DeviceAddedEventArgs.HardwareType Property

DeviceAddedEventArgs HardwareType Property dln.net.dll
Hardware type

Namespace: Dln
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public HardwareType HardwareType { get; }
public HardwareType HardwareType { get; }
Public ReadOnly Property HardwareType As HardwareType
    Get
Public ReadOnly Property HardwareType As HardwareType
    Get
public:
property HardwareType HardwareType {
    HardwareType get ();
}
public:
property HardwareType HardwareType {
    HardwareType get ();
}
Property Value
Type: HardwareType
See Also
Reference
DeviceAddedEventArgs Class
Dln Namespace


DeviceAddedEventArgs.ID Property

DeviceAddedEventArgs ID Property dln.net.dll
Device ID

Namespace: Dln
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public uint ID { get; }
public uint ID { get; }
Public ReadOnly Property ID As UInteger
    Get
Public ReadOnly Property ID As UInteger
    Get
public:
property unsigned int ID {
    unsigned int get ();
}
public:
property unsigned int ID {
    unsigned int get ();
}
Property Value
Type: UInt32
See Also
Reference
DeviceAddedEventArgs Class
Dln Namespace


DeviceAddedEventArgs.SN Property

DeviceAddedEventArgs SN Property dln.net.dll
Serial number

Namespace: Dln
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public uint SN { get; }
public uint SN { get; }
Public ReadOnly Property SN As UInteger
    Get
Public ReadOnly Property SN As UInteger
    Get
public:
property unsigned int SN {
    unsigned int get ();
}
public:
property unsigned int SN {
    unsigned int get ();
}
Property Value
Type: UInt32
See Also
Reference
DeviceAddedEventArgs Class
Dln Namespace


Handle Enumeration

Handle Enumeration dln.net.dll
Device handle

Namespace: Dln
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public enum Handle
public enum Handle
Public Enumeration Handle
Public Enumeration Handle
public enum class Handle
public enum class Handle
Members
Member name | Value | Description
AllDevices | 0 | All devices
Invalid | 65535 | Invalid handle number
See Also
Reference
Dln Namespace


HardwareType Enumeration

HardwareType Enumeration dln.net.dll
HardwareType enumeration describes all possible DLN device types.

Namespace: Dln
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public enum HardwareType
public enum HardwareType
Public Enumeration HardwareType
Public Enumeration HardwareType
public enum class HardwareType
public enum class HardwareType
Members
Member name | Value | Description
Unknown | 0 |
Dln1 | 256 |
Dln2 | 512 |
Dln3 | 768 |
Dln4m | 1025 |
Dln4s | 1026 |
See Also
Reference
Dln Namespace


Library Class

Library Class dln.net.dll
Library class handles the main operations such as connection/disconnection to/from Dln Server, library version, opening handle to device and events handling.
Inheritance Hierarchy
System Object
Dln Library

Namespace: Dln
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public static class Library
public static class Library
Public NotInheritable Class Library
Public NotInheritable Class Library
public ref class Library abstract sealed
public ref class Library abstract sealed
The Library type exposes the following members.
Methods
Name | Description
Connect | Connect method connects dln.net library to Dln Server on the local computer.
Connect(String, UInt16) | Connect method connects dln.net library to Dln Server
Disconnect | Disconnect method of Library class. Disconnects library from Dln Server by providing Connection class object.
DisconnectAll | Disconnect method of Library class. Disconnects library from all Dln Server connections.
Top
Properties
Name | Description
SynchronizationContext | The SyncronizationContext to marshal the thread-safe event handler calls. See remarks section for additional details. The SyncronizationContext property connects an application threading model to For Windows Forms applications, WPF applications, and Silverlight applications, the GUI thread will have a SynchronizationContext-derived class associated with it. whenever a thread pool thread needs to have the GUI thread update the UI will post to the GUI thread
ThrowWarningExceptions | ThrowWarningExceptions property
Version | Library version.
Top
Events
Name | Description
DeviceAdded | Event handler for DeviceAdded event.
DeviceAddedLV | On static events, the sender parameter should be null (Nothing in Visual Basic). http://msdn.microsoft.com/en-us/library/ms229011.aspx This is event for LabView. The difference between DeviceAddedAT and DeviceAddedLV that DeviceAddedLV passes null as sender object, and DeviceAddedLV passes the event object both in sender and in event parameter (LabView doesn't correctly handles the null as object).
DeviceAddedThreadSafe | Event handler for DeviceAddedThreadSafe event.
Top
See Also
Reference
Dln Namespace


Library Methods

Library Methods dln.net.dll

The Library type exposes the following members.

Methods
Name | Description
Connect | Connect method connects dln.net library to Dln Server on the local computer.
Connect(String, UInt16) | Connect method connects dln.net library to Dln Server
Disconnect | Disconnect method of Library class. Disconnects library from Dln Server by providing Connection class object.
DisconnectAll | Disconnect method of Library class. Disconnects library from all Dln Server connections.
Top
See Also

Reference

Library Class
Dln Namespace


Library.Connect Method

Library Connect Method dln.net.dll
Overload List
Name | Description
Connect | Connect method connects dln.net library to Dln Server on the local computer.
Connect(String, UInt16) | Connect method connects dln.net library to Dln Server
Top
See Also

Reference

Library Class
Dln Namespace


Library.Connect Method

Library Connect Method dln.net.dll
Connect method connects dln.net library to Dln Server on the local computer.

Namespace: Dln
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public static Connection Connect()
public static Connection Connect()
Public Shared Function Connect As Connection
Public Shared Function Connect As Connection
public:
static Connection^ Connect()
public:
static Connection^ Connect()
Return Value
Type: Connection
New Connection class object.
See Also
Reference
Library Class
Connect Overload
Dln Namespace


Library.Connect Method (String, UInt16)

Library Connect Method (String, UInt16) dln.net.dll
Connect method connects dln.net library to Dln Server

Namespace: Dln
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public static Connection Connect(
    string host,
    ushort port
)
public static Connection Connect(
    string host,
    ushort port
)
Public Shared Function Connect (
    host As String,
    port As UShort
) As Connection
Public Shared Function Connect (
    host As String,
    port As UShort
) As Connection
public:
static Connection^ Connect(
    String^ host,
    unsigned short port
)
public:
static Connection^ Connect(
    String^ host,
    unsigned short port
)
Parameters
host
Type: System String
A server to establish the connection to. This value can be a URL (e.g. www.diolan.com), or an IP address (e.g. 127.0.0.1). In order to connect to a server, launched on the same computer, you can use the predefined "localhost" value as a host name.
port
Type: System UInt16
A port number of the DLN server. If you use DLN-series device on the same computer use "9656" port value.
Return Value
Type: Connection
New Connection class object.
See Also
Reference
Library Class
Connect Overload
Dln Namespace


Library.Disconnect Method

Library Disconnect Method dln.net.dll
Disconnect method of Library class. Disconnects library from Dln Server by providing Connection class object.

Namespace: Dln
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public static void Disconnect(
    Connection connection
)
public static void Disconnect(
    Connection connection
)
Public Shared Sub Disconnect (
    connection As Connection
)
Public Shared Sub Disconnect (
    connection As Connection
)
public:
static void Disconnect(
    Connection^ connection
)
public:
static void Disconnect(
    Connection^ connection
)
Parameters
connection
Type: Dln Connection
Connection class object, which was created earlier.
See Also
Reference
Library Class
Dln Namespace


Library.DisconnectAll Method

Library DisconnectAll Method dln.net.dll
Disconnect method of Library class. Disconnects library from all Dln Server connections.

Namespace: Dln
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public static void DisconnectAll()
public static void DisconnectAll()
Public Shared Sub DisconnectAll
Public Shared Sub DisconnectAll
public:
static void DisconnectAll()
public:
static void DisconnectAll()
See Also
Reference
Library Class
Dln Namespace


Library Properties

Library Properties dln.net.dll

The Library type exposes the following members.

Properties
Name | Description
SynchronizationContext | The SyncronizationContext to marshal the thread-safe event handler calls. See remarks section for additional details. The SyncronizationContext property connects an application threading model to For Windows Forms applications, WPF applications, and Silverlight applications, the GUI thread will have a SynchronizationContext-derived class associated with it. whenever a thread pool thread needs to have the GUI thread update the UI will post to the GUI thread
ThrowWarningExceptions | ThrowWarningExceptions property
Version | Library version.
Top
See Also

Reference

Library Class
Dln Namespace


Library.SynchronizationContext Property

Library SynchronizationContext Property dln.net.dll
The SyncronizationContext to marshal the thread-safe event handler calls. See remarks section for additional details. The SyncronizationContext property connects an application threading model to For Windows Forms applications, WPF applications, and Silverlight applications, the GUI thread will have a SynchronizationContext-derived class associated with it. whenever a thread pool thread needs to have the GUI thread update the UI will post to the GUI thread

Namespace: Dln
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public static SynchronizationContext SynchronizationContext { get; set; }
public static SynchronizationContext SynchronizationContext { get; set; }
Public Shared Property SynchronizationContext As SynchronizationContext
    Get
    Set
Public Shared Property SynchronizationContext As SynchronizationContext
    Get
    Set
public:
static property SynchronizationContext^ SynchronizationContext {
    SynchronizationContext^ get ();
    void set (SynchronizationContext^ value);
}
public:
static property SynchronizationContext^ SynchronizationContext {
    SynchronizationContext^ get ();
    void set (SynchronizationContext^ value);
}
Property Value
Type: SynchronizationContext
Remarks

            The DLN.NET library uses thread-pool
            Access to .NET Windows Forms controls is not inherently thread safe.

See Also
Reference
Library Class
Dln Namespace


Library.ThrowWarningExceptions Property

Library ThrowWarningExceptions Property dln.net.dll
ThrowWarningExceptions property

Namespace: Dln
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public static bool ThrowWarningExceptions { get; set; }
public static bool ThrowWarningExceptions { get; set; }
Public Shared Property ThrowWarningExceptions As Boolean
    Get
    Set
Public Shared Property ThrowWarningExceptions As Boolean
    Get
    Set
public:
static property bool ThrowWarningExceptions {
    bool get ();
    void set (bool value);
}
public:
static property bool ThrowWarningExceptions {
    bool get ();
    void set (bool value);
}
Property Value
Type: Boolean
See Also
Reference
Library Class
Dln Namespace


Library.Version Property

Library Version Property dln.net.dll
Library version.

Namespace: Dln
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public static uint Version { get; }
public static uint Version { get; }
Public Shared ReadOnly Property Version As UInteger
    Get
Public Shared ReadOnly Property Version As UInteger
    Get
public:
static property unsigned int Version {
    unsigned int get ();
}
public:
static property unsigned int Version {
    unsigned int get ();
}
Property Value
Type: UInt32
See Also
Reference
Library Class
Dln Namespace


Library Events

Library Events dln.net.dll

The Library type exposes the following members.

Events
Name | Description
DeviceAdded | Event handler for DeviceAdded event.
DeviceAddedLV | On static events, the sender parameter should be null (Nothing in Visual Basic). http://msdn.microsoft.com/en-us/library/ms229011.aspx This is event for LabView. The difference between DeviceAddedAT and DeviceAddedLV that DeviceAddedLV passes null as sender object, and DeviceAddedLV passes the event object both in sender and in event parameter (LabView doesn't correctly handles the null as object).
DeviceAddedThreadSafe | Event handler for DeviceAddedThreadSafe event.
Top
See Also

Reference

Library Class
Dln Namespace


Library.DeviceAdded Event

Library DeviceAdded Event dln.net.dll
Event handler for DeviceAdded event.

Namespace: Dln
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public static event EventHandler<DeviceAddedEventArgs> DeviceAdded
public static event EventHandler<DeviceAddedEventArgs> DeviceAdded
Public Shared Event DeviceAdded As EventHandler(Of DeviceAddedEventArgs)
Public Shared Event DeviceAdded As EventHandler(Of DeviceAddedEventArgs)
public:
static  event EventHandler<DeviceAddedEventArgs^>^ DeviceAdded {
    void add (EventHandler<DeviceAddedEventArgs^>^ value);
    void remove (EventHandler<DeviceAddedEventArgs^>^ value);
}
public:
static  event EventHandler<DeviceAddedEventArgs^>^ DeviceAdded {
    void add (EventHandler<DeviceAddedEventArgs^>^ value);
    void remove (EventHandler<DeviceAddedEventArgs^>^ value);
}
Value
Type: System EventHandler  DeviceAddedEventArgs
See Also
Reference
Library Class
Dln Namespace


Library.DeviceAddedLV Event

Library DeviceAddedLV Event dln.net.dll
On static events, the sender parameter should be null (Nothing in Visual Basic). http://msdn.microsoft.com/en-us/library/ms229011.aspx This is event for LabView. The difference between DeviceAddedAT and DeviceAddedLV that DeviceAddedLV passes null as sender object, and DeviceAddedLV passes the event object both in sender and in event parameter (LabView doesn't correctly handles the null as object).

Namespace: Dln
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public static event EventHandler<DeviceAddedEventArgs> DeviceAddedLV
public static event EventHandler<DeviceAddedEventArgs> DeviceAddedLV
Public Shared Event DeviceAddedLV As EventHandler(Of DeviceAddedEventArgs)
Public Shared Event DeviceAddedLV As EventHandler(Of DeviceAddedEventArgs)
public:
static  event EventHandler<DeviceAddedEventArgs^>^ DeviceAddedLV {
    void add (EventHandler<DeviceAddedEventArgs^>^ value);
    void remove (EventHandler<DeviceAddedEventArgs^>^ value);
}
public:
static  event EventHandler<DeviceAddedEventArgs^>^ DeviceAddedLV {
    void add (EventHandler<DeviceAddedEventArgs^>^ value);
    void remove (EventHandler<DeviceAddedEventArgs^>^ value);
}
Value
Type: System EventHandler  DeviceAddedEventArgs
See Also
Reference
Library Class
Dln Namespace


Library.DeviceAddedThreadSafe Event

Library DeviceAddedThreadSafe Event dln.net.dll
Event handler for DeviceAddedThreadSafe event.

Namespace: Dln
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public static event EventHandler<DeviceAddedEventArgs> DeviceAddedThreadSafe
public static event EventHandler<DeviceAddedEventArgs> DeviceAddedThreadSafe
Public Shared Event DeviceAddedThreadSafe As EventHandler(Of DeviceAddedEventArgs)
Public Shared Event DeviceAddedThreadSafe As EventHandler(Of DeviceAddedEventArgs)
public:
static  event EventHandler<DeviceAddedEventArgs^>^ DeviceAddedThreadSafe {
    void add (EventHandler<DeviceAddedEventArgs^>^ value);
    void remove (EventHandler<DeviceAddedEventArgs^>^ value);
}
public:
static  event EventHandler<DeviceAddedEventArgs^>^ DeviceAddedThreadSafe {
    void add (EventHandler<DeviceAddedEventArgs^>^ value);
    void remove (EventHandler<DeviceAddedEventArgs^>^ value);
}
Value
Type: System EventHandler  DeviceAddedEventArgs
See Also
Reference
Library Class
Dln Namespace


Restriction Enumeration

Restriction Enumeration dln.net.dll
Restriction enumeration describes all possible restriction types.

Namespace: Dln
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public enum Restriction
public enum Restriction
Public Enumeration Restriction
Public Enumeration Restriction
public enum class Restriction
public enum class Restriction
Members
Member name | Value | Description
NoRestriction | 0 |
MustBeDisabled | 1 |
MustBeEnabled | 2 |
MustBeIdle | 3 |
SetNotSupported | 254 |
NotSupported | 255 |
PortMustBeDisabled | 1 |
PortMustBeEnabled | 2 |
ChannelMustBeDisabled | 4 |
ChannelMustBeEnabled | 5 |
See Also
Reference
Dln Namespace


Result Enumeration

Result Enumeration dln.net.dll

[Missing <summary> documentation for "T:Dln.Result"]

Namespace: Dln
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public enum Result
public enum Result
Public Enumeration Result
Public Enumeration Result
public enum class Result
public enum class Result
Members
Member name | Value | Description
Success | 0 |
SuccessfulReinit | 1 |
Pending | 2 |
TransferCancelled | 32 |
ValueRounded | 33 |
HardwareNotFound | 129 |
OutdatedDriver | 130 |
Fail | 131 |
MessageAbsent | 132 |
BedParameter | 133 |
MemoryError | 134 |
NotInitialized | 135 |
InvalidCommandSize | 136 |
InvalidResponseSize | 137 |
InvalidMessageSize | 138 |
NotificationNotRegistered | 139 |
TransactionTimeout | 141 |
OperationTimeout | 141 |
ResponseWaitTimeout | 141 |
DeviceRemoved | 142 |
InvalidHandle | 143 |
InvalidMessageType | 144 |
NotImplemented | 145 |
CommandNotSupported | 145 |
TooManyConnections | 146 |
AlreadyInitialized | 147 |
ConnectionFailed | 148 |
MustBeDisabled | 149 |
InternalError | 150 |
DeviceNumberOutOfRange | 151 |
HostNameTooLong | 152 |
AlreadyConnected | 153 |
ConnectionLost | 160 |
NotConnected | 161 |
MessageSendingailed | 162 |
NoFreeStream | 163 |
HostLookupFailed | 164 |
PinInUse | 165 |
InvalidLedNumber | 166 |
InvalidLedState | 167 |
InvalidPortNumber | 168 |
InvalidEventType | 169 |
PinNotConnectedToModule | 170 |
InvalidPinNumber | 171 |
InvalidEventPeriod | 172 |
NonZeroReservedBit | 173 |
InvalidBufferSize | 174 |
NoFreeDmaChannel | 175 |
InvalidPlaneNumber | 179 |
InvalidAddress | 180 |
Overflow | 181 |
Busy | 182 |
Disabled | 183 |
SpiInvalidFrameSize | 184 |
InvalidCharacterLength | 184 |
SpiMasterInvalidSsValue | 185 |
I2cMasterSendingAddressFailed | 186 |
I2cMasterSendingDataFailed | 187 |
I2cMasterInvalidMemAddressLength | 188 |
I2cMasterArbitrationLost | 189 |
I2cSlaveAddressNeeded | 190 |
IvalidResolution | 191 |
InvalidChannelNumber | 192 |
ChannelDisabled | 193 |
ResAllChannelsDisabled | 194 |
InvalidFrequency | 195 |
InvalidBaudrate | 195 |
InvalidDutyCycle | 196 |
InvalidReplyType | 197 |
InvalidDelayValue | 198 |
InvalidMode | 199 |
InvalidCpol | 200 |
InvalidCpha | 201 |
InvalidTimeoutValue | 202 |
SpiSlaveSSIdleTimeout | 203 |
InvalidParity | 204 |
InvalidStopbits | 205 |
ConfigurationNotSupported | 206 |
NoFreeTimer | 208 |
VerificationError | 209 |
SocketInitializationFailed | 224 |
InsufficientResources | 225 |
See Also
Reference
Dln Namespace


ResultExtension Class

ResultExtension Class dln.net.dll

[Missing <summary> documentation for "T:Dln.ResultExtension"]

Inheritance Hierarchy
System Object
Dln ResultExtension

Namespace: Dln
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public static class ResultExtension
public static class ResultExtension
<ExtensionAttribute>
Public NotInheritable Class ResultExtension
<ExtensionAttribute>
Public NotInheritable Class ResultExtension
[ExtensionAttribute]
public ref class ResultExtension abstract sealed
[ExtensionAttribute]
public ref class ResultExtension abstract sealed
The ResultExtension type exposes the following members.
Methods
Name | Description
Failed |
IsError |
IsSuccess |
IsWarning |
Succeeded |
Top
See Also
Reference
Dln Namespace


ResultExtension Methods

ResultExtension Methods dln.net.dll

The ResultExtension type exposes the following members.

Methods
Name | Description
Failed |
IsError |
IsSuccess |
IsWarning |
Succeeded |
Top
See Also

Reference

ResultExtension Class
Dln Namespace


ResultExtension.Failed Method

ResultExtension Failed Method dln.net.dll

[Missing <summary> documentation for "M:Dln.ResultExtension.Failed(Dln.Result)"]

Namespace: Dln
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public static bool Failed(
    this Result result
)
public static bool Failed(
    this Result result
)
<ExtensionAttribute>
Public Shared Function Failed (
    result As Result
) As Boolean
<ExtensionAttribute>
Public Shared Function Failed (
    result As Result
) As Boolean
public:
[ExtensionAttribute]
static bool Failed(
    Result result
)
public:
[ExtensionAttribute]
static bool Failed(
    Result result
)
Parameters
result
Type: Dln Result
[Missing <param name="result"/> documentation for "M:Dln.ResultExtension.Failed(Dln.Result)"]
Return Value
Type: Boolean
[Missing <returns> documentation for "M:Dln.ResultExtension.Failed(Dln.Result)"]
Usage Note
In Visual Basic and C#, you can call this method as an instance method on any object of type Result. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also
Reference
ResultExtension Class
Dln Namespace


ResultExtension.IsError Method

ResultExtension IsError Method dln.net.dll

[Missing <summary> documentation for "M:Dln.ResultExtension.IsError(Dln.Result)"]

Namespace: Dln
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public static bool IsError(
    this Result result
)
public static bool IsError(
    this Result result
)
<ExtensionAttribute>
Public Shared Function IsError (
    result As Result
) As Boolean
<ExtensionAttribute>
Public Shared Function IsError (
    result As Result
) As Boolean
public:
[ExtensionAttribute]
static bool IsError(
    Result result
)
public:
[ExtensionAttribute]
static bool IsError(
    Result result
)
Parameters
result
Type: Dln Result
[Missing <param name="result"/> documentation for "M:Dln.ResultExtension.IsError(Dln.Result)"]
Return Value
Type: Boolean
[Missing <returns> documentation for "M:Dln.ResultExtension.IsError(Dln.Result)"]
Usage Note
In Visual Basic and C#, you can call this method as an instance method on any object of type Result. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also
Reference
ResultExtension Class
Dln Namespace


ResultExtension.IsSuccess Method

ResultExtension IsSuccess Method dln.net.dll

[Missing <summary> documentation for "M:Dln.ResultExtension.IsSuccess(Dln.Result)"]

Namespace: Dln
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public static bool IsSuccess(
    this Result result
)
public static bool IsSuccess(
    this Result result
)
<ExtensionAttribute>
Public Shared Function IsSuccess (
    result As Result
) As Boolean
<ExtensionAttribute>
Public Shared Function IsSuccess (
    result As Result
) As Boolean
public:
[ExtensionAttribute]
static bool IsSuccess(
    Result result
)
public:
[ExtensionAttribute]
static bool IsSuccess(
    Result result
)
Parameters
result
Type: Dln Result
[Missing <param name="result"/> documentation for "M:Dln.ResultExtension.IsSuccess(Dln.Result)"]
Return Value
Type: Boolean
[Missing <returns> documentation for "M:Dln.ResultExtension.IsSuccess(Dln.Result)"]
Usage Note
In Visual Basic and C#, you can call this method as an instance method on any object of type Result. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also
Reference
ResultExtension Class
Dln Namespace


ResultExtension.IsWarning Method

ResultExtension IsWarning Method dln.net.dll

[Missing <summary> documentation for "M:Dln.ResultExtension.IsWarning(Dln.Result)"]

Namespace: Dln
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public static bool IsWarning(
    this Result result
)
public static bool IsWarning(
    this Result result
)
<ExtensionAttribute>
Public Shared Function IsWarning (
    result As Result
) As Boolean
<ExtensionAttribute>
Public Shared Function IsWarning (
    result As Result
) As Boolean
public:
[ExtensionAttribute]
static bool IsWarning(
    Result result
)
public:
[ExtensionAttribute]
static bool IsWarning(
    Result result
)
Parameters
result
Type: Dln Result
[Missing <param name="result"/> documentation for "M:Dln.ResultExtension.IsWarning(Dln.Result)"]
Return Value
Type: Boolean
[Missing <returns> documentation for "M:Dln.ResultExtension.IsWarning(Dln.Result)"]
Usage Note
In Visual Basic and C#, you can call this method as an instance method on any object of type Result. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also
Reference
ResultExtension Class
Dln Namespace


ResultExtension.Succeeded Method

ResultExtension Succeeded Method dln.net.dll

[Missing <summary> documentation for "M:Dln.ResultExtension.Succeeded(Dln.Result)"]

Namespace: Dln
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public static bool Succeeded(
    this Result result
)
public static bool Succeeded(
    this Result result
)
<ExtensionAttribute>
Public Shared Function Succeeded (
    result As Result
) As Boolean
<ExtensionAttribute>
Public Shared Function Succeeded (
    result As Result
) As Boolean
public:
[ExtensionAttribute]
static bool Succeeded(
    Result result
)
public:
[ExtensionAttribute]
static bool Succeeded(
    Result result
)
Parameters
result
Type: Dln Result
[Missing <param name="result"/> documentation for "M:Dln.ResultExtension.Succeeded(Dln.Result)"]
Return Value
Type: Boolean
[Missing <returns> documentation for "M:Dln.ResultExtension.Succeeded(Dln.Result)"]
Usage Note
In Visual Basic and C#, you can call this method as an instance method on any object of type Result. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also
Reference
ResultExtension Class
Dln Namespace


Dln.Adc Namespace

Dln.Adc Namespace dln.net.dll
The Dln.Adc namespace contains types that allow ADC module usage of DLN-series adapters.
Classes
 | Class | Description
Public class | Channel | Channel class describes ADC channel properties and methods.
Public class | ChannelRestrictions | Restrictions for ADC channel.
Public class | Channels | Channels class
Public class | ConditionMetEventArgs | ConditionMetEventArgs class
Public class | Module | Module class
Public class | Port | Port class describes properties and methods for ADC port.
Public class | PortRestrictions | Restrictions for ADC port
Public class | Ports | Ports class
Enumerations
 | Enumeration | Description
Public enumeration | EventType |


Channel Class

Channel Class dln.net.dll
Channel class describes ADC channel properties and methods.
Inheritance Hierarchy
System Object
Dln.Adc Channel

Namespace: Dln.Adc
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public class Channel
public class Channel
Public Class Channel
Public Class Channel
public ref class Channel
public ref class Channel
The Channel type exposes the following members.
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetEventConfig | SetEventConfig method configures event parameters.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Enabled | Enable or desable ADC module. Set true or false values. Leave blank to get current property value.
Public property | EventPeriod | Get current event Period value.
Public property | EventType | Get event generation condition for the ADC channel.
Public property | Restrictions | ADC channel restrictions
Public property | SupportedEventTypes | Supported event types property.
Public property | ThresholdHigh | Get a higher threshold value specified in bits.
Public property | ThresholdLow | Get a lower threshold value, specified in bits.
Public property | Value | Retrieve ADC channel value.
Top
Events
 | Name | Description
Public event | ConditionMet | Condition met event handler.
Public event | ConditionMetThreadSafe | Condition met event handler in separate thread.
Top
See Also
Reference
Dln.Adc Namespace


Channel Methods

Channel Methods dln.net.dll

The Channel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetEventConfig | SetEventConfig method configures event parameters.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Channel Class
Dln.Adc Namespace


Channel.SetEventConfig Method

Channel SetEventConfig Method dln.net.dll
SetEventConfig method configures event parameters.

Namespace: Dln.Adc
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public void SetEventConfig(
    EventType eventType,
    int eventPeriod,
    int thresholdLow,
    int thresholdHigh
)
public void SetEventConfig(
    EventType eventType,
    int eventPeriod,
    int thresholdLow,
    int thresholdHigh
)
Public Sub SetEventConfig (
    eventType As EventType,
    eventPeriod As Integer,
    thresholdLow As Integer,
    thresholdHigh As Integer
)
Public Sub SetEventConfig (
    eventType As EventType,
    eventPeriod As Integer,
    thresholdLow As Integer,
    thresholdHigh As Integer
)
public:
void SetEventConfig(
    EventType eventType,
    int eventPeriod,
    int thresholdLow,
    int thresholdHigh
)
public:
void SetEventConfig(
    EventType eventType,
    int eventPeriod,
    int thresholdLow,
    int thresholdHigh
)
Parameters
eventType
Type: Dln.Adc EventType
Must contain the event generation condition for the ADC channel. Use SupportedEventTypes property to get all available ADC event types.
eventPeriod
Type: System Int32
Event Period value. The repeat interval is set in ms (1 to 65,535ms). If the repeat interval is set to 0, the DLN-series adapter will send a single event when the level on the line changes to meet the specified conditions.
thresholdLow
Type: System Int32
The lower threshold value, specified in bits.
thresholdHigh
Type: System Int32
The higher threshold value specified in bits.
See Also
Reference
Channel Class
Dln.Adc Namespace


Channel Properties

Channel Properties dln.net.dll

The Channel type exposes the following members.

Properties
 | Name | Description
Public property | Enabled | Enable or desable ADC module. Set true or false values. Leave blank to get current property value.
Public property | EventPeriod | Get current event Period value.
Public property | EventType | Get event generation condition for the ADC channel.
Public property | Restrictions | ADC channel restrictions
Public property | SupportedEventTypes | Supported event types property.
Public property | ThresholdHigh | Get a higher threshold value specified in bits.
Public property | ThresholdLow | Get a lower threshold value, specified in bits.
Public property | Value | Retrieve ADC channel value.
Top
See Also

Reference

Channel Class
Dln.Adc Namespace


Channel.Enabled Property

Channel Enabled Property dln.net.dll
Enable or desable ADC module. Set true or false values. Leave blank to get current property value.

Namespace: Dln.Adc
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public bool Enabled { get; set; }
public bool Enabled { get; set; }
Public Property Enabled As Boolean
    Get
    Set
Public Property Enabled As Boolean
    Get
    Set
public:
property bool Enabled {
    bool get ();
    void set (bool value);
}
public:
property bool Enabled {
    bool get ();
    void set (bool value);
}
Property Value
Type: Boolean
See Also
Reference
Channel Class
Dln.Adc Namespace


Channel.EventPeriod Property

Channel EventPeriod Property dln.net.dll
Get current event Period value.

Namespace: Dln.Adc
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public int EventPeriod { get; }
public int EventPeriod { get; }
Public ReadOnly Property EventPeriod As Integer
    Get
Public ReadOnly Property EventPeriod As Integer
    Get
public:
property int EventPeriod {
    int get ();
}
public:
property int EventPeriod {
    int get ();
}
Property Value
Type: Int32
See Also
Reference
Channel Class
Dln.Adc Namespace


Channel.EventType Property

Channel EventType Property dln.net.dll
Get event generation condition for the ADC channel.

Namespace: Dln.Adc
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public EventType EventType { get; }
public EventType EventType { get; }
Public ReadOnly Property EventType As EventType
    Get
Public ReadOnly Property EventType As EventType
    Get
public:
property EventType EventType {
    EventType get ();
}
public:
property EventType EventType {
    EventType get ();
}
Property Value
Type: EventType
See Also
Reference
Channel Class
Dln.Adc Namespace


Channel.Restrictions Property

Channel Restrictions Property dln.net.dll
ADC channel restrictions

Namespace: Dln.Adc
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public ChannelRestrictions Restrictions { get; }
public ChannelRestrictions Restrictions { get; }
Public ReadOnly Property Restrictions As ChannelRestrictions
    Get
Public ReadOnly Property Restrictions As ChannelRestrictions
    Get
public:
property ChannelRestrictions^ Restrictions {
    ChannelRestrictions^ get ();
}
public:
property ChannelRestrictions^ Restrictions {
    ChannelRestrictions^ get ();
}
Property Value
Type: ChannelRestrictions
See Also
Reference
Channel Class
Dln.Adc Namespace


Channel.SupportedEventTypes Property

Channel SupportedEventTypes Property dln.net.dll
Supported event types property.

Namespace: Dln.Adc
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public EventType[] SupportedEventTypes { get; }
public EventType[] SupportedEventTypes { get; }
Public ReadOnly Property SupportedEventTypes As EventType()
    Get
Public ReadOnly Property SupportedEventTypes As EventType()
    Get
public:
property array<EventType>^ SupportedEventTypes {
    array<EventType>^ get ();
}
public:
property array<EventType>^ SupportedEventTypes {
    array<EventType>^ get ();
}
Property Value
Type:  EventType
See Also
Reference
Channel Class
Dln.Adc Namespace


Channel.ThresholdHigh Property

Channel ThresholdHigh Property dln.net.dll
Get a higher threshold value specified in bits.

Namespace: Dln.Adc
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public int ThresholdHigh { get; }
public int ThresholdHigh { get; }
Public ReadOnly Property ThresholdHigh As Integer
    Get
Public ReadOnly Property ThresholdHigh As Integer
    Get
public:
property int ThresholdHigh {
    int get ();
}
public:
property int ThresholdHigh {
    int get ();
}
Property Value
Type: Int32
See Also
Reference
Channel Class
Dln.Adc Namespace


Channel.ThresholdLow Property

Channel ThresholdLow Property dln.net.dll
Get a lower threshold value, specified in bits.

Namespace: Dln.Adc
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public int ThresholdLow { get; }
public int ThresholdLow { get; }
Public ReadOnly Property ThresholdLow As Integer
    Get
Public ReadOnly Property ThresholdLow As Integer
    Get
public:
property int ThresholdLow {
    int get ();
}
public:
property int ThresholdLow {
    int get ();
}
Property Value
Type: Int32
See Also
Reference
Channel Class
Dln.Adc Namespace


Channel.Value Property

Channel Value Property dln.net.dll
Retrieve ADC channel value.

Namespace: Dln.Adc
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public int Value { get; }
public int Value { get; }
Public ReadOnly Property Value As Integer
    Get
Public ReadOnly Property Value As Integer
    Get
public:
property int Value {
    int get ();
}
public:
property int Value {
    int get ();
}
Property Value
Type: Int32
See Also
Reference
Channel Class
Dln.Adc Namespace


Channel Events

Channel Events dln.net.dll

The Channel type exposes the following members.

Events
 | Name | Description
Public event | ConditionMet | Condition met event handler.
Public event | ConditionMetThreadSafe | Condition met event handler in separate thread.
Top
See Also

Reference

Channel Class
Dln.Adc Namespace


Channel.ConditionMet Event

Channel ConditionMet Event dln.net.dll
Condition met event handler.

Namespace: Dln.Adc
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public event EventHandler<ConditionMetEventArgs> ConditionMet
public event EventHandler<ConditionMetEventArgs> ConditionMet
Public Event ConditionMet As EventHandler(Of ConditionMetEventArgs)
Public Event ConditionMet As EventHandler(Of ConditionMetEventArgs)
public:
 event EventHandler<ConditionMetEventArgs^>^ ConditionMet {
    void add (EventHandler<ConditionMetEventArgs^>^ value);
    void remove (EventHandler<ConditionMetEventArgs^>^ value);
}
public:
 event EventHandler<ConditionMetEventArgs^>^ ConditionMet {
    void add (EventHandler<ConditionMetEventArgs^>^ value);
    void remove (EventHandler<ConditionMetEventArgs^>^ value);
}
Value
Type: System EventHandler  ConditionMetEventArgs
See Also
Reference
Channel Class
Dln.Adc Namespace


Channel.ConditionMetThreadSafe Event

Channel ConditionMetThreadSafe Event dln.net.dll
Condition met event handler in separate thread.

Namespace: Dln.Adc
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public event EventHandler<ConditionMetEventArgs> ConditionMetThreadSafe
public event EventHandler<ConditionMetEventArgs> ConditionMetThreadSafe
Public Event ConditionMetThreadSafe As EventHandler(Of ConditionMetEventArgs)
Public Event ConditionMetThreadSafe As EventHandler(Of ConditionMetEventArgs)
public:
 event EventHandler<ConditionMetEventArgs^>^ ConditionMetThreadSafe {
    void add (EventHandler<ConditionMetEventArgs^>^ value);
    void remove (EventHandler<ConditionMetEventArgs^>^ value);
}
public:
 event EventHandler<ConditionMetEventArgs^>^ ConditionMetThreadSafe {
    void add (EventHandler<ConditionMetEventArgs^>^ value);
    void remove (EventHandler<ConditionMetEventArgs^>^ value);
}
Value
Type: System EventHandler  ConditionMetEventArgs
See Also
Reference
Channel Class
Dln.Adc Namespace


ChannelRestrictions Class

ChannelRestrictions Class dln.net.dll
Restrictions for ADC channel.
Inheritance Hierarchy
System Object
Dln.Adc ChannelRestrictions

Namespace: Dln.Adc
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public class ChannelRestrictions
public class ChannelRestrictions
Public Class ChannelRestrictions
Public Class ChannelRestrictions
public ref class ChannelRestrictions
public ref class ChannelRestrictions
The ChannelRestrictions type exposes the following members.
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Enabled | Enabled restriction property
Public property | EventPeriod | EventPeriod restriction property
Public property | EventType | EventType restriction property
Public property | SetEventConfig | SetEventConfig restriction property
Public property | SupportedEventTypes | SupportedEventTypes restriction property
Public property | ThresholdHigh | ThresholdHigh restriction property
Public property | ThresholdLow | ThresholdLow restriction property
Public property | Value | Value restriction property
Top
See Also
Reference
Dln.Adc Namespace


ChannelRestrictions Methods

ChannelRestrictions Methods dln.net.dll

The ChannelRestrictions type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ChannelRestrictions Class
Dln.Adc Namespace


ChannelRestrictions Properties

ChannelRestrictions Properties dln.net.dll

The ChannelRestrictions type exposes the following members.

Properties
 | Name | Description
Public property | Enabled | Enabled restriction property
Public property | EventPeriod | EventPeriod restriction property
Public property | EventType | EventType restriction property
Public property | SetEventConfig | SetEventConfig restriction property
Public property | SupportedEventTypes | SupportedEventTypes restriction property
Public property | ThresholdHigh | ThresholdHigh restriction property
Public property | ThresholdLow | ThresholdLow restriction property
Public property | Value | Value restriction property
Top
See Also

Reference

ChannelRestrictions Class
Dln.Adc Namespace


ChannelRestrictions.Enabled Property

ChannelRestrictions Enabled Property dln.net.dll
Enabled restriction property

Namespace: Dln.Adc
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public Restriction Enabled { get; }
public Restriction Enabled { get; }
Public ReadOnly Property Enabled As Restriction
    Get
Public ReadOnly Property Enabled As Restriction
    Get
public:
property Restriction Enabled {
    Restriction get ();
}
public:
property Restriction Enabled {
    Restriction get ();
}
Property Value
Type: Restriction
See Also
Reference
ChannelRestrictions Class
Dln.Adc Namespace


ChannelRestrictions.EventPeriod Property

ChannelRestrictions EventPeriod Property dln.net.dll
EventPeriod restriction property

Namespace: Dln.Adc
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public Restriction EventPeriod { get; }
public Restriction EventPeriod { get; }
Public ReadOnly Property EventPeriod As Restriction
    Get
Public ReadOnly Property EventPeriod As Restriction
    Get
public:
property Restriction EventPeriod {
    Restriction get ();
}
public:
property Restriction EventPeriod {
    Restriction get ();
}
Property Value
Type: Restriction
See Also
Reference
ChannelRestrictions Class
Dln.Adc Namespace


ChannelRestrictions.EventType Property

ChannelRestrictions EventType Property dln.net.dll
EventType restriction property

Namespace: Dln.Adc
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public Restriction EventType { get; }
public Restriction EventType { get; }
Public ReadOnly Property EventType As Restriction
    Get
Public ReadOnly Property EventType As Restriction
    Get
public:
property Restriction EventType {
    Restriction get ();
}
public:
property Restriction EventType {
    Restriction get ();
}
Property Value
Type: Restriction
See Also
Reference
ChannelRestrictions Class
Dln.Adc Namespace


ChannelRestrictions.SetEventConfig Property

ChannelRestrictions SetEventConfig Property dln.net.dll
SetEventConfig restriction property

Namespace: Dln.Adc
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public Restriction SetEventConfig { get; }
public Restriction SetEventConfig { get; }
Public ReadOnly Property SetEventConfig As Restriction
    Get
Public ReadOnly Property SetEventConfig As Restriction
    Get
public:
property Restriction SetEventConfig {
    Restriction get ();
}
public:
property Restriction SetEventConfig {
    Restriction get ();
}
Property Value
Type: Restriction
See Also
Reference
ChannelRestrictions Class
Dln.Adc Namespace


ChannelRestrictions.SupportedEventTypes Property

ChannelRestrictions SupportedEventTypes Property dln.net.dll
SupportedEventTypes restriction property

Namespace: Dln.Adc
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public Restriction SupportedEventTypes { get; }
public Restriction SupportedEventTypes { get; }
Public ReadOnly Property SupportedEventTypes As Restriction
    Get
Public ReadOnly Property SupportedEventTypes As Restriction
    Get
public:
property Restriction SupportedEventTypes {
    Restriction get ();
}
public:
property Restriction SupportedEventTypes {
    Restriction get ();
}
Property Value
Type: Restriction
See Also
Reference
ChannelRestrictions Class
Dln.Adc Namespace


ChannelRestrictions.ThresholdHigh Property

ChannelRestrictions ThresholdHigh Property dln.net.dll
ThresholdHigh restriction property

Namespace: Dln.Adc
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public Restriction ThresholdHigh { get; }
public Restriction ThresholdHigh { get; }
Public ReadOnly Property ThresholdHigh As Restriction
    Get
Public ReadOnly Property ThresholdHigh As Restriction
    Get
public:
property Restriction ThresholdHigh {
    Restriction get ();
}
public:
property Restriction ThresholdHigh {
    Restriction get ();
}
Property Value
Type: Restriction
See Also
Reference
ChannelRestrictions Class
Dln.Adc Namespace


ChannelRestrictions.ThresholdLow Property

ChannelRestrictions ThresholdLow Property dln.net.dll
ThresholdLow restriction property

Namespace: Dln.Adc
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public Restriction ThresholdLow { get; }
public Restriction ThresholdLow { get; }
Public ReadOnly Property ThresholdLow As Restriction
    Get
Public ReadOnly Property ThresholdLow As Restriction
    Get
public:
property Restriction ThresholdLow {
    Restriction get ();
}
public:
property Restriction ThresholdLow {
    Restriction get ();
}
Property Value
Type: Restriction
See Also
Reference
ChannelRestrictions Class
Dln.Adc Namespace


ChannelRestrictions.Value Property

ChannelRestrictions Value Property dln.net.dll
Value restriction property

Namespace: Dln.Adc
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public Restriction Value { get; }
public Restriction Value { get; }
Public ReadOnly Property Value As Restriction
    Get
Public ReadOnly Property Value As Restriction
    Get
public:
property Restriction Value {
    Restriction get ();
}
public:
property Restriction Value {
    Restriction get ();
}
Property Value
Type: Restriction
See Also
Reference
ChannelRestrictions Class
Dln.Adc Namespace


Channels Class

Channels Class dln.net.dll
Channels class
Inheritance Hierarchy
System Object
System.Collections.ObjectModel ReadOnlyCollection Channel
Dln.Adc Channels

Namespace: Dln.Adc
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public class Channels : ReadOnlyCollection<Channel>
public class Channels : ReadOnlyCollection<Channel>
Public Class Channels
    Inherits ReadOnlyCollection(Of Channel)
Public Class Channels
    Inherits ReadOnlyCollection(Of Channel)
public ref class Channels : public ReadOnlyCollection<Channel^>
public ref class Channels : public ReadOnlyCollection<Channel^>
The Channels type exposes the following members.
Methods
 | Name | Description
Public method | Contains | Determines whether an element is in the ReadOnlyCollection T . (Inherited from ReadOnlyCollection Channel .)
Public method | CopyTo | Copies the entire ReadOnlyCollection T to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from ReadOnlyCollection Channel .)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the ReadOnlyCollection T . (Inherited from ReadOnlyCollection Channel .)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Public method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ReadOnlyCollection T . (Inherited from ReadOnlyCollection Channel .)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the ReadOnlyCollection T instance. (Inherited from ReadOnlyCollection Channel .)
Public property | Item |
Protected property | Items | Returns the IList T that the ReadOnlyCollection T wraps. (Inherited from ReadOnlyCollection Channel .)
Top
See Also
Reference
Dln.Adc Namespace


Channels Methods

Channels Methods dln.net.dll

The Channels type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Determines whether an element is in the ReadOnlyCollection T . (Inherited from ReadOnlyCollection Channel .)
Public method | CopyTo | Copies the entire ReadOnlyCollection T to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from ReadOnlyCollection Channel .)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the ReadOnlyCollection T . (Inherited from ReadOnlyCollection Channel .)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Public method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ReadOnlyCollection T . (Inherited from ReadOnlyCollection Channel .)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Channels Class
Dln.Adc Namespace


Channels Properties

Channels Properties dln.net.dll

The Channels type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the ReadOnlyCollection T instance. (Inherited from ReadOnlyCollection Channel .)
Public property | Item |
Protected property | Items | Returns the IList T that the ReadOnlyCollection T wraps. (Inherited from ReadOnlyCollection Channel .)
Top
See Also

Reference

Channels Class
Dln.Adc Namespace


Channels.Item Property

Channels Item Property dln.net.dll

[Missing <summary> documentation for "P:Dln.Adc.Channels.Item(System.Int32)"]

Namespace: Dln.Adc
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public Channel this[
    int index
] { get; }
public Channel this[
    int index
] { get; }
Public ReadOnly Default Property Item (
    index As Integer
) As Channel
    Get
Public ReadOnly Default Property Item (
    index As Integer
) As Channel
    Get
public:
property Channel^ default[int index] {
    Channel^ get (int index);
}
public:
property Channel^ default[int index] {
    Channel^ get (int index);
}
Parameters
index
Type: System Int32
Channel index
Return Value
Type: Channel
Channel by index
See Also
Reference
Channels Class
Dln.Adc Namespace


ConditionMetEventArgs Class

ConditionMetEventArgs Class dln.net.dll
ConditionMetEventArgs class
Inheritance Hierarchy
System Object
System EventArgs
Dln.Adc ConditionMetEventArgs

Namespace: Dln.Adc
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public class ConditionMetEventArgs : EventArgs
public class ConditionMetEventArgs : EventArgs
Public Class ConditionMetEventArgs
    Inherits EventArgs
Public Class ConditionMetEventArgs
    Inherits EventArgs
public ref class ConditionMetEventArgs : public EventArgs
public ref class ConditionMetEventArgs : public EventArgs
The ConditionMetEventArgs type exposes the following members.
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Channel | ADC port channel
Public property | EventType | Event type
Public property | Port | ADC module port
Public property | Value | ADC channel value
Top
See Also
Reference
Dln.Adc Namespace


ConditionMetEventArgs Methods

ConditionMetEventArgs Methods dln.net.dll

The ConditionMetEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ConditionMetEventArgs Class
Dln.Adc Namespace


ConditionMetEventArgs Properties

ConditionMetEventArgs Properties dln.net.dll

The ConditionMetEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Channel | ADC port channel
Public property | EventType | Event type
Public property | Port | ADC module port
Public property | Value | ADC channel value
Top
See Also

Reference

ConditionMetEventArgs Class
Dln.Adc Namespace


ConditionMetEventArgs.Channel Property

ConditionMetEventArgs Channel Property dln.net.dll
ADC port channel

Namespace: Dln.Adc
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public int Channel { get; }
public int Channel { get; }
Public ReadOnly Property Channel As Integer
    Get
Public ReadOnly Property Channel As Integer
    Get
public:
property int Channel {
    int get ();
}
public:
property int Channel {
    int get ();
}
Property Value
Type: Int32
See Also
Reference
ConditionMetEventArgs Class
Dln.Adc Namespace


ConditionMetEventArgs.EventType Property

ConditionMetEventArgs EventType Property dln.net.dll
Event type

Namespace: Dln.Adc
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public EventType EventType { get; }
public EventType EventType { get; }
Public ReadOnly Property EventType As EventType
    Get
Public ReadOnly Property EventType As EventType
    Get
public:
property EventType EventType {
    EventType get ();
}
public:
property EventType EventType {
    EventType get ();
}
Property Value
Type: EventType
See Also
Reference
ConditionMetEventArgs Class
Dln.Adc Namespace


ConditionMetEventArgs.Port Property

ConditionMetEventArgs Port Property dln.net.dll
ADC module port

Namespace: Dln.Adc
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public int Port { get; }
public int Port { get; }
Public ReadOnly Property Port As Integer
    Get
Public ReadOnly Property Port As Integer
    Get
public:
property int Port {
    int get ();
}
public:
property int Port {
    int get ();
}
Property Value
Type: Int32
See Also
Reference
ConditionMetEventArgs Class
Dln.Adc Namespace


ConditionMetEventArgs.Value Property

ConditionMetEventArgs Value Property dln.net.dll
ADC channel value

Namespace: Dln.Adc
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public int Value { get; }
public int Value { get; }
Public ReadOnly Property Value As Integer
    Get
Public ReadOnly Property Value As Integer
    Get
public:
property int Value {
    int get ();
}
public:
property int Value {
    int get ();
}
Property Value
Type: Int32
See Also
Reference
ConditionMetEventArgs Class
Dln.Adc Namespace


EventType Enumeration

EventType Enumeration dln.net.dll

[Missing <summary> documentation for "T:Dln.Adc.EventType"]

Namespace: Dln.Adc
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public enum EventType
public enum EventType
Public Enumeration EventType
Public Enumeration EventType
public enum class EventType
public enum class EventType
Members
Member name | Value | Description
None | 0 |
Below | 1 |
Above | 2 |
Outside | 3 |
Inside | 4 |
Always | 5 |
See Also
Reference
Dln.Adc Namespace


Module Class

Module Class dln.net.dll
Module class
Inheritance Hierarchy
System Object
Dln.Adc Module

Namespace: Dln.Adc
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public class Module
public class Module
Public Class Module
Public Class Module
public ref class Module
public ref class Module
The Module type exposes the following members.
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Ports | Retrieve ADC module ports
Top
See Also
Reference
Dln.Adc Namespace


Module Methods

Module Methods dln.net.dll

The Module type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Module Class
Dln.Adc Namespace


Module Properties

Module Properties dln.net.dll

The Module type exposes the following members.

Properties
 | Name | Description
Public property | Ports | Retrieve ADC module ports
Top
See Also

Reference

Module Class
Dln.Adc Namespace


Module.Ports Property

Module Ports Property dln.net.dll
Retrieve ADC module ports

Namespace: Dln.Adc
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public Ports Ports { get; }
public Ports Ports { get; }
Public ReadOnly Property Ports As Ports
    Get
Public ReadOnly Property Ports As Ports
    Get
public:
property Ports^ Ports {
    Ports^ get ();
}
public:
property Ports^ Ports {
    Ports^ get ();
}
Property Value
Type: Ports
See Also
Reference
Module Class
Dln.Adc Namespace


Port Class

Port Class dln.net.dll
Port class describes properties and methods for ADC port.
Inheritance Hierarchy
System Object
Dln.Adc Port

Namespace: Dln.Adc
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public class Port
public class Port
Public Class Port
Public Class Port
public ref class Port
public ref class Port
The Port type exposes the following members.
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Channels | ADC module port channels
Public property | Enabled | Set ADC port to enabled or disabled state. Provide true or false values respectively.
Public property | Resolution | Resolution property. Use SupportedResolutions property to get available values.
Public property | Restrictions | ADC port restrictions
Public property | SupportedResolutions | Get supported ADC port resolution values
Public property | Values | Get all ADC channels values for current ADC port.
Top
See Also
Reference
Dln.Adc Namespace


Port Methods

Port Methods dln.net.dll

The Port type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Port Class
Dln.Adc Namespace


Port Properties

Port Properties dln.net.dll

The Port type exposes the following members.

Properties
 | Name | Description
Public property | Channels | ADC module port channels
Public property | Enabled | Set ADC port to enabled or disabled state. Provide true or false values respectively.
Public property | Resolution | Resolution property. Use SupportedResolutions property to get available values.
Public property | Restrictions | ADC port restrictions
Public property | SupportedResolutions | Get supported ADC port resolution values
Public property | Values | Get all ADC channels values for current ADC port.
Top
See Also

Reference

Port Class
Dln.Adc Namespace


Port.Channels Property

Port Channels Property dln.net.dll
ADC module port channels

Namespace: Dln.Adc
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public Channels Channels { get; }
public Channels Channels { get; }
Public ReadOnly Property Channels As Channels
    Get
Public ReadOnly Property Channels As Channels
    Get
public:
property Channels^ Channels {
    Channels^ get ();
}
public:
property Channels^ Channels {
    Channels^ get ();
}
Property Value
Type: Channels
See Also
Reference
Port Class
Dln.Adc Namespace


Port.Enabled Property

Port Enabled Property dln.net.dll
Set ADC port to enabled or disabled state. Provide true or false values respectively.

Namespace: Dln.Adc
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public bool Enabled { get; set; }
public bool Enabled { get; set; }
Public Property Enabled As Boolean
    Get
    Set
Public Property Enabled As Boolean
    Get
    Set
public:
property bool Enabled {
    bool get ();
    void set (bool value);
}
public:
property bool Enabled {
    bool get ();
    void set (bool value);
}
Property Value
Type: Boolean
See Also
Reference
Port Class
Dln.Adc Namespace


Port.Resolution Property

Port Resolution Property dln.net.dll
Resolution property. Use SupportedResolutions property to get available values.

Namespace: Dln.Adc
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public int Resolution { get; set; }
public int Resolution { get; set; }
Public Property Resolution As Integer
    Get
    Set
Public Property Resolution As Integer
    Get
    Set
public:
property int Resolution {
    int get ();
    void set (int value);
}
public:
property int Resolution {
    int get ();
    void set (int value);
}
Property Value
Type: Int32
See Also
Reference
Port Class
Dln.Adc Namespace


Port.Restrictions Property

Port Restrictions Property dln.net.dll
ADC port restrictions

Namespace: Dln.Adc
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public PortRestrictions Restrictions { get; }
public PortRestrictions Restrictions { get; }
Public ReadOnly Property Restrictions As PortRestrictions
    Get
Public ReadOnly Property Restrictions As PortRestrictions
    Get
public:
property PortRestrictions^ Restrictions {
    PortRestrictions^ get ();
}
public:
property PortRestrictions^ Restrictions {
    PortRestrictions^ get ();
}
Property Value
Type: PortRestrictions
See Also
Reference
Port Class
Dln.Adc Namespace


Port.SupportedResolutions Property

Port SupportedResolutions Property dln.net.dll
Get supported ADC port resolution values

Namespace: Dln.Adc
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public int[] SupportedResolutions { get; }
public int[] SupportedResolutions { get; }
Public ReadOnly Property SupportedResolutions As Integer()
    Get
Public ReadOnly Property SupportedResolutions As Integer()
    Get
public:
property array<int>^ SupportedResolutions {
    array<int>^ get ();
}
public:
property array<int>^ SupportedResolutions {
    array<int>^ get ();
}
Property Value
Type:  Int32
See Also
Reference
Port Class
Dln.Adc Namespace


Port.Values Property

Port Values Property dln.net.dll
Get all ADC channels values for current ADC port.

Namespace: Dln.Adc
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public int[] Values { get; }
public int[] Values { get; }
Public ReadOnly Property Values As Integer()
    Get
Public ReadOnly Property Values As Integer()
    Get
public:
property array<int>^ Values {
    array<int>^ get ();
}
public:
property array<int>^ Values {
    array<int>^ get ();
}
Property Value
Type:  Int32
See Also
Reference
Port Class
Dln.Adc Namespace


PortRestrictions Class

PortRestrictions Class dln.net.dll
Restrictions for ADC port
Inheritance Hierarchy
System Object
Dln.Adc PortRestrictions

Namespace: Dln.Adc
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public class PortRestrictions
public class PortRestrictions
Public Class PortRestrictions
Public Class PortRestrictions
public ref class PortRestrictions
public ref class PortRestrictions
The PortRestrictions type exposes the following members.
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Enabled | Enabled restriction property
Public property | Resolution | Resolution restriction property
Public property | SupportedResolutions | SuportedResolutions restriction property
Public property | Values | Values restriction property
Top
See Also
Reference
Dln.Adc Namespace


PortRestrictions Methods

PortRestrictions Methods dln.net.dll

The PortRestrictions type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PortRestrictions Class
Dln.Adc Namespace


PortRestrictions Properties

PortRestrictions Properties dln.net.dll

The PortRestrictions type exposes the following members.

Properties
 | Name | Description
Public property | Enabled | Enabled restriction property
Public property | Resolution | Resolution restriction property
Public property | SupportedResolutions | SuportedResolutions restriction property
Public property | Values | Values restriction property
Top
See Also

Reference

PortRestrictions Class
Dln.Adc Namespace


PortRestrictions.Enabled Property

PortRestrictions Enabled Property dln.net.dll
Enabled restriction property

Namespace: Dln.Adc
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public Restriction Enabled { get; }
public Restriction Enabled { get; }
Public ReadOnly Property Enabled As Restriction
    Get
Public ReadOnly Property Enabled As Restriction
    Get
public:
property Restriction Enabled {
    Restriction get ();
}
public:
property Restriction Enabled {
    Restriction get ();
}
Property Value
Type: Restriction
See Also
Reference
PortRestrictions Class
Dln.Adc Namespace


PortRestrictions.Resolution Property

PortRestrictions Resolution Property dln.net.dll
Resolution restriction property

Namespace: Dln.Adc
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public Restriction Resolution { get; }
public Restriction Resolution { get; }
Public ReadOnly Property Resolution As Restriction
    Get
Public ReadOnly Property Resolution As Restriction
    Get
public:
property Restriction Resolution {
    Restriction get ();
}
public:
property Restriction Resolution {
    Restriction get ();
}
Property Value
Type: Restriction
See Also
Reference
PortRestrictions Class
Dln.Adc Namespace


PortRestrictions.SupportedResolutions Property

PortRestrictions SupportedResolutions Property dln.net.dll
SuportedResolutions restriction property

Namespace: Dln.Adc
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public Restriction SupportedResolutions { get; }
public Restriction SupportedResolutions { get; }
Public ReadOnly Property SupportedResolutions As Restriction
    Get
Public ReadOnly Property SupportedResolutions As Restriction
    Get
public:
property Restriction SupportedResolutions {
    Restriction get ();
}
public:
property Restriction SupportedResolutions {
    Restriction get ();
}
Property Value
Type: Restriction
See Also
Reference
PortRestrictions Class
Dln.Adc Namespace


PortRestrictions.Values Property

PortRestrictions Values Property dln.net.dll
Values restriction property

Namespace: Dln.Adc
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public Restriction Values { get; }
public Restriction Values { get; }
Public ReadOnly Property Values As Restriction
    Get
Public ReadOnly Property Values As Restriction
    Get
public:
property Restriction Values {
    Restriction get ();
}
public:
property Restriction Values {
    Restriction get ();
}
Property Value
Type: Restriction
See Also
Reference
PortRestrictions Class
Dln.Adc Namespace


Ports Class

Ports Class dln.net.dll
Ports class
Inheritance Hierarchy
System Object
System.Collections.ObjectModel ReadOnlyCollection Port
Dln.Adc Ports

Namespace: Dln.Adc
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public class Ports : ReadOnlyCollection<Port>
public class Ports : ReadOnlyCollection<Port>
Public Class Ports
    Inherits ReadOnlyCollection(Of Port)
Public Class Ports
    Inherits ReadOnlyCollection(Of Port)
public ref class Ports : public ReadOnlyCollection<Port^>
public ref class Ports : public ReadOnlyCollection<Port^>
The Ports type exposes the following members.
Methods
 | Name | Description
Public method | Contains | Determines whether an element is in the ReadOnlyCollection T . (Inherited from ReadOnlyCollection Port .)
Public method | CopyTo | Copies the entire ReadOnlyCollection T to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from ReadOnlyCollection Port .)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the ReadOnlyCollection T . (Inherited from ReadOnlyCollection Port .)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Public method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ReadOnlyCollection T . (Inherited from ReadOnlyCollection Port .)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the ReadOnlyCollection T instance. (Inherited from ReadOnlyCollection Port .)
Public property | Item |
Protected property | Items | Returns the IList T that the ReadOnlyCollection T wraps. (Inherited from ReadOnlyCollection Port .)
Top
See Also
Reference
Dln.Adc Namespace


Ports Methods

Ports Methods dln.net.dll

The Ports type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Determines whether an element is in the ReadOnlyCollection T . (Inherited from ReadOnlyCollection Port .)
Public method | CopyTo | Copies the entire ReadOnlyCollection T to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from ReadOnlyCollection Port .)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the ReadOnlyCollection T . (Inherited from ReadOnlyCollection Port .)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Public method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ReadOnlyCollection T . (Inherited from ReadOnlyCollection Port .)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Ports Class
Dln.Adc Namespace


Ports Properties

Ports Properties dln.net.dll

The Ports type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the ReadOnlyCollection T instance. (Inherited from ReadOnlyCollection Port .)
Public property | Item |
Protected property | Items | Returns the IList T that the ReadOnlyCollection T wraps. (Inherited from ReadOnlyCollection Port .)
Top
See Also

Reference

Ports Class
Dln.Adc Namespace


Ports.Item Property

Ports Item Property dln.net.dll

[Missing <summary> documentation for "P:Dln.Adc.Ports.Item(System.Int32)"]

Namespace: Dln.Adc
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public Port this[
    int index
] { get; }
public Port this[
    int index
] { get; }
Public ReadOnly Default Property Item (
    index As Integer
) As Port
    Get
Public ReadOnly Default Property Item (
    index As Integer
) As Port
    Get
public:
property Port^ default[int index] {
    Port^ get (int index);
}
public:
property Port^ default[int index] {
    Port^ get (int index);
}
Parameters
index
Type: System Int32
Port insex
Return Value
Type: Port
Port number
See Also
Reference
Ports Class
Dln.Adc Namespace


Dln.Exceptions Namespace

Dln.Exceptions Namespace dln.net.dll
The Dln.Exceptions namespace describes dln.net.dll library exceptions.
Classes
 | Class | Description
Public class | AlreadyConnectedException |
Public class | DlnError |
Public class | DlnException |
Public class | DlnWarning |
Public class | HardwareNotFoundException |
Public class | PinInUseException |
Public class | ResponseWaitTimeoutException |
Public class | ValueRoundedException |


AlreadyConnectedException Class

AlreadyConnectedException Class dln.net.dll

[Missing <summary> documentation for "T:Dln.Exceptions.AlreadyConnectedException"]

Inheritance Hierarchy
System Object
System Exception
Dln.Exceptions DlnException
Dln.Exceptions DlnWarning
Dln.Exceptions AlreadyConnectedException

Namespace: Dln.Exceptions
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public class AlreadyConnectedException : DlnWarning
public class AlreadyConnectedException : DlnWarning
Public Class AlreadyConnectedException
    Inherits DlnWarning
Public Class AlreadyConnectedException
    Inherits DlnWarning
public ref class AlreadyConnectedException : public DlnWarning
public ref class AlreadyConnectedException : public DlnWarning
The AlreadyConnectedException type exposes the following members.
Constructors
 | Name | Description
Public method | AlreadyConnectedException | Initializes a new instance of the AlreadyConnectedException class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Fields
 | Name | Description
Protected field | _message | (Inherited from DlnException.)
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | (Inherited from DlnException.)
Public property | OtherConnection |
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also
Reference
Dln.Exceptions Namespace


AlreadyConnectedException Constructor

AlreadyConnectedException Constructor dln.net.dll
Initializes a new instance of the AlreadyConnectedException class

Namespace: Dln.Exceptions
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public AlreadyConnectedException(
    Connection otherConnection
)
public AlreadyConnectedException(
    Connection otherConnection
)
Public Sub New (
    otherConnection As Connection
)
Public Sub New (
    otherConnection As Connection
)
public:
AlreadyConnectedException(
    Connection^ otherConnection
)
public:
AlreadyConnectedException(
    Connection^ otherConnection
)
Parameters
otherConnection
Type: Dln Connection
[Missing <param name="otherConnection"/> documentation for "M:Dln.Exceptions.AlreadyConnectedException.#ctor(Dln.Connection)"]
See Also
Reference
AlreadyConnectedException Class
Dln.Exceptions Namespace


AlreadyConnectedException Fields

AlreadyConnectedException Fields dln.net.dll

The AlreadyConnectedException type exposes the following members.

Fields
 | Name | Description
Protected field | _message | (Inherited from DlnException.)
Top
See Also

Reference

AlreadyConnectedException Class
Dln.Exceptions Namespace


AlreadyConnectedException Methods

AlreadyConnectedException Methods dln.net.dll

The AlreadyConnectedException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

AlreadyConnectedException Class
Dln.Exceptions Namespace


AlreadyConnectedException Properties

AlreadyConnectedException Properties dln.net.dll

The AlreadyConnectedException type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | (Inherited from DlnException.)
Public property | OtherConnection |
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

AlreadyConnectedException Class
Dln.Exceptions Namespace


AlreadyConnectedException.OtherConnection Property

AlreadyConnectedException OtherConnection Property dln.net.dll

[Missing <summary> documentation for "P:Dln.Exceptions.AlreadyConnectedException.OtherConnection"]

Namespace: Dln.Exceptions
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public Connection OtherConnection { get; }
public Connection OtherConnection { get; }
Public ReadOnly Property OtherConnection As Connection
    Get
Public ReadOnly Property OtherConnection As Connection
    Get
public:
property Connection^ OtherConnection {
    Connection^ get ();
}
public:
property Connection^ OtherConnection {
    Connection^ get ();
}
Property Value
Type: Connection
See Also
Reference
AlreadyConnectedException Class
Dln.Exceptions Namespace


DlnError Class

DlnError Class dln.net.dll

[Missing <summary> documentation for "T:Dln.Exceptions.DlnError"]

Inheritance Hierarchy
System Object
System Exception
Dln.Exceptions DlnException
Dln.Exceptions DlnError
Dln.Exceptions HardwareNotFoundException
Dln.Exceptions PinInUseException
Dln.Exceptions ResponseWaitTimeoutException

Namespace: Dln.Exceptions
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public class DlnError : DlnException
public class DlnError : DlnException
Public Class DlnError
    Inherits DlnException
Public Class DlnError
    Inherits DlnException
public ref class DlnError : public DlnException
public ref class DlnError : public DlnException
The DlnError type exposes the following members.
Constructors
 | Name | Description
Public method | DlnError(Result) | Initializes a new instance of the DlnError class
Public method | DlnError(String, Result) | Initializes a new instance of the DlnError class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Fields
 | Name | Description
Protected field | _message | (Inherited from DlnException.)
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | (Inherited from DlnException.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also
Reference
Dln.Exceptions Namespace


DlnError Constructor

DlnError Constructor dln.net.dll
Overload List
 | Name | Description
Public method | DlnError(Result) | Initializes a new instance of the DlnError class
Public method | DlnError(String, Result) | Initializes a new instance of the DlnError class
Top
See Also

Reference

DlnError Class
Dln.Exceptions Namespace


DlnError Constructor (Result)

DlnError Constructor (Result) dln.net.dll
Initializes a new instance of the DlnError class

Namespace: Dln.Exceptions
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public DlnError(
    Result result
)
public DlnError(
    Result result
)
Public Sub New (
    result As Result
)
Public Sub New (
    result As Result
)
public:
DlnError(
    Result result
)
public:
DlnError(
    Result result
)
Parameters
result
Type: Dln Result
[Missing <param name="result"/> documentation for "M:Dln.Exceptions.DlnError.#ctor(Dln.Result)"]
See Also
Reference
DlnError Class
DlnError Overload
Dln.Exceptions Namespace


DlnError Constructor (String, Result)

DlnError Constructor (String, Result) dln.net.dll
Initializes a new instance of the DlnError class

Namespace: Dln.Exceptions
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public DlnError(
    string message,
    Result result
)
public DlnError(
    string message,
    Result result
)
Public Sub New (
    message As String,
    result As Result
)
Public Sub New (
    message As String,
    result As Result
)
public:
DlnError(
    String^ message,
    Result result
)
public:
DlnError(
    String^ message,
    Result result
)
Parameters
message
Type: System String
[Missing <param name="message"/> documentation for "M:Dln.Exceptions.DlnError.#ctor(System.String,Dln.Result)"]
result
Type: Dln Result
[Missing <param name="result"/> documentation for "M:Dln.Exceptions.DlnError.#ctor(System.String,Dln.Result)"]
See Also
Reference
DlnError Class
DlnError Overload
Dln.Exceptions Namespace


DlnError Fields

DlnError Fields dln.net.dll

The DlnError type exposes the following members.

Fields
 | Name | Description
Protected field | _message | (Inherited from DlnException.)
Top
See Also

Reference

DlnError Class
Dln.Exceptions Namespace


DlnError Methods

DlnError Methods dln.net.dll

The DlnError type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

DlnError Class
Dln.Exceptions Namespace


DlnError Properties

DlnError Properties dln.net.dll

The DlnError type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | (Inherited from DlnException.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

DlnError Class
Dln.Exceptions Namespace


DlnException Class

DlnException Class dln.net.dll

[Missing <summary> documentation for "T:Dln.Exceptions.DlnException"]

Inheritance Hierarchy
System Object
System Exception
Dln.Exceptions DlnException
Dln.Exceptions DlnError
Dln.Exceptions DlnWarning

Namespace: Dln.Exceptions
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public class DlnException : Exception
public class DlnException : Exception
Public Class DlnException
    Inherits Exception
Public Class DlnException
    Inherits Exception
public ref class DlnException : public Exception
public ref class DlnException : public Exception
The DlnException type exposes the following members.
Constructors
 | Name | Description
Public method | DlnException(Result) | Initializes a new instance of the DlnException class
Public method | DlnException(String, Result) | Initializes a new instance of the DlnException class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Fields
 | Name | Description
Protected field | _message |
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | (Overrides Exception Message.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also
Reference
Dln.Exceptions Namespace


DlnException Constructor

DlnException Constructor dln.net.dll
Overload List
 | Name | Description
Public method | DlnException(Result) | Initializes a new instance of the DlnException class
Public method | DlnException(String, Result) | Initializes a new instance of the DlnException class
Top
See Also

Reference

DlnException Class
Dln.Exceptions Namespace


DlnException Constructor (Result)

DlnException Constructor (Result) dln.net.dll
Initializes a new instance of the DlnException class

Namespace: Dln.Exceptions
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public DlnException(
    Result result
)
public DlnException(
    Result result
)
Public Sub New (
    result As Result
)
Public Sub New (
    result As Result
)
public:
DlnException(
    Result result
)
public:
DlnException(
    Result result
)
Parameters
result
Type: Dln Result
[Missing <param name="result"/> documentation for "M:Dln.Exceptions.DlnException.#ctor(Dln.Result)"]
See Also
Reference
DlnException Class
DlnException Overload
Dln.Exceptions Namespace


DlnException Constructor (String, Result)

DlnException Constructor (String, Result) dln.net.dll
Initializes a new instance of the DlnException class

Namespace: Dln.Exceptions
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public DlnException(
    string message,
    Result result
)
public DlnException(
    string message,
    Result result
)
Public Sub New (
    message As String,
    result As Result
)
Public Sub New (
    message As String,
    result As Result
)
public:
DlnException(
    String^ message,
    Result result
)
public:
DlnException(
    String^ message,
    Result result
)
Parameters
message
Type: System String
[Missing <param name="message"/> documentation for "M:Dln.Exceptions.DlnException.#ctor(System.String,Dln.Result)"]
result
Type: Dln Result
[Missing <param name="result"/> documentation for "M:Dln.Exceptions.DlnException.#ctor(System.String,Dln.Result)"]
See Also
Reference
DlnException Class
DlnException Overload
Dln.Exceptions Namespace


DlnException Fields

DlnException Fields dln.net.dll

The DlnException type exposes the following members.

Fields
 | Name | Description
Protected field | _message |
Top
See Also

Reference

DlnException Class
Dln.Exceptions Namespace


DlnException._message Field

DlnException _message Field dln.net.dll

[Missing <summary> documentation for "F:Dln.Exceptions.DlnException._message"]

Namespace: Dln.Exceptions
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
protected string _message
protected string _message
Protected _message As String
Protected _message As String
protected:
String^ _message
protected:
String^ _message
Field Value
Type: String
See Also
Reference
DlnException Class
Dln.Exceptions Namespace


DlnException Methods

DlnException Methods dln.net.dll

The DlnException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

DlnException Class
Dln.Exceptions Namespace


DlnException Properties

DlnException Properties dln.net.dll

The DlnException type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | (Overrides Exception Message.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

DlnException Class
Dln.Exceptions Namespace


DlnException.Message Property

DlnException Message Property dln.net.dll

[Missing <summary> documentation for "P:Dln.Exceptions.DlnException.Message"]

Namespace: Dln.Exceptions
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public override string Message { get; }
public override string Message { get; }
Public Overrides ReadOnly Property Message As String
    Get
Public Overrides ReadOnly Property Message As String
    Get
public:
virtual property String^ Message {
    String^ get () override;
}
public:
virtual property String^ Message {
    String^ get () override;
}
Property Value
Type: String
Implements
_Exception Message
See Also
Reference
DlnException Class
Dln.Exceptions Namespace


DlnWarning Class

DlnWarning Class dln.net.dll

[Missing <summary> documentation for "T:Dln.Exceptions.DlnWarning"]

Inheritance Hierarchy
System Object
System Exception
Dln.Exceptions DlnException
Dln.Exceptions DlnWarning
Dln.Exceptions AlreadyConnectedException
Dln.Exceptions ValueRoundedException

Namespace: Dln.Exceptions
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public class DlnWarning : DlnException
public class DlnWarning : DlnException
Public Class DlnWarning
    Inherits DlnException
Public Class DlnWarning
    Inherits DlnException
public ref class DlnWarning : public DlnException
public ref class DlnWarning : public DlnException
The DlnWarning type exposes the following members.
Constructors
 | Name | Description
Public method | DlnWarning(Result) | Initializes a new instance of the DlnWarning class
Public method | DlnWarning(String, Result) | Initializes a new instance of the DlnWarning class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Fields
 | Name | Description
Protected field | _message | (Inherited from DlnException.)
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | (Inherited from DlnException.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also
Reference
Dln.Exceptions Namespace


DlnWarning Constructor

DlnWarning Constructor dln.net.dll
Overload List
 | Name | Description
Public method | DlnWarning(Result) | Initializes a new instance of the DlnWarning class
Public method | DlnWarning(String, Result) | Initializes a new instance of the DlnWarning class
Top
See Also

Reference

DlnWarning Class
Dln.Exceptions Namespace


DlnWarning Constructor (Result)

DlnWarning Constructor (Result) dln.net.dll
Initializes a new instance of the DlnWarning class

Namespace: Dln.Exceptions
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public DlnWarning(
    Result result
)
public DlnWarning(
    Result result
)
Public Sub New (
    result As Result
)
Public Sub New (
    result As Result
)
public:
DlnWarning(
    Result result
)
public:
DlnWarning(
    Result result
)
Parameters
result
Type: Dln Result
[Missing <param name="result"/> documentation for "M:Dln.Exceptions.DlnWarning.#ctor(Dln.Result)"]
See Also
Reference
DlnWarning Class
DlnWarning Overload
Dln.Exceptions Namespace


DlnWarning Constructor (String, Result)

DlnWarning Constructor (String, Result) dln.net.dll
Initializes a new instance of the DlnWarning class

Namespace: Dln.Exceptions
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public DlnWarning(
    string message,
    Result result
)
public DlnWarning(
    string message,
    Result result
)
Public Sub New (
    message As String,
    result As Result
)
Public Sub New (
    message As String,
    result As Result
)
public:
DlnWarning(
    String^ message,
    Result result
)
public:
DlnWarning(
    String^ message,
    Result result
)
Parameters
message
Type: System String
[Missing <param name="message"/> documentation for "M:Dln.Exceptions.DlnWarning.#ctor(System.String,Dln.Result)"]
result
Type: Dln Result
[Missing <param name="result"/> documentation for "M:Dln.Exceptions.DlnWarning.#ctor(System.String,Dln.Result)"]
See Also
Reference
DlnWarning Class
DlnWarning Overload
Dln.Exceptions Namespace


DlnWarning Fields

DlnWarning Fields dln.net.dll

The DlnWarning type exposes the following members.

Fields
 | Name | Description
Protected field | _message | (Inherited from DlnException.)
Top
See Also

Reference

DlnWarning Class
Dln.Exceptions Namespace


DlnWarning Methods

DlnWarning Methods dln.net.dll

The DlnWarning type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

DlnWarning Class
Dln.Exceptions Namespace


DlnWarning Properties

DlnWarning Properties dln.net.dll

The DlnWarning type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | (Inherited from DlnException.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

DlnWarning Class
Dln.Exceptions Namespace


HardwareNotFoundException Class

HardwareNotFoundException Class dln.net.dll

[Missing <summary> documentation for "T:Dln.Exceptions.HardwareNotFoundException"]

Inheritance Hierarchy
System Object
System Exception
Dln.Exceptions DlnException
Dln.Exceptions DlnError
Dln.Exceptions HardwareNotFoundException

Namespace: Dln.Exceptions
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public class HardwareNotFoundException : DlnError
public class HardwareNotFoundException : DlnError
Public Class HardwareNotFoundException
    Inherits DlnError
Public Class HardwareNotFoundException
    Inherits DlnError
public ref class HardwareNotFoundException : public DlnError
public ref class HardwareNotFoundException : public DlnError
The HardwareNotFoundException type exposes the following members.
Constructors
 | Name | Description
Public method | HardwareNotFoundException | Initializes a new instance of the HardwareNotFoundException class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Fields
 | Name | Description
Protected field | _message | (Inherited from DlnException.)
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | (Inherited from DlnException.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also
Reference
Dln.Exceptions Namespace


HardwareNotFoundException Constructor

HardwareNotFoundException Constructor dln.net.dll
Initializes a new instance of the HardwareNotFoundException class

Namespace: Dln.Exceptions
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public HardwareNotFoundException()
public HardwareNotFoundException()
Public Sub New
Public Sub New
public:
HardwareNotFoundException()
public:
HardwareNotFoundException()
See Also
Reference
HardwareNotFoundException Class
Dln.Exceptions Namespace


HardwareNotFoundException Fields

HardwareNotFoundException Fields dln.net.dll

The HardwareNotFoundException type exposes the following members.

Fields
 | Name | Description
Protected field | _message | (Inherited from DlnException.)
Top
See Also

Reference

HardwareNotFoundException Class
Dln.Exceptions Namespace


HardwareNotFoundException Methods

HardwareNotFoundException Methods dln.net.dll

The HardwareNotFoundException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

HardwareNotFoundException Class
Dln.Exceptions Namespace


HardwareNotFoundException Properties

HardwareNotFoundException Properties dln.net.dll

The HardwareNotFoundException type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | (Inherited from DlnException.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

HardwareNotFoundException Class
Dln.Exceptions Namespace


PinInUseException Class

PinInUseException Class dln.net.dll

[Missing <summary> documentation for "T:Dln.Exceptions.PinInUseException"]

Inheritance Hierarchy
System Object
System Exception
Dln.Exceptions DlnException
Dln.Exceptions DlnError
Dln.Exceptions PinInUseException

Namespace: Dln.Exceptions
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public class PinInUseException : DlnError
public class PinInUseException : DlnError
Public Class PinInUseException
    Inherits DlnError
Public Class PinInUseException
    Inherits DlnError
public ref class PinInUseException : public DlnError
public ref class PinInUseException : public DlnError
The PinInUseException type exposes the following members.
Constructors
 | Name | Description
Public method | PinInUseException | Initializes a new instance of the PinInUseException class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Fields
 | Name | Description
Protected field | _message | (Inherited from DlnException.)
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | (Inherited from DlnException.)
Public property | Pin |
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also
Reference
Dln.Exceptions Namespace


PinInUseException Constructor

PinInUseException Constructor dln.net.dll
Initializes a new instance of the PinInUseException class

Namespace: Dln.Exceptions
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public PinInUseException(
    ushort pin
)
public PinInUseException(
    ushort pin
)
Public Sub New (
    pin As UShort
)
Public Sub New (
    pin As UShort
)
public:
PinInUseException(
    unsigned short pin
)
public:
PinInUseException(
    unsigned short pin
)
Parameters
pin
Type: System UInt16
[Missing <param name="pin"/> documentation for "M:Dln.Exceptions.PinInUseException.#ctor(System.UInt16)"]
See Also
Reference
PinInUseException Class
Dln.Exceptions Namespace


PinInUseException Fields

PinInUseException Fields dln.net.dll

The PinInUseException type exposes the following members.

Fields
 | Name | Description
Protected field | _message | (Inherited from DlnException.)
Top
See Also

Reference

PinInUseException Class
Dln.Exceptions Namespace


PinInUseException Methods

PinInUseException Methods dln.net.dll

The PinInUseException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

PinInUseException Class
Dln.Exceptions Namespace


PinInUseException Properties

PinInUseException Properties dln.net.dll

The PinInUseException type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | (Inherited from DlnException.)
Public property | Pin |
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

PinInUseException Class
Dln.Exceptions Namespace


PinInUseException.Pin Property

PinInUseException Pin Property dln.net.dll

[Missing <summary> documentation for "P:Dln.Exceptions.PinInUseException.Pin"]

Namespace: Dln.Exceptions
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public ushort Pin { get; }
public ushort Pin { get; }
Public ReadOnly Property Pin As UShort
    Get
Public ReadOnly Property Pin As UShort
    Get
public:
property unsigned short Pin {
    unsigned short get ();
}
public:
property unsigned short Pin {
    unsigned short get ();
}
Property Value
Type: UInt16
See Also
Reference
PinInUseException Class
Dln.Exceptions Namespace


ResponseWaitTimeoutException Class

ResponseWaitTimeoutException Class dln.net.dll

[Missing <summary> documentation for "T:Dln.Exceptions.ResponseWaitTimeoutException"]

Inheritance Hierarchy
System Object
System Exception
Dln.Exceptions DlnException
Dln.Exceptions DlnError
Dln.Exceptions ResponseWaitTimeoutException

Namespace: Dln.Exceptions
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public class ResponseWaitTimeoutException : DlnError
public class ResponseWaitTimeoutException : DlnError
Public Class ResponseWaitTimeoutException
    Inherits DlnError
Public Class ResponseWaitTimeoutException
    Inherits DlnError
public ref class ResponseWaitTimeoutException : public DlnError
public ref class ResponseWaitTimeoutException : public DlnError
The ResponseWaitTimeoutException type exposes the following members.
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Fields
 | Name | Description
Protected field | _message | (Inherited from DlnException.)
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | (Inherited from DlnException.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also
Reference
Dln.Exceptions Namespace


ResponseWaitTimeoutException Fields

ResponseWaitTimeoutException Fields dln.net.dll

The ResponseWaitTimeoutException type exposes the following members.

Fields
 | Name | Description
Protected field | _message | (Inherited from DlnException.)
Top
See Also

Reference

ResponseWaitTimeoutException Class
Dln.Exceptions Namespace


ResponseWaitTimeoutException Methods

ResponseWaitTimeoutException Methods dln.net.dll

The ResponseWaitTimeoutException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

ResponseWaitTimeoutException Class
Dln.Exceptions Namespace


ResponseWaitTimeoutException Properties

ResponseWaitTimeoutException Properties dln.net.dll

The ResponseWaitTimeoutException type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | (Inherited from DlnException.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

ResponseWaitTimeoutException Class
Dln.Exceptions Namespace


ValueRoundedException Class

ValueRoundedException Class dln.net.dll

[Missing <summary> documentation for "T:Dln.Exceptions.ValueRoundedException"]

Inheritance Hierarchy
System Object
System Exception
Dln.Exceptions DlnException
Dln.Exceptions DlnWarning
Dln.Exceptions ValueRoundedException

Namespace: Dln.Exceptions
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public class ValueRoundedException : DlnWarning
public class ValueRoundedException : DlnWarning
Public Class ValueRoundedException
    Inherits DlnWarning
Public Class ValueRoundedException
    Inherits DlnWarning
public ref class ValueRoundedException : public DlnWarning
public ref class ValueRoundedException : public DlnWarning
The ValueRoundedException type exposes the following members.
Constructors
 | Name | Description
Public method | ValueRoundedException | Initializes a new instance of the ValueRoundedException class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Fields
 | Name | Description
Protected field | _message | (Inherited from DlnException.)
Top
Properties
 | Name | Description
Public property | ActualValue |
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | (Inherited from DlnException.)
Public property | RequestedValue |
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also
Reference
Dln.Exceptions Namespace


ValueRoundedException Constructor

ValueRoundedException Constructor dln.net.dll
Initializes a new instance of the ValueRoundedException class

Namespace: Dln.Exceptions
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public ValueRoundedException(
    string message,
    uint requestedValue,
    uint actualValue
)
public ValueRoundedException(
    string message,
    uint requestedValue,
    uint actualValue
)
Public Sub New (
    message As String,
    requestedValue As UInteger,
    actualValue As UInteger
)
Public Sub New (
    message As String,
    requestedValue As UInteger,
    actualValue As UInteger
)
public:
ValueRoundedException(
    String^ message,
    unsigned int requestedValue,
    unsigned int actualValue
)
public:
ValueRoundedException(
    String^ message,
    unsigned int requestedValue,
    unsigned int actualValue
)
Parameters
message
Type: System String
[Missing <param name="message"/> documentation for "M:Dln.Exceptions.ValueRoundedException.#ctor(System.String,System.UInt32,System.UInt32)"]
requestedValue
Type: System UInt32
[Missing <param name="requestedValue"/> documentation for "M:Dln.Exceptions.ValueRoundedException.#ctor(System.String,System.UInt32,System.UInt32)"]
actualValue
Type: System UInt32
[Missing <param name="actualValue"/> documentation for "M:Dln.Exceptions.ValueRoundedException.#ctor(System.String,System.UInt32,System.UInt32)"]
See Also
Reference
ValueRoundedException Class
Dln.Exceptions Namespace


ValueRoundedException Fields

ValueRoundedException Fields dln.net.dll

The ValueRoundedException type exposes the following members.

Fields
 | Name | Description
Protected field | _message | (Inherited from DlnException.)
Top
See Also

Reference

ValueRoundedException Class
Dln.Exceptions Namespace


ValueRoundedException Methods

ValueRoundedException Methods dln.net.dll

The ValueRoundedException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

ValueRoundedException Class
Dln.Exceptions Namespace


ValueRoundedException Properties

ValueRoundedException Properties dln.net.dll

The ValueRoundedException type exposes the following members.

Properties
 | Name | Description
Public property | ActualValue |
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | (Inherited from DlnException.)
Public property | RequestedValue |
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

ValueRoundedException Class
Dln.Exceptions Namespace


ValueRoundedException.ActualValue Property

ValueRoundedException ActualValue Property dln.net.dll

[Missing <summary> documentation for "P:Dln.Exceptions.ValueRoundedException.ActualValue"]

Namespace: Dln.Exceptions
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public uint ActualValue { get; }
public uint ActualValue { get; }
Public ReadOnly Property ActualValue As UInteger
    Get
Public ReadOnly Property ActualValue As UInteger
    Get
public:
property unsigned int ActualValue {
    unsigned int get ();
}
public:
property unsigned int ActualValue {
    unsigned int get ();
}
Property Value
Type: UInt32
See Also
Reference
ValueRoundedException Class
Dln.Exceptions Namespace


ValueRoundedException.RequestedValue Property

ValueRoundedException RequestedValue Property dln.net.dll

[Missing <summary> documentation for "P:Dln.Exceptions.ValueRoundedException.RequestedValue"]

Namespace: Dln.Exceptions
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public uint RequestedValue { get; }
public uint RequestedValue { get; }
Public ReadOnly Property RequestedValue As UInteger
    Get
Public ReadOnly Property RequestedValue As UInteger
    Get
public:
property unsigned int RequestedValue {
    unsigned int get ();
}
public:
property unsigned int RequestedValue {
    unsigned int get ();
}
Property Value
Type: UInt32
See Also
Reference
ValueRoundedException Class
Dln.Exceptions Namespace


Dln.Gpio Namespace

Dln.Gpio Namespace dln.net.dll
The Dln.Gpio namespace contains types that allow GPIO module usage of DLN-series adapters.
Classes
 | Class | Description
Public class | ConditionMetEventArgs | ConditionMetEventArgs class describes an event arguments for GPIO events.
Public class | Module | Module class describes properties and methods for GPIO module
Public class | ModuleRestrictions | ModuleRestrictions describes restrictions for whole GPIO module.
Public class | Pin | Pin class describes GPIO pin functionality: properties and methods.
Public class | PinRestrictions | Class PinRestrictions describes GPIO pins restrictions.
Public class | Pins | Pins class
Enumerations
 | Enumeration | Description
Public enumeration | EventType | EventType emumeration describes all possibe GPIO event types.


ConditionMetEventArgs Class

ConditionMetEventArgs Class dln.net.dll
ConditionMetEventArgs class describes an event arguments for GPIO events.
Inheritance Hierarchy
System Object
System EventArgs
Dln.Gpio ConditionMetEventArgs

Namespace: Dln.Gpio
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public class ConditionMetEventArgs : EventArgs
public class ConditionMetEventArgs : EventArgs
Public Class ConditionMetEventArgs
    Inherits EventArgs
Public Class ConditionMetEventArgs
    Inherits EventArgs
public ref class ConditionMetEventArgs : public EventArgs
public ref class ConditionMetEventArgs : public EventArgs
The ConditionMetEventArgs type exposes the following members.
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | EventType | EventType read-only property
Public property | Pin | Pin read-only property
Public property | Value | Value read-only property
Top
See Also
Reference
Dln.Gpio Namespace


ConditionMetEventArgs Methods

ConditionMetEventArgs Methods dln.net.dll

The ConditionMetEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ConditionMetEventArgs Class
Dln.Gpio Namespace


ConditionMetEventArgs Properties

ConditionMetEventArgs Properties dln.net.dll

The ConditionMetEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | EventType | EventType read-only property
Public property | Pin | Pin read-only property
Public property | Value | Value read-only property
Top
See Also

Reference

ConditionMetEventArgs Class
Dln.Gpio Namespace


ConditionMetEventArgs.EventType Property

ConditionMetEventArgs EventType Property dln.net.dll
EventType read-only property

Namespace: Dln.Gpio
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public EventType EventType { get; }
public EventType EventType { get; }
Public ReadOnly Property EventType As EventType
    Get
Public ReadOnly Property EventType As EventType
    Get
public:
property EventType EventType {
    EventType get ();
}
public:
property EventType EventType {
    EventType get ();
}
Property Value
Type: EventType
See Also
Reference
ConditionMetEventArgs Class
Dln.Gpio Namespace


ConditionMetEventArgs.Pin Property

ConditionMetEventArgs Pin Property dln.net.dll
Pin read-only property

Namespace: Dln.Gpio
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public int Pin { get; }
public int Pin { get; }
Public ReadOnly Property Pin As Integer
    Get
Public ReadOnly Property Pin As Integer
    Get
public:
property int Pin {
    int get ();
}
public:
property int Pin {
    int get ();
}
Property Value
Type: Int32
See Also
Reference
ConditionMetEventArgs Class
Dln.Gpio Namespace


ConditionMetEventArgs.Value Property

ConditionMetEventArgs Value Property dln.net.dll
Value read-only property

Namespace: Dln.Gpio
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public int Value { get; }
public int Value { get; }
Public ReadOnly Property Value As Integer
    Get
Public ReadOnly Property Value As Integer
    Get
public:
property int Value {
    int get ();
}
public:
property int Value {
    int get ();
}
Property Value
Type: Int32
See Also
Reference
ConditionMetEventArgs Class
Dln.Gpio Namespace


EventType Enumeration

EventType Enumeration dln.net.dll
EventType emumeration describes all possibe GPIO event types.

Namespace: Dln.Gpio
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public enum EventType
public enum EventType
Public Enumeration EventType
Public Enumeration EventType
public enum class EventType
public enum class EventType
Members
Member name | Value | Description
None | 0 | No events
Change | 1 | Pin state has been changed event
LevelHigh | 2 | Pin has been changed to high state
LevelLow | 3 | Pin has been changed to low state
Always | 4 | Constantly monitor pin state and fire event
See Also
Reference
Dln.Gpio Namespace


Module Class

Module Class dln.net.dll
Module class describes properties and methods for GPIO module
Inheritance Hierarchy
System Object
Dln.Gpio Module

Namespace: Dln.Gpio
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public class Module
public class Module
Public Class Module
Public Class Module
public ref class Module
public ref class Module
The Module type exposes the following members.
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Debounce | Debounce property sets or gets GPIO module debounce.
Public property | Pins | Get Pin class object
Public property | Restrictions | Get GPIO module restrictions
Top
See Also
Reference
Dln.Gpio Namespace


Module Methods

Module Methods dln.net.dll

The Module type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Module Class
Dln.Gpio Namespace


Module Properties

Module Properties dln.net.dll

The Module type exposes the following members.

Properties
 | Name | Description
Public property | Debounce | Debounce property sets or gets GPIO module debounce.
Public property | Pins | Get Pin class object
Public property | Restrictions | Get GPIO module restrictions
Top
See Also

Reference

Module Class
Dln.Gpio Namespace


Module.Debounce Property

Module Debounce Property dln.net.dll
Debounce property sets or gets GPIO module debounce.

Namespace: Dln.Gpio
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public int Debounce { get; set; }
public int Debounce { get; set; }
Public Property Debounce As Integer
    Get
    Set
Public Property Debounce As Integer
    Get
    Set
public:
property int Debounce {
    int get ();
    void set (int value);
}
public:
property int Debounce {
    int get ();
    void set (int value);
}
Property Value
Type: Int32
See Also
Reference
Module Class
Dln.Gpio Namespace


Module.Pins Property

Module Pins Property dln.net.dll
Get Pin class object

Namespace: Dln.Gpio
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public Pins Pins { get; }
public Pins Pins { get; }
Public ReadOnly Property Pins As Pins
    Get
Public ReadOnly Property Pins As Pins
    Get
public:
property Pins^ Pins {
    Pins^ get ();
}
public:
property Pins^ Pins {
    Pins^ get ();
}
Property Value
Type: Pins
See Also
Reference
Module Class
Dln.Gpio Namespace


Module.Restrictions Property

Module Restrictions Property dln.net.dll
Get GPIO module restrictions

Namespace: Dln.Gpio
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public ModuleRestrictions Restrictions { get; }
public ModuleRestrictions Restrictions { get; }
Public ReadOnly Property Restrictions As ModuleRestrictions
    Get
Public ReadOnly Property Restrictions As ModuleRestrictions
    Get
public:
property ModuleRestrictions^ Restrictions {
    ModuleRestrictions^ get ();
}
public:
property ModuleRestrictions^ Restrictions {
    ModuleRestrictions^ get ();
}
Property Value
Type: ModuleRestrictions
See Also
Reference
Module Class
Dln.Gpio Namespace


ModuleRestrictions Class

ModuleRestrictions Class dln.net.dll
ModuleRestrictions describes restrictions for whole GPIO module.
Inheritance Hierarchy
System Object
Dln.Gpio ModuleRestrictions

Namespace: Dln.Gpio
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public class ModuleRestrictions
public class ModuleRestrictions
Public Class ModuleRestrictions
Public Class ModuleRestrictions
public ref class ModuleRestrictions
public ref class ModuleRestrictions
The ModuleRestrictions type exposes the following members.
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Debounce | Debounce restriction.
Top
See Also
Reference
Dln.Gpio Namespace


ModuleRestrictions Methods

ModuleRestrictions Methods dln.net.dll

The ModuleRestrictions type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ModuleRestrictions Class
Dln.Gpio Namespace


ModuleRestrictions Properties

ModuleRestrictions Properties dln.net.dll

The ModuleRestrictions type exposes the following members.

Properties
 | Name | Description
Public property | Debounce | Debounce restriction.
Top
See Also

Reference

ModuleRestrictions Class
Dln.Gpio Namespace


ModuleRestrictions.Debounce Property

ModuleRestrictions Debounce Property dln.net.dll
Debounce restriction.

Namespace: Dln.Gpio
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public Restriction Debounce { get; }
public Restriction Debounce { get; }
Public ReadOnly Property Debounce As Restriction
    Get
Public ReadOnly Property Debounce As Restriction
    Get
public:
property Restriction Debounce {
    Restriction get ();
}
public:
property Restriction Debounce {
    Restriction get ();
}
Property Value
Type: Restriction
See Also
Reference
ModuleRestrictions Class
Dln.Gpio Namespace


Pin Class

Pin Class dln.net.dll
Pin class describes GPIO pin functionality: properties and methods.
Inheritance Hierarchy
System Object
Dln.Gpio Pin

Namespace: Dln.Gpio
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public class Pin
public class Pin
Public Class Pin
Public Class Pin
public ref class Pin
public ref class Pin
The Pin type exposes the following members.
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetEventConfiguration | SetEventConfiguration method allows to set event period and event type
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | DebounceEnabled | Debounce property. You can set true or false values. Leave property blank if you want to get current direction value.
Public property | Direction | Direction property. Set to 0 for input or 1 for output. Leave property blank if you want to get current direction value.
Public property | Enabled | Enabled property. truec> or false values can be assigned. Leave property blank to get current value.
Public property | EventPeriod | EventPeriod property. Defines the event period for event in ms.
Public property | EventType | EventType property. Set event type for GPIO pin.
Public property | OpendrainEnabled | OpenDrain property. You can set true or false values. Leave property blank if you want to get current direction value.
Public property | OutputValue | OutputValue property. You can set 0 or 1 values. Leave property blank if you want to get current direction value.
Public property | PulldownEnabled | Pulldown property. You can set true or false values. Leave property blank if you want to get current direction value.
Public property | PullupEnabled | Pullup property. You can set true or false values. Leave property blank if you want to get current direction value.
Public property | Restrictions | Gpio interface restrictions
Public property | SupportedEventTypes | SupportedEventTypes property to retrieve all possible event type values.
Public property | Value | Value property.
Top
Events
 | Name | Description
Public event | ConditionMet | Condition met event handler
Public event | ConditionMetThreadSafe | Condition met event handler in safe thread
Top
See Also
Reference
Dln.Gpio Namespace


Pin Methods

Pin Methods dln.net.dll

The Pin type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetEventConfiguration | SetEventConfiguration method allows to set event period and event type
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Pin Class
Dln.Gpio Namespace


Pin.SetEventConfiguration Method

Pin SetEventConfiguration Method dln.net.dll
SetEventConfiguration method allows to set event period and event type

Namespace: Dln.Gpio
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public void SetEventConfiguration(
    EventType eventType,
    int eventPeriod
)
public void SetEventConfiguration(
    EventType eventType,
    int eventPeriod
)
Public Sub SetEventConfiguration (
    eventType As EventType,
    eventPeriod As Integer
)
Public Sub SetEventConfiguration (
    eventType As EventType,
    eventPeriod As Integer
)
public:
void SetEventConfiguration(
    EventType eventType,
    int eventPeriod
)
public:
void SetEventConfiguration(
    EventType eventType,
    int eventPeriod
)
Parameters
eventType
Type: Dln.Gpio EventType
Event type value. Use SupportedEventTypes property to retrieve all possible event type values.
eventPeriod
Type: System Int32
Event period value.
See Also
Reference
Pin Class
Dln.Gpio Namespace


Pin Properties

Pin Properties dln.net.dll

The Pin type exposes the following members.

Properties
 | Name | Description
Public property | DebounceEnabled | Debounce property. You can set true or false values. Leave property blank if you want to get current direction value.
Public property | Direction | Direction property. Set to 0 for input or 1 for output. Leave property blank if you want to get current direction value.
Public property | Enabled | Enabled property. truec> or false values can be assigned. Leave property blank to get current value.
Public property | EventPeriod | EventPeriod property. Defines the event period for event in ms.
Public property | EventType | EventType property. Set event type for GPIO pin.
Public property | OpendrainEnabled | OpenDrain property. You can set true or false values. Leave property blank if you want to get current direction value.
Public property | OutputValue | OutputValue property. You can set 0 or 1 values. Leave property blank if you want to get current direction value.
Public property | PulldownEnabled | Pulldown property. You can set true or false values. Leave property blank if you want to get current direction value.
Public property | PullupEnabled | Pullup property. You can set true or false values. Leave property blank if you want to get current direction value.
Public property | Restrictions | Gpio interface restrictions
Public property | SupportedEventTypes | SupportedEventTypes property to retrieve all possible event type values.
Public property | Value | Value property.
Top
See Also

Reference

Pin Class
Dln.Gpio Namespace


Pin.DebounceEnabled Property

Pin DebounceEnabled Property dln.net.dll
Debounce property. You can set true or false values. Leave property blank if you want to get current direction value.

Namespace: Dln.Gpio
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public bool DebounceEnabled { get; set; }
public bool DebounceEnabled { get; set; }
Public Property DebounceEnabled As Boolean
    Get
    Set
Public Property DebounceEnabled As Boolean
    Get
    Set
public:
property bool DebounceEnabled {
    bool get ();
    void set (bool value);
}
public:
property bool DebounceEnabled {
    bool get ();
    void set (bool value);
}
Property Value
Type: Boolean
See Also
Reference
Pin Class
Dln.Gpio Namespace


Pin.Direction Property

Pin Direction Property dln.net.dll
Direction property. Set to 0 for input or 1 for output. Leave property blank if you want to get current direction value.

Namespace: Dln.Gpio
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public int Direction { get; set; }
public int Direction { get; set; }
Public Property Direction As Integer
    Get
    Set
Public Property Direction As Integer
    Get
    Set
public:
property int Direction {
    int get ();
    void set (int value);
}
public:
property int Direction {
    int get ();
    void set (int value);
}
Property Value
Type: Int32
See Also
Reference
Pin Class
Dln.Gpio Namespace


Pin.Enabled Property

Pin Enabled Property dln.net.dll
Enabled property. truec> or false values can be assigned. Leave property blank to get current value.

Namespace: Dln.Gpio
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public bool Enabled { get; set; }
public bool Enabled { get; set; }
Public Property Enabled As Boolean
    Get
    Set
Public Property Enabled As Boolean
    Get
    Set
public:
property bool Enabled {
    bool get ();
    void set (bool value);
}
public:
property bool Enabled {
    bool get ();
    void set (bool value);
}
Property Value
Type: Boolean
See Also
Reference
Pin Class
Dln.Gpio Namespace


Pin.EventPeriod Property

Pin EventPeriod Property dln.net.dll
EventPeriod property. Defines the event period for event in ms.

Namespace: Dln.Gpio
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public int EventPeriod { get; }
public int EventPeriod { get; }
Public ReadOnly Property EventPeriod As Integer
    Get
Public ReadOnly Property EventPeriod As Integer
    Get
public:
property int EventPeriod {
    int get ();
}
public:
property int EventPeriod {
    int get ();
}
Property Value
Type: Int32
See Also
Reference
Pin Class
Dln.Gpio Namespace


Pin.EventType Property

Pin EventType Property dln.net.dll
EventType property. Set event type for GPIO pin.

Namespace: Dln.Gpio
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public EventType EventType { get; }
public EventType EventType { get; }
Public ReadOnly Property EventType As EventType
    Get
Public ReadOnly Property EventType As EventType
    Get
public:
property EventType EventType {
    EventType get ();
}
public:
property EventType EventType {
    EventType get ();
}
Property Value
Type: EventType
See Also
Reference
Pin Class
Dln.Gpio Namespace


Pin.OpendrainEnabled Property

Pin OpendrainEnabled Property dln.net.dll
OpenDrain property. You can set true or false values. Leave property blank if you want to get current direction value.

Namespace: Dln.Gpio
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public bool OpendrainEnabled { get; set; }
public bool OpendrainEnabled { get; set; }
Public Property OpendrainEnabled As Boolean
    Get
    Set
Public Property OpendrainEnabled As Boolean
    Get
    Set
public:
property bool OpendrainEnabled {
    bool get ();
    void set (bool value);
}
public:
property bool OpendrainEnabled {
    bool get ();
    void set (bool value);
}
Property Value
Type: Boolean
See Also
Reference
Pin Class
Dln.Gpio Namespace


Pin.OutputValue Property

Pin OutputValue Property dln.net.dll
OutputValue property. You can set 0 or 1 values. Leave property blank if you want to get current direction value.

Namespace: Dln.Gpio
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public int OutputValue { get; set; }
public int OutputValue { get; set; }
Public Property OutputValue As Integer
    Get
    Set
Public Property OutputValue As Integer
    Get
    Set
public:
property int OutputValue {
    int get ();
    void set (int value);
}
public:
property int OutputValue {
    int get ();
    void set (int value);
}
Property Value
Type: Int32
See Also
Reference
Pin Class
Dln.Gpio Namespace


Pin.PulldownEnabled Property

Pin PulldownEnabled Property dln.net.dll
Pulldown property. You can set true or false values. Leave property blank if you want to get current direction value.

Namespace: Dln.Gpio
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public bool PulldownEnabled { get; set; }
public bool PulldownEnabled { get; set; }
Public Property PulldownEnabled As Boolean
    Get
    Set
Public Property PulldownEnabled As Boolean
    Get
    Set
public:
property bool PulldownEnabled {
    bool get ();
    void set (bool value);
}
public:
property bool PulldownEnabled {
    bool get ();
    void set (bool value);
}
Property Value
Type: Boolean
See Also
Reference
Pin Class
Dln.Gpio Namespace


Pin.PullupEnabled Property

Pin PullupEnabled Property dln.net.dll
Pullup property. You can set true or false values. Leave property blank if you want to get current direction value.

Namespace: Dln.Gpio
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public bool PullupEnabled { get; set; }
public bool PullupEnabled { get; set; }
Public Property PullupEnabled As Boolean
    Get
    Set
Public Property PullupEnabled As Boolean
    Get
    Set
public:
property bool PullupEnabled {
    bool get ();
    void set (bool value);
}
public:
property bool PullupEnabled {
    bool get ();
    void set (bool value);
}
Property Value
Type: Boolean
See Also
Reference
Pin Class
Dln.Gpio Namespace


Pin.Restrictions Property

Pin Restrictions Property dln.net.dll
Gpio interface restrictions

Namespace: Dln.Gpio
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public PinRestrictions Restrictions { get; }
public PinRestrictions Restrictions { get; }
Public ReadOnly Property Restrictions As PinRestrictions
    Get
Public ReadOnly Property Restrictions As PinRestrictions
    Get
public:
property PinRestrictions^ Restrictions {
    PinRestrictions^ get ();
}
public:
property PinRestrictions^ Restrictions {
    PinRestrictions^ get ();
}
Property Value
Type: PinRestrictions
See Also
Reference
Pin Class
Dln.Gpio Namespace


Pin.SupportedEventTypes Property

Pin SupportedEventTypes Property dln.net.dll
SupportedEventTypes property to retrieve all possible event type values.

Namespace: Dln.Gpio
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public ReadOnlyCollection<EventType> SupportedEventTypes { get; }
public ReadOnlyCollection<EventType> SupportedEventTypes { get; }
Public ReadOnly Property SupportedEventTypes As ReadOnlyCollection(Of EventType)
    Get
Public ReadOnly Property SupportedEventTypes As ReadOnlyCollection(Of EventType)
    Get
public:
property ReadOnlyCollection<EventType>^ SupportedEventTypes {
    ReadOnlyCollection<EventType>^ get ();
}
public:
property ReadOnlyCollection<EventType>^ SupportedEventTypes {
    ReadOnlyCollection<EventType>^ get ();
}
Property Value
Type: ReadOnlyCollection  EventType
See Also
Reference
Pin Class
Dln.Gpio Namespace


Pin.Value Property

Pin Value Property dln.net.dll
Value property.

Namespace: Dln.Gpio
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public int Value { get; }
public int Value { get; }
Public ReadOnly Property Value As Integer
    Get
Public ReadOnly Property Value As Integer
    Get
public:
property int Value {
    int get ();
}
public:
property int Value {
    int get ();
}
Property Value
Type: Int32
See Also
Reference
Pin Class
Dln.Gpio Namespace


Pin Events

Pin Events dln.net.dll

The Pin type exposes the following members.

Events
 | Name | Description
Public event | ConditionMet | Condition met event handler
Public event | ConditionMetThreadSafe | Condition met event handler in safe thread
Top
See Also

Reference

Pin Class
Dln.Gpio Namespace


Pin.ConditionMet Event

Pin ConditionMet Event dln.net.dll
Condition met event handler

Namespace: Dln.Gpio
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public event EventHandler<ConditionMetEventArgs> ConditionMet
public event EventHandler<ConditionMetEventArgs> ConditionMet
Public Event ConditionMet As EventHandler(Of ConditionMetEventArgs)
Public Event ConditionMet As EventHandler(Of ConditionMetEventArgs)
public:
 event EventHandler<ConditionMetEventArgs^>^ ConditionMet {
    void add (EventHandler<ConditionMetEventArgs^>^ value);
    void remove (EventHandler<ConditionMetEventArgs^>^ value);
}
public:
 event EventHandler<ConditionMetEventArgs^>^ ConditionMet {
    void add (EventHandler<ConditionMetEventArgs^>^ value);
    void remove (EventHandler<ConditionMetEventArgs^>^ value);
}
Value
Type: System EventHandler  ConditionMetEventArgs
See Also
Reference
Pin Class
Dln.Gpio Namespace


Pin.ConditionMetThreadSafe Event

Pin ConditionMetThreadSafe Event dln.net.dll
Condition met event handler in safe thread

Namespace: Dln.Gpio
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public event EventHandler<ConditionMetEventArgs> ConditionMetThreadSafe
public event EventHandler<ConditionMetEventArgs> ConditionMetThreadSafe
Public Event ConditionMetThreadSafe As EventHandler(Of ConditionMetEventArgs)
Public Event ConditionMetThreadSafe As EventHandler(Of ConditionMetEventArgs)
public:
 event EventHandler<ConditionMetEventArgs^>^ ConditionMetThreadSafe {
    void add (EventHandler<ConditionMetEventArgs^>^ value);
    void remove (EventHandler<ConditionMetEventArgs^>^ value);
}
public:
 event EventHandler<ConditionMetEventArgs^>^ ConditionMetThreadSafe {
    void add (EventHandler<ConditionMetEventArgs^>^ value);
    void remove (EventHandler<ConditionMetEventArgs^>^ value);
}
Value
Type: System EventHandler  ConditionMetEventArgs
See Also
Reference
Pin Class
Dln.Gpio Namespace


PinRestrictions Class

PinRestrictions Class dln.net.dll
Class PinRestrictions describes GPIO pins restrictions.
Inheritance Hierarchy
System Object
Dln.Gpio PinRestrictions

Namespace: Dln.Gpio
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public class PinRestrictions
public class PinRestrictions
Public Class PinRestrictions
Public Class PinRestrictions
public ref class PinRestrictions
public ref class PinRestrictions
The PinRestrictions type exposes the following members.
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | DebounceEnabled | DebounceEnabled pin restriction
Public property | Direction | Direction pin restriction
Public property | Enabled | Enabled pin restriction
Public property | EventPeriod | EventPeriod pin restriction
Public property | EventType | EventType pin restriction
Public property | OpendrainEnabled | OpendrainEnabled pin restriction
Public property | OutputValue | OutputValue pin restriction
Public property | PulldownEnabled | PulldownEnabled pin restriction
Public property | PullupEnabled | PullupEnabled pin restriction
Public property | SetEventConfiguration | SetEventConfiguration pin restriction
Public property | Value | Value pin restriction
Top
See Also
Reference
Dln.Gpio Namespace


PinRestrictions Methods

PinRestrictions Methods dln.net.dll

The PinRestrictions type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PinRestrictions Class
Dln.Gpio Namespace


PinRestrictions Properties

PinRestrictions Properties dln.net.dll

The PinRestrictions type exposes the following members.

Properties
 | Name | Description
Public property | DebounceEnabled | DebounceEnabled pin restriction
Public property | Direction | Direction pin restriction
Public property | Enabled | Enabled pin restriction
Public property | EventPeriod | EventPeriod pin restriction
Public property | EventType | EventType pin restriction
Public property | OpendrainEnabled | OpendrainEnabled pin restriction
Public property | OutputValue | OutputValue pin restriction
Public property | PulldownEnabled | PulldownEnabled pin restriction
Public property | PullupEnabled | PullupEnabled pin restriction
Public property | SetEventConfiguration | SetEventConfiguration pin restriction
Public property | Value | Value pin restriction
Top
See Also

Reference

PinRestrictions Class
Dln.Gpio Namespace


PinRestrictions.DebounceEnabled Property

PinRestrictions DebounceEnabled Property dln.net.dll
DebounceEnabled pin restriction

Namespace: Dln.Gpio
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public Restriction DebounceEnabled { get; }
public Restriction DebounceEnabled { get; }
Public ReadOnly Property DebounceEnabled As Restriction
    Get
Public ReadOnly Property DebounceEnabled As Restriction
    Get
public:
property Restriction DebounceEnabled {
    Restriction get ();
}
public:
property Restriction DebounceEnabled {
    Restriction get ();
}
Property Value
Type: Restriction
See Also
Reference
PinRestrictions Class
Dln.Gpio Namespace


PinRestrictions.Direction Property

PinRestrictions Direction Property dln.net.dll
Direction pin restriction

Namespace: Dln.Gpio
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public Restriction Direction { get; }
public Restriction Direction { get; }
Public ReadOnly Property Direction As Restriction
    Get
Public ReadOnly Property Direction As Restriction
    Get
public:
property Restriction Direction {
    Restriction get ();
}
public:
property Restriction Direction {
    Restriction get ();
}
Property Value
Type: Restriction
See Also
Reference
PinRestrictions Class
Dln.Gpio Namespace


PinRestrictions.Enabled Property

PinRestrictions Enabled Property dln.net.dll
Enabled pin restriction

Namespace: Dln.Gpio
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public Restriction Enabled { get; }
public Restriction Enabled { get; }
Public ReadOnly Property Enabled As Restriction
    Get
Public ReadOnly Property Enabled As Restriction
    Get
public:
property Restriction Enabled {
    Restriction get ();
}
public:
property Restriction Enabled {
    Restriction get ();
}
Property Value
Type: Restriction
See Also
Reference
PinRestrictions Class
Dln.Gpio Namespace


PinRestrictions.EventPeriod Property

PinRestrictions EventPeriod Property dln.net.dll
EventPeriod pin restriction

Namespace: Dln.Gpio
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public Restriction EventPeriod { get; }
public Restriction EventPeriod { get; }
Public ReadOnly Property EventPeriod As Restriction
    Get
Public ReadOnly Property EventPeriod As Restriction
    Get
public:
property Restriction EventPeriod {
    Restriction get ();
}
public:
property Restriction EventPeriod {
    Restriction get ();
}
Property Value
Type: Restriction
See Also
Reference
PinRestrictions Class
Dln.Gpio Namespace


PinRestrictions.EventType Property

PinRestrictions EventType Property dln.net.dll
EventType pin restriction

Namespace: Dln.Gpio
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public Restriction EventType { get; }
public Restriction EventType { get; }
Public ReadOnly Property EventType As Restriction
    Get
Public ReadOnly Property EventType As Restriction
    Get
public:
property Restriction EventType {
    Restriction get ();
}
public:
property Restriction EventType {
    Restriction get ();
}
Property Value
Type: Restriction
See Also
Reference
PinRestrictions Class
Dln.Gpio Namespace


PinRestrictions.OpendrainEnabled Property

PinRestrictions OpendrainEnabled Property dln.net.dll
OpendrainEnabled pin restriction

Namespace: Dln.Gpio
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public Restriction OpendrainEnabled { get; }
public Restriction OpendrainEnabled { get; }
Public ReadOnly Property OpendrainEnabled As Restriction
    Get
Public ReadOnly Property OpendrainEnabled As Restriction
    Get
public:
property Restriction OpendrainEnabled {
    Restriction get ();
}
public:
property Restriction OpendrainEnabled {
    Restriction get ();
}
Property Value
Type: Restriction
See Also
Reference
PinRestrictions Class
Dln.Gpio Namespace


PinRestrictions.OutputValue Property

PinRestrictions OutputValue Property dln.net.dll
OutputValue pin restriction

Namespace: Dln.Gpio
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public Restriction OutputValue { get; }
public Restriction OutputValue { get; }
Public ReadOnly Property OutputValue As Restriction
    Get
Public ReadOnly Property OutputValue As Restriction
    Get
public:
property Restriction OutputValue {
    Restriction get ();
}
public:
property Restriction OutputValue {
    Restriction get ();
}
Property Value
Type: Restriction
See Also
Reference
PinRestrictions Class
Dln.Gpio Namespace


PinRestrictions.PulldownEnabled Property

PinRestrictions PulldownEnabled Property dln.net.dll
PulldownEnabled pin restriction

Namespace: Dln.Gpio
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public Restriction PulldownEnabled { get; }
public Restriction PulldownEnabled { get; }
Public ReadOnly Property PulldownEnabled As Restriction
    Get
Public ReadOnly Property PulldownEnabled As Restriction
    Get
public:
property Restriction PulldownEnabled {
    Restriction get ();
}
public:
property Restriction PulldownEnabled {
    Restriction get ();
}
Property Value
Type: Restriction
See Also
Reference
PinRestrictions Class
Dln.Gpio Namespace


PinRestrictions.PullupEnabled Property

PinRestrictions PullupEnabled Property dln.net.dll
PullupEnabled pin restriction

Namespace: Dln.Gpio
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public Restriction PullupEnabled { get; }
public Restriction PullupEnabled { get; }
Public ReadOnly Property PullupEnabled As Restriction
    Get
Public ReadOnly Property PullupEnabled As Restriction
    Get
public:
property Restriction PullupEnabled {
    Restriction get ();
}
public:
property Restriction PullupEnabled {
    Restriction get ();
}
Property Value
Type: Restriction
See Also
Reference
PinRestrictions Class
Dln.Gpio Namespace


PinRestrictions.SetEventConfiguration Property

PinRestrictions SetEventConfiguration Property dln.net.dll
SetEventConfiguration pin restriction

Namespace: Dln.Gpio
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public Restriction SetEventConfiguration { get; }
public Restriction SetEventConfiguration { get; }
Public ReadOnly Property SetEventConfiguration As Restriction
    Get
Public ReadOnly Property SetEventConfiguration As Restriction
    Get
public:
property Restriction SetEventConfiguration {
    Restriction get ();
}
public:
property Restriction SetEventConfiguration {
    Restriction get ();
}
Property Value
Type: Restriction
See Also
Reference
PinRestrictions Class
Dln.Gpio Namespace


PinRestrictions.Value Property

PinRestrictions Value Property dln.net.dll
Value pin restriction

Namespace: Dln.Gpio
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public Restriction Value { get; }
public Restriction Value { get; }
Public ReadOnly Property Value As Restriction
    Get
Public ReadOnly Property Value As Restriction
    Get
public:
property Restriction Value {
    Restriction get ();
}
public:
property Restriction Value {
    Restriction get ();
}
Property Value
Type: Restriction
See Also
Reference
PinRestrictions Class
Dln.Gpio Namespace


Pins Class

Pins Class dln.net.dll
Pins class
Inheritance Hierarchy
System Object
System.Collections.ObjectModel ReadOnlyCollection Pin
Dln.Gpio Pins

Namespace: Dln.Gpio
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public class Pins : ReadOnlyCollection<Pin>
public class Pins : ReadOnlyCollection<Pin>
Public Class Pins
    Inherits ReadOnlyCollection(Of Pin)
Public Class Pins
    Inherits ReadOnlyCollection(Of Pin)
public ref class Pins : public ReadOnlyCollection<Pin^>
public ref class Pins : public ReadOnlyCollection<Pin^>
The Pins type exposes the following members.
Methods
 | Name | Description
Public method | Contains | Determines whether an element is in the ReadOnlyCollection T . (Inherited from ReadOnlyCollection Pin .)
Public method | CopyTo | Copies the entire ReadOnlyCollection T to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from ReadOnlyCollection Pin .)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the ReadOnlyCollection T . (Inherited from ReadOnlyCollection Pin .)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Public method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ReadOnlyCollection T . (Inherited from ReadOnlyCollection Pin .)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the ReadOnlyCollection T instance. (Inherited from ReadOnlyCollection Pin .)
Public property | Item |
Protected property | Items | Returns the IList T that the ReadOnlyCollection T wraps. (Inherited from ReadOnlyCollection Pin .)
Top
See Also
Reference
Dln.Gpio Namespace


Pins Methods

Pins Methods dln.net.dll

The Pins type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Determines whether an element is in the ReadOnlyCollection T . (Inherited from ReadOnlyCollection Pin .)
Public method | CopyTo | Copies the entire ReadOnlyCollection T to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from ReadOnlyCollection Pin .)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the ReadOnlyCollection T . (Inherited from ReadOnlyCollection Pin .)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Public method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ReadOnlyCollection T . (Inherited from ReadOnlyCollection Pin .)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Pins Class
Dln.Gpio Namespace


Pins Properties

Pins Properties dln.net.dll

The Pins type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the ReadOnlyCollection T instance. (Inherited from ReadOnlyCollection Pin .)
Public property | Item |
Protected property | Items | Returns the IList T that the ReadOnlyCollection T wraps. (Inherited from ReadOnlyCollection Pin .)
Top
See Also

Reference

Pins Class
Dln.Gpio Namespace


Pins.Item Property

Pins Item Property dln.net.dll

[Missing <summary> documentation for "P:Dln.Gpio.Pins.Item(System.Int32)"]

Namespace: Dln.Gpio
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public Pin this[
    int index
] { get; }
public Pin this[
    int index
] { get; }
Public ReadOnly Default Property Item (
    index As Integer
) As Pin
    Get
Public ReadOnly Default Property Item (
    index As Integer
) As Pin
    Get
public:
property Pin^ default[int index] {
    Pin^ get (int index);
}
public:
property Pin^ default[int index] {
    Pin^ get (int index);
}
Parameters
index
Type: System Int32
Return Value
Type: Pin
See Also
Reference
Pins Class
Dln.Gpio Namespace


Dln.I2cMaster Namespace

Dln.I2cMaster Namespace dln.net.dll
The Dln.I2cMaster namespace contains types that allow usage of DLN-series adapters as I2C bus master device.
Classes
 | Class | Description
Public class | Module | Module class describes functionality of I2C master module
Public class | Port | Port class describes all proprties
Public class | PortRestrictions | PortRestrictions class describes all I2c master module restrictions.
Public class | Ports | Ports class


Module Class

Module Class dln.net.dll
Module class describes functionality of I2C master module
Inheritance Hierarchy
System Object
Dln.I2cMaster Module

Namespace: Dln.I2cMaster
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public class Module
public class Module
Public Class Module
Public Class Module
public ref class Module
public ref class Module
The Module type exposes the following members.
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Ports | Retrieves I2C master module ports
Top
See Also
Reference
Dln.I2cMaster Namespace


Module Methods

Module Methods dln.net.dll

The Module type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Module Class
Dln.I2cMaster Namespace


Module Properties

Module Properties dln.net.dll

The Module type exposes the following members.

Properties
 | Name | Description
Public property | Ports | Retrieves I2C master module ports
Top
See Also

Reference

Module Class
Dln.I2cMaster Namespace


Module.Ports Property

Module Ports Property dln.net.dll
Retrieves I2C master module ports

Namespace: Dln.I2cMaster
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public Ports Ports { get; }
public Ports Ports { get; }
Public ReadOnly Property Ports As Ports
    Get
Public ReadOnly Property Ports As Ports
    Get
public:
property Ports^ Ports {
    Ports^ get ();
}
public:
property Ports^ Ports {
    Ports^ get ();
}
Property Value
Type: Ports
See Also
Reference
Module Class
Dln.I2cMaster Namespace


Port Class

Port Class dln.net.dll
Port class describes all proprties
Inheritance Hierarchy
System Object
Dln.I2cMaster Port

Namespace: Dln.I2cMaster
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public class Port
public class Port
Public Class Port
Public Class Port
public ref class Port
public ref class Port
The Port type exposes the following members.
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Read(Int32, Byte ) | Reads data from the specified I2C slave device.
Public method | Read(Int32, Int32, Int32, Byte ) | Reads data from the specified I2C slave device.
Public method | Read(Int32, Int32, Int32, Byte , Int32) | Reads data from the specified I2C slave device.
Public method | Read(Int32, Int32, Int32, Byte , Int32, Int32) | Reads data from the specified I2C slave device.
Public method | ScanDevices | ScanDevices method scans for available I2C slave device addresses.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Transfer(Int32, Byte , Byte ) | Transfer method performs a transfer (read/write) operation between I2C master and slave devices.
Public method | Transfer(Int32, Byte , Int32, Byte , Int32) | Transfer method performs a transfer (read/write) operation between I2C master and slave devices.
Public method | Transfer(Int32, Byte , Int32, Int32, Byte , Int32, Int32) | Transfer method performs a transfer (read/write) operation between I2C master and slave devices.
Public method | Write(Int32, Byte ) | Send data via I2C interface from the DLN-series adapter to the specified I2C slave device.
Public method | Write(Int32, Int32, Int32, Byte ) | Send data via I2C interface from the DLN-series adapter to the specified I2C slave device.
Public method | Write(Int32, Int32, Int32, Byte , Int32) | Send data via I2C interface from the DLN-series adapter to the specified I2C slave device.
Public method | Write(Int32, Int32, Int32, Byte , Int32, Int32) | Send data via I2C interface from the DLN-series adapter to the specified I2C slave device.
Top
Properties
 | Name | Description
Public property | Enabled | Set I2C master port status. Set true or false to enable or disable I2C master port respectively. Leave property blank to retrieve current I2C master port status.
Public property | Frequency | Set frequency of I2C master port. Leave property blank to get current frequency value.
Public property | MaxFrequency | Get maximum possible frequency value.
Public property | MaxReplyCount | Retrieves maximum reply count for I2C master port.
Public property | MinFrequency | Get minimal possible frequency value.
Public property | Restrictions | Restrictions class
Top
See Also
Reference
Dln.I2cMaster Namespace


Port Methods

Port Methods dln.net.dll

The Port type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Read(Int32, Byte ) | Reads data from the specified I2C slave device.
Public method | Read(Int32, Int32, Int32, Byte ) | Reads data from the specified I2C slave device.
Public method | Read(Int32, Int32, Int32, Byte , Int32) | Reads data from the specified I2C slave device.
Public method | Read(Int32, Int32, Int32, Byte , Int32, Int32) | Reads data from the specified I2C slave device.
Public method | ScanDevices | ScanDevices method scans for available I2C slave device addresses.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Transfer(Int32, Byte , Byte ) | Transfer method performs a transfer (read/write) operation between I2C master and slave devices.
Public method | Transfer(Int32, Byte , Int32, Byte , Int32) | Transfer method performs a transfer (read/write) operation between I2C master and slave devices.
Public method | Transfer(Int32, Byte , Int32, Int32, Byte , Int32, Int32) | Transfer method performs a transfer (read/write) operation between I2C master and slave devices.
Public method | Write(Int32, Byte ) | Send data via I2C interface from the DLN-series adapter to the specified I2C slave device.
Public method | Write(Int32, Int32, Int32, Byte ) | Send data via I2C interface from the DLN-series adapter to the specified I2C slave device.
Public method | Write(Int32, Int32, Int32, Byte , Int32) | Send data via I2C interface from the DLN-series adapter to the specified I2C slave device.
Public method | Write(Int32, Int32, Int32, Byte , Int32, Int32) | Send data via I2C interface from the DLN-series adapter to the specified I2C slave device.
Top
See Also

Reference

Port Class
Dln.I2cMaster Namespace


Port.Read Method

Port Read Method dln.net.dll
Overload List
 | Name | Description
Public method | Read(Int32, Byte ) | Reads data from the specified I2C slave device.
Public method | Read(Int32, Int32, Int32, Byte ) | Reads data from the specified I2C slave device.
Public method | Read(Int32, Int32, Int32, Byte , Int32) | Reads data from the specified I2C slave device.
Public method | Read(Int32, Int32, Int32, Byte , Int32, Int32) | Reads data from the specified I2C slave device.
Top
See Also

Reference

Port Class
Dln.I2cMaster Namespace


Port.Read Method (Int32, Byte[])

Port Read Method (Int32, Byte ) dln.net.dll
Reads data from the specified I2C slave device.

Namespace: Dln.I2cMaster
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public void Read(
    int slaveDeviceAddress,
    byte[] data
)
public void Read(
    int slaveDeviceAddress,
    byte[] data
)
Public Sub Read (
    slaveDeviceAddress As Integer,
    data As Byte()
)
Public Sub Read (
    slaveDeviceAddress As Integer,
    data As Byte()
)
public:
void Read(
    int slaveDeviceAddress,
    array<unsigned char>^ data
)
public:
void Read(
    int slaveDeviceAddress,
    array<unsigned char>^ data
)
Parameters
slaveDeviceAddress
Type: System Int32
A 7-bit number, assigned to each I2C slave device.
data
Type:  System Byte
Array variable for data to be read
See Also
Reference
Port Class
Read Overload
Dln.I2cMaster Namespace


Port.Read Method (Int32, Int32, Int32, Byte[])

Port Read Method (Int32, Int32, Int32, Byte ) dln.net.dll
Reads data from the specified I2C slave device.

Namespace: Dln.I2cMaster
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public void Read(
    int slaveDeviceAddress,
    int memoryAddressLength,
    int memoryAddress,
    byte[] data
)
public void Read(
    int slaveDeviceAddress,
    int memoryAddressLength,
    int memoryAddress,
    byte[] data
)
Public Sub Read (
    slaveDeviceAddress As Integer,
    memoryAddressLength As Integer,
    memoryAddress As Integer,
    data As Byte()
)
Public Sub Read (
    slaveDeviceAddress As Integer,
    memoryAddressLength As Integer,
    memoryAddress As Integer,
    data As Byte()
)
public:
void Read(
    int slaveDeviceAddress,
    int memoryAddressLength,
    int memoryAddress,
    array<unsigned char>^ data
)
public:
void Read(
    int slaveDeviceAddress,
    int memoryAddressLength,
    int memoryAddress,
    array<unsigned char>^ data
)
Parameters
slaveDeviceAddress
Type: System Int32
A 7-bit number, assigned to each I2C slave device.
memoryAddressLength
Type: System Int32
An internal address length. If set to zero, no internal address is sent.
memoryAddress
Type: System Int32
An internal I2C slave device address.
data
Type:  System Byte
Array variable for data to be read
See Also
Reference
Port Class
Read Overload
Dln.I2cMaster Namespace


Port.Read Method (Int32, Int32, Int32, Byte[], Int32)

Port Read Method (Int32, Int32, Int32, Byte , Int32) dln.net.dll
Reads data from the specified I2C slave device.

Namespace: Dln.I2cMaster
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public void Read(
    int slaveDeviceAddress,
    int memoryAddressLength,
    int memoryAddress,
    byte[] data,
    int dataSize
)
public void Read(
    int slaveDeviceAddress,
    int memoryAddressLength,
    int memoryAddress,
    byte[] data,
    int dataSize
)
Public Sub Read (
    slaveDeviceAddress As Integer,
    memoryAddressLength As Integer,
    memoryAddress As Integer,
    data As Byte(),
    dataSize As Integer
)
Public Sub Read (
    slaveDeviceAddress As Integer,
    memoryAddressLength As Integer,
    memoryAddress As Integer,
    data As Byte(),
    dataSize As Integer
)
public:
void Read(
    int slaveDeviceAddress,
    int memoryAddressLength,
    int memoryAddress,
    array<unsigned char>^ data,
    int dataSize
)
public:
void Read(
    int slaveDeviceAddress,
    int memoryAddressLength,
    int memoryAddress,
    array<unsigned char>^ data,
    int dataSize
)
Parameters
slaveDeviceAddress
Type: System Int32
A 7-bit number, assigned to each I2C slave device.
memoryAddressLength
Type: System Int32
An internal address length. If set to zero, no internal address is sent.
memoryAddress
Type: System Int32
An internal I2C slave device address.
data
Type:  System Byte
Array variable for data to be read
dataSize
Type: System Int32
[Missing <param name="dataSize"/> documentation for "M:Dln.I2cMaster.Port.Read(System.Int32,System.Int32,System.Int32,System.Byte[],System.Int32)"]
See Also
Reference
Port Class
Read Overload
Dln.I2cMaster Namespace


Port.Read Method (Int32, Int32, Int32, Byte[], Int32, Int32)

Port Read Method (Int32, Int32, Int32, Byte , Int32, Int32) dln.net.dll
Reads data from the specified I2C slave device.

Namespace: Dln.I2cMaster
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public void Read(
    int slaveDeviceAddress,
    int memoryAddressLength,
    int memoryAddress,
    byte[] data,
    int dataOffset,
    int dataSize
)
public void Read(
    int slaveDeviceAddress,
    int memoryAddressLength,
    int memoryAddress,
    byte[] data,
    int dataOffset,
    int dataSize
)
Public Sub Read (
    slaveDeviceAddress As Integer,
    memoryAddressLength As Integer,
    memoryAddress As Integer,
    data As Byte(),
    dataOffset As Integer,
    dataSize As Integer
)
Public Sub Read (
    slaveDeviceAddress As Integer,
    memoryAddressLength As Integer,
    memoryAddress As Integer,
    data As Byte(),
    dataOffset As Integer,
    dataSize As Integer
)
public:
void Read(
    int slaveDeviceAddress,
    int memoryAddressLength,
    int memoryAddress,
    array<unsigned char>^ data,
    int dataOffset,
    int dataSize
)
public:
void Read(
    int slaveDeviceAddress,
    int memoryAddressLength,
    int memoryAddress,
    array<unsigned char>^ data,
    int dataOffset,
    int dataSize
)
Parameters
slaveDeviceAddress
Type: System Int32
A 7-bit number, assigned to each I2C slave device.
memoryAddressLength
Type: System Int32
An internal address length. If set to zero, no internal address is sent.
memoryAddress
Type: System Int32
An internal I2C slave device address.
data
Type:  System Byte
Array variable for data to be read
dataOffset
Type: System Int32
Data offset
dataSize
Type: System Int32
Data size
See Also
Reference
Port Class
Read Overload
Dln.I2cMaster Namespace


Port.ScanDevices Method

Port ScanDevices Method dln.net.dll
ScanDevices method scans for available I2C slave device addresses.

Namespace: Dln.I2cMaster
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public int[] ScanDevices()
public int[] ScanDevices()
Public Function ScanDevices As Integer()
Public Function ScanDevices As Integer()
public:
array<int>^ ScanDevices()
public:
array<int>^ ScanDevices()
Return Value
Type:  Int32
Array with all available I2C slave device addresses
See Also
Reference
Port Class
Dln.I2cMaster Namespace


Port.Transfer Method

Port Transfer Method dln.net.dll
Overload List
 | Name | Description
Public method | Transfer(Int32, Byte , Byte ) | Transfer method performs a transfer (read/write) operation between I2C master and slave devices.
Public method | Transfer(Int32, Byte , Int32, Byte , Int32) | Transfer method performs a transfer (read/write) operation between I2C master and slave devices.
Public method | Transfer(Int32, Byte , Int32, Int32, Byte , Int32, Int32) | Transfer method performs a transfer (read/write) operation between I2C master and slave devices.
Top
See Also

Reference

Port Class
Dln.I2cMaster Namespace


Port.Transfer Method (Int32, Byte[], Byte[])

Port Transfer Method (Int32, Byte , Byte ) dln.net.dll
Transfer method performs a transfer (read/write) operation between I2C master and slave devices.

Namespace: Dln.I2cMaster
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public void Transfer(
    int slaveDeviceAddress,
    byte[] writeBuffer,
    byte[] readBuffer
)
public void Transfer(
    int slaveDeviceAddress,
    byte[] writeBuffer,
    byte[] readBuffer
)
Public Sub Transfer (
    slaveDeviceAddress As Integer,
    writeBuffer As Byte(),
    readBuffer As Byte()
)
Public Sub Transfer (
    slaveDeviceAddress As Integer,
    writeBuffer As Byte(),
    readBuffer As Byte()
)
public:
void Transfer(
    int slaveDeviceAddress,
    array<unsigned char>^ writeBuffer,
    array<unsigned char>^ readBuffer
)
public:
void Transfer(
    int slaveDeviceAddress,
    array<unsigned char>^ writeBuffer,
    array<unsigned char>^ readBuffer
)
Parameters
slaveDeviceAddress
Type: System Int32
A 7-bit number, assigned to each I2C slave device.
writeBuffer
Type:  System Byte
A pointer to an array of unsigned 8-bit integers. This array must be filled with data to be sent to a slave during the function execution.
readBuffer
Type:  System Byte
A pointer to an array of unsigned 8-bit integers. This array will be filled with data received from slave during the function execution.
See Also
Reference
Port Class
Transfer Overload
Dln.I2cMaster Namespace


Port.Transfer Method (Int32, Byte[], Int32, Byte[], Int32)

Port Transfer Method (Int32, Byte , Int32, Byte , Int32) dln.net.dll
Transfer method performs a transfer (read/write) operation between I2C master and slave devices.

Namespace: Dln.I2cMaster
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public void Transfer(
    int slaveDeviceAddress,
    byte[] writeBuffer,
    int writeLength,
    byte[] readBuffer,
    int readLength
)
public void Transfer(
    int slaveDeviceAddress,
    byte[] writeBuffer,
    int writeLength,
    byte[] readBuffer,
    int readLength
)
Public Sub Transfer (
    slaveDeviceAddress As Integer,
    writeBuffer As Byte(),
    writeLength As Integer,
    readBuffer As Byte(),
    readLength As Integer
)
Public Sub Transfer (
    slaveDeviceAddress As Integer,
    writeBuffer As Byte(),
    writeLength As Integer,
    readBuffer As Byte(),
    readLength As Integer
)
public:
void Transfer(
    int slaveDeviceAddress,
    array<unsigned char>^ writeBuffer,
    int writeLength,
    array<unsigned char>^ readBuffer,
    int readLength
)
public:
void Transfer(
    int slaveDeviceAddress,
    array<unsigned char>^ writeBuffer,
    int writeLength,
    array<unsigned char>^ readBuffer,
    int readLength
)
Parameters
slaveDeviceAddress
Type: System Int32
A 7-bit number, assigned to each I2C slave device.
writeBuffer
Type:  System Byte
A pointer to an array of unsigned 8-bit integers. This array must be filled with data to be sent to a slave during the function execution.
writeLength
Type: System Int32
Data length to be written to slave device.
readBuffer
Type:  System Byte
A pointer to an array of unsigned 8-bit integers. This array will be filled with data received from slave during the function execution.
readLength
Type: System Int32
Data length to be read from the slave device.
See Also
Reference
Port Class
Transfer Overload
Dln.I2cMaster Namespace


Port.Transfer Method (Int32, Byte[], Int32, Int32, Byte[], Int32, Int32)

Port Transfer Method (Int32, Byte , Int32, Int32, Byte , Int32, Int32) dln.net.dll
Transfer method performs a transfer (read/write) operation between I2C master and slave devices.

Namespace: Dln.I2cMaster
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public void Transfer(
    int slaveDeviceAddress,
    byte[] writeBuffer,
    int writeOffset,
    int writeLength,
    byte[] readBuffer,
    int readOffset,
    int readLength
)
public void Transfer(
    int slaveDeviceAddress,
    byte[] writeBuffer,
    int writeOffset,
    int writeLength,
    byte[] readBuffer,
    int readOffset,
    int readLength
)
Public Sub Transfer (
    slaveDeviceAddress As Integer,
    writeBuffer As Byte(),
    writeOffset As Integer,
    writeLength As Integer,
    readBuffer As Byte(),
    readOffset As Integer,
    readLength As Integer
)
Public Sub Transfer (
    slaveDeviceAddress As Integer,
    writeBuffer As Byte(),
    writeOffset As Integer,
    writeLength As Integer,
    readBuffer As Byte(),
    readOffset As Integer,
    readLength As Integer
)
public:
void Transfer(
    int slaveDeviceAddress,
    array<unsigned char>^ writeBuffer,
    int writeOffset,
    int writeLength,
    array<unsigned char>^ readBuffer,
    int readOffset,
    int readLength
)
public:
void Transfer(
    int slaveDeviceAddress,
    array<unsigned char>^ writeBuffer,
    int writeOffset,
    int writeLength,
    array<unsigned char>^ readBuffer,
    int readOffset,
    int readLength
)
Parameters
slaveDeviceAddress
Type: System Int32
A 7-bit number, assigned to each I2C slave device.
writeBuffer
Type:  System Byte
A pointer to an array of unsigned 8-bit integers. This array must be filled with data to be sent to a slave during the function execution.
writeOffset
Type: System Int32
Data offset for write operation.
writeLength
Type: System Int32
Data length to be written to slave device.
readBuffer
Type:  System Byte
A pointer to an array of unsigned 8-bit integers. This array will be filled with data received from slave during the function execution.
readOffset
Type: System Int32
Data offset for read operation.
readLength
Type: System Int32
Data length to be read from the slave device.
See Also
Reference
Port Class
Transfer Overload
Dln.I2cMaster Namespace


Port.Write Method

Port Write Method dln.net.dll
Overload List
 | Name | Description
Public method | Write(Int32, Byte ) | Send data via I2C interface from the DLN-series adapter to the specified I2C slave device.
Public method | Write(Int32, Int32, Int32, Byte ) | Send data via I2C interface from the DLN-series adapter to the specified I2C slave device.
Public method | Write(Int32, Int32, Int32, Byte , Int32) | Send data via I2C interface from the DLN-series adapter to the specified I2C slave device.
Public method | Write(Int32, Int32, Int32, Byte , Int32, Int32) | Send data via I2C interface from the DLN-series adapter to the specified I2C slave device.
Top
See Also

Reference

Port Class
Dln.I2cMaster Namespace


Port.Write Method (Int32, Byte[])

Port Write Method (Int32, Byte ) dln.net.dll
Send data via I2C interface from the DLN-series adapter to the specified I2C slave device.

Namespace: Dln.I2cMaster
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public void Write(
    int slaveDeviceAddress,
    byte[] data
)
public void Write(
    int slaveDeviceAddress,
    byte[] data
)
Public Sub Write (
    slaveDeviceAddress As Integer,
    data As Byte()
)
Public Sub Write (
    slaveDeviceAddress As Integer,
    data As Byte()
)
public:
void Write(
    int slaveDeviceAddress,
    array<unsigned char>^ data
)
public:
void Write(
    int slaveDeviceAddress,
    array<unsigned char>^ data
)
Parameters
slaveDeviceAddress
Type: System Int32
A 7-bit number, uniquely assigned to each I2C slave device
data
Type:  System Byte
Data to be sent
See Also
Reference
Port Class
Write Overload
Dln.I2cMaster Namespace


Port.Write Method (Int32, Int32, Int32, Byte[])

Port Write Method (Int32, Int32, Int32, Byte ) dln.net.dll
Send data via I2C interface from the DLN-series adapter to the specified I2C slave device.

Namespace: Dln.I2cMaster
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public void Write(
    int slaveDeviceAddress,
    int memoryAddressLength,
    int memoryAddress,
    byte[] data
)
public void Write(
    int slaveDeviceAddress,
    int memoryAddressLength,
    int memoryAddress,
    byte[] data
)
Public Sub Write (
    slaveDeviceAddress As Integer,
    memoryAddressLength As Integer,
    memoryAddress As Integer,
    data As Byte()
)
Public Sub Write (
    slaveDeviceAddress As Integer,
    memoryAddressLength As Integer,
    memoryAddress As Integer,
    data As Byte()
)
public:
void Write(
    int slaveDeviceAddress,
    int memoryAddressLength,
    int memoryAddress,
    array<unsigned char>^ data
)
public:
void Write(
    int slaveDeviceAddress,
    int memoryAddressLength,
    int memoryAddress,
    array<unsigned char>^ data
)
Parameters
slaveDeviceAddress
Type: System Int32
A 7-bit number, uniquely assigned to each I2C slave device.
memoryAddressLength
Type: System Int32
Must contain an internal address length. If set to zero, no internal address is sent.
memoryAddress
Type: System Int32
An internal I2C slave device address.
data
Type:  System Byte
Data to be sent
See Also
Reference
Port Class
Write Overload
Dln.I2cMaster Namespace


Port.Write Method (Int32, Int32, Int32, Byte[], Int32)

Port Write Method (Int32, Int32, Int32, Byte , Int32) dln.net.dll
Send data via I2C interface from the DLN-series adapter to the specified I2C slave device.

Namespace: Dln.I2cMaster
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public void Write(
    int slaveDeviceAddress,
    int memoryAddressLength,
    int memoryAddress,
    byte[] data,
    int dataSize
)
public void Write(
    int slaveDeviceAddress,
    int memoryAddressLength,
    int memoryAddress,
    byte[] data,
    int dataSize
)
Public Sub Write (
    slaveDeviceAddress As Integer,
    memoryAddressLength As Integer,
    memoryAddress As Integer,
    data As Byte(),
    dataSize As Integer
)
Public Sub Write (
    slaveDeviceAddress As Integer,
    memoryAddressLength As Integer,
    memoryAddress As Integer,
    data As Byte(),
    dataSize As Integer
)
public:
void Write(
    int slaveDeviceAddress,
    int memoryAddressLength,
    int memoryAddress,
    array<unsigned char>^ data,
    int dataSize
)
public:
void Write(
    int slaveDeviceAddress,
    int memoryAddressLength,
    int memoryAddress,
    array<unsigned char>^ data,
    int dataSize
)
Parameters
slaveDeviceAddress
Type: System Int32
A 7-bit number, uniquely assigned to each I2C slave device.
memoryAddressLength
Type: System Int32
Must contain an internal address length. If set to zero, no internal address is sent.
memoryAddress
Type: System Int32
An internal I2C slave device address.
data
Type:  System Byte
Data to be sent
dataSize
Type: System Int32
Data size
See Also
Reference
Port Class
Write Overload
Dln.I2cMaster Namespace


Port.Write Method (Int32, Int32, Int32, Byte[], Int32, Int32)

Port Write Method (Int32, Int32, Int32, Byte , Int32, Int32) dln.net.dll
Send data via I2C interface from the DLN-series adapter to the specified I2C slave device.

Namespace: Dln.I2cMaster
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public void Write(
    int slaveDeviceAddress,
    int memoryAddressLength,
    int memoryAddress,
    byte[] data,
    int dataOffset,
    int dataSize
)
public void Write(
    int slaveDeviceAddress,
    int memoryAddressLength,
    int memoryAddress,
    byte[] data,
    int dataOffset,
    int dataSize
)
Public Sub Write (
    slaveDeviceAddress As Integer,
    memoryAddressLength As Integer,
    memoryAddress As Integer,
    data As Byte(),
    dataOffset As Integer,
    dataSize As Integer
)
Public Sub Write (
    slaveDeviceAddress As Integer,
    memoryAddressLength As Integer,
    memoryAddress As Integer,
    data As Byte(),
    dataOffset As Integer,
    dataSize As Integer
)
public:
void Write(
    int slaveDeviceAddress,
    int memoryAddressLength,
    int memoryAddress,
    array<unsigned char>^ data,
    int dataOffset,
    int dataSize
)
public:
void Write(
    int slaveDeviceAddress,
    int memoryAddressLength,
    int memoryAddress,
    array<unsigned char>^ data,
    int dataOffset,
    int dataSize
)
Parameters
slaveDeviceAddress
Type: System Int32
A 7-bit number, uniquely assigned to each I2C slave device.
memoryAddressLength
Type: System Int32
Must contain an internal address length. If set to zero, no internal address is sent.
memoryAddress
Type: System Int32
An internal I2C slave device address.
data
Type:  System Byte
Data to be sent
dataOffset
Type: System Int32
Data offset
dataSize
Type: System Int32
Data size
See Also
Reference
Port Class
Write Overload
Dln.I2cMaster Namespace


Port Properties

Port Properties dln.net.dll

The Port type exposes the following members.

Properties
 | Name | Description
Public property | Enabled | Set I2C master port status. Set true or false to enable or disable I2C master port respectively. Leave property blank to retrieve current I2C master port status.
Public property | Frequency | Set frequency of I2C master port. Leave property blank to get current frequency value.
Public property | MaxFrequency | Get maximum possible frequency value.
Public property | MaxReplyCount | Retrieves maximum reply count for I2C master port.
Public property | MinFrequency | Get minimal possible frequency value.
Public property | Restrictions | Restrictions class
Top
See Also

Reference

Port Class
Dln.I2cMaster Namespace


Port.Enabled Property

Port Enabled Property dln.net.dll
Set I2C master port status. Set true or false to enable or disable I2C master port respectively. Leave property blank to retrieve current I2C master port status.

Namespace: Dln.I2cMaster
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public bool Enabled { get; set; }
public bool Enabled { get; set; }
Public Property Enabled As Boolean
    Get
    Set
Public Property Enabled As Boolean
    Get
    Set
public:
property bool Enabled {
    bool get ();
    void set (bool value);
}
public:
property bool Enabled {
    bool get ();
    void set (bool value);
}
Property Value
Type: Boolean
See Also
Reference
Port Class
Dln.I2cMaster Namespace


Port.Frequency Property

Port Frequency Property dln.net.dll
Set frequency of I2C master port. Leave property blank to get current frequency value.

Namespace: Dln.I2cMaster
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public int Frequency { get; set; }
public int Frequency { get; set; }
Public Property Frequency As Integer
    Get
    Set
Public Property Frequency As Integer
    Get
    Set
public:
property int Frequency {
    int get ();
    void set (int value);
}
public:
property int Frequency {
    int get ();
    void set (int value);
}
Property Value
Type: Int32
See Also
Reference
Port Class
Dln.I2cMaster Namespace


Port.MaxFrequency Property

Port MaxFrequency Property dln.net.dll
Get maximum possible frequency value.

Namespace: Dln.I2cMaster
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public int MaxFrequency { get; }
public int MaxFrequency { get; }
Public ReadOnly Property MaxFrequency As Integer
    Get
Public ReadOnly Property MaxFrequency As Integer
    Get
public:
property int MaxFrequency {
    int get ();
}
public:
property int MaxFrequency {
    int get ();
}
Property Value
Type: Int32
See Also
Reference
Port Class
Dln.I2cMaster Namespace


Port.MaxReplyCount Property

Port MaxReplyCount Property dln.net.dll
Retrieves maximum reply count for I2C master port.

Namespace: Dln.I2cMaster
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public int MaxReplyCount { get; set; }
public int MaxReplyCount { get; set; }
Public Property MaxReplyCount As Integer
    Get
    Set
Public Property MaxReplyCount As Integer
    Get
    Set
public:
property int MaxReplyCount {
    int get ();
    void set (int value);
}
public:
property int MaxReplyCount {
    int get ();
    void set (int value);
}
Property Value
Type: Int32
See Also
Reference
Port Class
Dln.I2cMaster Namespace


Port.MinFrequency Property

Port MinFrequency Property dln.net.dll
Get minimal possible frequency value.

Namespace: Dln.I2cMaster
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public int MinFrequency { get; }
public int MinFrequency { get; }
Public ReadOnly Property MinFrequency As Integer
    Get
Public ReadOnly Property MinFrequency As Integer
    Get
public:
property int MinFrequency {
    int get ();
}
public:
property int MinFrequency {
    int get ();
}
Property Value
Type: Int32
See Also
Reference
Port Class
Dln.I2cMaster Namespace


Port.Restrictions Property

Port Restrictions Property dln.net.dll
Restrictions class

Namespace: Dln.I2cMaster
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public PortRestrictions Restrictions { get; }
public PortRestrictions Restrictions { get; }
Public ReadOnly Property Restrictions As PortRestrictions
    Get
Public ReadOnly Property Restrictions As PortRestrictions
    Get
public:
property PortRestrictions^ Restrictions {
    PortRestrictions^ get ();
}
public:
property PortRestrictions^ Restrictions {
    PortRestrictions^ get ();
}
Property Value
Type: PortRestrictions
See Also
Reference
Port Class
Dln.I2cMaster Namespace


PortRestrictions Class

PortRestrictions Class dln.net.dll
PortRestrictions class describes all I2c master module restrictions.
Inheritance Hierarchy
System Object
Dln.I2cMaster PortRestrictions

Namespace: Dln.I2cMaster
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public class PortRestrictions
public class PortRestrictions
Public Class PortRestrictions
Public Class PortRestrictions
public ref class PortRestrictions
public ref class PortRestrictions
The PortRestrictions type exposes the following members.
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Enabled | Enabled restriction
Public property | Frequency | Ferquency restriction
Public property | MaxFrequency | MaxFrequency restriction
Public property | MaxReplyCount | MaxReplyCount restriction
Public property | MinFrequency | MinFrequency restriction
Public property | Read | Read restriction
Public property | ScanDevices | ScanDevices restriction
Public property | Transfer | Transfer restriction
Public property | Write | Write restriction
Top
See Also
Reference
Dln.I2cMaster Namespace


PortRestrictions Methods

PortRestrictions Methods dln.net.dll

The PortRestrictions type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PortRestrictions Class
Dln.I2cMaster Namespace


PortRestrictions Properties

PortRestrictions Properties dln.net.dll

The PortRestrictions type exposes the following members.

Properties
 | Name | Description
Public property | Enabled | Enabled restriction
Public property | Frequency | Ferquency restriction
Public property | MaxFrequency | MaxFrequency restriction
Public property | MaxReplyCount | MaxReplyCount restriction
Public property | MinFrequency | MinFrequency restriction
Public property | Read | Read restriction
Public property | ScanDevices | ScanDevices restriction
Public property | Transfer | Transfer restriction
Public property | Write | Write restriction
Top
See Also

Reference

PortRestrictions Class
Dln.I2cMaster Namespace


PortRestrictions.Enabled Property

PortRestrictions Enabled Property dln.net.dll
Enabled restriction

Namespace: Dln.I2cMaster
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public Restriction Enabled { get; }
public Restriction Enabled { get; }
Public ReadOnly Property Enabled As Restriction
    Get
Public ReadOnly Property Enabled As Restriction
    Get
public:
property Restriction Enabled {
    Restriction get ();
}
public:
property Restriction Enabled {
    Restriction get ();
}
Property Value
Type: Restriction
See Also
Reference
PortRestrictions Class
Dln.I2cMaster Namespace


PortRestrictions.Frequency Property

PortRestrictions Frequency Property dln.net.dll
Ferquency restriction

Namespace: Dln.I2cMaster
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public Restriction Frequency { get; }
public Restriction Frequency { get; }
Public ReadOnly Property Frequency As Restriction
    Get
Public ReadOnly Property Frequency As Restriction
    Get
public:
property Restriction Frequency {
    Restriction get ();
}
public:
property Restriction Frequency {
    Restriction get ();
}
Property Value
Type: Restriction
See Also
Reference
PortRestrictions Class
Dln.I2cMaster Namespace


PortRestrictions.MaxFrequency Property

PortRestrictions MaxFrequency Property dln.net.dll
MaxFrequency restriction

Namespace: Dln.I2cMaster
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public Restriction MaxFrequency { get; }
public Restriction MaxFrequency { get; }
Public ReadOnly Property MaxFrequency As Restriction
    Get
Public ReadOnly Property MaxFrequency As Restriction
    Get
public:
property Restriction MaxFrequency {
    Restriction get ();
}
public:
property Restriction MaxFrequency {
    Restriction get ();
}
Property Value
Type: Restriction
See Also
Reference
PortRestrictions Class
Dln.I2cMaster Namespace


PortRestrictions.MaxReplyCount Property

PortRestrictions MaxReplyCount Property dln.net.dll
MaxReplyCount restriction

Namespace: Dln.I2cMaster
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public Restriction MaxReplyCount { get; }
public Restriction MaxReplyCount { get; }
Public ReadOnly Property MaxReplyCount As Restriction
    Get
Public ReadOnly Property MaxReplyCount As Restriction
    Get
public:
property Restriction MaxReplyCount {
    Restriction get ();
}
public:
property Restriction MaxReplyCount {
    Restriction get ();
}
Property Value
Type: Restriction
See Also
Reference
PortRestrictions Class
Dln.I2cMaster Namespace


PortRestrictions.MinFrequency Property

PortRestrictions MinFrequency Property dln.net.dll
MinFrequency restriction

Namespace: Dln.I2cMaster
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public Restriction MinFrequency { get; }
public Restriction MinFrequency { get; }
Public ReadOnly Property MinFrequency As Restriction
    Get
Public ReadOnly Property MinFrequency As Restriction
    Get
public:
property Restriction MinFrequency {
    Restriction get ();
}
public:
property Restriction MinFrequency {
    Restriction get ();
}
Property Value
Type: Restriction
See Also
Reference
PortRestrictions Class
Dln.I2cMaster Namespace


PortRestrictions.Read Property

PortRestrictions Read Property dln.net.dll
Read restriction

Namespace: Dln.I2cMaster
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public Restriction Read { get; }
public Restriction Read { get; }
Public ReadOnly Property Read As Restriction
    Get
Public ReadOnly Property Read As Restriction
    Get
public:
property Restriction Read {
    Restriction get ();
}
public:
property Restriction Read {
    Restriction get ();
}
Property Value
Type: Restriction
See Also
Reference
PortRestrictions Class
Dln.I2cMaster Namespace


PortRestrictions.ScanDevices Property

PortRestrictions ScanDevices Property dln.net.dll
ScanDevices restriction

Namespace: Dln.I2cMaster
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public Restriction ScanDevices { get; }
public Restriction ScanDevices { get; }
Public ReadOnly Property ScanDevices As Restriction
    Get
Public ReadOnly Property ScanDevices As Restriction
    Get
public:
property Restriction ScanDevices {
    Restriction get ();
}
public:
property Restriction ScanDevices {
    Restriction get ();
}
Property Value
Type: Restriction
See Also
Reference
PortRestrictions Class
Dln.I2cMaster Namespace


PortRestrictions.Transfer Property

PortRestrictions Transfer Property dln.net.dll
Transfer restriction

Namespace: Dln.I2cMaster
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public Restriction Transfer { get; }
public Restriction Transfer { get; }
Public ReadOnly Property Transfer As Restriction
    Get
Public ReadOnly Property Transfer As Restriction
    Get
public:
property Restriction Transfer {
    Restriction get ();
}
public:
property Restriction Transfer {
    Restriction get ();
}
Property Value
Type: Restriction
See Also
Reference
PortRestrictions Class
Dln.I2cMaster Namespace


PortRestrictions.Write Property

PortRestrictions Write Property dln.net.dll
Write restriction

Namespace: Dln.I2cMaster
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public Restriction Write { get; }
public Restriction Write { get; }
Public ReadOnly Property Write As Restriction
    Get
Public ReadOnly Property Write As Restriction
    Get
public:
property Restriction Write {
    Restriction get ();
}
public:
property Restriction Write {
    Restriction get ();
}
Property Value
Type: Restriction
See Also
Reference
PortRestrictions Class
Dln.I2cMaster Namespace


Ports Class

Ports Class dln.net.dll
Ports class
Inheritance Hierarchy
System Object
System.Collections.ObjectModel ReadOnlyCollection Port
Dln.I2cMaster Ports

Namespace: Dln.I2cMaster
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public class Ports : ReadOnlyCollection<Port>
public class Ports : ReadOnlyCollection<Port>
Public Class Ports
    Inherits ReadOnlyCollection(Of Port)
Public Class Ports
    Inherits ReadOnlyCollection(Of Port)
public ref class Ports : public ReadOnlyCollection<Port^>
public ref class Ports : public ReadOnlyCollection<Port^>
The Ports type exposes the following members.
Methods
 | Name | Description
Public method | Contains | Determines whether an element is in the ReadOnlyCollection T . (Inherited from ReadOnlyCollection Port .)
Public method | CopyTo | Copies the entire ReadOnlyCollection T to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from ReadOnlyCollection Port .)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the ReadOnlyCollection T . (Inherited from ReadOnlyCollection Port .)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Public method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ReadOnlyCollection T . (Inherited from ReadOnlyCollection Port .)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the ReadOnlyCollection T instance. (Inherited from ReadOnlyCollection Port .)
Public property | Item |
Protected property | Items | Returns the IList T that the ReadOnlyCollection T wraps. (Inherited from ReadOnlyCollection Port .)
Top
See Also
Reference
Dln.I2cMaster Namespace


Ports Methods

Ports Methods dln.net.dll

The Ports type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Determines whether an element is in the ReadOnlyCollection T . (Inherited from ReadOnlyCollection Port .)
Public method | CopyTo | Copies the entire ReadOnlyCollection T to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from ReadOnlyCollection Port .)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the ReadOnlyCollection T . (Inherited from ReadOnlyCollection Port .)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Public method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ReadOnlyCollection T . (Inherited from ReadOnlyCollection Port .)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Ports Class
Dln.I2cMaster Namespace


Ports Properties

Ports Properties dln.net.dll

The Ports type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the ReadOnlyCollection T instance. (Inherited from ReadOnlyCollection Port .)
Public property | Item |
Protected property | Items | Returns the IList T that the ReadOnlyCollection T wraps. (Inherited from ReadOnlyCollection Port .)
Top
See Also

Reference

Ports Class
Dln.I2cMaster Namespace


Ports.Item Property

Ports Item Property dln.net.dll

[Missing <summary> documentation for "P:Dln.I2cMaster.Ports.Item(System.Int32)"]

Namespace: Dln.I2cMaster
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public Port this[
    int index
] { get; }
public Port this[
    int index
] { get; }
Public ReadOnly Default Property Item (
    index As Integer
) As Port
    Get
Public ReadOnly Default Property Item (
    index As Integer
) As Port
    Get
public:
property Port^ default[int index] {
    Port^ get (int index);
}
public:
property Port^ default[int index] {
    Port^ get (int index);
}
Parameters
index
Type: System Int32
Port index
Return Value
Type: Port
Ports array by current index
See Also
Reference
Ports Class
Dln.I2cMaster Namespace


Dln.I2cSlave Namespace

Dln.I2cSlave Namespace dln.net.dll
The Dln.I2cSlave namespace contains types that allow usage of DLN-series adapters as I2C bus slave device.
Classes
 | Class | Description
Public class | Module | Module class describes
Public class | Port | Port class describes methods and properties for I2C Slave port.
Public class | PortRestrictions | Restriction for I2C slave port
Public class | Ports | Ports class
Public class | ReadEventArgs | ReadEventArg class allows to retrieve all event arguments.
Public class | SlaveDevice | SlaveDevice class
Public class | SlaveDeviceRestrictions | Restrictions for I2C slave device
Public class | SlaveDevices | Slave Devices
Public class | WriteEventArgs | WriteEventArgs class
Enumerations
 | Enumeration | Description
Public enumeration | EventType | Predefined event types


EventType Enumeration

EventType Enumeration dln.net.dll
Predefined event types

Namespace: Dln.I2cSlave
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public enum EventType
public enum EventType
Public Enumeration EventType
Public Enumeration EventType
public enum class EventType
public enum class EventType
Members
Member name | Value | Description
None | 0 | No events
Read | 1 | Read event
Write | 2 | Write event
ReadWrite | 3 | Read/Write event
See Also
Reference
Dln.I2cSlave Namespace


Module Class

Module Class dln.net.dll
Module class describes
Inheritance Hierarchy
System Object
Dln.I2cSlave Module

Namespace: Dln.I2cSlave
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public class Module
public class Module
Public Class Module
Public Class Module
public ref class Module
public ref class Module
The Module type exposes the following members.
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Ports | I2C slave module ports
Top
See Also
Reference
Dln.I2cSlave Namespace


Module Methods

Module Methods dln.net.dll

The Module type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Module Class
Dln.I2cSlave Namespace


Module Properties

Module Properties dln.net.dll

The Module type exposes the following members.

Properties
 | Name | Description
Public property | Ports | I2C slave module ports
Top
See Also

Reference

Module Class
Dln.I2cSlave Namespace


Module.Ports Property

Module Ports Property dln.net.dll
I2C slave module ports

Namespace: Dln.I2cSlave
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public Ports Ports { get; }
public Ports Ports { get; }
Public ReadOnly Property Ports As Ports
    Get
Public ReadOnly Property Ports As Ports
    Get
public:
property Ports^ Ports {
    Ports^ get ();
}
public:
property Ports^ Ports {
    Ports^ get ();
}
Property Value
Type: Ports
See Also
Reference
Module Class
Dln.I2cSlave Namespace


Port Class

Port Class dln.net.dll
Port class describes methods and properties for I2C Slave port.
Inheritance Hierarchy
System Object
Dln.I2cSlave Port

Namespace: Dln.I2cSlave
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public class Port
public class Port
Public Class Port
Public Class Port
public ref class Port
public ref class Port
The Port type exposes the following members.
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Enabled | Change the status of I2C slave port.
Public property | Restrictions | I2C slave port restrictions
Public property | SlaveDevices | SlaveDevices property
Top
See Also
Reference
Dln.I2cSlave Namespace


Port Methods

Port Methods dln.net.dll

The Port type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Port Class
Dln.I2cSlave Namespace


Port Properties

Port Properties dln.net.dll

The Port type exposes the following members.

Properties
 | Name | Description
Public property | Enabled | Change the status of I2C slave port.
Public property | Restrictions | I2C slave port restrictions
Public property | SlaveDevices | SlaveDevices property
Top
See Also

Reference

Port Class
Dln.I2cSlave Namespace


Port.Enabled Property

Port Enabled Property dln.net.dll
Change the status of I2C slave port.

Namespace: Dln.I2cSlave
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public bool Enabled { get; set; }
public bool Enabled { get; set; }
Public Property Enabled As Boolean
    Get
    Set
Public Property Enabled As Boolean
    Get
    Set
public:
property bool Enabled {
    bool get ();
    void set (bool value);
}
public:
property bool Enabled {
    bool get ();
    void set (bool value);
}
Property Value
Type: Boolean
See Also
Reference
Port Class
Dln.I2cSlave Namespace


Port.Restrictions Property

Port Restrictions Property dln.net.dll
I2C slave port restrictions

Namespace: Dln.I2cSlave
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public PortRestrictions Restrictions { get; }
public PortRestrictions Restrictions { get; }
Public ReadOnly Property Restrictions As PortRestrictions
    Get
Public ReadOnly Property Restrictions As PortRestrictions
    Get
public:
property PortRestrictions^ Restrictions {
    PortRestrictions^ get ();
}
public:
property PortRestrictions^ Restrictions {
    PortRestrictions^ get ();
}
Property Value
Type: PortRestrictions
See Also
Reference
Port Class
Dln.I2cSlave Namespace


Port.SlaveDevices Property

Port SlaveDevices Property dln.net.dll
SlaveDevices property

Namespace: Dln.I2cSlave
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public SlaveDevices SlaveDevices { get; }
public SlaveDevices SlaveDevices { get; }
Public ReadOnly Property SlaveDevices As SlaveDevices
    Get
Public ReadOnly Property SlaveDevices As SlaveDevices
    Get
public:
property SlaveDevices^ SlaveDevices {
    SlaveDevices^ get ();
}
public:
property SlaveDevices^ SlaveDevices {
    SlaveDevices^ get ();
}
Property Value
Type: SlaveDevices
See Also
Reference
Port Class
Dln.I2cSlave Namespace


PortRestrictions Class

PortRestrictions Class dln.net.dll
Restriction for I2C slave port
Inheritance Hierarchy
System Object
Dln.I2cSlave PortRestrictions

Namespace: Dln.I2cSlave
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public class PortRestrictions
public class PortRestrictions
Public Class PortRestrictions
Public Class PortRestrictions
public ref class PortRestrictions
public ref class PortRestrictions
The PortRestrictions type exposes the following members.
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Enabled | Enabled restriction
Top
See Also
Reference
Dln.I2cSlave Namespace


PortRestrictions Methods

PortRestrictions Methods dln.net.dll

The PortRestrictions type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PortRestrictions Class
Dln.I2cSlave Namespace


PortRestrictions Properties

PortRestrictions Properties dln.net.dll

The PortRestrictions type exposes the following members.

Properties
 | Name | Description
Public property | Enabled | Enabled restriction
Top
See Also

Reference

PortRestrictions Class
Dln.I2cSlave Namespace


PortRestrictions.Enabled Property

PortRestrictions Enabled Property dln.net.dll
Enabled restriction

Namespace: Dln.I2cSlave
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public Restriction Enabled { get; }
public Restriction Enabled { get; }
Public ReadOnly Property Enabled As Restriction
    Get
Public ReadOnly Property Enabled As Restriction
    Get
public:
property Restriction Enabled {
    Restriction get ();
}
public:
property Restriction Enabled {
    Restriction get ();
}
Property Value
Type: Restriction
See Also
Reference
PortRestrictions Class
Dln.I2cSlave Namespace


Ports Class

Ports Class dln.net.dll
Ports class
Inheritance Hierarchy
System Object
System.Collections.ObjectModel ReadOnlyCollection Port
Dln.I2cSlave Ports

Namespace: Dln.I2cSlave
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public class Ports : ReadOnlyCollection<Port>
public class Ports : ReadOnlyCollection<Port>
Public Class Ports
    Inherits ReadOnlyCollection(Of Port)
Public Class Ports
    Inherits ReadOnlyCollection(Of Port)
public ref class Ports : public ReadOnlyCollection<Port^>
public ref class Ports : public ReadOnlyCollection<Port^>
The Ports type exposes the following members.
Methods
 | Name | Description
Public method | Contains | Determines whether an element is in the ReadOnlyCollection T . (Inherited from ReadOnlyCollection Port .)
Public method | CopyTo | Copies the entire ReadOnlyCollection T to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from ReadOnlyCollection Port .)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the ReadOnlyCollection T . (Inherited from ReadOnlyCollection Port .)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Public method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ReadOnlyCollection T . (Inherited from ReadOnlyCollection Port .)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the ReadOnlyCollection T instance. (Inherited from ReadOnlyCollection Port .)
Public property | Item |
Protected property | Items | Returns the IList T that the ReadOnlyCollection T wraps. (Inherited from ReadOnlyCollection Port .)
Top
See Also
Reference
Dln.I2cSlave Namespace


Ports Methods

Ports Methods dln.net.dll

The Ports type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Determines whether an element is in the ReadOnlyCollection T . (Inherited from ReadOnlyCollection Port .)
Public method | CopyTo | Copies the entire ReadOnlyCollection T to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from ReadOnlyCollection Port .)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the ReadOnlyCollection T . (Inherited from ReadOnlyCollection Port .)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Public method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ReadOnlyCollection T . (Inherited from ReadOnlyCollection Port .)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Ports Class
Dln.I2cSlave Namespace


Ports Properties

Ports Properties dln.net.dll

The Ports type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the ReadOnlyCollection T instance. (Inherited from ReadOnlyCollection Port .)
Public property | Item |
Protected property | Items | Returns the IList T that the ReadOnlyCollection T wraps. (Inherited from ReadOnlyCollection Port .)
Top
See Also

Reference

Ports Class
Dln.I2cSlave Namespace


Ports.Item Property

Ports Item Property dln.net.dll

[Missing <summary> documentation for "P:Dln.I2cSlave.Ports.Item(System.Int32)"]

Namespace: Dln.I2cSlave
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public Port this[
    int index
] { get; }
public Port this[
    int index
] { get; }
Public ReadOnly Default Property Item (
    index As Integer
) As Port
    Get
Public ReadOnly Default Property Item (
    index As Integer
) As Port
    Get
public:
property Port^ default[int index] {
    Port^ get (int index);
}
public:
property Port^ default[int index] {
    Port^ get (int index);
}
Parameters
index
Type: System Int32
Port index
Return Value
Type: Port
Returns Port class object for specified port
See Also
Reference
Ports Class
Dln.I2cSlave Namespace


ReadEventArgs Class

ReadEventArgs Class dln.net.dll
ReadEventArg class allows to retrieve all event arguments.
Inheritance Hierarchy
System Object
System EventArgs
Dln.I2cSlave ReadEventArgs

Namespace: Dln.I2cSlave
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public class ReadEventArgs : EventArgs
public class ReadEventArgs : EventArgs
Public Class ReadEventArgs
    Inherits EventArgs
Public Class ReadEventArgs
    Inherits EventArgs
public ref class ReadEventArgs : public EventArgs
public ref class ReadEventArgs : public EventArgs
The ReadEventArgs type exposes the following members.
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | ReadSize | Get transfer size
Public property | SlaveAddress | Get I2C slave address
Top
See Also
Reference
Dln.I2cSlave Namespace


ReadEventArgs Methods

ReadEventArgs Methods dln.net.dll

The ReadEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ReadEventArgs Class
Dln.I2cSlave Namespace


ReadEventArgs Properties

ReadEventArgs Properties dln.net.dll

The ReadEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | ReadSize | Get transfer size
Public property | SlaveAddress | Get I2C slave address
Top
See Also

Reference

ReadEventArgs Class
Dln.I2cSlave Namespace


ReadEventArgs.ReadSize Property

ReadEventArgs ReadSize Property dln.net.dll
Get transfer size

Namespace: Dln.I2cSlave
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public int ReadSize { get; }
public int ReadSize { get; }
Public ReadOnly Property ReadSize As Integer
    Get
Public ReadOnly Property ReadSize As Integer
    Get
public:
property int ReadSize {
    int get ();
}
public:
property int ReadSize {
    int get ();
}
Property Value
Type: Int32
See Also
Reference
ReadEventArgs Class
Dln.I2cSlave Namespace


ReadEventArgs.SlaveAddress Property

ReadEventArgs SlaveAddress Property dln.net.dll
Get I2C slave address

Namespace: Dln.I2cSlave
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public int SlaveAddress { get; }
public int SlaveAddress { get; }
Public ReadOnly Property SlaveAddress As Integer
    Get
Public ReadOnly Property SlaveAddress As Integer
    Get
public:
property int SlaveAddress {
    int get ();
}
public:
property int SlaveAddress {
    int get ();
}
Property Value
Type: Int32
See Also
Reference
ReadEventArgs Class
Dln.I2cSlave Namespace


SlaveDevice Class

SlaveDevice Class dln.net.dll
SlaveDevice class
Inheritance Hierarchy
System Object
Dln.I2cSlave SlaveDevice

Namespace: Dln.I2cSlave
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public class SlaveDevice
public class SlaveDevice
Public Class SlaveDevice
Public Class SlaveDevice
public ref class SlaveDevice
public ref class SlaveDevice
The SlaveDevice type exposes the following members.
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Public method | LoadReply( Byte ) | LoadReply mwthod loads data to be transferred to an I2C master device.
Public method | LoadReply( Byte , Int32, Int32) | LoadReply property. Loads data to be transferred to an I2C master device.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Address | I2C slave device address property
Public property | EventType | EventType property
Public property | Restrictions | Restrictions property
Public property | SupportedEventTypes | SupportedEventTypes property
Top
Events
 | Name | Description
Public event | Read | Read event handler
Public event | ReadThreadSafe | Read event handles with thread safe
Public event | Write | Write event handler
Public event | WriteThreadSafe | Write event handler with thread safe
Top
See Also
Reference
Dln.I2cSlave Namespace


SlaveDevice Methods

SlaveDevice Methods dln.net.dll

The SlaveDevice type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Public method | LoadReply( Byte ) | LoadReply mwthod loads data to be transferred to an I2C master device.
Public method | LoadReply( Byte , Int32, Int32) | LoadReply property. Loads data to be transferred to an I2C master device.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SlaveDevice Class
Dln.I2cSlave Namespace


SlaveDevice.LoadReply Method

SlaveDevice LoadReply Method dln.net.dll
Overload List
 | Name | Description
Public method | LoadReply( Byte ) | LoadReply mwthod loads data to be transferred to an I2C master device.
Public method | LoadReply( Byte , Int32, Int32) | LoadReply property. Loads data to be transferred to an I2C master device.
Top
See Also

Reference

SlaveDevice Class
Dln.I2cSlave Namespace


SlaveDevice.LoadReply Method (Byte[])

SlaveDevice LoadReply Method ( Byte ) dln.net.dll
LoadReply mwthod loads data to be transferred to an I2C master device.

Namespace: Dln.I2cSlave
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public void LoadReply(
    byte[] buffer
)
public void LoadReply(
    byte[] buffer
)
Public Sub LoadReply (
    buffer As Byte()
)
Public Sub LoadReply (
    buffer As Byte()
)
public:
void LoadReply(
    array<unsigned char>^ buffer
)
public:
void LoadReply(
    array<unsigned char>^ buffer
)
Parameters
buffer
Type:  System Byte
Buffer with data
See Also
Reference
SlaveDevice Class
LoadReply Overload
Dln.I2cSlave Namespace


SlaveDevice.LoadReply Method (Byte[], Int32, Int32)

SlaveDevice LoadReply Method ( Byte , Int32, Int32) dln.net.dll
LoadReply property. Loads data to be transferred to an I2C master device.

Namespace: Dln.I2cSlave
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public void LoadReply(
    byte[] buffer,
    int offset,
    int count
)
public void LoadReply(
    byte[] buffer,
    int offset,
    int count
)
Public Sub LoadReply (
    buffer As Byte(),
    offset As Integer,
    count As Integer
)
Public Sub LoadReply (
    buffer As Byte(),
    offset As Integer,
    count As Integer
)
public:
void LoadReply(
    array<unsigned char>^ buffer,
    int offset,
    int count
)
public:
void LoadReply(
    array<unsigned char>^ buffer,
    int offset,
    int count
)
Parameters
buffer
Type:  System Byte
Buffer with data
offset
Type: System Int32
Data offset
count
Type: System Int32
Count
See Also
Reference
SlaveDevice Class
LoadReply Overload
Dln.I2cSlave Namespace


SlaveDevice Properties

SlaveDevice Properties dln.net.dll

The SlaveDevice type exposes the following members.

Properties
 | Name | Description
Public property | Address | I2C slave device address property
Public property | EventType | EventType property
Public property | Restrictions | Restrictions property
Public property | SupportedEventTypes | SupportedEventTypes property
Top
See Also

Reference

SlaveDevice Class
Dln.I2cSlave Namespace


SlaveDevice.Address Property

SlaveDevice Address Property dln.net.dll
I2C slave device address property

Namespace: Dln.I2cSlave
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public int Address { get; set; }
public int Address { get; set; }
Public Property Address As Integer
    Get
    Set
Public Property Address As Integer
    Get
    Set
public:
property int Address {
    int get ();
    void set (int value);
}
public:
property int Address {
    int get ();
    void set (int value);
}
Property Value
Type: Int32
See Also
Reference
SlaveDevice Class
Dln.I2cSlave Namespace


SlaveDevice.EventType Property

SlaveDevice EventType Property dln.net.dll
EventType property

Namespace: Dln.I2cSlave
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public EventType EventType { get; set; }
public EventType EventType { get; set; }
Public Property EventType As EventType
    Get
    Set
Public Property EventType As EventType
    Get
    Set
public:
property EventType EventType {
    EventType get ();
    void set (EventType value);
}
public:
property EventType EventType {
    EventType get ();
    void set (EventType value);
}
Property Value
Type: EventType
See Also
Reference
SlaveDevice Class
Dln.I2cSlave Namespace


SlaveDevice.Restrictions Property

SlaveDevice Restrictions Property dln.net.dll
Restrictions property

Namespace: Dln.I2cSlave
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public SlaveDeviceRestrictions Restrictions { get; }
public SlaveDeviceRestrictions Restrictions { get; }
Public ReadOnly Property Restrictions As SlaveDeviceRestrictions
    Get
Public ReadOnly Property Restrictions As SlaveDeviceRestrictions
    Get
public:
property SlaveDeviceRestrictions^ Restrictions {
    SlaveDeviceRestrictions^ get ();
}
public:
property SlaveDeviceRestrictions^ Restrictions {
    SlaveDeviceRestrictions^ get ();
}
Property Value
Type: SlaveDeviceRestrictions
See Also
Reference
SlaveDevice Class
Dln.I2cSlave Namespace


SlaveDevice.SupportedEventTypes Property

SlaveDevice SupportedEventTypes Property dln.net.dll
SupportedEventTypes property

Namespace: Dln.I2cSlave
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public ReadOnlyCollection<EventType> SupportedEventTypes { get; }
public ReadOnlyCollection<EventType> SupportedEventTypes { get; }
Public ReadOnly Property SupportedEventTypes As ReadOnlyCollection(Of EventType)
    Get
Public ReadOnly Property SupportedEventTypes As ReadOnlyCollection(Of EventType)
    Get
public:
property ReadOnlyCollection<EventType>^ SupportedEventTypes {
    ReadOnlyCollection<EventType>^ get ();
}
public:
property ReadOnlyCollection<EventType>^ SupportedEventTypes {
    ReadOnlyCollection<EventType>^ get ();
}
Property Value
Type: ReadOnlyCollection  EventType
See Also
Reference
SlaveDevice Class
Dln.I2cSlave Namespace


SlaveDevice Events

SlaveDevice Events dln.net.dll

The SlaveDevice type exposes the following members.

Events
 | Name | Description
Public event | Read | Read event handler
Public event | ReadThreadSafe | Read event handles with thread safe
Public event | Write | Write event handler
Public event | WriteThreadSafe | Write event handler with thread safe
Top
See Also

Reference

SlaveDevice Class
Dln.I2cSlave Namespace


SlaveDevice.Read Event

SlaveDevice Read Event dln.net.dll
Read event handler

Namespace: Dln.I2cSlave
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public event EventHandler<ReadEventArgs> Read
public event EventHandler<ReadEventArgs> Read
Public Event Read As EventHandler(Of ReadEventArgs)
Public Event Read As EventHandler(Of ReadEventArgs)
public:
 event EventHandler<ReadEventArgs^>^ Read {
    void add (EventHandler<ReadEventArgs^>^ value);
    void remove (EventHandler<ReadEventArgs^>^ value);
}
public:
 event EventHandler<ReadEventArgs^>^ Read {
    void add (EventHandler<ReadEventArgs^>^ value);
    void remove (EventHandler<ReadEventArgs^>^ value);
}
Value
Type: System EventHandler  ReadEventArgs
See Also
Reference
SlaveDevice Class
Dln.I2cSlave Namespace


SlaveDevice.ReadThreadSafe Event

SlaveDevice ReadThreadSafe Event dln.net.dll
Read event handles with thread safe

Namespace: Dln.I2cSlave
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public event EventHandler<ReadEventArgs> ReadThreadSafe
public event EventHandler<ReadEventArgs> ReadThreadSafe
Public Event ReadThreadSafe As EventHandler(Of ReadEventArgs)
Public Event ReadThreadSafe As EventHandler(Of ReadEventArgs)
public:
 event EventHandler<ReadEventArgs^>^ ReadThreadSafe {
    void add (EventHandler<ReadEventArgs^>^ value);
    void remove (EventHandler<ReadEventArgs^>^ value);
}
public:
 event EventHandler<ReadEventArgs^>^ ReadThreadSafe {
    void add (EventHandler<ReadEventArgs^>^ value);
    void remove (EventHandler<ReadEventArgs^>^ value);
}
Value
Type: System EventHandler  ReadEventArgs
See Also
Reference
SlaveDevice Class
Dln.I2cSlave Namespace


SlaveDevice.Write Event

SlaveDevice Write Event dln.net.dll
Write event handler

Namespace: Dln.I2cSlave
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public event EventHandler<WriteEventArgs> Write
public event EventHandler<WriteEventArgs> Write
Public Event Write As EventHandler(Of WriteEventArgs)
Public Event Write As EventHandler(Of WriteEventArgs)
public:
 event EventHandler<WriteEventArgs^>^ Write {
    void add (EventHandler<WriteEventArgs^>^ value);
    void remove (EventHandler<WriteEventArgs^>^ value);
}
public:
 event EventHandler<WriteEventArgs^>^ Write {
    void add (EventHandler<WriteEventArgs^>^ value);
    void remove (EventHandler<WriteEventArgs^>^ value);
}
Value
Type: System EventHandler  WriteEventArgs
See Also
Reference
SlaveDevice Class
Dln.I2cSlave Namespace


SlaveDevice.WriteThreadSafe Event

SlaveDevice WriteThreadSafe Event dln.net.dll
Write event handler with thread safe

Namespace: Dln.I2cSlave
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public event EventHandler<WriteEventArgs> WriteThreadSafe
public event EventHandler<WriteEventArgs> WriteThreadSafe
Public Event WriteThreadSafe As EventHandler(Of WriteEventArgs)
Public Event WriteThreadSafe As EventHandler(Of WriteEventArgs)
public:
 event EventHandler<WriteEventArgs^>^ WriteThreadSafe {
    void add (EventHandler<WriteEventArgs^>^ value);
    void remove (EventHandler<WriteEventArgs^>^ value);
}
public:
 event EventHandler<WriteEventArgs^>^ WriteThreadSafe {
    void add (EventHandler<WriteEventArgs^>^ value);
    void remove (EventHandler<WriteEventArgs^>^ value);
}
Value
Type: System EventHandler  WriteEventArgs
See Also
Reference
SlaveDevice Class
Dln.I2cSlave Namespace


SlaveDeviceRestrictions Class

SlaveDeviceRestrictions Class dln.net.dll
Restrictions for I2C slave device
Inheritance Hierarchy
System Object
Dln.I2cSlave SlaveDeviceRestrictions

Namespace: Dln.I2cSlave
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public class SlaveDeviceRestrictions
public class SlaveDeviceRestrictions
Public Class SlaveDeviceRestrictions
Public Class SlaveDeviceRestrictions
public ref class SlaveDeviceRestrictions
public ref class SlaveDeviceRestrictions
The SlaveDeviceRestrictions type exposes the following members.
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Address | Address restriction
Public property | EventType | EventType restriction
Public property | LoadReply | LoadReply restriction
Public property | SupportedEventTypes | SupportedEventType restriction
Top
See Also
Reference
Dln.I2cSlave Namespace


SlaveDeviceRestrictions Methods

SlaveDeviceRestrictions Methods dln.net.dll

The SlaveDeviceRestrictions type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SlaveDeviceRestrictions Class
Dln.I2cSlave Namespace


SlaveDeviceRestrictions Properties

SlaveDeviceRestrictions Properties dln.net.dll

The SlaveDeviceRestrictions type exposes the following members.

Properties
 | Name | Description
Public property | Address | Address restriction
Public property | EventType | EventType restriction
Public property | LoadReply | LoadReply restriction
Public property | SupportedEventTypes | SupportedEventType restriction
Top
See Also

Reference

SlaveDeviceRestrictions Class
Dln.I2cSlave Namespace


SlaveDeviceRestrictions.Address Property

SlaveDeviceRestrictions Address Property dln.net.dll
Address restriction

Namespace: Dln.I2cSlave
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public Restriction Address { get; }
public Restriction Address { get; }
Public ReadOnly Property Address As Restriction
    Get
Public ReadOnly Property Address As Restriction
    Get
public:
property Restriction Address {
    Restriction get ();
}
public:
property Restriction Address {
    Restriction get ();
}
Property Value
Type: Restriction
See Also
Reference
SlaveDeviceRestrictions Class
Dln.I2cSlave Namespace


SlaveDeviceRestrictions.EventType Property

SlaveDeviceRestrictions EventType Property dln.net.dll
EventType restriction

Namespace: Dln.I2cSlave
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public Restriction EventType { get; }
public Restriction EventType { get; }
Public ReadOnly Property EventType As Restriction
    Get
Public ReadOnly Property EventType As Restriction
    Get
public:
property Restriction EventType {
    Restriction get ();
}
public:
property Restriction EventType {
    Restriction get ();
}
Property Value
Type: Restriction
See Also
Reference
SlaveDeviceRestrictions Class
Dln.I2cSlave Namespace


SlaveDeviceRestrictions.LoadReply Property

SlaveDeviceRestrictions LoadReply Property dln.net.dll
LoadReply restriction

Namespace: Dln.I2cSlave
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public Restriction LoadReply { get; }
public Restriction LoadReply { get; }
Public ReadOnly Property LoadReply As Restriction
    Get
Public ReadOnly Property LoadReply As Restriction
    Get
public:
property Restriction LoadReply {
    Restriction get ();
}
public:
property Restriction LoadReply {
    Restriction get ();
}
Property Value
Type: Restriction
See Also
Reference
SlaveDeviceRestrictions Class
Dln.I2cSlave Namespace


SlaveDeviceRestrictions.SupportedEventTypes Property

SlaveDeviceRestrictions SupportedEventTypes Property dln.net.dll
SupportedEventType restriction

Namespace: Dln.I2cSlave
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public Restriction SupportedEventTypes { get; }
public Restriction SupportedEventTypes { get; }
Public ReadOnly Property SupportedEventTypes As Restriction
    Get
Public ReadOnly Property SupportedEventTypes As Restriction
    Get
public:
property Restriction SupportedEventTypes {
    Restriction get ();
}
public:
property Restriction SupportedEventTypes {
    Restriction get ();
}
Property Value
Type: Restriction
See Also
Reference
SlaveDeviceRestrictions Class
Dln.I2cSlave Namespace


SlaveDevices Class

SlaveDevices Class dln.net.dll
Slave Devices
Inheritance Hierarchy
System Object
System.Collections.ObjectModel ReadOnlyCollection SlaveDevice
Dln.I2cSlave SlaveDevices

Namespace: Dln.I2cSlave
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public class SlaveDevices : ReadOnlyCollection<SlaveDevice>
public class SlaveDevices : ReadOnlyCollection<SlaveDevice>
Public Class SlaveDevices
    Inherits ReadOnlyCollection(Of SlaveDevice)
Public Class SlaveDevices
    Inherits ReadOnlyCollection(Of SlaveDevice)
public ref class SlaveDevices : public ReadOnlyCollection<SlaveDevice^>
public ref class SlaveDevices : public ReadOnlyCollection<SlaveDevice^>
The SlaveDevices type exposes the following members.
Methods
 | Name | Description
Public method | Contains | Determines whether an element is in the ReadOnlyCollection T . (Inherited from ReadOnlyCollection SlaveDevice .)
Public method | CopyTo | Copies the entire ReadOnlyCollection T to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from ReadOnlyCollection SlaveDevice .)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the ReadOnlyCollection T . (Inherited from ReadOnlyCollection SlaveDevice .)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Public method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ReadOnlyCollection T . (Inherited from ReadOnlyCollection SlaveDevice .)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the ReadOnlyCollection T instance. (Inherited from ReadOnlyCollection SlaveDevice .)
Public property | Item |
Protected property | Items | Returns the IList T that the ReadOnlyCollection T wraps. (Inherited from ReadOnlyCollection SlaveDevice .)
Top
See Also
Reference
Dln.I2cSlave Namespace


SlaveDevices Methods

SlaveDevices Methods dln.net.dll

The SlaveDevices type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Determines whether an element is in the ReadOnlyCollection T . (Inherited from ReadOnlyCollection SlaveDevice .)
Public method | CopyTo | Copies the entire ReadOnlyCollection T to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from ReadOnlyCollection SlaveDevice .)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the ReadOnlyCollection T . (Inherited from ReadOnlyCollection SlaveDevice .)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Public method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ReadOnlyCollection T . (Inherited from ReadOnlyCollection SlaveDevice .)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SlaveDevices Class
Dln.I2cSlave Namespace


SlaveDevices Properties

SlaveDevices Properties dln.net.dll

The SlaveDevices type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the ReadOnlyCollection T instance. (Inherited from ReadOnlyCollection SlaveDevice .)
Public property | Item |
Protected property | Items | Returns the IList T that the ReadOnlyCollection T wraps. (Inherited from ReadOnlyCollection SlaveDevice .)
Top
See Also

Reference

SlaveDevices Class
Dln.I2cSlave Namespace


SlaveDevices.Item Property

SlaveDevices Item Property dln.net.dll

[Missing <summary> documentation for "P:Dln.I2cSlave.SlaveDevices.Item(System.Int32)"]

Namespace: Dln.I2cSlave
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public SlaveDevice this[
    int index
] { get; }
public SlaveDevice this[
    int index
] { get; }
Public ReadOnly Default Property Item (
    index As Integer
) As SlaveDevice
    Get
Public ReadOnly Default Property Item (
    index As Integer
) As SlaveDevice
    Get
public:
property SlaveDevice^ default[int index] {
    SlaveDevice^ get (int index);
}
public:
property SlaveDevice^ default[int index] {
    SlaveDevice^ get (int index);
}
Parameters
index
Type: System Int32
Return Value
Type: SlaveDevice
See Also
Reference
SlaveDevices Class
Dln.I2cSlave Namespace


WriteEventArgs Class

WriteEventArgs Class dln.net.dll
WriteEventArgs class
Inheritance Hierarchy
System Object
System EventArgs
Dln.I2cSlave WriteEventArgs

Namespace: Dln.I2cSlave
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public class WriteEventArgs : EventArgs
public class WriteEventArgs : EventArgs
Public Class WriteEventArgs
    Inherits EventArgs
Public Class WriteEventArgs
    Inherits EventArgs
public ref class WriteEventArgs : public EventArgs
public ref class WriteEventArgs : public EventArgs
The WriteEventArgs type exposes the following members.
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | SlaveAddress | Slave address
Public property | WriteData | Write data
Top
See Also
Reference
Dln.I2cSlave Namespace


WriteEventArgs Methods

WriteEventArgs Methods dln.net.dll

The WriteEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

WriteEventArgs Class
Dln.I2cSlave Namespace


WriteEventArgs Properties

WriteEventArgs Properties dln.net.dll

The WriteEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | SlaveAddress | Slave address
Public property | WriteData | Write data
Top
See Also

Reference

WriteEventArgs Class
Dln.I2cSlave Namespace


WriteEventArgs.SlaveAddress Property

WriteEventArgs SlaveAddress Property dln.net.dll
Slave address

Namespace: Dln.I2cSlave
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public int SlaveAddress { get; }
public int SlaveAddress { get; }
Public ReadOnly Property SlaveAddress As Integer
    Get
Public ReadOnly Property SlaveAddress As Integer
    Get
public:
property int SlaveAddress {
    int get ();
}
public:
property int SlaveAddress {
    int get ();
}
Property Value
Type: Int32
See Also
Reference
WriteEventArgs Class
Dln.I2cSlave Namespace


WriteEventArgs.WriteData Property

WriteEventArgs WriteData Property dln.net.dll
Write data

Namespace: Dln.I2cSlave
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public ReadOnlyCollection<byte> WriteData { get; }
public ReadOnlyCollection<byte> WriteData { get; }
Public ReadOnly Property WriteData As ReadOnlyCollection(Of Byte)
    Get
Public ReadOnly Property WriteData As ReadOnlyCollection(Of Byte)
    Get
public:
property ReadOnlyCollection<unsigned char>^ WriteData {
    ReadOnlyCollection<unsigned char>^ get ();
}
public:
property ReadOnlyCollection<unsigned char>^ WriteData {
    ReadOnlyCollection<unsigned char>^ get ();
}
Property Value
Type: ReadOnlyCollection  Byte
See Also
Reference
WriteEventArgs Class
Dln.I2cSlave Namespace


Dln.Led Namespace

Dln.Led Namespace dln.net.dll
The Dln.Led namespace contains types that allow Led module usage of DLN-series adapters.
Classes
 | Class | Description
Public class | Led | Led class describes Led module functionality
Public class | LedRestrictions | LedRestrictions class describes restrictions for Led module.
Public class | Leds | Leds class
Public class | Module | Module class describes functionality of Led module
Enumerations
 | Enumeration | Description
Public enumeration | State |


Led Class

Led Class dln.net.dll
Led class describes Led module functionality
Inheritance Hierarchy
System Object
Dln.Led Led

Namespace: Dln.Led
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public class Led
public class Led
Public Class Led
Public Class Led
public ref class Led
public ref class Led
The Led type exposes the following members.
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | State | State property cen be used to modify Led state. Provide new led state value or leave blank to get current led state.
Public property | SupportedStates | SupportedStates property return all supported blinking modes for led.
Top
See Also
Reference
Dln.Led Namespace


Led Methods

Led Methods dln.net.dll

The Led type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Led Class
Dln.Led Namespace


Led Properties

Led Properties dln.net.dll

The Led type exposes the following members.

Properties
 | Name | Description
Public property | State | State property cen be used to modify Led state. Provide new led state value or leave blank to get current led state.
Public property | SupportedStates | SupportedStates property return all supported blinking modes for led.
Top
See Also

Reference

Led Class
Dln.Led Namespace


Led.State Property

Led State Property dln.net.dll
State property cen be used to modify Led state. Provide new led state value or leave blank to get current led state.

Namespace: Dln.Led
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public State State { get; set; }
public State State { get; set; }
Public Property State As State
    Get
    Set
Public Property State As State
    Get
    Set
public:
property State State {
    State get ();
    void set (State value);
}
public:
property State State {
    State get ();
    void set (State value);
}
Property Value
Type: State
See Also
Reference
Led Class
Dln.Led Namespace


Led.SupportedStates Property

Led SupportedStates Property dln.net.dll
SupportedStates property return all supported blinking modes for led.

Namespace: Dln.Led
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public ReadOnlyCollection<State> SupportedStates { get; }
public ReadOnlyCollection<State> SupportedStates { get; }
Public ReadOnly Property SupportedStates As ReadOnlyCollection(Of State)
    Get
Public ReadOnly Property SupportedStates As ReadOnlyCollection(Of State)
    Get
public:
property ReadOnlyCollection<State>^ SupportedStates {
    ReadOnlyCollection<State>^ get ();
}
public:
property ReadOnlyCollection<State>^ SupportedStates {
    ReadOnlyCollection<State>^ get ();
}
Property Value
Type: ReadOnlyCollection  State
See Also
Reference
Led Class
Dln.Led Namespace


LedRestrictions Class

LedRestrictions Class dln.net.dll
LedRestrictions class describes restrictions for Led module.
Inheritance Hierarchy
System Object
Dln.Led LedRestrictions

Namespace: Dln.Led
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public class LedRestrictions
public class LedRestrictions
Public Class LedRestrictions
Public Class LedRestrictions
public ref class LedRestrictions
public ref class LedRestrictions
The LedRestrictions type exposes the following members.
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | State | State restriction
Public property | SupportedStates | SupportedStates restriction
Top
See Also
Reference
Dln.Led Namespace


LedRestrictions Methods

LedRestrictions Methods dln.net.dll

The LedRestrictions type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

LedRestrictions Class
Dln.Led Namespace


LedRestrictions Properties

LedRestrictions Properties dln.net.dll

The LedRestrictions type exposes the following members.

Properties
 | Name | Description
Public property | State | State restriction
Public property | SupportedStates | SupportedStates restriction
Top
See Also

Reference

LedRestrictions Class
Dln.Led Namespace


LedRestrictions.State Property

LedRestrictions State Property dln.net.dll
State restriction

Namespace: Dln.Led
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public Restriction State { get; }
public Restriction State { get; }
Public ReadOnly Property State As Restriction
    Get
Public ReadOnly Property State As Restriction
    Get
public:
property Restriction State {
    Restriction get ();
}
public:
property Restriction State {
    Restriction get ();
}
Property Value
Type: Restriction
See Also
Reference
LedRestrictions Class
Dln.Led Namespace


LedRestrictions.SupportedStates Property

LedRestrictions SupportedStates Property dln.net.dll
SupportedStates restriction

Namespace: Dln.Led
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public Restriction SupportedStates { get; }
public Restriction SupportedStates { get; }
Public ReadOnly Property SupportedStates As Restriction
    Get
Public ReadOnly Property SupportedStates As Restriction
    Get
public:
property Restriction SupportedStates {
    Restriction get ();
}
public:
property Restriction SupportedStates {
    Restriction get ();
}
Property Value
Type: Restriction
See Also
Reference
LedRestrictions Class
Dln.Led Namespace


Leds Class

Leds Class dln.net.dll
Leds class
Inheritance Hierarchy
System Object
System.Collections.ObjectModel ReadOnlyCollection Led
Dln.Led Leds

Namespace: Dln.Led
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public class Leds : ReadOnlyCollection<Led>
public class Leds : ReadOnlyCollection<Led>
Public Class Leds
    Inherits ReadOnlyCollection(Of Led)
Public Class Leds
    Inherits ReadOnlyCollection(Of Led)
public ref class Leds : public ReadOnlyCollection<Led^>
public ref class Leds : public ReadOnlyCollection<Led^>
The Leds type exposes the following members.
Methods
 | Name | Description
Public method | Contains | Determines whether an element is in the ReadOnlyCollection T . (Inherited from ReadOnlyCollection Led .)
Public method | CopyTo | Copies the entire ReadOnlyCollection T to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from ReadOnlyCollection Led .)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the ReadOnlyCollection T . (Inherited from ReadOnlyCollection Led .)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Public method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ReadOnlyCollection T . (Inherited from ReadOnlyCollection Led .)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the ReadOnlyCollection T instance. (Inherited from ReadOnlyCollection Led .)
Public property | Item |
Protected property | Items | Returns the IList T that the ReadOnlyCollection T wraps. (Inherited from ReadOnlyCollection Led .)
Top
See Also
Reference
Dln.Led Namespace


Leds Methods

Leds Methods dln.net.dll

The Leds type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Determines whether an element is in the ReadOnlyCollection T . (Inherited from ReadOnlyCollection Led .)
Public method | CopyTo | Copies the entire ReadOnlyCollection T to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from ReadOnlyCollection Led .)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the ReadOnlyCollection T . (Inherited from ReadOnlyCollection Led .)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Public method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ReadOnlyCollection T . (Inherited from ReadOnlyCollection Led .)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Leds Class
Dln.Led Namespace


Leds Properties

Leds Properties dln.net.dll

The Leds type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the ReadOnlyCollection T instance. (Inherited from ReadOnlyCollection Led .)
Public property | Item |
Protected property | Items | Returns the IList T that the ReadOnlyCollection T wraps. (Inherited from ReadOnlyCollection Led .)
Top
See Also

Reference

Leds Class
Dln.Led Namespace


Leds.Item Property

Leds Item Property dln.net.dll

[Missing <summary> documentation for "P:Dln.Led.Leds.Item(System.Int32)"]

Namespace: Dln.Led
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public Led this[
    int index
] { get; }
public Led this[
    int index
] { get; }
Public ReadOnly Default Property Item (
    index As Integer
) As Led
    Get
Public ReadOnly Default Property Item (
    index As Integer
) As Led
    Get
public:
property Led^ default[int index] {
    Led^ get (int index);
}
public:
property Led^ default[int index] {
    Led^ get (int index);
}
Parameters
index
Type: System Int32
Led index
Return Value
Type: Led
Led class object array
See Also
Reference
Leds Class
Dln.Led Namespace


Module Class

Module Class dln.net.dll
Module class describes functionality of Led module
Inheritance Hierarchy
System Object
Dln.Led Module

Namespace: Dln.Led
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public class Module
public class Module
Public Class Module
Public Class Module
public ref class Module
public ref class Module
The Module type exposes the following members.
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Leds | Gets Leds class object
Top
See Also
Reference
Dln.Led Namespace


Module Methods

Module Methods dln.net.dll

The Module type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Module Class
Dln.Led Namespace


Module Properties

Module Properties dln.net.dll

The Module type exposes the following members.

Properties
 | Name | Description
Public property | Leds | Gets Leds class object
Top
See Also

Reference

Module Class
Dln.Led Namespace


Module.Leds Property

Module Leds Property dln.net.dll
Gets Leds class object

Namespace: Dln.Led
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public Leds Leds { get; }
public Leds Leds { get; }
Public ReadOnly Property Leds As Leds
    Get
Public ReadOnly Property Leds As Leds
    Get
public:
property Leds^ Leds {
    Leds^ get ();
}
public:
property Leds^ Leds {
    Leds^ get ();
}
Property Value
Type: Leds
See Also
Reference
Module Class
Dln.Led Namespace


State Enumeration

State Enumeration dln.net.dll

[Missing <summary> documentation for "T:Dln.Led.State"]

Namespace: Dln.Led
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public enum State
public enum State
Public Enumeration State
Public Enumeration State
public enum class State
public enum class State
Members
Member name | Value | Description
Off | 0 |
On | 1 |
SlowBlink | 2 |
FastBlink | 3 |
DoubleBlink | 4 |
TripleBlink | 5 |
See Also
Reference
Dln.Led Namespace


Dln.PulseCounter Namespace

Dln.PulseCounter Namespace dln.net.dll
The Dln.PulseCounter namespace contains types that allow Pulse Counter module usage of DLN-series adapters.
Classes
 | Class | Description
Public class | ConditionMetEventArgs | ConditionMetEventArgs class
Public class | Module |
Public class | Port | Port class describes functionality of the pulse counter module port.
Public class | PortRestrictions | Pulse counter port restrictions
Public class | Ports | Ports class
Enumerations
 | Enumeration | Description
Public enumeration | EventType | EventType emuneration describes all availalbe event types for pulse counter module.
Public enumeration | Mode | Pulse counter module modes


ConditionMetEventArgs Class

ConditionMetEventArgs Class dln.net.dll
ConditionMetEventArgs class
Inheritance Hierarchy
System Object
System EventArgs
Dln.PulseCounter ConditionMetEventArgs

Namespace: Dln.PulseCounter
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public class ConditionMetEventArgs : EventArgs
public class ConditionMetEventArgs : EventArgs
Public Class ConditionMetEventArgs
    Inherits EventArgs
Public Class ConditionMetEventArgs
    Inherits EventArgs
public ref class ConditionMetEventArgs : public EventArgs
public ref class ConditionMetEventArgs : public EventArgs
The ConditionMetEventArgs type exposes the following members.
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | CounterValue | Counter value
Public property | EventType | Event type value
Public property | Port | Port value
Public property | TimerValue | Timer value
Top
See Also
Reference
Dln.PulseCounter Namespace


ConditionMetEventArgs Methods

ConditionMetEventArgs Methods dln.net.dll

The ConditionMetEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ConditionMetEventArgs Class
Dln.PulseCounter Namespace


ConditionMetEventArgs Properties

ConditionMetEventArgs Properties dln.net.dll

The ConditionMetEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | CounterValue | Counter value
Public property | EventType | Event type value
Public property | Port | Port value
Public property | TimerValue | Timer value
Top
See Also

Reference

ConditionMetEventArgs Class
Dln.PulseCounter Namespace


ConditionMetEventArgs.CounterValue Property

ConditionMetEventArgs CounterValue Property dln.net.dll
Counter value

Namespace: Dln.PulseCounter
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public uint CounterValue { get; }
public uint CounterValue { get; }
Public ReadOnly Property CounterValue As UInteger
    Get
Public ReadOnly Property CounterValue As UInteger
    Get
public:
property unsigned int CounterValue {
    unsigned int get ();
}
public:
property unsigned int CounterValue {
    unsigned int get ();
}
Property Value
Type: UInt32
See Also
Reference
ConditionMetEventArgs Class
Dln.PulseCounter Namespace


ConditionMetEventArgs.EventType Property

ConditionMetEventArgs EventType Property dln.net.dll
Event type value

Namespace: Dln.PulseCounter
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public EventType EventType { get; }
public EventType EventType { get; }
Public ReadOnly Property EventType As EventType
    Get
Public ReadOnly Property EventType As EventType
    Get
public:
property EventType EventType {
    EventType get ();
}
public:
property EventType EventType {
    EventType get ();
}
Property Value
Type: EventType
See Also
Reference
ConditionMetEventArgs Class
Dln.PulseCounter Namespace


ConditionMetEventArgs.Port Property

ConditionMetEventArgs Port Property dln.net.dll
Port value

Namespace: Dln.PulseCounter
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public int Port { get; }
public int Port { get; }
Public ReadOnly Property Port As Integer
    Get
Public ReadOnly Property Port As Integer
    Get
public:
property int Port {
    int get ();
}
public:
property int Port {
    int get ();
}
Property Value
Type: Int32
See Also
Reference
ConditionMetEventArgs Class
Dln.PulseCounter Namespace


ConditionMetEventArgs.TimerValue Property

ConditionMetEventArgs TimerValue Property dln.net.dll
Timer value

Namespace: Dln.PulseCounter
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public uint TimerValue { get; }
public uint TimerValue { get; }
Public ReadOnly Property TimerValue As UInteger
    Get
Public ReadOnly Property TimerValue As UInteger
    Get
public:
property unsigned int TimerValue {
    unsigned int get ();
}
public:
property unsigned int TimerValue {
    unsigned int get ();
}
Property Value
Type: UInt32
See Also
Reference
ConditionMetEventArgs Class
Dln.PulseCounter Namespace


EventType Enumeration

EventType Enumeration dln.net.dll
EventType emuneration describes all availalbe event types for pulse counter module.

Namespace: Dln.PulseCounter
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
[FlagsAttribute]
public enum EventType
[FlagsAttribute]
public enum EventType
<FlagsAttribute>
Public Enumeration EventType
<FlagsAttribute>
Public Enumeration EventType
[FlagsAttribute]
public enum class EventType
[FlagsAttribute]
public enum class EventType
Members
Member name | Value | Description
None | 0 | No events
Overflow | 1 | Pulse counter overflow event
Match | 2 | Match event
Repeat | 4 | Repeat event
See Also
Reference
Dln.PulseCounter Namespace


Mode Enumeration

Mode Enumeration dln.net.dll
Pulse counter module modes

Namespace: Dln.PulseCounter
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public enum Mode
public enum Mode
Public Enumeration Mode
Public Enumeration Mode
public enum class Mode
public enum class Mode
Members
Member name | Value | Description
FreeRun | 0 | Free-run mode
TimeBased | 1 | Timer-based mode
PulseBased | 2 | Pulse-based mode
See Also
Reference
Dln.PulseCounter Namespace


Module Class

Module Class dln.net.dll
Inheritance Hierarchy
System Object
Dln.PulseCounter Module

Namespace: Dln.PulseCounter
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public class Module
public class Module
Public Class Module
Public Class Module
public ref class Module
public ref class Module
The Module type exposes the following members.
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Ports | Ports class
Top
See Also
Reference
Dln.PulseCounter Namespace


Module Methods

Module Methods dln.net.dll

The Module type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Module Class
Dln.PulseCounter Namespace


Module Properties

Module Properties dln.net.dll

The Module type exposes the following members.

Properties
 | Name | Description
Public property | Ports | Ports class
Top
See Also

Reference

Module Class
Dln.PulseCounter Namespace


Module.Ports Property

Module Ports Property dln.net.dll
Ports class

Namespace: Dln.PulseCounter
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public Ports Ports { get; }
public Ports Ports { get; }
Public ReadOnly Property Ports As Ports
    Get
Public ReadOnly Property Ports As Ports
    Get
public:
property Ports^ Ports {
    Ports^ get ();
}
public:
property Ports^ Ports {
    Ports^ get ();
}
Property Value
Type: Ports
See Also
Reference
Module Class
Dln.PulseCounter Namespace


Port Class

Port Class dln.net.dll
Port class describes functionality of the pulse counter module port.
Inheritance Hierarchy
System Object
Dln.PulseCounter Port

Namespace: Dln.PulseCounter
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public class Port
public class Port
Public Class Port
Public Class Port
public ref class Port
public ref class Port
The Port type exposes the following members.
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Public method | GetValue | GetValue method returns timer and pulse counter values
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Reset | Reset method resets timer and counter.
Public method | SetEventConfig | SetEventConfig method is used to set event configuration of specified Pulse Counter port.
Public method | SetMode | SetMode method is used to set mode and limit parameters of specified Pulse Counter port.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | CounterValue | CounterValue property returns pulse counter current value
Public property | Enabled | Enabled property changes pulse counter port status. Use true or false values to enable or disable pulse counter port. Leave property blank to get current port status.
Public property | EventType | Eventype property returns the current event type parameter.
Public property | Limit | Limti property returns the limit parameter of the Pulse Counter port.
Public property | Mode | Mode property returns the mode parameter of the Pulse Counter port.
Public property | RepeatInterval | RepeatInterval property returns the current repeat interval parameter.
Public property | Resolution | Resolution property
Public property | Restrictions | Get pulse counter module restrictions
Public property | SupportedEventTypes | SupportedEventTypes returns array with supported event type values.
Public property | SupportedModes | SupportedModes returns array with supported pulse counter module operation modes.
Public property | TimerValue | TimerValue property returns timer current value.
Top
Events
 | Name | Description
Public event | ConditionMet | Condition met event handler
Public event | ConditionMetThreadSafe | Condition met event handler in safe thread
Top
See Also
Reference
Dln.PulseCounter Namespace


Port Methods

Port Methods dln.net.dll

The Port type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Public method | GetValue | GetValue method returns timer and pulse counter values
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Reset | Reset method resets timer and counter.
Public method | SetEventConfig | SetEventConfig method is used to set event configuration of specified Pulse Counter port.
Public method | SetMode | SetMode method is used to set mode and limit parameters of specified Pulse Counter port.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Port Class
Dln.PulseCounter Namespace


Port.GetValue Method

Port GetValue Method dln.net.dll
GetValue method returns timer and pulse counter values

Namespace: Dln.PulseCounter
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public void GetValue(
    out uint timerValue,
    out uint counterValue
)
public void GetValue(
    out uint timerValue,
    out uint counterValue
)
Public Sub GetValue (
    <OutAttribute> ByRef timerValue As UInteger,
    <OutAttribute> ByRef counterValue As UInteger
)
Public Sub GetValue (
    <OutAttribute> ByRef timerValue As UInteger,
    <OutAttribute> ByRef counterValue As UInteger
)
public:
void GetValue(
    [OutAttribute] unsigned int% timerValue,
    [OutAttribute] unsigned int% counterValue
)
public:
void GetValue(
    [OutAttribute] unsigned int% timerValue,
    [OutAttribute] unsigned int% counterValue
)
Parameters
timerValue
Type: System UInt32
Out Timer value parameter
counterValue
Type: System UInt32
Out Pulse counter value parameter
See Also
Reference
Port Class
Dln.PulseCounter Namespace


Port.Reset Method

Port Reset Method dln.net.dll
Reset method resets timer and counter.

Namespace: Dln.PulseCounter
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public void Reset(
    bool resetTimer,
    bool resetCounter
)
public void Reset(
    bool resetTimer,
    bool resetCounter
)
Public Sub Reset (
    resetTimer As Boolean,
    resetCounter As Boolean
)
Public Sub Reset (
    resetTimer As Boolean,
    resetCounter As Boolean
)
public:
void Reset(
    bool resetTimer,
    bool resetCounter
)
public:
void Reset(
    bool resetTimer,
    bool resetCounter
)
Parameters
resetTimer
Type: System Boolean
Provide true value to reset timer or false to leave its value.
resetCounter
Type: System Boolean
Provide true value to reset counter or false to leave its value.
See Also
Reference
Port Class
Dln.PulseCounter Namespace


Port.SetEventConfig Method

Port SetEventConfig Method dln.net.dll
SetEventConfig method is used to set event configuration of specified Pulse Counter port.

Namespace: Dln.PulseCounter
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public void SetEventConfig(
    EventType eventType,
    uint repeatInterval
)
public void SetEventConfig(
    EventType eventType,
    uint repeatInterval
)
Public Sub SetEventConfig (
    eventType As EventType,
    repeatInterval As UInteger
)
Public Sub SetEventConfig (
    eventType As EventType,
    repeatInterval As UInteger
)
public:
void SetEventConfig(
    EventType eventType,
    unsigned int repeatInterval
)
public:
void SetEventConfig(
    EventType eventType,
    unsigned int repeatInterval
)
Parameters
eventType
Type: Dln.PulseCounter EventType
Defines the current event type parameter.
repeatInterval
Type: System UInt32
Defines the current repeat interval parameter.
See Also
Reference
Port Class
Dln.PulseCounter Namespace


Port.SetMode Method

Port SetMode Method dln.net.dll
SetMode method is used to set mode and limit parameters of specified Pulse Counter port.

Namespace: Dln.PulseCounter
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public void SetMode(
    Mode mode,
    uint limit
)
public void SetMode(
    Mode mode,
    uint limit
)
Public Sub SetMode (
    mode As Mode,
    limit As UInteger
)
Public Sub SetMode (
    mode As Mode,
    limit As UInteger
)
public:
void SetMode(
    Mode mode,
    unsigned int limit
)
public:
void SetMode(
    Mode mode,
    unsigned int limit
)
Parameters
mode
Type: Dln.PulseCounter Mode
Defines the mode parameter of the Pulse Counter port.
limit
Type: System UInt32
Defines the limit parameter of the Pulse Counter port.
See Also
Reference
Port Class
Dln.PulseCounter Namespace


Port Properties

Port Properties dln.net.dll

The Port type exposes the following members.

Properties
 | Name | Description
Public property | CounterValue | CounterValue property returns pulse counter current value
Public property | Enabled | Enabled property changes pulse counter port status. Use true or false values to enable or disable pulse counter port. Leave property blank to get current port status.
Public property | EventType | Eventype property returns the current event type parameter.
Public property | Limit | Limti property returns the limit parameter of the Pulse Counter port.
Public property | Mode | Mode property returns the mode parameter of the Pulse Counter port.
Public property | RepeatInterval | RepeatInterval property returns the current repeat interval parameter.
Public property | Resolution | Resolution property
Public property | Restrictions | Get pulse counter module restrictions
Public property | SupportedEventTypes | SupportedEventTypes returns array with supported event type values.
Public property | SupportedModes | SupportedModes returns array with supported pulse counter module operation modes.
Public property | TimerValue | TimerValue property returns timer current value.
Top
See Also

Reference

Port Class
Dln.PulseCounter Namespace


Port.CounterValue Property

Port CounterValue Property dln.net.dll
CounterValue property returns pulse counter current value

Namespace: Dln.PulseCounter
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public uint CounterValue { get; }
public uint CounterValue { get; }
Public ReadOnly Property CounterValue As UInteger
    Get
Public ReadOnly Property CounterValue As UInteger
    Get
public:
property unsigned int CounterValue {
    unsigned int get ();
}
public:
property unsigned int CounterValue {
    unsigned int get ();
}
Property Value
Type: UInt32
See Also
Reference
Port Class
Dln.PulseCounter Namespace


Port.Enabled Property

Port Enabled Property dln.net.dll
Enabled property changes pulse counter port status. Use true or false values to enable or disable pulse counter port. Leave property blank to get current port status.

Namespace: Dln.PulseCounter
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public bool Enabled { get; set; }
public bool Enabled { get; set; }
Public Property Enabled As Boolean
    Get
    Set
Public Property Enabled As Boolean
    Get
    Set
public:
property bool Enabled {
    bool get ();
    void set (bool value);
}
public:
property bool Enabled {
    bool get ();
    void set (bool value);
}
Property Value
Type: Boolean
See Also
Reference
Port Class
Dln.PulseCounter Namespace


Port.EventType Property

Port EventType Property dln.net.dll
Eventype property returns the current event type parameter.

Namespace: Dln.PulseCounter
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public EventType EventType { get; }
public EventType EventType { get; }
Public ReadOnly Property EventType As EventType
    Get
Public ReadOnly Property EventType As EventType
    Get
public:
property EventType EventType {
    EventType get ();
}
public:
property EventType EventType {
    EventType get ();
}
Property Value
Type: EventType
See Also
Reference
Port Class
Dln.PulseCounter Namespace


Port.Limit Property

Port Limit Property dln.net.dll
Limti property returns the limit parameter of the Pulse Counter port.

Namespace: Dln.PulseCounter
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public uint Limit { get; }
public uint Limit { get; }
Public ReadOnly Property Limit As UInteger
    Get
Public ReadOnly Property Limit As UInteger
    Get
public:
property unsigned int Limit {
    unsigned int get ();
}
public:
property unsigned int Limit {
    unsigned int get ();
}
Property Value
Type: UInt32
See Also
Reference
Port Class
Dln.PulseCounter Namespace


Port.Mode Property

Port Mode Property dln.net.dll
Mode property returns the mode parameter of the Pulse Counter port.

Namespace: Dln.PulseCounter
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public Mode Mode { get; }
public Mode Mode { get; }
Public ReadOnly Property Mode As Mode
    Get
Public ReadOnly Property Mode As Mode
    Get
public:
property Mode Mode {
    Mode get ();
}
public:
property Mode Mode {
    Mode get ();
}
Property Value
Type: Mode
See Also
Reference
Port Class
Dln.PulseCounter Namespace


Port.RepeatInterval Property

Port RepeatInterval Property dln.net.dll
RepeatInterval property returns the current repeat interval parameter.

Namespace: Dln.PulseCounter
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public uint RepeatInterval { get; }
public uint RepeatInterval { get; }
Public ReadOnly Property RepeatInterval As UInteger
    Get
Public ReadOnly Property RepeatInterval As UInteger
    Get
public:
property unsigned int RepeatInterval {
    unsigned int get ();
}
public:
property unsigned int RepeatInterval {
    unsigned int get ();
}
Property Value
Type: UInt32
See Also
Reference
Port Class
Dln.PulseCounter Namespace


Port.Resolution Property

Port Resolution Property dln.net.dll
Resolution property

Namespace: Dln.PulseCounter
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public int Resolution { get; }
public int Resolution { get; }
Public ReadOnly Property Resolution As Integer
    Get
Public ReadOnly Property Resolution As Integer
    Get
public:
property int Resolution {
    int get ();
}
public:
property int Resolution {
    int get ();
}
Property Value
Type: Int32
See Also
Reference
Port Class
Dln.PulseCounter Namespace


Port.Restrictions Property

Port Restrictions Property dln.net.dll
Get pulse counter module restrictions

Namespace: Dln.PulseCounter
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public PortRestrictions Restrictions { get; }
public PortRestrictions Restrictions { get; }
Public ReadOnly Property Restrictions As PortRestrictions
    Get
Public ReadOnly Property Restrictions As PortRestrictions
    Get
public:
property PortRestrictions^ Restrictions {
    PortRestrictions^ get ();
}
public:
property PortRestrictions^ Restrictions {
    PortRestrictions^ get ();
}
Property Value
Type: PortRestrictions
See Also
Reference
Port Class
Dln.PulseCounter Namespace


Port.SupportedEventTypes Property

Port SupportedEventTypes Property dln.net.dll
SupportedEventTypes returns array with supported event type values.

Namespace: Dln.PulseCounter
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public ReadOnlyCollection<EventType> SupportedEventTypes { get; }
public ReadOnlyCollection<EventType> SupportedEventTypes { get; }
Public ReadOnly Property SupportedEventTypes As ReadOnlyCollection(Of EventType)
    Get
Public ReadOnly Property SupportedEventTypes As ReadOnlyCollection(Of EventType)
    Get
public:
property ReadOnlyCollection<EventType>^ SupportedEventTypes {
    ReadOnlyCollection<EventType>^ get ();
}
public:
property ReadOnlyCollection<EventType>^ SupportedEventTypes {
    ReadOnlyCollection<EventType>^ get ();
}
Property Value
Type: ReadOnlyCollection  EventType
See Also
Reference
Port Class
Dln.PulseCounter Namespace


Port.SupportedModes Property

Port SupportedModes Property dln.net.dll
SupportedModes returns array with supported pulse counter module operation modes.

Namespace: Dln.PulseCounter
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public ReadOnlyCollection<Mode> SupportedModes { get; }
public ReadOnlyCollection<Mode> SupportedModes { get; }
Public ReadOnly Property SupportedModes As ReadOnlyCollection(Of Mode)
    Get
Public ReadOnly Property SupportedModes As ReadOnlyCollection(Of Mode)
    Get
public:
property ReadOnlyCollection<Mode>^ SupportedModes {
    ReadOnlyCollection<Mode>^ get ();
}
public:
property ReadOnlyCollection<Mode>^ SupportedModes {
    ReadOnlyCollection<Mode>^ get ();
}
Property Value
Type: ReadOnlyCollection  Mode
See Also
Reference
Port Class
Dln.PulseCounter Namespace


Port.TimerValue Property

Port TimerValue Property dln.net.dll
TimerValue property returns timer current value.

Namespace: Dln.PulseCounter
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public uint TimerValue { get; }
public uint TimerValue { get; }
Public ReadOnly Property TimerValue As UInteger
    Get
Public ReadOnly Property TimerValue As UInteger
    Get
public:
property unsigned int TimerValue {
    unsigned int get ();
}
public:
property unsigned int TimerValue {
    unsigned int get ();
}
Property Value
Type: UInt32
See Also
Reference
Port Class
Dln.PulseCounter Namespace


Port Events

Port Events dln.net.dll

The Port type exposes the following members.

Events
 | Name | Description
Public event | ConditionMet | Condition met event handler
Public event | ConditionMetThreadSafe | Condition met event handler in safe thread
Top
See Also

Reference

Port Class
Dln.PulseCounter Namespace


Port.ConditionMet Event

Port ConditionMet Event dln.net.dll
Condition met event handler

Namespace: Dln.PulseCounter
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public event EventHandler<ConditionMetEventArgs> ConditionMet
public event EventHandler<ConditionMetEventArgs> ConditionMet
Public Event ConditionMet As EventHandler(Of ConditionMetEventArgs)
Public Event ConditionMet As EventHandler(Of ConditionMetEventArgs)
public:
 event EventHandler<ConditionMetEventArgs^>^ ConditionMet {
    void add (EventHandler<ConditionMetEventArgs^>^ value);
    void remove (EventHandler<ConditionMetEventArgs^>^ value);
}
public:
 event EventHandler<ConditionMetEventArgs^>^ ConditionMet {
    void add (EventHandler<ConditionMetEventArgs^>^ value);
    void remove (EventHandler<ConditionMetEventArgs^>^ value);
}
Value
Type: System EventHandler  ConditionMetEventArgs
See Also
Reference
Port Class
Dln.PulseCounter Namespace


Port.ConditionMetThreadSafe Event

Port ConditionMetThreadSafe Event dln.net.dll
Condition met event handler in safe thread

Namespace: Dln.PulseCounter
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public event EventHandler<ConditionMetEventArgs> ConditionMetThreadSafe
public event EventHandler<ConditionMetEventArgs> ConditionMetThreadSafe
Public Event ConditionMetThreadSafe As EventHandler(Of ConditionMetEventArgs)
Public Event ConditionMetThreadSafe As EventHandler(Of ConditionMetEventArgs)
public:
 event EventHandler<ConditionMetEventArgs^>^ ConditionMetThreadSafe {
    void add (EventHandler<ConditionMetEventArgs^>^ value);
    void remove (EventHandler<ConditionMetEventArgs^>^ value);
}
public:
 event EventHandler<ConditionMetEventArgs^>^ ConditionMetThreadSafe {
    void add (EventHandler<ConditionMetEventArgs^>^ value);
    void remove (EventHandler<ConditionMetEventArgs^>^ value);
}
Value
Type: System EventHandler  ConditionMetEventArgs
See Also
Reference
Port Class
Dln.PulseCounter Namespace


PortRestrictions Class

PortRestrictions Class dln.net.dll
Pulse counter port restrictions
Inheritance Hierarchy
System Object
Dln.PulseCounter PortRestrictions

Namespace: Dln.PulseCounter
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public class PortRestrictions
public class PortRestrictions
Public Class PortRestrictions
Public Class PortRestrictions
public ref class PortRestrictions
public ref class PortRestrictions
The PortRestrictions type exposes the following members.
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | CounterValue | CounterValue restriction
Public property | Enabled | Enabled restriction
Public property | EventType | EventType restriction
Public property | GetValue | GetValue restriction
Public property | Limit | Limit restriction
Public property | Mode | Mode restriction
Public property | RepeatInterval | RepeatInterval restriction
Public property | Reset | Reset restriction
Public property | Resolution | Resolution restriction
Public property | SetEvent | SetEvent restriction
Public property | SetMode | SetMode restriction
Public property | SupportedEventTypes | SupportedEventTypes restriction
Public property | SupportedModes | SupportedModes restriction
Public property | TimerValue | TimerValue restriction
Top
See Also
Reference
Dln.PulseCounter Namespace


PortRestrictions Methods

PortRestrictions Methods dln.net.dll

The PortRestrictions type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PortRestrictions Class
Dln.PulseCounter Namespace


PortRestrictions Properties

PortRestrictions Properties dln.net.dll

The PortRestrictions type exposes the following members.

Properties
 | Name | Description
Public property | CounterValue | CounterValue restriction
Public property | Enabled | Enabled restriction
Public property | EventType | EventType restriction
Public property | GetValue | GetValue restriction
Public property | Limit | Limit restriction
Public property | Mode | Mode restriction
Public property | RepeatInterval | RepeatInterval restriction
Public property | Reset | Reset restriction
Public property | Resolution | Resolution restriction
Public property | SetEvent | SetEvent restriction
Public property | SetMode | SetMode restriction
Public property | SupportedEventTypes | SupportedEventTypes restriction
Public property | SupportedModes | SupportedModes restriction
Public property | TimerValue | TimerValue restriction
Top
See Also

Reference

PortRestrictions Class
Dln.PulseCounter Namespace


PortRestrictions.CounterValue Property

PortRestrictions CounterValue Property dln.net.dll
CounterValue restriction

Namespace: Dln.PulseCounter
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public Restriction CounterValue { get; }
public Restriction CounterValue { get; }
Public ReadOnly Property CounterValue As Restriction
    Get
Public ReadOnly Property CounterValue As Restriction
    Get
public:
property Restriction CounterValue {
    Restriction get ();
}
public:
property Restriction CounterValue {
    Restriction get ();
}
Property Value
Type: Restriction
See Also
Reference
PortRestrictions Class
Dln.PulseCounter Namespace


PortRestrictions.Enabled Property

PortRestrictions Enabled Property dln.net.dll
Enabled restriction

Namespace: Dln.PulseCounter
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public Restriction Enabled { get; }
public Restriction Enabled { get; }
Public ReadOnly Property Enabled As Restriction
    Get
Public ReadOnly Property Enabled As Restriction
    Get
public:
property Restriction Enabled {
    Restriction get ();
}
public:
property Restriction Enabled {
    Restriction get ();
}
Property Value
Type: Restriction
See Also
Reference
PortRestrictions Class
Dln.PulseCounter Namespace


PortRestrictions.EventType Property

PortRestrictions EventType Property dln.net.dll
EventType restriction

Namespace: Dln.PulseCounter
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public Restriction EventType { get; }
public Restriction EventType { get; }
Public ReadOnly Property EventType As Restriction
    Get
Public ReadOnly Property EventType As Restriction
    Get
public:
property Restriction EventType {
    Restriction get ();
}
public:
property Restriction EventType {
    Restriction get ();
}
Property Value
Type: Restriction
See Also
Reference
PortRestrictions Class
Dln.PulseCounter Namespace


PortRestrictions.GetValue Property

PortRestrictions GetValue Property dln.net.dll
GetValue restriction

Namespace: Dln.PulseCounter
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public Restriction GetValue { get; }
public Restriction GetValue { get; }
Public ReadOnly Property GetValue As Restriction
    Get
Public ReadOnly Property GetValue As Restriction
    Get
public:
property Restriction GetValue {
    Restriction get ();
}
public:
property Restriction GetValue {
    Restriction get ();
}
Property Value
Type: Restriction
See Also
Reference
PortRestrictions Class
Dln.PulseCounter Namespace


PortRestrictions.Limit Property

PortRestrictions Limit Property dln.net.dll
Limit restriction

Namespace: Dln.PulseCounter
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public Restriction Limit { get; }
public Restriction Limit { get; }
Public ReadOnly Property Limit As Restriction
    Get
Public ReadOnly Property Limit As Restriction
    Get
public:
property Restriction Limit {
    Restriction get ();
}
public:
property Restriction Limit {
    Restriction get ();
}
Property Value
Type: Restriction
See Also
Reference
PortRestrictions Class
Dln.PulseCounter Namespace


PortRestrictions.Mode Property

PortRestrictions Mode Property dln.net.dll
Mode restriction

Namespace: Dln.PulseCounter
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public Restriction Mode { get; }
public Restriction Mode { get; }
Public ReadOnly Property Mode As Restriction
    Get
Public ReadOnly Property Mode As Restriction
    Get
public:
property Restriction Mode {
    Restriction get ();
}
public:
property Restriction Mode {
    Restriction get ();
}
Property Value
Type: Restriction
See Also
Reference
PortRestrictions Class
Dln.PulseCounter Namespace


PortRestrictions.RepeatInterval Property

PortRestrictions RepeatInterval Property dln.net.dll
RepeatInterval restriction

Namespace: Dln.PulseCounter
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public Restriction RepeatInterval { get; }
public Restriction RepeatInterval { get; }
Public ReadOnly Property RepeatInterval As Restriction
    Get
Public ReadOnly Property RepeatInterval As Restriction
    Get
public:
property Restriction RepeatInterval {
    Restriction get ();
}
public:
property Restriction RepeatInterval {
    Restriction get ();
}
Property Value
Type: Restriction
See Also
Reference
PortRestrictions Class
Dln.PulseCounter Namespace


PortRestrictions.Reset Property

PortRestrictions Reset Property dln.net.dll
Reset restriction

Namespace: Dln.PulseCounter
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public Restriction Reset { get; }
public Restriction Reset { get; }
Public ReadOnly Property Reset As Restriction
    Get
Public ReadOnly Property Reset As Restriction
    Get
public:
property Restriction Reset {
    Restriction get ();
}
public:
property Restriction Reset {
    Restriction get ();
}
Property Value
Type: Restriction
See Also
Reference
PortRestrictions Class
Dln.PulseCounter Namespace


PortRestrictions.Resolution Property

PortRestrictions Resolution Property dln.net.dll
Resolution restriction

Namespace: Dln.PulseCounter
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public Restriction Resolution { get; }
public Restriction Resolution { get; }
Public ReadOnly Property Resolution As Restriction
    Get
Public ReadOnly Property Resolution As Restriction
    Get
public:
property Restriction Resolution {
    Restriction get ();
}
public:
property Restriction Resolution {
    Restriction get ();
}
Property Value
Type: Restriction
See Also
Reference
PortRestrictions Class
Dln.PulseCounter Namespace


PortRestrictions.SetEvent Property

PortRestrictions SetEvent Property dln.net.dll
SetEvent restriction

Namespace: Dln.PulseCounter
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public Restriction SetEvent { get; }
public Restriction SetEvent { get; }
Public ReadOnly Property SetEvent As Restriction
    Get
Public ReadOnly Property SetEvent As Restriction
    Get
public:
property Restriction SetEvent {
    Restriction get ();
}
public:
property Restriction SetEvent {
    Restriction get ();
}
Property Value
Type: Restriction
See Also
Reference
PortRestrictions Class
Dln.PulseCounter Namespace


PortRestrictions.SetMode Property

PortRestrictions SetMode Property dln.net.dll
SetMode restriction

Namespace: Dln.PulseCounter
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public Restriction SetMode { get; }
public Restriction SetMode { get; }
Public ReadOnly Property SetMode As Restriction
    Get
Public ReadOnly Property SetMode As Restriction
    Get
public:
property Restriction SetMode {
    Restriction get ();
}
public:
property Restriction SetMode {
    Restriction get ();
}
Property Value
Type: Restriction
See Also
Reference
PortRestrictions Class
Dln.PulseCounter Namespace


PortRestrictions.SupportedEventTypes Property

PortRestrictions SupportedEventTypes Property dln.net.dll
SupportedEventTypes restriction

Namespace: Dln.PulseCounter
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public Restriction SupportedEventTypes { get; }
public Restriction SupportedEventTypes { get; }
Public ReadOnly Property SupportedEventTypes As Restriction
    Get
Public ReadOnly Property SupportedEventTypes As Restriction
    Get
public:
property Restriction SupportedEventTypes {
    Restriction get ();
}
public:
property Restriction SupportedEventTypes {
    Restriction get ();
}
Property Value
Type: Restriction
See Also
Reference
PortRestrictions Class
Dln.PulseCounter Namespace


PortRestrictions.SupportedModes Property

PortRestrictions SupportedModes Property dln.net.dll
SupportedModes restriction

Namespace: Dln.PulseCounter
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public Restriction SupportedModes { get; }
public Restriction SupportedModes { get; }
Public ReadOnly Property SupportedModes As Restriction
    Get
Public ReadOnly Property SupportedModes As Restriction
    Get
public:
property Restriction SupportedModes {
    Restriction get ();
}
public:
property Restriction SupportedModes {
    Restriction get ();
}
Property Value
Type: Restriction
See Also
Reference
PortRestrictions Class
Dln.PulseCounter Namespace


PortRestrictions.TimerValue Property

PortRestrictions TimerValue Property dln.net.dll
TimerValue restriction

Namespace: Dln.PulseCounter
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public Restriction TimerValue { get; }
public Restriction TimerValue { get; }
Public ReadOnly Property TimerValue As Restriction
    Get
Public ReadOnly Property TimerValue As Restriction
    Get
public:
property Restriction TimerValue {
    Restriction get ();
}
public:
property Restriction TimerValue {
    Restriction get ();
}
Property Value
Type: Restriction
See Also
Reference
PortRestrictions Class
Dln.PulseCounter Namespace


Ports Class

Ports Class dln.net.dll
Ports class
Inheritance Hierarchy
System Object
System.Collections.ObjectModel ReadOnlyCollection Port
Dln.PulseCounter Ports

Namespace: Dln.PulseCounter
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public class Ports : ReadOnlyCollection<Port>
public class Ports : ReadOnlyCollection<Port>
Public Class Ports
    Inherits ReadOnlyCollection(Of Port)
Public Class Ports
    Inherits ReadOnlyCollection(Of Port)
public ref class Ports : public ReadOnlyCollection<Port^>
public ref class Ports : public ReadOnlyCollection<Port^>
The Ports type exposes the following members.
Methods
 | Name | Description
Public method | Contains | Determines whether an element is in the ReadOnlyCollection T . (Inherited from ReadOnlyCollection Port .)
Public method | CopyTo | Copies the entire ReadOnlyCollection T to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from ReadOnlyCollection Port .)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the ReadOnlyCollection T . (Inherited from ReadOnlyCollection Port .)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Public method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ReadOnlyCollection T . (Inherited from ReadOnlyCollection Port .)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the ReadOnlyCollection T instance. (Inherited from ReadOnlyCollection Port .)
Public property | Item |
Protected property | Items | Returns the IList T that the ReadOnlyCollection T wraps. (Inherited from ReadOnlyCollection Port .)
Top
See Also
Reference
Dln.PulseCounter Namespace


Ports Methods

Ports Methods dln.net.dll

The Ports type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Determines whether an element is in the ReadOnlyCollection T . (Inherited from ReadOnlyCollection Port .)
Public method | CopyTo | Copies the entire ReadOnlyCollection T to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from ReadOnlyCollection Port .)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the ReadOnlyCollection T . (Inherited from ReadOnlyCollection Port .)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Public method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ReadOnlyCollection T . (Inherited from ReadOnlyCollection Port .)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Ports Class
Dln.PulseCounter Namespace


Ports Properties

Ports Properties dln.net.dll

The Ports type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the ReadOnlyCollection T instance. (Inherited from ReadOnlyCollection Port .)
Public property | Item |
Protected property | Items | Returns the IList T that the ReadOnlyCollection T wraps. (Inherited from ReadOnlyCollection Port .)
Top
See Also

Reference

Ports Class
Dln.PulseCounter Namespace


Ports.Item Property

Ports Item Property dln.net.dll

[Missing <summary> documentation for "P:Dln.PulseCounter.Ports.Item(System.Int32)"]

Namespace: Dln.PulseCounter
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public Port this[
    int index
] { get; }
public Port this[
    int index
] { get; }
Public ReadOnly Default Property Item (
    index As Integer
) As Port
    Get
Public ReadOnly Default Property Item (
    index As Integer
) As Port
    Get
public:
property Port^ default[int index] {
    Port^ get (int index);
}
public:
property Port^ default[int index] {
    Port^ get (int index);
}
Parameters
index
Type: System Int32
Port index
Return Value
Type: Port
 Pulse counter Port class object
See Also
Reference
Ports Class
Dln.PulseCounter Namespace


Dln.Pwm Namespace

Dln.Pwm Namespace dln.net.dll
The Dln.Pwm namespace contains types that allow PWM module usage of DLN-series adapters.
Classes
 | Class | Description
Public class | Channel | Channel class
Public class | ChannelRestrictions | ChannelRestrictions class describes restrictions for PWM channel.
Public class | Channels | Channels class
Public class | Module | Module class describes PWM module methods and properties
Public class | Port | Port class
Public class | PortRestrictions | PortRestrictions class describes restrictions for PWM port.
Public class | Ports | Ports class


Channel Class

Channel Class dln.net.dll
Channel class
Inheritance Hierarchy
System Object
Dln.Pwm Channel

Namespace: Dln.Pwm
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public class Channel
public class Channel
Public Class Channel
Public Class Channel
public ref class Channel
public ref class Channel
The Channel type exposes the following members.
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | DutyCycle | Sets or gets a PWM duty cycle, which is the ratio of the high time to the PWM period.
Public property | Enabled | Enables or disables the specified channel from the corresponding PWM port of your DLN-series adapter. Leave property blank to get the current property value.
Public property | Frequency | Sets or gets the PWM frequency.
Public property | Restrictions | Restrictions property
Top
See Also
Reference
Dln.Pwm Namespace


Channel Methods

Channel Methods dln.net.dll

The Channel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Channel Class
Dln.Pwm Namespace


Channel Properties

Channel Properties dln.net.dll

The Channel type exposes the following members.

Properties
 | Name | Description
Public property | DutyCycle | Sets or gets a PWM duty cycle, which is the ratio of the high time to the PWM period.
Public property | Enabled | Enables or disables the specified channel from the corresponding PWM port of your DLN-series adapter. Leave property blank to get the current property value.
Public property | Frequency | Sets or gets the PWM frequency.
Public property | Restrictions | Restrictions property
Top
See Also

Reference

Channel Class
Dln.Pwm Namespace


Channel.DutyCycle Property

Channel DutyCycle Property dln.net.dll
Sets or gets a PWM duty cycle, which is the ratio of the high time to the PWM period.

Namespace: Dln.Pwm
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public float DutyCycle { get; set; }
public float DutyCycle { get; set; }
Public Property DutyCycle As Single
    Get
    Set
Public Property DutyCycle As Single
    Get
    Set
public:
property float DutyCycle {
    float get ();
    void set (float value);
}
public:
property float DutyCycle {
    float get ();
    void set (float value);
}
Property Value
Type: Single
See Also
Reference
Channel Class
Dln.Pwm Namespace


Channel.Enabled Property

Channel Enabled Property dln.net.dll
Enables or disables the specified channel from the corresponding PWM port of your DLN-series adapter. Leave property blank to get the current property value.

Namespace: Dln.Pwm
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public bool Enabled { get; set; }
public bool Enabled { get; set; }
Public Property Enabled As Boolean
    Get
    Set
Public Property Enabled As Boolean
    Get
    Set
public:
property bool Enabled {
    bool get ();
    void set (bool value);
}
public:
property bool Enabled {
    bool get ();
    void set (bool value);
}
Property Value
Type: Boolean
See Also
Reference
Channel Class
Dln.Pwm Namespace


Channel.Frequency Property

Channel Frequency Property dln.net.dll
Sets or gets the PWM frequency.

Namespace: Dln.Pwm
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public int Frequency { get; set; }
public int Frequency { get; set; }
Public Property Frequency As Integer
    Get
    Set
Public Property Frequency As Integer
    Get
    Set
public:
property int Frequency {
    int get ();
    void set (int value);
}
public:
property int Frequency {
    int get ();
    void set (int value);
}
Property Value
Type: Int32
See Also
Reference
Channel Class
Dln.Pwm Namespace


Channel.Restrictions Property

Channel Restrictions Property dln.net.dll
Restrictions property

Namespace: Dln.Pwm
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public ChannelRestrictions Restrictions { get; }
public ChannelRestrictions Restrictions { get; }
Public ReadOnly Property Restrictions As ChannelRestrictions
    Get
Public ReadOnly Property Restrictions As ChannelRestrictions
    Get
public:
property ChannelRestrictions^ Restrictions {
    ChannelRestrictions^ get ();
}
public:
property ChannelRestrictions^ Restrictions {
    ChannelRestrictions^ get ();
}
Property Value
Type: ChannelRestrictions
See Also
Reference
Channel Class
Dln.Pwm Namespace


ChannelRestrictions Class

ChannelRestrictions Class dln.net.dll
ChannelRestrictions class describes restrictions for PWM channel.
Inheritance Hierarchy
System Object
Dln.Pwm ChannelRestrictions

Namespace: Dln.Pwm
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public class ChannelRestrictions
public class ChannelRestrictions
Public Class ChannelRestrictions
Public Class ChannelRestrictions
public ref class ChannelRestrictions
public ref class ChannelRestrictions
The ChannelRestrictions type exposes the following members.
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | DutyCycle | Duty cycle restriction
Public property | Enabled | Channel enables restriction
Public property | Frequency | Frequency restriction
Top
See Also
Reference
Dln.Pwm Namespace


ChannelRestrictions Methods

ChannelRestrictions Methods dln.net.dll

The ChannelRestrictions type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ChannelRestrictions Class
Dln.Pwm Namespace


ChannelRestrictions Properties

ChannelRestrictions Properties dln.net.dll

The ChannelRestrictions type exposes the following members.

Properties
 | Name | Description
Public property | DutyCycle | Duty cycle restriction
Public property | Enabled | Channel enables restriction
Public property | Frequency | Frequency restriction
Top
See Also

Reference

ChannelRestrictions Class
Dln.Pwm Namespace


ChannelRestrictions.DutyCycle Property

ChannelRestrictions DutyCycle Property dln.net.dll
Duty cycle restriction

Namespace: Dln.Pwm
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public Restriction DutyCycle { get; }
public Restriction DutyCycle { get; }
Public ReadOnly Property DutyCycle As Restriction
    Get
Public ReadOnly Property DutyCycle As Restriction
    Get
public:
property Restriction DutyCycle {
    Restriction get ();
}
public:
property Restriction DutyCycle {
    Restriction get ();
}
Property Value
Type: Restriction
See Also
Reference
ChannelRestrictions Class
Dln.Pwm Namespace


ChannelRestrictions.Enabled Property

ChannelRestrictions Enabled Property dln.net.dll
Channel enables restriction

Namespace: Dln.Pwm
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public Restriction Enabled { get; }
public Restriction Enabled { get; }
Public ReadOnly Property Enabled As Restriction
    Get
Public ReadOnly Property Enabled As Restriction
    Get
public:
property Restriction Enabled {
    Restriction get ();
}
public:
property Restriction Enabled {
    Restriction get ();
}
Property Value
Type: Restriction
See Also
Reference
ChannelRestrictions Class
Dln.Pwm Namespace


ChannelRestrictions.Frequency Property

ChannelRestrictions Frequency Property dln.net.dll
Frequency restriction

Namespace: Dln.Pwm
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public Restriction Frequency { get; }
public Restriction Frequency { get; }
Public ReadOnly Property Frequency As Restriction
    Get
Public ReadOnly Property Frequency As Restriction
    Get
public:
property Restriction Frequency {
    Restriction get ();
}
public:
property Restriction Frequency {
    Restriction get ();
}
Property Value
Type: Restriction
See Also
Reference
ChannelRestrictions Class
Dln.Pwm Namespace


Channels Class

Channels Class dln.net.dll
Channels class
Inheritance Hierarchy
System Object
System.Collections.ObjectModel ReadOnlyCollection Channel
Dln.Pwm Channels

Namespace: Dln.Pwm
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public class Channels : ReadOnlyCollection<Channel>
public class Channels : ReadOnlyCollection<Channel>
Public Class Channels
    Inherits ReadOnlyCollection(Of Channel)
Public Class Channels
    Inherits ReadOnlyCollection(Of Channel)
public ref class Channels : public ReadOnlyCollection<Channel^>
public ref class Channels : public ReadOnlyCollection<Channel^>
The Channels type exposes the following members.
Methods
 | Name | Description
Public method | Contains | Determines whether an element is in the ReadOnlyCollection T . (Inherited from ReadOnlyCollection Channel .)
Public method | CopyTo | Copies the entire ReadOnlyCollection T to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from ReadOnlyCollection Channel .)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the ReadOnlyCollection T . (Inherited from ReadOnlyCollection Channel .)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Public method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ReadOnlyCollection T . (Inherited from ReadOnlyCollection Channel .)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the ReadOnlyCollection T instance. (Inherited from ReadOnlyCollection Channel .)
Public property | Item |
Protected property | Items | Returns the IList T that the ReadOnlyCollection T wraps. (Inherited from ReadOnlyCollection Channel .)
Top
See Also
Reference
Dln.Pwm Namespace


Channels Methods

Channels Methods dln.net.dll

The Channels type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Determines whether an element is in the ReadOnlyCollection T . (Inherited from ReadOnlyCollection Channel .)
Public method | CopyTo | Copies the entire ReadOnlyCollection T to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from ReadOnlyCollection Channel .)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the ReadOnlyCollection T . (Inherited from ReadOnlyCollection Channel .)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Public method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ReadOnlyCollection T . (Inherited from ReadOnlyCollection Channel .)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Channels Class
Dln.Pwm Namespace


Channels Properties

Channels Properties dln.net.dll

The Channels type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the ReadOnlyCollection T instance. (Inherited from ReadOnlyCollection Channel .)
Public property | Item |
Protected property | Items | Returns the IList T that the ReadOnlyCollection T wraps. (Inherited from ReadOnlyCollection Channel .)
Top
See Also

Reference

Channels Class
Dln.Pwm Namespace


Channels.Item Property

Channels Item Property dln.net.dll

[Missing <summary> documentation for "P:Dln.Pwm.Channels.Item(System.Int32)"]

Namespace: Dln.Pwm
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public Channel this[
    int index
] { get; }
public Channel this[
    int index
] { get; }
Public ReadOnly Default Property Item (
    index As Integer
) As Channel
    Get
Public ReadOnly Default Property Item (
    index As Integer
) As Channel
    Get
public:
property Channel^ default[int index] {
    Channel^ get (int index);
}
public:
property Channel^ default[int index] {
    Channel^ get (int index);
}
Parameters
index
Type: System Int32
Channel index
Return Value
Type: Channel
Channel class object
See Also
Reference
Channels Class
Dln.Pwm Namespace


Module Class

Module Class dln.net.dll
Module class describes PWM module methods and properties
Inheritance Hierarchy
System Object
Dln.Pwm Module

Namespace: Dln.Pwm
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public class Module
public class Module
Public Class Module
Public Class Module
public ref class Module
public ref class Module
The Module type exposes the following members.
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Ports | Get Ports class object
Top
See Also
Reference
Dln.Pwm Namespace


Module Methods

Module Methods dln.net.dll

The Module type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Module Class
Dln.Pwm Namespace


Module Properties

Module Properties dln.net.dll

The Module type exposes the following members.

Properties
 | Name | Description
Public property | Ports | Get Ports class object
Top
See Also

Reference

Module Class
Dln.Pwm Namespace


Module.Ports Property

Module Ports Property dln.net.dll
Get Ports class object

Namespace: Dln.Pwm
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public Ports Ports { get; }
public Ports Ports { get; }
Public ReadOnly Property Ports As Ports
    Get
Public ReadOnly Property Ports As Ports
    Get
public:
property Ports^ Ports {
    Ports^ get ();
}
public:
property Ports^ Ports {
    Ports^ get ();
}
Property Value
Type: Ports
See Also
Reference
Module Class
Dln.Pwm Namespace


Port Class

Port Class dln.net.dll
Port class
Inheritance Hierarchy
System Object
Dln.Pwm Port

Namespace: Dln.Pwm
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public class Port
public class Port
Public Class Port
Public Class Port
public ref class Port
public ref class Port
The Port type exposes the following members.
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Channels | Get Channels class object
Public property | Enabled | Enables or disables the corresponding PWM port of your DLN-series adapter.
Public property | MaxFrequency | Retrieves the maximum valid frequency value.
Public property | MinFrequency | Retrieves the minimum valid frequency value.
Public property | Restrictions | Get PWM module restrictions
Top
See Also
Reference
Dln.Pwm Namespace


Port Methods

Port Methods dln.net.dll

The Port type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Port Class
Dln.Pwm Namespace


Port Properties

Port Properties dln.net.dll

The Port type exposes the following members.

Properties
 | Name | Description
Public property | Channels | Get Channels class object
Public property | Enabled | Enables or disables the corresponding PWM port of your DLN-series adapter.
Public property | MaxFrequency | Retrieves the maximum valid frequency value.
Public property | MinFrequency | Retrieves the minimum valid frequency value.
Public property | Restrictions | Get PWM module restrictions
Top
See Also

Reference

Port Class
Dln.Pwm Namespace


Port.Channels Property

Port Channels Property dln.net.dll
Get Channels class object

Namespace: Dln.Pwm
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public Channels Channels { get; }
public Channels Channels { get; }
Public ReadOnly Property Channels As Channels
    Get
Public ReadOnly Property Channels As Channels
    Get
public:
property Channels^ Channels {
    Channels^ get ();
}
public:
property Channels^ Channels {
    Channels^ get ();
}
Property Value
Type: Channels
See Also
Reference
Port Class
Dln.Pwm Namespace


Port.Enabled Property

Port Enabled Property dln.net.dll
Enables or disables the corresponding PWM port of your DLN-series adapter.

Namespace: Dln.Pwm
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public bool Enabled { get; set; }
public bool Enabled { get; set; }
Public Property Enabled As Boolean
    Get
    Set
Public Property Enabled As Boolean
    Get
    Set
public:
property bool Enabled {
    bool get ();
    void set (bool value);
}
public:
property bool Enabled {
    bool get ();
    void set (bool value);
}
Property Value
Type: Boolean
See Also
Reference
Port Class
Dln.Pwm Namespace


Port.MaxFrequency Property

Port MaxFrequency Property dln.net.dll
Retrieves the maximum valid frequency value.

Namespace: Dln.Pwm
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public int MaxFrequency { get; }
public int MaxFrequency { get; }
Public ReadOnly Property MaxFrequency As Integer
    Get
Public ReadOnly Property MaxFrequency As Integer
    Get
public:
property int MaxFrequency {
    int get ();
}
public:
property int MaxFrequency {
    int get ();
}
Property Value
Type: Int32
See Also
Reference
Port Class
Dln.Pwm Namespace


Port.MinFrequency Property

Port MinFrequency Property dln.net.dll
Retrieves the minimum valid frequency value.

Namespace: Dln.Pwm
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public int MinFrequency { get; }
public int MinFrequency { get; }
Public ReadOnly Property MinFrequency As Integer
    Get
Public ReadOnly Property MinFrequency As Integer
    Get
public:
property int MinFrequency {
    int get ();
}
public:
property int MinFrequency {
    int get ();
}
Property Value
Type: Int32
See Also
Reference
Port Class
Dln.Pwm Namespace


Port.Restrictions Property

Port Restrictions Property dln.net.dll
Get PWM module restrictions

Namespace: Dln.Pwm
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public PortRestrictions Restrictions { get; }
public PortRestrictions Restrictions { get; }
Public ReadOnly Property Restrictions As PortRestrictions
    Get
Public ReadOnly Property Restrictions As PortRestrictions
    Get
public:
property PortRestrictions^ Restrictions {
    PortRestrictions^ get ();
}
public:
property PortRestrictions^ Restrictions {
    PortRestrictions^ get ();
}
Property Value
Type: PortRestrictions
See Also
Reference
Port Class
Dln.Pwm Namespace


PortRestrictions Class

PortRestrictions Class dln.net.dll
PortRestrictions class describes restrictions for PWM port.
Inheritance Hierarchy
System Object
Dln.Pwm PortRestrictions

Namespace: Dln.Pwm
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public class PortRestrictions
public class PortRestrictions
Public Class PortRestrictions
Public Class PortRestrictions
public ref class PortRestrictions
public ref class PortRestrictions
The PortRestrictions type exposes the following members.
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Enabled | Port enabled restriction
Public property | MaxFrequency | Maximum frequency restriction
Public property | MinFrequency | Minimal frequency restriction
Top
See Also
Reference
Dln.Pwm Namespace


PortRestrictions Methods

PortRestrictions Methods dln.net.dll

The PortRestrictions type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PortRestrictions Class
Dln.Pwm Namespace


PortRestrictions Properties

PortRestrictions Properties dln.net.dll

The PortRestrictions type exposes the following members.

Properties
 | Name | Description
Public property | Enabled | Port enabled restriction
Public property | MaxFrequency | Maximum frequency restriction
Public property | MinFrequency | Minimal frequency restriction
Top
See Also

Reference

PortRestrictions Class
Dln.Pwm Namespace


PortRestrictions.Enabled Property

PortRestrictions Enabled Property dln.net.dll
Port enabled restriction

Namespace: Dln.Pwm
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public Restriction Enabled { get; }
public Restriction Enabled { get; }
Public ReadOnly Property Enabled As Restriction
    Get
Public ReadOnly Property Enabled As Restriction
    Get
public:
property Restriction Enabled {
    Restriction get ();
}
public:
property Restriction Enabled {
    Restriction get ();
}
Property Value
Type: Restriction
See Also
Reference
PortRestrictions Class
Dln.Pwm Namespace


PortRestrictions.MaxFrequency Property

PortRestrictions MaxFrequency Property dln.net.dll
Maximum frequency restriction

Namespace: Dln.Pwm
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public Restriction MaxFrequency { get; }
public Restriction MaxFrequency { get; }
Public ReadOnly Property MaxFrequency As Restriction
    Get
Public ReadOnly Property MaxFrequency As Restriction
    Get
public:
property Restriction MaxFrequency {
    Restriction get ();
}
public:
property Restriction MaxFrequency {
    Restriction get ();
}
Property Value
Type: Restriction
See Also
Reference
PortRestrictions Class
Dln.Pwm Namespace


PortRestrictions.MinFrequency Property

PortRestrictions MinFrequency Property dln.net.dll
Minimal frequency restriction

Namespace: Dln.Pwm
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public Restriction MinFrequency { get; }
public Restriction MinFrequency { get; }
Public ReadOnly Property MinFrequency As Restriction
    Get
Public ReadOnly Property MinFrequency As Restriction
    Get
public:
property Restriction MinFrequency {
    Restriction get ();
}
public:
property Restriction MinFrequency {
    Restriction get ();
}
Property Value
Type: Restriction
See Also
Reference
PortRestrictions Class
Dln.Pwm Namespace


Ports Class

Ports Class dln.net.dll
Ports class
Inheritance Hierarchy
System Object
System.Collections.ObjectModel ReadOnlyCollection Port
Dln.Pwm Ports

Namespace: Dln.Pwm
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public class Ports : ReadOnlyCollection<Port>
public class Ports : ReadOnlyCollection<Port>
Public Class Ports
    Inherits ReadOnlyCollection(Of Port)
Public Class Ports
    Inherits ReadOnlyCollection(Of Port)
public ref class Ports : public ReadOnlyCollection<Port^>
public ref class Ports : public ReadOnlyCollection<Port^>
The Ports type exposes the following members.
Methods
 | Name | Description
Public method | Contains | Determines whether an element is in the ReadOnlyCollection T . (Inherited from ReadOnlyCollection Port .)
Public method | CopyTo | Copies the entire ReadOnlyCollection T to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from ReadOnlyCollection Port .)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the ReadOnlyCollection T . (Inherited from ReadOnlyCollection Port .)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Public method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ReadOnlyCollection T . (Inherited from ReadOnlyCollection Port .)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the ReadOnlyCollection T instance. (Inherited from ReadOnlyCollection Port .)
Public property | Item |
Protected property | Items | Returns the IList T that the ReadOnlyCollection T wraps. (Inherited from ReadOnlyCollection Port .)
Top
See Also
Reference
Dln.Pwm Namespace


Ports Methods

Ports Methods dln.net.dll

The Ports type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Determines whether an element is in the ReadOnlyCollection T . (Inherited from ReadOnlyCollection Port .)
Public method | CopyTo | Copies the entire ReadOnlyCollection T to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from ReadOnlyCollection Port .)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the ReadOnlyCollection T . (Inherited from ReadOnlyCollection Port .)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Public method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ReadOnlyCollection T . (Inherited from ReadOnlyCollection Port .)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Ports Class
Dln.Pwm Namespace


Ports Properties

Ports Properties dln.net.dll

The Ports type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the ReadOnlyCollection T instance. (Inherited from ReadOnlyCollection Port .)
Public property | Item |
Protected property | Items | Returns the IList T that the ReadOnlyCollection T wraps. (Inherited from ReadOnlyCollection Port .)
Top
See Also

Reference

Ports Class
Dln.Pwm Namespace


Ports.Item Property

Ports Item Property dln.net.dll

[Missing <summary> documentation for "P:Dln.Pwm.Ports.Item(System.Int32)"]

Namespace: Dln.Pwm
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public Port this[
    int index
] { get; }
public Port this[
    int index
] { get; }
Public ReadOnly Default Property Item (
    index As Integer
) As Port
    Get
Public ReadOnly Default Property Item (
    index As Integer
) As Port
    Get
public:
property Port^ default[int index] {
    Port^ get (int index);
}
public:
property Port^ default[int index] {
    Port^ get (int index);
}
Parameters
index
Type: System Int32
Port index
Return Value
Type: Port
Port class object
See Also
Reference
Ports Class
Dln.Pwm Namespace


Dln.SpiFlash Namespace

Dln.SpiFlash Namespace dln.net.dll
The Dln.SpiFlash namespace contains types that allow SPI flash module usage of DLN-series adapters.
Classes
 | Class | Description
Public class | Module |
Public class | Port | Port class describes properties and mothods for operating with SPI flash module.
Public class | PortRestrictions |
Public class | Ports |


Module Class

Module Class dln.net.dll

[Missing <summary> documentation for "T:Dln.SpiFlash.Module"]

Inheritance Hierarchy
System Object
Dln.SpiFlash Module

Namespace: Dln.SpiFlash
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public class Module
public class Module
Public Class Module
Public Class Module
public ref class Module
public ref class Module
The Module type exposes the following members.
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Ports |
Top
See Also
Reference
Dln.SpiFlash Namespace


Module Methods

Module Methods dln.net.dll

The Module type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Module Class
Dln.SpiFlash Namespace


Module Properties

Module Properties dln.net.dll

The Module type exposes the following members.

Properties
 | Name | Description
Public property | Ports |
Top
See Also

Reference

Module Class
Dln.SpiFlash Namespace


Module.Ports Property

Module Ports Property dln.net.dll

[Missing <summary> documentation for "P:Dln.SpiFlash.Module.Ports"]

Namespace: Dln.SpiFlash
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public Ports Ports { get; }
public Ports Ports { get; }
Public ReadOnly Property Ports As Ports
    Get
Public ReadOnly Property Ports As Ports
    Get
public:
property Ports^ Ports {
    Ports^ get ();
}
public:
property Ports^ Ports {
    Ports^ get ();
}
Property Value
Type: Ports
See Also
Reference
Module Class
Dln.SpiFlash Namespace


Port Class

Port Class dln.net.dll
Port class describes properties and mothods for operating with SPI flash module.
Inheritance Hierarchy
System Object
Dln.SpiFlash Port

Namespace: Dln.SpiFlash
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public class Port
public class Port
Public Class Port
Public Class Port
public ref class Port
public ref class Port
The Port type exposes the following members.
Methods
 | Name | Description
Public method | Command( Byte , Byte , UInt32) |
Public method | Command( Byte , Int32, Int32, Byte , Int32, Int32, UInt32) |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Erase flash memory.
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetFlashID | Get flash ID
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Program( Byte ) |
Public method | Program(Int32, Byte ) | Program flash memory.
Public method | Program(Int32, Byte , Int32, Int32) | Program flash memory.
Public method | ProgramPage(Int32, Byte , UInt32) | Transfers data by using SPI flash interface.
Public method | ProgramPage(Int32, Byte , Int32, Int32, UInt32) | Transfers data by using SPI flash interface.
Public method | ProgramVerify( Byte ) | Verify transfered data.
Public method | ProgramVerify(Int32, Byte ) | Verify transfered data.
Public method | ProgramVerify(Int32, Byte , Int32, Int32) | Verify transfered data.
Public method | Read( Byte ) |
Public method | Read(Int32, Byte ) | Receives data via SPI flash interface.
Public method | Read(Int32, Byte , Int32, Int32) | Receives data via SPI flash interface.
Public method | ReadPage(Int32, Byte ) | Reads data from flash memory.
Public method | ReadPage(Int32, Byte , Int32, Int32) | Reads data from flash memory.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Enabled | Enables or disables SPI flash port. Leave property blank to get the current value.
Public property | Frequency | Sets or gets spi flash port frequency. Leave property blank to get the current value.
Public property | Restrictions | SPI flash interface restrictions
Public property | SS | Activates SS line.
Public property | SSMask | Activates SS lines by using mask value
Top
See Also
Reference
Dln.SpiFlash Namespace


Port Methods

Port Methods dln.net.dll

The Port type exposes the following members.

Methods
 | Name | Description
Public method | Command( Byte , Byte , UInt32) |
Public method | Command( Byte , Int32, Int32, Byte , Int32, Int32, UInt32) |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Erase flash memory.
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetFlashID | Get flash ID
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Program( Byte ) |
Public method | Program(Int32, Byte ) | Program flash memory.
Public method | Program(Int32, Byte , Int32, Int32) | Program flash memory.
Public method | ProgramPage(Int32, Byte , UInt32) | Transfers data by using SPI flash interface.
Public method | ProgramPage(Int32, Byte , Int32, Int32, UInt32) | Transfers data by using SPI flash interface.
Public method | ProgramVerify( Byte ) | Verify transfered data.
Public method | ProgramVerify(Int32, Byte ) | Verify transfered data.
Public method | ProgramVerify(Int32, Byte , Int32, Int32) | Verify transfered data.
Public method | Read( Byte ) |
Public method | Read(Int32, Byte ) | Receives data via SPI flash interface.
Public method | Read(Int32, Byte , Int32, Int32) | Receives data via SPI flash interface.
Public method | ReadPage(Int32, Byte ) | Reads data from flash memory.
Public method | ReadPage(Int32, Byte , Int32, Int32) | Reads data from flash memory.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Port Class
Dln.SpiFlash Namespace


Port.Command Method

Port Command Method dln.net.dll
Overload List
 | Name | Description
Public method | Command( Byte , Byte , UInt32) |
Public method | Command( Byte , Int32, Int32, Byte , Int32, Int32, UInt32) |
Top
See Also

Reference

Port Class
Dln.SpiFlash Namespace


Port.Command Method (Byte[], Byte[], UInt32)

Port Command Method ( Byte , Byte , UInt32) dln.net.dll

[Missing <summary> documentation for "M:Dln.SpiFlash.Port.Command(System.Byte[],System.Byte[],System.UInt32)"]

Namespace: Dln.SpiFlash
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public void Command(
    byte[] txBuffer,
    byte[] rxBuffer,
    uint timeout
)
public void Command(
    byte[] txBuffer,
    byte[] rxBuffer,
    uint timeout
)
Public Sub Command (
    txBuffer As Byte(),
    rxBuffer As Byte(),
    timeout As UInteger
)
Public Sub Command (
    txBuffer As Byte(),
    rxBuffer As Byte(),
    timeout As UInteger
)
public:
void Command(
    array<unsigned char>^ txBuffer,
    array<unsigned char>^ rxBuffer,
    unsigned int timeout
)
public:
void Command(
    array<unsigned char>^ txBuffer,
    array<unsigned char>^ rxBuffer,
    unsigned int timeout
)
Parameters
txBuffer
Type:  System Byte
[Missing <param name="txBuffer"/> documentation for "M:Dln.SpiFlash.Port.Command(System.Byte[],System.Byte[],System.UInt32)"]
rxBuffer
Type:  System Byte
[Missing <param name="rxBuffer"/> documentation for "M:Dln.SpiFlash.Port.Command(System.Byte[],System.Byte[],System.UInt32)"]
timeout
Type: System UInt32
[Missing <param name="timeout"/> documentation for "M:Dln.SpiFlash.Port.Command(System.Byte[],System.Byte[],System.UInt32)"]
See Also
Reference
Port Class
Command Overload
Dln.SpiFlash Namespace


Port.Command Method (Byte[], Int32, Int32, Byte[], Int32, Int32, UInt32)

Port Command Method ( Byte , Int32, Int32, Byte , Int32, Int32, UInt32) dln.net.dll

[Missing <summary> documentation for "M:Dln.SpiFlash.Port.Command(System.Byte[],System.Int32,System.Int32,System.Byte[],System.Int32,System.Int32,System.UInt32)"]

Namespace: Dln.SpiFlash
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public void Command(
    byte[] txBuffer,
    int txOffset,
    int txCount,
    byte[] rxBuffer,
    int rxOffset,
    int rxCount,
    uint timeout
)
public void Command(
    byte[] txBuffer,
    int txOffset,
    int txCount,
    byte[] rxBuffer,
    int rxOffset,
    int rxCount,
    uint timeout
)
Public Sub Command (
    txBuffer As Byte(),
    txOffset As Integer,
    txCount As Integer,
    rxBuffer As Byte(),
    rxOffset As Integer,
    rxCount As Integer,
    timeout As UInteger
)
Public Sub Command (
    txBuffer As Byte(),
    txOffset As Integer,
    txCount As Integer,
    rxBuffer As Byte(),
    rxOffset As Integer,
    rxCount As Integer,
    timeout As UInteger
)
public:
void Command(
    array<unsigned char>^ txBuffer,
    int txOffset,
    int txCount,
    array<unsigned char>^ rxBuffer,
    int rxOffset,
    int rxCount,
    unsigned int timeout
)
public:
void Command(
    array<unsigned char>^ txBuffer,
    int txOffset,
    int txCount,
    array<unsigned char>^ rxBuffer,
    int rxOffset,
    int rxCount,
    unsigned int timeout
)
Parameters
txBuffer
Type:  System Byte
[Missing <param name="txBuffer"/> documentation for "M:Dln.SpiFlash.Port.Command(System.Byte[],System.Int32,System.Int32,System.Byte[],System.Int32,System.Int32,System.UInt32)"]
txOffset
Type: System Int32
[Missing <param name="txOffset"/> documentation for "M:Dln.SpiFlash.Port.Command(System.Byte[],System.Int32,System.Int32,System.Byte[],System.Int32,System.Int32,System.UInt32)"]
txCount
Type: System Int32
[Missing <param name="txCount"/> documentation for "M:Dln.SpiFlash.Port.Command(System.Byte[],System.Int32,System.Int32,System.Byte[],System.Int32,System.Int32,System.UInt32)"]
rxBuffer
Type:  System Byte
[Missing <param name="rxBuffer"/> documentation for "M:Dln.SpiFlash.Port.Command(System.Byte[],System.Int32,System.Int32,System.Byte[],System.Int32,System.Int32,System.UInt32)"]
rxOffset
Type: System Int32
[Missing <param name="rxOffset"/> documentation for "M:Dln.SpiFlash.Port.Command(System.Byte[],System.Int32,System.Int32,System.Byte[],System.Int32,System.Int32,System.UInt32)"]
rxCount
Type: System Int32
[Missing <param name="rxCount"/> documentation for "M:Dln.SpiFlash.Port.Command(System.Byte[],System.Int32,System.Int32,System.Byte[],System.Int32,System.Int32,System.UInt32)"]
timeout
Type: System UInt32
[Missing <param name="timeout"/> documentation for "M:Dln.SpiFlash.Port.Command(System.Byte[],System.Int32,System.Int32,System.Byte[],System.Int32,System.Int32,System.UInt32)"]
See Also
Reference
Port Class
Command Overload
Dln.SpiFlash Namespace


Port.Erase Method

Port Erase Method dln.net.dll
Erase flash memory.

Namespace: Dln.SpiFlash
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public void Erase()
public void Erase()
Public Sub Erase
Public Sub Erase
public:
void Erase()
public:
void Erase()
See Also
Reference
Port Class
Dln.SpiFlash Namespace


Port.GetFlashID Method

Port GetFlashID Method dln.net.dll
Get flash ID

Namespace: Dln.SpiFlash
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public int GetFlashID()
public int GetFlashID()
Public Function GetFlashID As Integer
Public Function GetFlashID As Integer
public:
int GetFlashID()
public:
int GetFlashID()
Return Value
Type: Int32
[Missing <returns> documentation for "M:Dln.SpiFlash.Port.GetFlashID"]
See Also
Reference
Port Class
Dln.SpiFlash Namespace


Port.Program Method

Port Program Method dln.net.dll
Overload List
 | Name | Description
Public method | Program( Byte ) |
Public method | Program(Int32, Byte ) | Program flash memory.
Public method | Program(Int32, Byte , Int32, Int32) | Program flash memory.
Top
See Also

Reference

Port Class
Dln.SpiFlash Namespace


Port.Program Method (Byte[])

Port Program Method ( Byte ) dln.net.dll

[Missing <summary> documentation for "M:Dln.SpiFlash.Port.Program(System.Byte[])"]

Namespace: Dln.SpiFlash
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public void Program(
    byte[] buffer
)
public void Program(
    byte[] buffer
)
Public Sub Program (
    buffer As Byte()
)
Public Sub Program (
    buffer As Byte()
)
public:
void Program(
    array<unsigned char>^ buffer
)
public:
void Program(
    array<unsigned char>^ buffer
)
Parameters
buffer
Type:  System Byte
[Missing <param name="buffer"/> documentation for "M:Dln.SpiFlash.Port.Program(System.Byte[])"]
See Also
Reference
Port Class
Program Overload
Dln.SpiFlash Namespace


Port.Program Method (Int32, Byte[])

Port Program Method (Int32, Byte ) dln.net.dll
Program flash memory.

Namespace: Dln.SpiFlash
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public void Program(
    int startAddress,
    byte[] buffer
)
public void Program(
    int startAddress,
    byte[] buffer
)
Public Sub Program (
    startAddress As Integer,
    buffer As Byte()
)
Public Sub Program (
    startAddress As Integer,
    buffer As Byte()
)
public:
void Program(
    int startAddress,
    array<unsigned char>^ buffer
)
public:
void Program(
    int startAddress,
    array<unsigned char>^ buffer
)
Parameters
startAddress
Type: System Int32
Start flash memory address
buffer
Type:  System Byte
Data to be programmed
See Also
Reference
Port Class
Program Overload
Dln.SpiFlash Namespace


Port.Program Method (Int32, Byte[], Int32, Int32)

Port Program Method (Int32, Byte , Int32, Int32) dln.net.dll
Program flash memory.

Namespace: Dln.SpiFlash
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public void Program(
    int startAddress,
    byte[] buffer,
    int offset,
    int count
)
public void Program(
    int startAddress,
    byte[] buffer,
    int offset,
    int count
)
Public Sub Program (
    startAddress As Integer,
    buffer As Byte(),
    offset As Integer,
    count As Integer
)
Public Sub Program (
    startAddress As Integer,
    buffer As Byte(),
    offset As Integer,
    count As Integer
)
public:
void Program(
    int startAddress,
    array<unsigned char>^ buffer,
    int offset,
    int count
)
public:
void Program(
    int startAddress,
    array<unsigned char>^ buffer,
    int offset,
    int count
)
Parameters
startAddress
Type: System Int32
Start flash memory address
buffer
Type:  System Byte
Data to be programmed
offset
Type: System Int32
Data offset
count
Type: System Int32
Transfer count
See Also
Reference
Port Class
Program Overload
Dln.SpiFlash Namespace


Port.ProgramPage Method

Port ProgramPage Method dln.net.dll
Overload List
 | Name | Description
Public method | ProgramPage(Int32, Byte , UInt32) | Transfers data by using SPI flash interface.
Public method | ProgramPage(Int32, Byte , Int32, Int32, UInt32) | Transfers data by using SPI flash interface.
Top
See Also

Reference

Port Class
Dln.SpiFlash Namespace


Port.ProgramPage Method (Int32, Byte[], UInt32)

Port ProgramPage Method (Int32, Byte , UInt32) dln.net.dll
Transfers data by using SPI flash interface.

Namespace: Dln.SpiFlash
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public void ProgramPage(
    int address,
    byte[] buffer,
    uint timeout
)
public void ProgramPage(
    int address,
    byte[] buffer,
    uint timeout
)
Public Sub ProgramPage (
    address As Integer,
    buffer As Byte(),
    timeout As UInteger
)
Public Sub ProgramPage (
    address As Integer,
    buffer As Byte(),
    timeout As UInteger
)
public:
void ProgramPage(
    int address,
    array<unsigned char>^ buffer,
    unsigned int timeout
)
public:
void ProgramPage(
    int address,
    array<unsigned char>^ buffer,
    unsigned int timeout
)
Parameters
address
Type: System Int32
Flash memory address
buffer
Type:  System Byte
Data to be transfered
timeout
Type: System UInt32
Timeout value
See Also
Reference
Port Class
ProgramPage Overload
Dln.SpiFlash Namespace


Port.ProgramPage Method (Int32, Byte[], Int32, Int32, UInt32)

Port ProgramPage Method (Int32, Byte , Int32, Int32, UInt32) dln.net.dll
Transfers data by using SPI flash interface.

Namespace: Dln.SpiFlash
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public void ProgramPage(
    int address,
    byte[] buffer,
    int offset,
    int count,
    uint timeout
)
public void ProgramPage(
    int address,
    byte[] buffer,
    int offset,
    int count,
    uint timeout
)
Public Sub ProgramPage (
    address As Integer,
    buffer As Byte(),
    offset As Integer,
    count As Integer,
    timeout As UInteger
)
Public Sub ProgramPage (
    address As Integer,
    buffer As Byte(),
    offset As Integer,
    count As Integer,
    timeout As UInteger
)
public:
void ProgramPage(
    int address,
    array<unsigned char>^ buffer,
    int offset,
    int count,
    unsigned int timeout
)
public:
void ProgramPage(
    int address,
    array<unsigned char>^ buffer,
    int offset,
    int count,
    unsigned int timeout
)
Parameters
address
Type: System Int32
Flash memory address
buffer
Type:  System Byte
Data to be transfered
offset
Type: System Int32
Data offset
count
Type: System Int32
Transfer count
timeout
Type: System UInt32
Timeout value
See Also
Reference
Port Class
ProgramPage Overload
Dln.SpiFlash Namespace


Port.ProgramVerify Method

Port ProgramVerify Method dln.net.dll
Overload List
 | Name | Description
Public method | ProgramVerify( Byte ) | Verify transfered data.
Public method | ProgramVerify(Int32, Byte ) | Verify transfered data.
Public method | ProgramVerify(Int32, Byte , Int32, Int32) | Verify transfered data.
Top
See Also

Reference

Port Class
Dln.SpiFlash Namespace


Port.ProgramVerify Method (Byte[])

Port ProgramVerify Method ( Byte ) dln.net.dll
Verify transfered data.

Namespace: Dln.SpiFlash
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public void ProgramVerify(
    byte[] buffer
)
public void ProgramVerify(
    byte[] buffer
)
Public Sub ProgramVerify (
    buffer As Byte()
)
Public Sub ProgramVerify (
    buffer As Byte()
)
public:
void ProgramVerify(
    array<unsigned char>^ buffer
)
public:
void ProgramVerify(
    array<unsigned char>^ buffer
)
Parameters
buffer
Type:  System Byte
Data buffer for verification
See Also
Reference
Port Class
ProgramVerify Overload
Dln.SpiFlash Namespace


Port.ProgramVerify Method (Int32, Byte[])

Port ProgramVerify Method (Int32, Byte ) dln.net.dll
Verify transfered data.

Namespace: Dln.SpiFlash
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public void ProgramVerify(
    int startAddress,
    byte[] buffer
)
public void ProgramVerify(
    int startAddress,
    byte[] buffer
)
Public Sub ProgramVerify (
    startAddress As Integer,
    buffer As Byte()
)
Public Sub ProgramVerify (
    startAddress As Integer,
    buffer As Byte()
)
public:
void ProgramVerify(
    int startAddress,
    array<unsigned char>^ buffer
)
public:
void ProgramVerify(
    int startAddress,
    array<unsigned char>^ buffer
)
Parameters
startAddress
Type: System Int32
Start flash memory address
buffer
Type:  System Byte
Data buffer for verification
See Also
Reference
Port Class
ProgramVerify Overload
Dln.SpiFlash Namespace


Port.ProgramVerify Method (Int32, Byte[], Int32, Int32)

Port ProgramVerify Method (Int32, Byte , Int32, Int32) dln.net.dll
Verify transfered data.

Namespace: Dln.SpiFlash
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public void ProgramVerify(
    int startAddress,
    byte[] buffer,
    int offset,
    int count
)
public void ProgramVerify(
    int startAddress,
    byte[] buffer,
    int offset,
    int count
)
Public Sub ProgramVerify (
    startAddress As Integer,
    buffer As Byte(),
    offset As Integer,
    count As Integer
)
Public Sub ProgramVerify (
    startAddress As Integer,
    buffer As Byte(),
    offset As Integer,
    count As Integer
)
public:
void ProgramVerify(
    int startAddress,
    array<unsigned char>^ buffer,
    int offset,
    int count
)
public:
void ProgramVerify(
    int startAddress,
    array<unsigned char>^ buffer,
    int offset,
    int count
)
Parameters
startAddress
Type: System Int32
Start flash memory address
buffer
Type:  System Byte
Data buffer for verification
offset
Type: System Int32
Data offset
count
Type: System Int32
Transfer count
See Also
Reference
Port Class
ProgramVerify Overload
Dln.SpiFlash Namespace


Port.Read Method

Port Read Method dln.net.dll
Overload List
 | Name | Description
Public method | Read( Byte ) |
Public method | Read(Int32, Byte ) | Receives data via SPI flash interface.
Public method | Read(Int32, Byte , Int32, Int32) | Receives data via SPI flash interface.
Top
See Also

Reference

Port Class
Dln.SpiFlash Namespace


Port.Read Method (Byte[])

Port Read Method ( Byte ) dln.net.dll

[Missing <summary> documentation for "M:Dln.SpiFlash.Port.Read(System.Byte[])"]

Namespace: Dln.SpiFlash
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public void Read(
    byte[] buffer
)
public void Read(
    byte[] buffer
)
Public Sub Read (
    buffer As Byte()
)
Public Sub Read (
    buffer As Byte()
)
public:
void Read(
    array<unsigned char>^ buffer
)
public:
void Read(
    array<unsigned char>^ buffer
)
Parameters
buffer
Type:  System Byte
[Missing <param name="buffer"/> documentation for "M:Dln.SpiFlash.Port.Read(System.Byte[])"]
See Also
Reference
Port Class
Read Overload
Dln.SpiFlash Namespace


Port.Read Method (Int32, Byte[])

Port Read Method (Int32, Byte ) dln.net.dll
Receives data via SPI flash interface.

Namespace: Dln.SpiFlash
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public void Read(
    int startAddress,
    byte[] buffer
)
public void Read(
    int startAddress,
    byte[] buffer
)
Public Sub Read (
    startAddress As Integer,
    buffer As Byte()
)
Public Sub Read (
    startAddress As Integer,
    buffer As Byte()
)
public:
void Read(
    int startAddress,
    array<unsigned char>^ buffer
)
public:
void Read(
    int startAddress,
    array<unsigned char>^ buffer
)
Parameters
startAddress
Type: System Int32
Start flash memory address
buffer
Type:  System Byte
Buffer for data to be read
See Also
Reference
Port Class
Read Overload
Dln.SpiFlash Namespace


Port.Read Method (Int32, Byte[], Int32, Int32)

Port Read Method (Int32, Byte , Int32, Int32) dln.net.dll
Receives data via SPI flash interface.

Namespace: Dln.SpiFlash
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public void Read(
    int startAddress,
    byte[] buffer,
    int offset,
    int count
)
public void Read(
    int startAddress,
    byte[] buffer,
    int offset,
    int count
)
Public Sub Read (
    startAddress As Integer,
    buffer As Byte(),
    offset As Integer,
    count As Integer
)
Public Sub Read (
    startAddress As Integer,
    buffer As Byte(),
    offset As Integer,
    count As Integer
)
public:
void Read(
    int startAddress,
    array<unsigned char>^ buffer,
    int offset,
    int count
)
public:
void Read(
    int startAddress,
    array<unsigned char>^ buffer,
    int offset,
    int count
)
Parameters
startAddress
Type: System Int32
Start flash memory address
buffer
Type:  System Byte
Buffer for data to be read
offset
Type: System Int32
Data offset
count
Type: System Int32
Transfer count
See Also
Reference
Port Class
Read Overload
Dln.SpiFlash Namespace


Port.ReadPage Method

Port ReadPage Method dln.net.dll
Overload List
 | Name | Description
Public method | ReadPage(Int32, Byte ) | Reads data from flash memory.
Public method | ReadPage(Int32, Byte , Int32, Int32) | Reads data from flash memory.
Top
See Also

Reference

Port Class
Dln.SpiFlash Namespace


Port.ReadPage Method (Int32, Byte[])

Port ReadPage Method (Int32, Byte ) dln.net.dll
Reads data from flash memory.

Namespace: Dln.SpiFlash
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public void ReadPage(
    int address,
    byte[] buffer
)
public void ReadPage(
    int address,
    byte[] buffer
)
Public Sub ReadPage (
    address As Integer,
    buffer As Byte()
)
Public Sub ReadPage (
    address As Integer,
    buffer As Byte()
)
public:
void ReadPage(
    int address,
    array<unsigned char>^ buffer
)
public:
void ReadPage(
    int address,
    array<unsigned char>^ buffer
)
Parameters
address
Type: System Int32
Flash memory address
buffer
Type:  System Byte
Buffer for read data
See Also
Reference
Port Class
ReadPage Overload
Dln.SpiFlash Namespace


Port.ReadPage Method (Int32, Byte[], Int32, Int32)

Port ReadPage Method (Int32, Byte , Int32, Int32) dln.net.dll
Reads data from flash memory.

Namespace: Dln.SpiFlash
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public void ReadPage(
    int address,
    byte[] buffer,
    int offset,
    int count
)
public void ReadPage(
    int address,
    byte[] buffer,
    int offset,
    int count
)
Public Sub ReadPage (
    address As Integer,
    buffer As Byte(),
    offset As Integer,
    count As Integer
)
Public Sub ReadPage (
    address As Integer,
    buffer As Byte(),
    offset As Integer,
    count As Integer
)
public:
void ReadPage(
    int address,
    array<unsigned char>^ buffer,
    int offset,
    int count
)
public:
void ReadPage(
    int address,
    array<unsigned char>^ buffer,
    int offset,
    int count
)
Parameters
address
Type: System Int32
Flash memory address
buffer
Type:  System Byte
Buffer for read data
offset
Type: System Int32
Data offset
count
Type: System Int32
Data read count
See Also
Reference
Port Class
ReadPage Overload
Dln.SpiFlash Namespace


Port Properties

Port Properties dln.net.dll

The Port type exposes the following members.

Properties
 | Name | Description
Public property | Enabled | Enables or disables SPI flash port. Leave property blank to get the current value.
Public property | Frequency | Sets or gets spi flash port frequency. Leave property blank to get the current value.
Public property | Restrictions | SPI flash interface restrictions
Public property | SS | Activates SS line.
Public property | SSMask | Activates SS lines by using mask value
Top
See Also

Reference

Port Class
Dln.SpiFlash Namespace


Port.Enabled Property

Port Enabled Property dln.net.dll
Enables or disables SPI flash port. Leave property blank to get the current value.

Namespace: Dln.SpiFlash
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public bool Enabled { get; set; }
public bool Enabled { get; set; }
Public Property Enabled As Boolean
    Get
    Set
Public Property Enabled As Boolean
    Get
    Set
public:
property bool Enabled {
    bool get ();
    void set (bool value);
}
public:
property bool Enabled {
    bool get ();
    void set (bool value);
}
Property Value
Type: Boolean
See Also
Reference
Port Class
Dln.SpiFlash Namespace


Port.Frequency Property

Port Frequency Property dln.net.dll
Sets or gets spi flash port frequency. Leave property blank to get the current value.

Namespace: Dln.SpiFlash
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public int Frequency { get; set; }
public int Frequency { get; set; }
Public Property Frequency As Integer
    Get
    Set
Public Property Frequency As Integer
    Get
    Set
public:
property int Frequency {
    int get ();
    void set (int value);
}
public:
property int Frequency {
    int get ();
    void set (int value);
}
Property Value
Type: Int32
See Also
Reference
Port Class
Dln.SpiFlash Namespace


Port.Restrictions Property

Port Restrictions Property dln.net.dll
SPI flash interface restrictions

Namespace: Dln.SpiFlash
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public PortRestrictions Restrictions { get; }
public PortRestrictions Restrictions { get; }
Public ReadOnly Property Restrictions As PortRestrictions
    Get
Public ReadOnly Property Restrictions As PortRestrictions
    Get
public:
property PortRestrictions^ Restrictions {
    PortRestrictions^ get ();
}
public:
property PortRestrictions^ Restrictions {
    PortRestrictions^ get ();
}
Property Value
Type: PortRestrictions
See Also
Reference
Port Class
Dln.SpiFlash Namespace


Port.SS Property

Port SS Property dln.net.dll
Activates SS line.

Namespace: Dln.SpiFlash
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public int SS { get; set; }
public int SS { get; set; }
Public Property SS As Integer
    Get
    Set
Public Property SS As Integer
    Get
    Set
public:
property int SS {
    int get ();
    void set (int value);
}
public:
property int SS {
    int get ();
    void set (int value);
}
Property Value
Type: Int32
See Also
Reference
Port Class
Dln.SpiFlash Namespace


Port.SSMask Property

Port SSMask Property dln.net.dll
Activates SS lines by using mask value

Namespace: Dln.SpiFlash
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public int SSMask { get; set; }
public int SSMask { get; set; }
Public Property SSMask As Integer
    Get
    Set
Public Property SSMask As Integer
    Get
    Set
public:
property int SSMask {
    int get ();
    void set (int value);
}
public:
property int SSMask {
    int get ();
    void set (int value);
}
Property Value
Type: Int32
See Also
Reference
Port Class
Dln.SpiFlash Namespace


PortRestrictions Class

PortRestrictions Class dln.net.dll

[Missing <summary> documentation for "T:Dln.SpiFlash.PortRestrictions"]

Inheritance Hierarchy
System Object
Dln.SpiFlash PortRestrictions

Namespace: Dln.SpiFlash
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public class PortRestrictions
public class PortRestrictions
Public Class PortRestrictions
Public Class PortRestrictions
public ref class PortRestrictions
public ref class PortRestrictions
The PortRestrictions type exposes the following members.
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Command |
Public property | Enabled |
Public property | Erase |
Public property | Frequency |
Public property | GetFlashID |
Public property | Program |
Public property | ProgramPage |
Public property | ProgramVerify |
Public property | Read |
Public property | ReadPage |
Public property | SS |
Public property | SSMask |
Top
See Also
Reference
Dln.SpiFlash Namespace


PortRestrictions Methods

PortRestrictions Methods dln.net.dll

The PortRestrictions type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PortRestrictions Class
Dln.SpiFlash Namespace


PortRestrictions Properties

PortRestrictions Properties dln.net.dll

The PortRestrictions type exposes the following members.

Properties
 | Name | Description
Public property | Command |
Public property | Enabled |
Public property | Erase |
Public property | Frequency |
Public property | GetFlashID |
Public property | Program |
Public property | ProgramPage |
Public property | ProgramVerify |
Public property | Read |
Public property | ReadPage |
Public property | SS |
Public property | SSMask |
Top
See Also

Reference

PortRestrictions Class
Dln.SpiFlash Namespace


PortRestrictions.Command Property

PortRestrictions Command Property dln.net.dll

[Missing <summary> documentation for "P:Dln.SpiFlash.PortRestrictions.Command"]

Namespace: Dln.SpiFlash
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public Restriction Command { get; }
public Restriction Command { get; }
Public ReadOnly Property Command As Restriction
    Get
Public ReadOnly Property Command As Restriction
    Get
public:
property Restriction Command {
    Restriction get ();
}
public:
property Restriction Command {
    Restriction get ();
}
Property Value
Type: Restriction
See Also
Reference
PortRestrictions Class
Dln.SpiFlash Namespace


PortRestrictions.Enabled Property

PortRestrictions Enabled Property dln.net.dll

[Missing <summary> documentation for "P:Dln.SpiFlash.PortRestrictions.Enabled"]

Namespace: Dln.SpiFlash
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public Restriction Enabled { get; }
public Restriction Enabled { get; }
Public ReadOnly Property Enabled As Restriction
    Get
Public ReadOnly Property Enabled As Restriction
    Get
public:
property Restriction Enabled {
    Restriction get ();
}
public:
property Restriction Enabled {
    Restriction get ();
}
Property Value
Type: Restriction
See Also
Reference
PortRestrictions Class
Dln.SpiFlash Namespace


PortRestrictions.Erase Property

PortRestrictions Erase Property dln.net.dll

[Missing <summary> documentation for "P:Dln.SpiFlash.PortRestrictions.Erase"]

Namespace: Dln.SpiFlash
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public Restriction Erase { get; }
public Restriction Erase { get; }
Public ReadOnly Property Erase As Restriction
    Get
Public ReadOnly Property Erase As Restriction
    Get
public:
property Restriction Erase {
    Restriction get ();
}
public:
property Restriction Erase {
    Restriction get ();
}
Property Value
Type: Restriction
See Also
Reference
PortRestrictions Class
Dln.SpiFlash Namespace


PortRestrictions.Frequency Property

PortRestrictions Frequency Property dln.net.dll

[Missing <summary> documentation for "P:Dln.SpiFlash.PortRestrictions.Frequency"]

Namespace: Dln.SpiFlash
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public Restriction Frequency { get; }
public Restriction Frequency { get; }
Public ReadOnly Property Frequency As Restriction
    Get
Public ReadOnly Property Frequency As Restriction
    Get
public:
property Restriction Frequency {
    Restriction get ();
}
public:
property Restriction Frequency {
    Restriction get ();
}
Property Value
Type: Restriction
See Also
Reference
PortRestrictions Class
Dln.SpiFlash Namespace


PortRestrictions.GetFlashID Property

PortRestrictions GetFlashID Property dln.net.dll

[Missing <summary> documentation for "P:Dln.SpiFlash.PortRestrictions.GetFlashID"]

Namespace: Dln.SpiFlash
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public Restriction GetFlashID { get; }
public Restriction GetFlashID { get; }
Public ReadOnly Property GetFlashID As Restriction
    Get
Public ReadOnly Property GetFlashID As Restriction
    Get
public:
property Restriction GetFlashID {
    Restriction get ();
}
public:
property Restriction GetFlashID {
    Restriction get ();
}
Property Value
Type: Restriction
See Also
Reference
PortRestrictions Class
Dln.SpiFlash Namespace


PortRestrictions.Program Property

PortRestrictions Program Property dln.net.dll

[Missing <summary> documentation for "P:Dln.SpiFlash.PortRestrictions.Program"]

Namespace: Dln.SpiFlash
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public Restriction Program { get; }
public Restriction Program { get; }
Public ReadOnly Property Program As Restriction
    Get
Public ReadOnly Property Program As Restriction
    Get
public:
property Restriction Program {
    Restriction get ();
}
public:
property Restriction Program {
    Restriction get ();
}
Property Value
Type: Restriction
See Also
Reference
PortRestrictions Class
Dln.SpiFlash Namespace


PortRestrictions.ProgramPage Property

PortRestrictions ProgramPage Property dln.net.dll

[Missing <summary> documentation for "P:Dln.SpiFlash.PortRestrictions.ProgramPage"]

Namespace: Dln.SpiFlash
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public Restriction ProgramPage { get; }
public Restriction ProgramPage { get; }
Public ReadOnly Property ProgramPage As Restriction
    Get
Public ReadOnly Property ProgramPage As Restriction
    Get
public:
property Restriction ProgramPage {
    Restriction get ();
}
public:
property Restriction ProgramPage {
    Restriction get ();
}
Property Value
Type: Restriction
See Also
Reference
PortRestrictions Class
Dln.SpiFlash Namespace


PortRestrictions.ProgramVerify Property

PortRestrictions ProgramVerify Property dln.net.dll

[Missing <summary> documentation for "P:Dln.SpiFlash.PortRestrictions.ProgramVerify"]

Namespace: Dln.SpiFlash
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public Restriction ProgramVerify { get; }
public Restriction ProgramVerify { get; }
Public ReadOnly Property ProgramVerify As Restriction
    Get
Public ReadOnly Property ProgramVerify As Restriction
    Get
public:
property Restriction ProgramVerify {
    Restriction get ();
}
public:
property Restriction ProgramVerify {
    Restriction get ();
}
Property Value
Type: Restriction
See Also
Reference
PortRestrictions Class
Dln.SpiFlash Namespace


PortRestrictions.Read Property

PortRestrictions Read Property dln.net.dll

[Missing <summary> documentation for "P:Dln.SpiFlash.PortRestrictions.Read"]

Namespace: Dln.SpiFlash
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public Restriction Read { get; }
public Restriction Read { get; }
Public ReadOnly Property Read As Restriction
    Get
Public ReadOnly Property Read As Restriction
    Get
public:
property Restriction Read {
    Restriction get ();
}
public:
property Restriction Read {
    Restriction get ();
}
Property Value
Type: Restriction
See Also
Reference
PortRestrictions Class
Dln.SpiFlash Namespace


PortRestrictions.ReadPage Property

PortRestrictions ReadPage Property dln.net.dll

[Missing <summary> documentation for "P:Dln.SpiFlash.PortRestrictions.ReadPage"]

Namespace: Dln.SpiFlash
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public Restriction ReadPage { get; }
public Restriction ReadPage { get; }
Public ReadOnly Property ReadPage As Restriction
    Get
Public ReadOnly Property ReadPage As Restriction
    Get
public:
property Restriction ReadPage {
    Restriction get ();
}
public:
property Restriction ReadPage {
    Restriction get ();
}
Property Value
Type: Restriction
See Also
Reference
PortRestrictions Class
Dln.SpiFlash Namespace


PortRestrictions.SS Property

PortRestrictions SS Property dln.net.dll

[Missing <summary> documentation for "P:Dln.SpiFlash.PortRestrictions.SS"]

Namespace: Dln.SpiFlash
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public Restriction SS { get; }
public Restriction SS { get; }
Public ReadOnly Property SS As Restriction
    Get
Public ReadOnly Property SS As Restriction
    Get
public:
property Restriction SS {
    Restriction get ();
}
public:
property Restriction SS {
    Restriction get ();
}
Property Value
Type: Restriction
See Also
Reference
PortRestrictions Class
Dln.SpiFlash Namespace


PortRestrictions.SSMask Property

PortRestrictions SSMask Property dln.net.dll

[Missing <summary> documentation for "P:Dln.SpiFlash.PortRestrictions.SSMask"]

Namespace: Dln.SpiFlash
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public Restriction SSMask { get; }
public Restriction SSMask { get; }
Public ReadOnly Property SSMask As Restriction
    Get
Public ReadOnly Property SSMask As Restriction
    Get
public:
property Restriction SSMask {
    Restriction get ();
}
public:
property Restriction SSMask {
    Restriction get ();
}
Property Value
Type: Restriction
See Also
Reference
PortRestrictions Class
Dln.SpiFlash Namespace


Ports Class

Ports Class dln.net.dll

[Missing <summary> documentation for "T:Dln.SpiFlash.Ports"]

Inheritance Hierarchy
System Object
System.Collections.ObjectModel ReadOnlyCollection Port
Dln.SpiFlash Ports

Namespace: Dln.SpiFlash
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public class Ports : ReadOnlyCollection<Port>
public class Ports : ReadOnlyCollection<Port>
Public Class Ports
    Inherits ReadOnlyCollection(Of Port)
Public Class Ports
    Inherits ReadOnlyCollection(Of Port)
public ref class Ports : public ReadOnlyCollection<Port^>
public ref class Ports : public ReadOnlyCollection<Port^>
The Ports type exposes the following members.
Methods
 | Name | Description
Public method | Contains | Determines whether an element is in the ReadOnlyCollection T . (Inherited from ReadOnlyCollection Port .)
Public method | CopyTo | Copies the entire ReadOnlyCollection T to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from ReadOnlyCollection Port .)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the ReadOnlyCollection T . (Inherited from ReadOnlyCollection Port .)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Public method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ReadOnlyCollection T . (Inherited from ReadOnlyCollection Port .)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the ReadOnlyCollection T instance. (Inherited from ReadOnlyCollection Port .)
Public property | Item |
Protected property | Items | Returns the IList T that the ReadOnlyCollection T wraps. (Inherited from ReadOnlyCollection Port .)
Top
See Also
Reference
Dln.SpiFlash Namespace


Ports Methods

Ports Methods dln.net.dll

The Ports type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Determines whether an element is in the ReadOnlyCollection T . (Inherited from ReadOnlyCollection Port .)
Public method | CopyTo | Copies the entire ReadOnlyCollection T to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from ReadOnlyCollection Port .)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the ReadOnlyCollection T . (Inherited from ReadOnlyCollection Port .)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Public method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ReadOnlyCollection T . (Inherited from ReadOnlyCollection Port .)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Ports Class
Dln.SpiFlash Namespace


Ports Properties

Ports Properties dln.net.dll

The Ports type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the ReadOnlyCollection T instance. (Inherited from ReadOnlyCollection Port .)
Public property | Item |
Protected property | Items | Returns the IList T that the ReadOnlyCollection T wraps. (Inherited from ReadOnlyCollection Port .)
Top
See Also

Reference

Ports Class
Dln.SpiFlash Namespace


Ports.Item Property

Ports Item Property dln.net.dll

[Missing <summary> documentation for "P:Dln.SpiFlash.Ports.Item(System.Int32)"]

Namespace: Dln.SpiFlash
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public Port this[
    int index
] { get; }
public Port this[
    int index
] { get; }
Public ReadOnly Default Property Item (
    index As Integer
) As Port
    Get
Public ReadOnly Default Property Item (
    index As Integer
) As Port
    Get
public:
property Port^ default[int index] {
    Port^ get (int index);
}
public:
property Port^ default[int index] {
    Port^ get (int index);
}
Parameters
index
Type: System Int32
Property Value
Type: Port
See Also
Reference
Ports Class
Dln.SpiFlash Namespace


Dln.SpiMaster Namespace

Dln.SpiMaster Namespace dln.net.dll
The Dln.SpiMaster namespace contains types that allow usage of DLN-series adapters as SPI bus master device.
Classes
 | Class | Description
Public class | Module | Module class describes properties and methods generic for SPI master module
Public class | Port |
Public class | PortRestrictions |
Public class | Ports | Ports class


Module Class

Module Class dln.net.dll
Module class describes properties and methods generic for SPI master module
Inheritance Hierarchy
System Object
Dln.SpiMaster Module

Namespace: Dln.SpiMaster
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public class Module
public class Module
Public Class Module
Public Class Module
public ref class Module
public ref class Module
The Module type exposes the following members.
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Ports | Get Ports class object
Top
See Also
Reference
Dln.SpiMaster Namespace


Module Methods

Module Methods dln.net.dll

The Module type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Module Class
Dln.SpiMaster Namespace


Module Properties

Module Properties dln.net.dll

The Module type exposes the following members.

Properties
 | Name | Description
Public property | Ports | Get Ports class object
Top
See Also

Reference

Module Class
Dln.SpiMaster Namespace


Module.Ports Property

Module Ports Property dln.net.dll
Get Ports class object

Namespace: Dln.SpiMaster
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public Ports Ports { get; }
public Ports Ports { get; }
Public ReadOnly Property Ports As Ports
    Get
Public ReadOnly Property Ports As Ports
    Get
public:
property Ports^ Ports {
    Ports^ get ();
}
public:
property Ports^ Ports {
    Ports^ get ();
}
Property Value
Type: Ports
See Also
Reference
Module Class
Dln.SpiMaster Namespace


Port Class

Port Class dln.net.dll

[Missing <summary> documentation for "T:Dln.SpiMaster.Port"]

Inheritance Hierarchy
System Object
Dln.SpiMaster Port

Namespace: Dln.SpiMaster
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public class Port
public class Port
Public Class Port
Public Class Port
public ref class Port
public ref class Port
The Port type exposes the following members.
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Read(Int32) | Receives data via SPI bus.
Public method | Read( Byte , Int32, Int32) | Receives data via SPI bus.
Public method | ReadWrite( Byte ) | Sends and receives data via SPI bus. The data i received as an array of 1-byte elements. This function is suited to transmit data frames of 8 bits or less.
Public method | ReadWrite( Byte , Int32, Int32) | Sends and receives data via SPI bus. The data i received as an array of 1-byte elements. This function is suited to transmit data frames of 8 bits or less.
Public method | ReleaseSS |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Write( Byte ) |
Public method | Write( Byte , Int32, Int32) | Sends and receives data via SPI bus. The data i received as an array of 1-byte elements. This function is suited to transmit data frames of 8 bits or less.
Top
Properties
 | Name | Description
Public property | Cpha | Sets of gets the clock phase value. Leave property blank to get current value.
Public property | CphaValues | Retrieves the availalbe CPHA values.
Public property | Cpol | Sets or gets the clock polarity value. Leave property blank to get current value.
Public property | CpolValues | Retrieves CPOL values.
Public property | DelayAfterSS | Sets and gets a delay duration between assertion of an SS line and first data frame. Leave property blank to get current value.
Public property | DelayBetweenFrames | Sets or gets a delay between data frames exchanged with a single slave device. Leave property blank to get current value.
Public property | DelayBetweenSS | Sets or gets a minimum delay between release of an SS line and assertion of another SS line. Leave property blank to get current value.
Public property | Enabled | Activates corresponding SPI master port on your DLN-series adapter. Leave property blank to get current value.
Public property | FrameSize | Sets the size of a single SPI data frame. Leave property blank to get current value.
Public property | FrameSizeValues | Retrieves all available frame size values.
Public property | Frequency | Sets the clock frequency on the SCLK line, used to synchronize data transfer between master and slave devices. Leave property blank to get current value.
Public property | MaxDelayAfterSS | Retrieves the maximum valid delay after SS value
Public property | MaxDelayBetweenFrames | Retrieves the maximum valid delay between frames value
Public property | MaxDelayBetweenSS | Retrieves the maximum valid delay between SS value
Public property | MaxFrequency | Retrieves the maximum valid frequency value
Public property | MinDelayAfterSS | Retrieves the minimum valid delay after SS value
Public property | MinDelayBetweenFrames | Retrieves the minimum valid delay between frames value
Public property | MinDelayBetweenSS | Retrieves the minimum valid delay between SS value
Public property | MinFrequency | Retrieves the minimum valid frequency value
Public property | Mode | Sets SPI transmission parameters (CPOL and CPHA). Leave property blank to get current value.
Public property | ModeValues | Retrieves all supported spi master modes.
Public property | ReleaseSSBetweenFrames | Releases the slave select line between frames. Leave property blank to get current value.
Public property | Restrictions |
Public property | SS | Selects a Slave Select (SS) line. Leave property blank to get current value.
Public property | SSCount | Retrieves the total number of SS lines.
Public property | SSEnabled | Sets SS lines status by using mask. Leave property blank to get current value.
Top
See Also
Reference
Dln.SpiMaster Namespace


Port Methods

Port Methods dln.net.dll

The Port type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Read(Int32) | Receives data via SPI bus.
Public method | Read( Byte , Int32, Int32) | Receives data via SPI bus.
Public method | ReadWrite( Byte ) | Sends and receives data via SPI bus. The data i received as an array of 1-byte elements. This function is suited to transmit data frames of 8 bits or less.
Public method | ReadWrite( Byte , Int32, Int32) | Sends and receives data via SPI bus. The data i received as an array of 1-byte elements. This function is suited to transmit data frames of 8 bits or less.
Public method | ReleaseSS |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Write( Byte ) |
Public method | Write( Byte , Int32, Int32) | Sends and receives data via SPI bus. The data i received as an array of 1-byte elements. This function is suited to transmit data frames of 8 bits or less.
Top
See Also

Reference

Port Class
Dln.SpiMaster Namespace


Port.Read Method

Port Read Method dln.net.dll
Overload List
 | Name | Description
Public method | Read(Int32) | Receives data via SPI bus.
Public method | Read( Byte , Int32, Int32) | Receives data via SPI bus.
Top
See Also

Reference

Port Class
Dln.SpiMaster Namespace


Port.Read Method (Int32)

Port Read Method (Int32) dln.net.dll
Receives data via SPI bus.

Namespace: Dln.SpiMaster
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public byte[] Read(
    int size
)
public byte[] Read(
    int size
)
Public Function Read (
    size As Integer
) As Byte()
Public Function Read (
    size As Integer
) As Byte()
public:
array<unsigned char>^ Read(
    int size
)
public:
array<unsigned char>^ Read(
    int size
)
Parameters
size
Type: System Int32
The size of the message. This parameter is specified in bytes. The maximum value is 256 bytes.
Return Value
Type:  Byte
Returns read data.
See Also
Reference
Port Class
Read Overload
Dln.SpiMaster Namespace


Port.Read Method (Byte[], Int32, Int32)

Port Read Method ( Byte , Int32, Int32) dln.net.dll
Receives data via SPI bus.

Namespace: Dln.SpiMaster
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public void Read(
    byte[] readData,
    int readOffset,
    int size
)
public void Read(
    byte[] readData,
    int readOffset,
    int size
)
Public Sub Read (
    readData As Byte(),
    readOffset As Integer,
    size As Integer
)
Public Sub Read (
    readData As Byte(),
    readOffset As Integer,
    size As Integer
)
public:
void Read(
    array<unsigned char>^ readData,
    int readOffset,
    int size
)
public:
void Read(
    array<unsigned char>^ readData,
    int readOffset,
    int size
)
Parameters
readData
Type:  System Byte
Read data.
readOffset
Type: System Int32
Read data offset
size
Type: System Int32
The size of the message buffer. This parameter is specified in bytes. The maximum value is 256 bytes.
See Also
Reference
Port Class
Read Overload
Dln.SpiMaster Namespace


Port.ReadWrite Method

Port ReadWrite Method dln.net.dll
Overload List
 | Name | Description
Public method | ReadWrite( Byte ) | Sends and receives data via SPI bus. The data i received as an array of 1-byte elements. This function is suited to transmit data frames of 8 bits or less.
Public method | ReadWrite( Byte , Int32, Int32) | Sends and receives data via SPI bus. The data i received as an array of 1-byte elements. This function is suited to transmit data frames of 8 bits or less.
Top
See Also

Reference

Port Class
Dln.SpiMaster Namespace


Port.ReadWrite Method (Byte[])

Port ReadWrite Method ( Byte ) dln.net.dll
Sends and receives data via SPI bus. The data i received as an array of 1-byte elements. This function is suited to transmit data frames of 8 bits or less.

Namespace: Dln.SpiMaster
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public byte[] ReadWrite(
    byte[] writeData
)
public byte[] ReadWrite(
    byte[] writeData
)
Public Function ReadWrite (
    writeData As Byte()
) As Byte()
Public Function ReadWrite (
    writeData As Byte()
) As Byte()
public:
array<unsigned char>^ ReadWrite(
    array<unsigned char>^ writeData
)
public:
array<unsigned char>^ ReadWrite(
    array<unsigned char>^ writeData
)
Parameters
writeData
Type:  System Byte
An array of unsigned 8-bit integers. This array must be filled with data to be sent to a slave during the function execution.
Return Value
Type:  Byte
Returns read data.
See Also
Reference
Port Class
ReadWrite Overload
Dln.SpiMaster Namespace


Port.ReadWrite Method (Byte[], Int32, Int32)

Port ReadWrite Method ( Byte , Int32, Int32) dln.net.dll
Sends and receives data via SPI bus. The data i received as an array of 1-byte elements. This function is suited to transmit data frames of 8 bits or less.

Namespace: Dln.SpiMaster
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public byte[] ReadWrite(
    byte[] writeData,
    int writeOffset,
    int size
)
public byte[] ReadWrite(
    byte[] writeData,
    int writeOffset,
    int size
)
Public Function ReadWrite (
    writeData As Byte(),
    writeOffset As Integer,
    size As Integer
) As Byte()
Public Function ReadWrite (
    writeData As Byte(),
    writeOffset As Integer,
    size As Integer
) As Byte()
public:
array<unsigned char>^ ReadWrite(
    array<unsigned char>^ writeData,
    int writeOffset,
    int size
)
public:
array<unsigned char>^ ReadWrite(
    array<unsigned char>^ writeData,
    int writeOffset,
    int size
)
Parameters
writeData
Type:  System Byte
An array of unsigned 8-bit integers. This array must be filled with data to be sent to a slave during the function execution.
writeOffset
Type: System Int32
Data offset.
size
Type: System Int32
The size of the message buffer. This parameter is specified in bytes. The maximum value is 256 bytes.
Return Value
Type:  Byte
Returns read data.
See Also
Reference
Port Class
ReadWrite Overload
Dln.SpiMaster Namespace


Port.ReleaseSS Method

Port ReleaseSS Method dln.net.dll

[Missing <summary> documentation for "M:Dln.SpiMaster.Port.ReleaseSS"]

Namespace: Dln.SpiMaster
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public void ReleaseSS()
public void ReleaseSS()
Public Sub ReleaseSS
Public Sub ReleaseSS
public:
void ReleaseSS()
public:
void ReleaseSS()
See Also
Reference
Port Class
Dln.SpiMaster Namespace


Port.Write Method

Port Write Method dln.net.dll
Overload List
 | Name | Description
Public method | Write( Byte ) |
Public method | Write( Byte , Int32, Int32) | Sends and receives data via SPI bus. The data i received as an array of 1-byte elements. This function is suited to transmit data frames of 8 bits or less.
Top
See Also

Reference

Port Class
Dln.SpiMaster Namespace


Port.Write Method (Byte[])

Port Write Method ( Byte ) dln.net.dll

[Missing <summary> documentation for "M:Dln.SpiMaster.Port.Write(System.Byte[])"]

Namespace: Dln.SpiMaster
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public void Write(
    byte[] writeData
)
public void Write(
    byte[] writeData
)
Public Sub Write (
    writeData As Byte()
)
Public Sub Write (
    writeData As Byte()
)
public:
void Write(
    array<unsigned char>^ writeData
)
public:
void Write(
    array<unsigned char>^ writeData
)
Parameters
writeData
Type:  System Byte
[Missing <param name="writeData"/> documentation for "M:Dln.SpiMaster.Port.Write(System.Byte[])"]
See Also
Reference
Port Class
Write Overload
Dln.SpiMaster Namespace


Port.Write Method (Byte[], Int32, Int32)

Port Write Method ( Byte , Int32, Int32) dln.net.dll
Sends and receives data via SPI bus. The data i received as an array of 1-byte elements. This function is suited to transmit data frames of 8 bits or less.

Namespace: Dln.SpiMaster
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public void Write(
    byte[] writeData,
    int writeOffset,
    int size
)
public void Write(
    byte[] writeData,
    int writeOffset,
    int size
)
Public Sub Write (
    writeData As Byte(),
    writeOffset As Integer,
    size As Integer
)
Public Sub Write (
    writeData As Byte(),
    writeOffset As Integer,
    size As Integer
)
public:
void Write(
    array<unsigned char>^ writeData,
    int writeOffset,
    int size
)
public:
void Write(
    array<unsigned char>^ writeData,
    int writeOffset,
    int size
)
Parameters
writeData
Type:  System Byte
An array of unsigned 8-bit integers. This array must be filled with data to be sent to a slave during the function execution.
writeOffset
Type: System Int32
Write data offset
size
Type: System Int32
The size of the message buffer. This parameter is specified in bytes. The maximum value is 256 bytes.
See Also
Reference
Port Class
Write Overload
Dln.SpiMaster Namespace


Port Properties

Port Properties dln.net.dll

The Port type exposes the following members.

Properties
 | Name | Description
Public property | Cpha | Sets of gets the clock phase value. Leave property blank to get current value.
Public property | CphaValues | Retrieves the availalbe CPHA values.
Public property | Cpol | Sets or gets the clock polarity value. Leave property blank to get current value.
Public property | CpolValues | Retrieves CPOL values.
Public property | DelayAfterSS | Sets and gets a delay duration between assertion of an SS line and first data frame. Leave property blank to get current value.
Public property | DelayBetweenFrames | Sets or gets a delay between data frames exchanged with a single slave device. Leave property blank to get current value.
Public property | DelayBetweenSS | Sets or gets a minimum delay between release of an SS line and assertion of another SS line. Leave property blank to get current value.
Public property | Enabled | Activates corresponding SPI master port on your DLN-series adapter. Leave property blank to get current value.
Public property | FrameSize | Sets the size of a single SPI data frame. Leave property blank to get current value.
Public property | FrameSizeValues | Retrieves all available frame size values.
Public property | Frequency | Sets the clock frequency on the SCLK line, used to synchronize data transfer between master and slave devices. Leave property blank to get current value.
Public property | MaxDelayAfterSS | Retrieves the maximum valid delay after SS value
Public property | MaxDelayBetweenFrames | Retrieves the maximum valid delay between frames value
Public property | MaxDelayBetweenSS | Retrieves the maximum valid delay between SS value
Public property | MaxFrequency | Retrieves the maximum valid frequency value
Public property | MinDelayAfterSS | Retrieves the minimum valid delay after SS value
Public property | MinDelayBetweenFrames | Retrieves the minimum valid delay between frames value
Public property | MinDelayBetweenSS | Retrieves the minimum valid delay between SS value
Public property | MinFrequency | Retrieves the minimum valid frequency value
Public property | Mode | Sets SPI transmission parameters (CPOL and CPHA). Leave property blank to get current value.
Public property | ModeValues | Retrieves all supported spi master modes.
Public property | ReleaseSSBetweenFrames | Releases the slave select line between frames. Leave property blank to get current value.
Public property | Restrictions |
Public property | SS | Selects a Slave Select (SS) line. Leave property blank to get current value.
Public property | SSCount | Retrieves the total number of SS lines.
Public property | SSEnabled | Sets SS lines status by using mask. Leave property blank to get current value.
Top
See Also

Reference

Port Class
Dln.SpiMaster Namespace


Port.Cpha Property

Port Cpha Property dln.net.dll
Sets of gets the clock phase value. Leave property blank to get current value.

Namespace: Dln.SpiMaster
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public int Cpha { get; set; }
public int Cpha { get; set; }
Public Property Cpha As Integer
    Get
    Set
Public Property Cpha As Integer
    Get
    Set
public:
property int Cpha {
    int get ();
    void set (int value);
}
public:
property int Cpha {
    int get ();
    void set (int value);
}
Property Value
Type: Int32
See Also
Reference
Port Class
Dln.SpiMaster Namespace


Port.CphaValues Property

Port CphaValues Property dln.net.dll
Retrieves the availalbe CPHA values.

Namespace: Dln.SpiMaster
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public ReadOnlyCollection<int> CphaValues { get; }
public ReadOnlyCollection<int> CphaValues { get; }
Public ReadOnly Property CphaValues As ReadOnlyCollection(Of Integer)
    Get
Public ReadOnly Property CphaValues As ReadOnlyCollection(Of Integer)
    Get
public:
property ReadOnlyCollection<int>^ CphaValues {
    ReadOnlyCollection<int>^ get ();
}
public:
property ReadOnlyCollection<int>^ CphaValues {
    ReadOnlyCollection<int>^ get ();
}
Property Value
Type: ReadOnlyCollection  Int32
See Also
Reference
Port Class
Dln.SpiMaster Namespace


Port.Cpol Property

Port Cpol Property dln.net.dll
Sets or gets the clock polarity value. Leave property blank to get current value.

Namespace: Dln.SpiMaster
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public int Cpol { get; set; }
public int Cpol { get; set; }
Public Property Cpol As Integer
    Get
    Set
Public Property Cpol As Integer
    Get
    Set
public:
property int Cpol {
    int get ();
    void set (int value);
}
public:
property int Cpol {
    int get ();
    void set (int value);
}
Property Value
Type: Int32
See Also
Reference
Port Class
Dln.SpiMaster Namespace


Port.CpolValues Property

Port CpolValues Property dln.net.dll
Retrieves CPOL values.

Namespace: Dln.SpiMaster
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public ReadOnlyCollection<int> CpolValues { get; }
public ReadOnlyCollection<int> CpolValues { get; }
Public ReadOnly Property CpolValues As ReadOnlyCollection(Of Integer)
    Get
Public ReadOnly Property CpolValues As ReadOnlyCollection(Of Integer)
    Get
public:
property ReadOnlyCollection<int>^ CpolValues {
    ReadOnlyCollection<int>^ get ();
}
public:
property ReadOnlyCollection<int>^ CpolValues {
    ReadOnlyCollection<int>^ get ();
}
Property Value
Type: ReadOnlyCollection  Int32
See Also
Reference
Port Class
Dln.SpiMaster Namespace


Port.DelayAfterSS Property

Port DelayAfterSS Property dln.net.dll
Sets and gets a delay duration between assertion of an SS line and first data frame. Leave property blank to get current value.

Namespace: Dln.SpiMaster
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public int DelayAfterSS { get; set; }
public int DelayAfterSS { get; set; }
Public Property DelayAfterSS As Integer
    Get
    Set
Public Property DelayAfterSS As Integer
    Get
    Set
public:
property int DelayAfterSS {
    int get ();
    void set (int value);
}
public:
property int DelayAfterSS {
    int get ();
    void set (int value);
}
Property Value
Type: Int32
See Also
Reference
Port Class
Dln.SpiMaster Namespace


Port.DelayBetweenFrames Property

Port DelayBetweenFrames Property dln.net.dll
Sets or gets a delay between data frames exchanged with a single slave device. Leave property blank to get current value.

Namespace: Dln.SpiMaster
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public int DelayBetweenFrames { get; set; }
public int DelayBetweenFrames { get; set; }
Public Property DelayBetweenFrames As Integer
    Get
    Set
Public Property DelayBetweenFrames As Integer
    Get
    Set
public:
property int DelayBetweenFrames {
    int get ();
    void set (int value);
}
public:
property int DelayBetweenFrames {
    int get ();
    void set (int value);
}
Property Value
Type: Int32
See Also
Reference
Port Class
Dln.SpiMaster Namespace


Port.DelayBetweenSS Property

Port DelayBetweenSS Property dln.net.dll
Sets or gets a minimum delay between release of an SS line and assertion of another SS line. Leave property blank to get current value.

Namespace: Dln.SpiMaster
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public int DelayBetweenSS { get; set; }
public int DelayBetweenSS { get; set; }
Public Property DelayBetweenSS As Integer
    Get
    Set
Public Property DelayBetweenSS As Integer
    Get
    Set
public:
property int DelayBetweenSS {
    int get ();
    void set (int value);
}
public:
property int DelayBetweenSS {
    int get ();
    void set (int value);
}
Property Value
Type: Int32
See Also
Reference
Port Class
Dln.SpiMaster Namespace


Port.Enabled Property

Port Enabled Property dln.net.dll
Activates corresponding SPI master port on your DLN-series adapter. Leave property blank to get current value.

Namespace: Dln.SpiMaster
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public bool Enabled { get; set; }
public bool Enabled { get; set; }
Public Property Enabled As Boolean
    Get
    Set
Public Property Enabled As Boolean
    Get
    Set
public:
property bool Enabled {
    bool get ();
    void set (bool value);
}
public:
property bool Enabled {
    bool get ();
    void set (bool value);
}
Property Value
Type: Boolean
See Also
Reference
Port Class
Dln.SpiMaster Namespace


Port.FrameSize Property

Port FrameSize Property dln.net.dll
Sets the size of a single SPI data frame. Leave property blank to get current value.

Namespace: Dln.SpiMaster
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public int FrameSize { get; set; }
public int FrameSize { get; set; }
Public Property FrameSize As Integer
    Get
    Set
Public Property FrameSize As Integer
    Get
    Set
public:
property int FrameSize {
    int get ();
    void set (int value);
}
public:
property int FrameSize {
    int get ();
    void set (int value);
}
Property Value
Type: Int32
See Also
Reference
Port Class
Dln.SpiMaster Namespace


Port.FrameSizeValues Property

Port FrameSizeValues Property dln.net.dll
Retrieves all available frame size values.

Namespace: Dln.SpiMaster
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public ReadOnlyCollection<int> FrameSizeValues { get; }
public ReadOnlyCollection<int> FrameSizeValues { get; }
Public ReadOnly Property FrameSizeValues As ReadOnlyCollection(Of Integer)
    Get
Public ReadOnly Property FrameSizeValues As ReadOnlyCollection(Of Integer)
    Get
public:
property ReadOnlyCollection<int>^ FrameSizeValues {
    ReadOnlyCollection<int>^ get ();
}
public:
property ReadOnlyCollection<int>^ FrameSizeValues {
    ReadOnlyCollection<int>^ get ();
}
Property Value
Type: ReadOnlyCollection  Int32
See Also
Reference
Port Class
Dln.SpiMaster Namespace


Port.Frequency Property

Port Frequency Property dln.net.dll
Sets the clock frequency on the SCLK line, used to synchronize data transfer between master and slave devices. Leave property blank to get current value.

Namespace: Dln.SpiMaster
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public int Frequency { get; set; }
public int Frequency { get; set; }
Public Property Frequency As Integer
    Get
    Set
Public Property Frequency As Integer
    Get
    Set
public:
property int Frequency {
    int get ();
    void set (int value);
}
public:
property int Frequency {
    int get ();
    void set (int value);
}
Property Value
Type: Int32
See Also
Reference
Port Class
Dln.SpiMaster Namespace


Port.MaxDelayAfterSS Property

Port MaxDelayAfterSS Property dln.net.dll
Retrieves the maximum valid delay after SS value

Namespace: Dln.SpiMaster
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public int MaxDelayAfterSS { get; }
public int MaxDelayAfterSS { get; }
Public ReadOnly Property MaxDelayAfterSS As Integer
    Get
Public ReadOnly Property MaxDelayAfterSS As Integer
    Get
public:
property int MaxDelayAfterSS {
    int get ();
}
public:
property int MaxDelayAfterSS {
    int get ();
}
Property Value
Type: Int32
See Also
Reference
Port Class
Dln.SpiMaster Namespace


Port.MaxDelayBetweenFrames Property

Port MaxDelayBetweenFrames Property dln.net.dll
Retrieves the maximum valid delay between frames value

Namespace: Dln.SpiMaster
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public int MaxDelayBetweenFrames { get; }
public int MaxDelayBetweenFrames { get; }
Public ReadOnly Property MaxDelayBetweenFrames As Integer
    Get
Public ReadOnly Property MaxDelayBetweenFrames As Integer
    Get
public:
property int MaxDelayBetweenFrames {
    int get ();
}
public:
property int MaxDelayBetweenFrames {
    int get ();
}
Property Value
Type: Int32
See Also
Reference
Port Class
Dln.SpiMaster Namespace


Port.MaxDelayBetweenSS Property

Port MaxDelayBetweenSS Property dln.net.dll
Retrieves the maximum valid delay between SS value

Namespace: Dln.SpiMaster
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public int MaxDelayBetweenSS { get; }
public int MaxDelayBetweenSS { get; }
Public ReadOnly Property MaxDelayBetweenSS As Integer
    Get
Public ReadOnly Property MaxDelayBetweenSS As Integer
    Get
public:
property int MaxDelayBetweenSS {
    int get ();
}
public:
property int MaxDelayBetweenSS {
    int get ();
}
Property Value
Type: Int32
See Also
Reference
Port Class
Dln.SpiMaster Namespace


Port.MaxFrequency Property

Port MaxFrequency Property dln.net.dll
Retrieves the maximum valid frequency value

Namespace: Dln.SpiMaster
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public int MaxFrequency { get; }
public int MaxFrequency { get; }
Public ReadOnly Property MaxFrequency As Integer
    Get
Public ReadOnly Property MaxFrequency As Integer
    Get
public:
property int MaxFrequency {
    int get ();
}
public:
property int MaxFrequency {
    int get ();
}
Property Value
Type: Int32
See Also
Reference
Port Class
Dln.SpiMaster Namespace


Port.MinDelayAfterSS Property

Port MinDelayAfterSS Property dln.net.dll
Retrieves the minimum valid delay after SS value

Namespace: Dln.SpiMaster
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public int MinDelayAfterSS { get; }
public int MinDelayAfterSS { get; }
Public ReadOnly Property MinDelayAfterSS As Integer
    Get
Public ReadOnly Property MinDelayAfterSS As Integer
    Get
public:
property int MinDelayAfterSS {
    int get ();
}
public:
property int MinDelayAfterSS {
    int get ();
}
Property Value
Type: Int32
See Also
Reference
Port Class
Dln.SpiMaster Namespace


Port.MinDelayBetweenFrames Property

Port MinDelayBetweenFrames Property dln.net.dll
Retrieves the minimum valid delay between frames value

Namespace: Dln.SpiMaster
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public int MinDelayBetweenFrames { get; }
public int MinDelayBetweenFrames { get; }
Public ReadOnly Property MinDelayBetweenFrames As Integer
    Get
Public ReadOnly Property MinDelayBetweenFrames As Integer
    Get
public:
property int MinDelayBetweenFrames {
    int get ();
}
public:
property int MinDelayBetweenFrames {
    int get ();
}
Property Value
Type: Int32
See Also
Reference
Port Class
Dln.SpiMaster Namespace


Port.MinDelayBetweenSS Property

Port MinDelayBetweenSS Property dln.net.dll
Retrieves the minimum valid delay between SS value

Namespace: Dln.SpiMaster
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public int MinDelayBetweenSS { get; }
public int MinDelayBetweenSS { get; }
Public ReadOnly Property MinDelayBetweenSS As Integer
    Get
Public ReadOnly Property MinDelayBetweenSS As Integer
    Get
public:
property int MinDelayBetweenSS {
    int get ();
}
public:
property int MinDelayBetweenSS {
    int get ();
}
Property Value
Type: Int32
See Also
Reference
Port Class
Dln.SpiMaster Namespace


Port.MinFrequency Property

Port MinFrequency Property dln.net.dll
Retrieves the minimum valid frequency value

Namespace: Dln.SpiMaster
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public int MinFrequency { get; }
public int MinFrequency { get; }
Public ReadOnly Property MinFrequency As Integer
    Get
Public ReadOnly Property MinFrequency As Integer
    Get
public:
property int MinFrequency {
    int get ();
}
public:
property int MinFrequency {
    int get ();
}
Property Value
Type: Int32
See Also
Reference
Port Class
Dln.SpiMaster Namespace


Port.Mode Property

Port Mode Property dln.net.dll
Sets SPI transmission parameters (CPOL and CPHA). Leave property blank to get current value.

Namespace: Dln.SpiMaster
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public int Mode { get; set; }
public int Mode { get; set; }
Public Property Mode As Integer
    Get
    Set
Public Property Mode As Integer
    Get
    Set
public:
property int Mode {
    int get ();
    void set (int value);
}
public:
property int Mode {
    int get ();
    void set (int value);
}
Property Value
Type: Int32
See Also
Reference
Port Class
Dln.SpiMaster Namespace


Port.ModeValues Property

Port ModeValues Property dln.net.dll
Retrieves all supported spi master modes.

Namespace: Dln.SpiMaster
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public ReadOnlyCollection<int> ModeValues { get; }
public ReadOnlyCollection<int> ModeValues { get; }
Public ReadOnly Property ModeValues As ReadOnlyCollection(Of Integer)
    Get
Public ReadOnly Property ModeValues As ReadOnlyCollection(Of Integer)
    Get
public:
property ReadOnlyCollection<int>^ ModeValues {
    ReadOnlyCollection<int>^ get ();
}
public:
property ReadOnlyCollection<int>^ ModeValues {
    ReadOnlyCollection<int>^ get ();
}
Property Value
Type: ReadOnlyCollection  Int32
See Also
Reference
Port Class
Dln.SpiMaster Namespace


Port.ReleaseSSBetweenFrames Property

Port ReleaseSSBetweenFrames Property dln.net.dll
Releases the slave select line between frames. Leave property blank to get current value.

Namespace: Dln.SpiMaster
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public bool ReleaseSSBetweenFrames { get; set; }
public bool ReleaseSSBetweenFrames { get; set; }
Public Property ReleaseSSBetweenFrames As Boolean
    Get
    Set
Public Property ReleaseSSBetweenFrames As Boolean
    Get
    Set
public:
property bool ReleaseSSBetweenFrames {
    bool get ();
    void set (bool value);
}
public:
property bool ReleaseSSBetweenFrames {
    bool get ();
    void set (bool value);
}
Property Value
Type: Boolean
See Also
Reference
Port Class
Dln.SpiMaster Namespace


Port.Restrictions Property

Port Restrictions Property dln.net.dll

[Missing <summary> documentation for "P:Dln.SpiMaster.Port.Restrictions"]

Namespace: Dln.SpiMaster
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public PortRestrictions Restrictions { get; }
public PortRestrictions Restrictions { get; }
Public ReadOnly Property Restrictions As PortRestrictions
    Get
Public ReadOnly Property Restrictions As PortRestrictions
    Get
public:
property PortRestrictions^ Restrictions {
    PortRestrictions^ get ();
}
public:
property PortRestrictions^ Restrictions {
    PortRestrictions^ get ();
}
Property Value
Type: PortRestrictions
See Also
Reference
Port Class
Dln.SpiMaster Namespace


Port.SS Property

Port SS Property dln.net.dll
Selects a Slave Select (SS) line. Leave property blank to get current value.

Namespace: Dln.SpiMaster
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public int SS { get; set; }
public int SS { get; set; }
Public Property SS As Integer
    Get
    Set
Public Property SS As Integer
    Get
    Set
public:
property int SS {
    int get ();
    void set (int value);
}
public:
property int SS {
    int get ();
    void set (int value);
}
Property Value
Type: Int32
See Also
Reference
Port Class
Dln.SpiMaster Namespace


Port.SSCount Property

Port SSCount Property dln.net.dll
Retrieves the total number of SS lines.

Namespace: Dln.SpiMaster
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public int SSCount { get; }
public int SSCount { get; }
Public ReadOnly Property SSCount As Integer
    Get
Public ReadOnly Property SSCount As Integer
    Get
public:
property int SSCount {
    int get ();
}
public:
property int SSCount {
    int get ();
}
Property Value
Type: Int32
See Also
Reference
Port Class
Dln.SpiMaster Namespace


Port.SSEnabled Property

Port SSEnabled Property dln.net.dll
Sets SS lines status by using mask. Leave property blank to get current value.

Namespace: Dln.SpiMaster
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public int SSEnabled { get; set; }
public int SSEnabled { get; set; }
Public Property SSEnabled As Integer
    Get
    Set
Public Property SSEnabled As Integer
    Get
    Set
public:
property int SSEnabled {
    int get ();
    void set (int value);
}
public:
property int SSEnabled {
    int get ();
    void set (int value);
}
Property Value
Type: Int32
See Also
Reference
Port Class
Dln.SpiMaster Namespace


PortRestrictions Class

PortRestrictions Class dln.net.dll

[Missing <summary> documentation for "T:Dln.SpiMaster.PortRestrictions"]

Inheritance Hierarchy
System Object
Dln.SpiMaster PortRestrictions

Namespace: Dln.SpiMaster
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public class PortRestrictions
public class PortRestrictions
Public Class PortRestrictions
Public Class PortRestrictions
public ref class PortRestrictions
public ref class PortRestrictions
The PortRestrictions type exposes the following members.
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Cpha |
Public property | CphaValues |
Public property | Cpol |
Public property | CpolValues |
Public property | DelayAfterSS |
Public property | DelayBetweenFrames |
Public property | DelayBetweenSS |
Public property | Enabled |
Public property | FrameSize |
Public property | FrameSizeValues |
Public property | Frequency |
Public property | MaxDelayAfterSS |
Public property | MaxDelayBetweenFrames |
Public property | MaxDelayBetweenSS |
Public property | MaxFrequency |
Public property | MinDelayAfterSS |
Public property | MinDelayBetweenFrames |
Public property | MinDelayBetweenSS |
Public property | MinFrequency |
Public property | Mode |
Public property | ModeValues |
Public property | Read |
Public property | ReadWrite |
Public property | ReleaseSS |
Public property | ReleaseSSBetweenFrames |
Public property | SS |
Public property | SSCount |
Public property | SSEnabled |
Public property | Write |
Top
See Also
Reference
Dln.SpiMaster Namespace


PortRestrictions Methods

PortRestrictions Methods dln.net.dll

The PortRestrictions type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PortRestrictions Class
Dln.SpiMaster Namespace


PortRestrictions Properties

PortRestrictions Properties dln.net.dll

The PortRestrictions type exposes the following members.

Properties
 | Name | Description
Public property | Cpha |
Public property | CphaValues |
Public property | Cpol |
Public property | CpolValues |
Public property | DelayAfterSS |
Public property | DelayBetweenFrames |
Public property | DelayBetweenSS |
Public property | Enabled |
Public property | FrameSize |
Public property | FrameSizeValues |
Public property | Frequency |
Public property | MaxDelayAfterSS |
Public property | MaxDelayBetweenFrames |
Public property | MaxDelayBetweenSS |
Public property | MaxFrequency |
Public property | MinDelayAfterSS |
Public property | MinDelayBetweenFrames |
Public property | MinDelayBetweenSS |
Public property | MinFrequency |
Public property | Mode |
Public property | ModeValues |
Public property | Read |
Public property | ReadWrite |
Public property | ReleaseSS |
Public property | ReleaseSSBetweenFrames |
Public property | SS |
Public property | SSCount |
Public property | SSEnabled |
Public property | Write |
Top
See Also

Reference

PortRestrictions Class
Dln.SpiMaster Namespace


PortRestrictions.Cpha Property

PortRestrictions Cpha Property dln.net.dll

[Missing <summary> documentation for "P:Dln.SpiMaster.PortRestrictions.Cpha"]

Namespace: Dln.SpiMaster
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public Restriction Cpha { get; }
public Restriction Cpha { get; }
Public ReadOnly Property Cpha As Restriction
    Get
Public ReadOnly Property Cpha As Restriction
    Get
public:
property Restriction Cpha {
    Restriction get ();
}
public:
property Restriction Cpha {
    Restriction get ();
}
Property Value
Type: Restriction
See Also
Reference
PortRestrictions Class
Dln.SpiMaster Namespace


PortRestrictions.CphaValues Property

PortRestrictions CphaValues Property dln.net.dll

[Missing <summary> documentation for "P:Dln.SpiMaster.PortRestrictions.CphaValues"]

Namespace: Dln.SpiMaster
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public Restriction CphaValues { get; }
public Restriction CphaValues { get; }
Public ReadOnly Property CphaValues As Restriction
    Get
Public ReadOnly Property CphaValues As Restriction
    Get
public:
property Restriction CphaValues {
    Restriction get ();
}
public:
property Restriction CphaValues {
    Restriction get ();
}
Property Value
Type: Restriction
See Also
Reference
PortRestrictions Class
Dln.SpiMaster Namespace


PortRestrictions.Cpol Property

PortRestrictions Cpol Property dln.net.dll

[Missing <summary> documentation for "P:Dln.SpiMaster.PortRestrictions.Cpol"]

Namespace: Dln.SpiMaster
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public Restriction Cpol { get; }
public Restriction Cpol { get; }
Public ReadOnly Property Cpol As Restriction
    Get
Public ReadOnly Property Cpol As Restriction
    Get
public:
property Restriction Cpol {
    Restriction get ();
}
public:
property Restriction Cpol {
    Restriction get ();
}
Property Value
Type: Restriction
See Also
Reference
PortRestrictions Class
Dln.SpiMaster Namespace


PortRestrictions.CpolValues Property

PortRestrictions CpolValues Property dln.net.dll

[Missing <summary> documentation for "P:Dln.SpiMaster.PortRestrictions.CpolValues"]

Namespace: Dln.SpiMaster
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public Restriction CpolValues { get; }
public Restriction CpolValues { get; }
Public ReadOnly Property CpolValues As Restriction
    Get
Public ReadOnly Property CpolValues As Restriction
    Get
public:
property Restriction CpolValues {
    Restriction get ();
}
public:
property Restriction CpolValues {
    Restriction get ();
}
Property Value
Type: Restriction
See Also
Reference
PortRestrictions Class
Dln.SpiMaster Namespace


PortRestrictions.DelayAfterSS Property

PortRestrictions DelayAfterSS Property dln.net.dll

[Missing <summary> documentation for "P:Dln.SpiMaster.PortRestrictions.DelayAfterSS"]

Namespace: Dln.SpiMaster
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public Restriction DelayAfterSS { get; }
public Restriction DelayAfterSS { get; }
Public ReadOnly Property DelayAfterSS As Restriction
    Get
Public ReadOnly Property DelayAfterSS As Restriction
    Get
public:
property Restriction DelayAfterSS {
    Restriction get ();
}
public:
property Restriction DelayAfterSS {
    Restriction get ();
}
Property Value
Type: Restriction
See Also
Reference
PortRestrictions Class
Dln.SpiMaster Namespace


PortRestrictions.DelayBetweenFrames Property

PortRestrictions DelayBetweenFrames Property dln.net.dll

[Missing <summary> documentation for "P:Dln.SpiMaster.PortRestrictions.DelayBetweenFrames"]

Namespace: Dln.SpiMaster
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public Restriction DelayBetweenFrames { get; }
public Restriction DelayBetweenFrames { get; }
Public ReadOnly Property DelayBetweenFrames As Restriction
    Get
Public ReadOnly Property DelayBetweenFrames As Restriction
    Get
public:
property Restriction DelayBetweenFrames {
    Restriction get ();
}
public:
property Restriction DelayBetweenFrames {
    Restriction get ();
}
Property Value
Type: Restriction
See Also
Reference
PortRestrictions Class
Dln.SpiMaster Namespace


PortRestrictions.DelayBetweenSS Property

PortRestrictions DelayBetweenSS Property dln.net.dll

[Missing <summary> documentation for "P:Dln.SpiMaster.PortRestrictions.DelayBetweenSS"]

Namespace: Dln.SpiMaster
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public Restriction DelayBetweenSS { get; }
public Restriction DelayBetweenSS { get; }
Public ReadOnly Property DelayBetweenSS As Restriction
    Get
Public ReadOnly Property DelayBetweenSS As Restriction
    Get
public:
property Restriction DelayBetweenSS {
    Restriction get ();
}
public:
property Restriction DelayBetweenSS {
    Restriction get ();
}
Property Value
Type: Restriction
See Also
Reference
PortRestrictions Class
Dln.SpiMaster Namespace


PortRestrictions.Enabled Property

PortRestrictions Enabled Property dln.net.dll

[Missing <summary> documentation for "P:Dln.SpiMaster.PortRestrictions.Enabled"]

Namespace: Dln.SpiMaster
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public Restriction Enabled { get; }
public Restriction Enabled { get; }
Public ReadOnly Property Enabled As Restriction
    Get
Public ReadOnly Property Enabled As Restriction
    Get
public:
property Restriction Enabled {
    Restriction get ();
}
public:
property Restriction Enabled {
    Restriction get ();
}
Property Value
Type: Restriction
See Also
Reference
PortRestrictions Class
Dln.SpiMaster Namespace


PortRestrictions.FrameSize Property

PortRestrictions FrameSize Property dln.net.dll

[Missing <summary> documentation for "P:Dln.SpiMaster.PortRestrictions.FrameSize"]

Namespace: Dln.SpiMaster
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public Restriction FrameSize { get; }
public Restriction FrameSize { get; }
Public ReadOnly Property FrameSize As Restriction
    Get
Public ReadOnly Property FrameSize As Restriction
    Get
public:
property Restriction FrameSize {
    Restriction get ();
}
public:
property Restriction FrameSize {
    Restriction get ();
}
Property Value
Type: Restriction
See Also
Reference
PortRestrictions Class
Dln.SpiMaster Namespace


PortRestrictions.FrameSizeValues Property

PortRestrictions FrameSizeValues Property dln.net.dll

[Missing <summary> documentation for "P:Dln.SpiMaster.PortRestrictions.FrameSizeValues"]

Namespace: Dln.SpiMaster
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public Restriction FrameSizeValues { get; }
public Restriction FrameSizeValues { get; }
Public ReadOnly Property FrameSizeValues As Restriction
    Get
Public ReadOnly Property FrameSizeValues As Restriction
    Get
public:
property Restriction FrameSizeValues {
    Restriction get ();
}
public:
property Restriction FrameSizeValues {
    Restriction get ();
}
Property Value
Type: Restriction
See Also
Reference
PortRestrictions Class
Dln.SpiMaster Namespace


PortRestrictions.Frequency Property

PortRestrictions Frequency Property dln.net.dll

[Missing <summary> documentation for "P:Dln.SpiMaster.PortRestrictions.Frequency"]

Namespace: Dln.SpiMaster
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public Restriction Frequency { get; }
public Restriction Frequency { get; }
Public ReadOnly Property Frequency As Restriction
    Get
Public ReadOnly Property Frequency As Restriction
    Get
public:
property Restriction Frequency {
    Restriction get ();
}
public:
property Restriction Frequency {
    Restriction get ();
}
Property Value
Type: Restriction
See Also
Reference
PortRestrictions Class
Dln.SpiMaster Namespace


PortRestrictions.MaxDelayAfterSS Property

PortRestrictions MaxDelayAfterSS Property dln.net.dll

[Missing <summary> documentation for "P:Dln.SpiMaster.PortRestrictions.MaxDelayAfterSS"]

Namespace: Dln.SpiMaster
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public Restriction MaxDelayAfterSS { get; }
public Restriction MaxDelayAfterSS { get; }
Public ReadOnly Property MaxDelayAfterSS As Restriction
    Get
Public ReadOnly Property MaxDelayAfterSS As Restriction
    Get
public:
property Restriction MaxDelayAfterSS {
    Restriction get ();
}
public:
property Restriction MaxDelayAfterSS {
    Restriction get ();
}
Property Value
Type: Restriction
See Also
Reference
PortRestrictions Class
Dln.SpiMaster Namespace


PortRestrictions.MaxDelayBetweenFrames Property

PortRestrictions MaxDelayBetweenFrames Property dln.net.dll

[Missing <summary> documentation for "P:Dln.SpiMaster.PortRestrictions.MaxDelayBetweenFrames"]

Namespace: Dln.SpiMaster
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public Restriction MaxDelayBetweenFrames { get; }
public Restriction MaxDelayBetweenFrames { get; }
Public ReadOnly Property MaxDelayBetweenFrames As Restriction
    Get
Public ReadOnly Property MaxDelayBetweenFrames As Restriction
    Get
public:
property Restriction MaxDelayBetweenFrames {
    Restriction get ();
}
public:
property Restriction MaxDelayBetweenFrames {
    Restriction get ();
}
Property Value
Type: Restriction
See Also
Reference
PortRestrictions Class
Dln.SpiMaster Namespace


PortRestrictions.MaxDelayBetweenSS Property

PortRestrictions MaxDelayBetweenSS Property dln.net.dll

[Missing <summary> documentation for "P:Dln.SpiMaster.PortRestrictions.MaxDelayBetweenSS"]

Namespace: Dln.SpiMaster
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public Restriction MaxDelayBetweenSS { get; }
public Restriction MaxDelayBetweenSS { get; }
Public ReadOnly Property MaxDelayBetweenSS As Restriction
    Get
Public ReadOnly Property MaxDelayBetweenSS As Restriction
    Get
public:
property Restriction MaxDelayBetweenSS {
    Restriction get ();
}
public:
property Restriction MaxDelayBetweenSS {
    Restriction get ();
}
Property Value
Type: Restriction
See Also
Reference
PortRestrictions Class
Dln.SpiMaster Namespace


PortRestrictions.MaxFrequency Property

PortRestrictions MaxFrequency Property dln.net.dll

[Missing <summary> documentation for "P:Dln.SpiMaster.PortRestrictions.MaxFrequency"]

Namespace: Dln.SpiMaster
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public Restriction MaxFrequency { get; }
public Restriction MaxFrequency { get; }
Public ReadOnly Property MaxFrequency As Restriction
    Get
Public ReadOnly Property MaxFrequency As Restriction
    Get
public:
property Restriction MaxFrequency {
    Restriction get ();
}
public:
property Restriction MaxFrequency {
    Restriction get ();
}
Property Value
Type: Restriction
See Also
Reference
PortRestrictions Class
Dln.SpiMaster Namespace


PortRestrictions.MinDelayAfterSS Property

PortRestrictions MinDelayAfterSS Property dln.net.dll

[Missing <summary> documentation for "P:Dln.SpiMaster.PortRestrictions.MinDelayAfterSS"]

Namespace: Dln.SpiMaster
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public Restriction MinDelayAfterSS { get; }
public Restriction MinDelayAfterSS { get; }
Public ReadOnly Property MinDelayAfterSS As Restriction
    Get
Public ReadOnly Property MinDelayAfterSS As Restriction
    Get
public:
property Restriction MinDelayAfterSS {
    Restriction get ();
}
public:
property Restriction MinDelayAfterSS {
    Restriction get ();
}
Property Value
Type: Restriction
See Also
Reference
PortRestrictions Class
Dln.SpiMaster Namespace


PortRestrictions.MinDelayBetweenFrames Property

PortRestrictions MinDelayBetweenFrames Property dln.net.dll

[Missing <summary> documentation for "P:Dln.SpiMaster.PortRestrictions.MinDelayBetweenFrames"]

Namespace: Dln.SpiMaster
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public Restriction MinDelayBetweenFrames { get; }
public Restriction MinDelayBetweenFrames { get; }
Public ReadOnly Property MinDelayBetweenFrames As Restriction
    Get
Public ReadOnly Property MinDelayBetweenFrames As Restriction
    Get
public:
property Restriction MinDelayBetweenFrames {
    Restriction get ();
}
public:
property Restriction MinDelayBetweenFrames {
    Restriction get ();
}
Property Value
Type: Restriction
See Also
Reference
PortRestrictions Class
Dln.SpiMaster Namespace


PortRestrictions.MinDelayBetweenSS Property

PortRestrictions MinDelayBetweenSS Property dln.net.dll

[Missing <summary> documentation for "P:Dln.SpiMaster.PortRestrictions.MinDelayBetweenSS"]

Namespace: Dln.SpiMaster
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public Restriction MinDelayBetweenSS { get; }
public Restriction MinDelayBetweenSS { get; }
Public ReadOnly Property MinDelayBetweenSS As Restriction
    Get
Public ReadOnly Property MinDelayBetweenSS As Restriction
    Get
public:
property Restriction MinDelayBetweenSS {
    Restriction get ();
}
public:
property Restriction MinDelayBetweenSS {
    Restriction get ();
}
Property Value
Type: Restriction
See Also
Reference
PortRestrictions Class
Dln.SpiMaster Namespace


PortRestrictions.MinFrequency Property

PortRestrictions MinFrequency Property dln.net.dll

[Missing <summary> documentation for "P:Dln.SpiMaster.PortRestrictions.MinFrequency"]

Namespace: Dln.SpiMaster
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public Restriction MinFrequency { get; }
public Restriction MinFrequency { get; }
Public ReadOnly Property MinFrequency As Restriction
    Get
Public ReadOnly Property MinFrequency As Restriction
    Get
public:
property Restriction MinFrequency {
    Restriction get ();
}
public:
property Restriction MinFrequency {
    Restriction get ();
}
Property Value
Type: Restriction
See Also
Reference
PortRestrictions Class
Dln.SpiMaster Namespace


PortRestrictions.Mode Property

PortRestrictions Mode Property dln.net.dll

[Missing <summary> documentation for "P:Dln.SpiMaster.PortRestrictions.Mode"]

Namespace: Dln.SpiMaster
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public Restriction Mode { get; }
public Restriction Mode { get; }
Public ReadOnly Property Mode As Restriction
    Get
Public ReadOnly Property Mode As Restriction
    Get
public:
property Restriction Mode {
    Restriction get ();
}
public:
property Restriction Mode {
    Restriction get ();
}
Property Value
Type: Restriction
See Also
Reference
PortRestrictions Class
Dln.SpiMaster Namespace


PortRestrictions.ModeValues Property

PortRestrictions ModeValues Property dln.net.dll

[Missing <summary> documentation for "P:Dln.SpiMaster.PortRestrictions.ModeValues"]

Namespace: Dln.SpiMaster
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public Restriction ModeValues { get; }
public Restriction ModeValues { get; }
Public ReadOnly Property ModeValues As Restriction
    Get
Public ReadOnly Property ModeValues As Restriction
    Get
public:
property Restriction ModeValues {
    Restriction get ();
}
public:
property Restriction ModeValues {
    Restriction get ();
}
Property Value
Type: Restriction
See Also
Reference
PortRestrictions Class
Dln.SpiMaster Namespace


PortRestrictions.Read Property

PortRestrictions Read Property dln.net.dll

[Missing <summary> documentation for "P:Dln.SpiMaster.PortRestrictions.Read"]

Namespace: Dln.SpiMaster
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public Restriction Read { get; }
public Restriction Read { get; }
Public ReadOnly Property Read As Restriction
    Get
Public ReadOnly Property Read As Restriction
    Get
public:
property Restriction Read {
    Restriction get ();
}
public:
property Restriction Read {
    Restriction get ();
}
Property Value
Type: Restriction
See Also
Reference
PortRestrictions Class
Dln.SpiMaster Namespace


PortRestrictions.ReadWrite Property

PortRestrictions ReadWrite Property dln.net.dll

[Missing <summary> documentation for "P:Dln.SpiMaster.PortRestrictions.ReadWrite"]

Namespace: Dln.SpiMaster
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public Restriction ReadWrite { get; }
public Restriction ReadWrite { get; }
Public ReadOnly Property ReadWrite As Restriction
    Get
Public ReadOnly Property ReadWrite As Restriction
    Get
public:
property Restriction ReadWrite {
    Restriction get ();
}
public:
property Restriction ReadWrite {
    Restriction get ();
}
Property Value
Type: Restriction
See Also
Reference
PortRestrictions Class
Dln.SpiMaster Namespace


PortRestrictions.ReleaseSS Property

PortRestrictions ReleaseSS Property dln.net.dll

[Missing <summary> documentation for "P:Dln.SpiMaster.PortRestrictions.ReleaseSS"]

Namespace: Dln.SpiMaster
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public Restriction ReleaseSS { get; }
public Restriction ReleaseSS { get; }
Public ReadOnly Property ReleaseSS As Restriction
    Get
Public ReadOnly Property ReleaseSS As Restriction
    Get
public:
property Restriction ReleaseSS {
    Restriction get ();
}
public:
property Restriction ReleaseSS {
    Restriction get ();
}
Property Value
Type: Restriction
See Also
Reference
PortRestrictions Class
Dln.SpiMaster Namespace


PortRestrictions.ReleaseSSBetweenFrames Property

PortRestrictions ReleaseSSBetweenFrames Property dln.net.dll

[Missing <summary> documentation for "P:Dln.SpiMaster.PortRestrictions.ReleaseSSBetweenFrames"]

Namespace: Dln.SpiMaster
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public Restriction ReleaseSSBetweenFrames { get; }
public Restriction ReleaseSSBetweenFrames { get; }
Public ReadOnly Property ReleaseSSBetweenFrames As Restriction
    Get
Public ReadOnly Property ReleaseSSBetweenFrames As Restriction
    Get
public:
property Restriction ReleaseSSBetweenFrames {
    Restriction get ();
}
public:
property Restriction ReleaseSSBetweenFrames {
    Restriction get ();
}
Property Value
Type: Restriction
See Also
Reference
PortRestrictions Class
Dln.SpiMaster Namespace


PortRestrictions.SS Property

PortRestrictions SS Property dln.net.dll

[Missing <summary> documentation for "P:Dln.SpiMaster.PortRestrictions.SS"]

Namespace: Dln.SpiMaster
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public Restriction SS { get; }
public Restriction SS { get; }
Public ReadOnly Property SS As Restriction
    Get
Public ReadOnly Property SS As Restriction
    Get
public:
property Restriction SS {
    Restriction get ();
}
public:
property Restriction SS {
    Restriction get ();
}
Property Value
Type: Restriction
See Also
Reference
PortRestrictions Class
Dln.SpiMaster Namespace


PortRestrictions.SSCount Property

PortRestrictions SSCount Property dln.net.dll

[Missing <summary> documentation for "P:Dln.SpiMaster.PortRestrictions.SSCount"]

Namespace: Dln.SpiMaster
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public Restriction SSCount { get; }
public Restriction SSCount { get; }
Public ReadOnly Property SSCount As Restriction
    Get
Public ReadOnly Property SSCount As Restriction
    Get
public:
property Restriction SSCount {
    Restriction get ();
}
public:
property Restriction SSCount {
    Restriction get ();
}
Property Value
Type: Restriction
See Also
Reference
PortRestrictions Class
Dln.SpiMaster Namespace


PortRestrictions.SSEnabled Property

PortRestrictions SSEnabled Property dln.net.dll

[Missing <summary> documentation for "P:Dln.SpiMaster.PortRestrictions.SSEnabled"]

Namespace: Dln.SpiMaster
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public Restriction SSEnabled { get; }
public Restriction SSEnabled { get; }
Public ReadOnly Property SSEnabled As Restriction
    Get
Public ReadOnly Property SSEnabled As Restriction
    Get
public:
property Restriction SSEnabled {
    Restriction get ();
}
public:
property Restriction SSEnabled {
    Restriction get ();
}
Property Value
Type: Restriction
See Also
Reference
PortRestrictions Class
Dln.SpiMaster Namespace


PortRestrictions.Write Property

PortRestrictions Write Property dln.net.dll

[Missing <summary> documentation for "P:Dln.SpiMaster.PortRestrictions.Write"]

Namespace: Dln.SpiMaster
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public Restriction Write { get; }
public Restriction Write { get; }
Public ReadOnly Property Write As Restriction
    Get
Public ReadOnly Property Write As Restriction
    Get
public:
property Restriction Write {
    Restriction get ();
}
public:
property Restriction Write {
    Restriction get ();
}
Property Value
Type: Restriction
See Also
Reference
PortRestrictions Class
Dln.SpiMaster Namespace


Ports Class

Ports Class dln.net.dll
Ports class
Inheritance Hierarchy
System Object
System.Collections.ObjectModel ReadOnlyCollection Port
Dln.SpiMaster Ports

Namespace: Dln.SpiMaster
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public class Ports : ReadOnlyCollection<Port>
public class Ports : ReadOnlyCollection<Port>
Public Class Ports
    Inherits ReadOnlyCollection(Of Port)
Public Class Ports
    Inherits ReadOnlyCollection(Of Port)
public ref class Ports : public ReadOnlyCollection<Port^>
public ref class Ports : public ReadOnlyCollection<Port^>
The Ports type exposes the following members.
Methods
 | Name | Description
Public method | Contains | Determines whether an element is in the ReadOnlyCollection T . (Inherited from ReadOnlyCollection Port .)
Public method | CopyTo | Copies the entire ReadOnlyCollection T to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from ReadOnlyCollection Port .)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the ReadOnlyCollection T . (Inherited from ReadOnlyCollection Port .)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Public method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ReadOnlyCollection T . (Inherited from ReadOnlyCollection Port .)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the ReadOnlyCollection T instance. (Inherited from ReadOnlyCollection Port .)
Public property | Item | Gets the element at the specified index. (Inherited from ReadOnlyCollection Port .)
Protected property | Items | Returns the IList T that the ReadOnlyCollection T wraps. (Inherited from ReadOnlyCollection Port .)
Top
See Also
Reference
Dln.SpiMaster Namespace


Ports Methods

Ports Methods dln.net.dll

The Ports type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Determines whether an element is in the ReadOnlyCollection T . (Inherited from ReadOnlyCollection Port .)
Public method | CopyTo | Copies the entire ReadOnlyCollection T to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from ReadOnlyCollection Port .)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the ReadOnlyCollection T . (Inherited from ReadOnlyCollection Port .)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Public method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ReadOnlyCollection T . (Inherited from ReadOnlyCollection Port .)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Ports Class
Dln.SpiMaster Namespace


Ports Properties

Ports Properties dln.net.dll

The Ports type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the ReadOnlyCollection T instance. (Inherited from ReadOnlyCollection Port .)
Public property | Item | Gets the element at the specified index. (Inherited from ReadOnlyCollection Port .)
Protected property | Items | Returns the IList T that the ReadOnlyCollection T wraps. (Inherited from ReadOnlyCollection Port .)
Top
See Also

Reference

Ports Class
Dln.SpiMaster Namespace


Dln.SpiSlave Namespace

Dln.SpiSlave Namespace dln.net.dll
The Dln.SpiSlave namespace contains types that allow usage of DLN-series adapters as SPI bus slave device.
Classes
 | Class | Description
Public class | DataReceivedEventArgs | SPI slave event arguments
Public class | Module |
Public class | Port | Port class describes SPI slave port.
Public class | PortRestrictions | SPI slave port restrictions
Public class | Ports |
Enumerations
 | Enumeration | Description
Public enumeration | EventType | Represents available event types.
Public enumeration | ReplyMode | Represents available reply modes.
Public enumeration | ReplyShortageAction | Represents available reply shortage values.


DataReceivedEventArgs Class

DataReceivedEventArgs Class dln.net.dll
SPI slave event arguments
Inheritance Hierarchy
System Object
System EventArgs
Dln.SpiSlave DataReceivedEventArgs

Namespace: Dln.SpiSlave
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public class DataReceivedEventArgs : EventArgs
public class DataReceivedEventArgs : EventArgs
Public Class DataReceivedEventArgs
    Inherits EventArgs
Public Class DataReceivedEventArgs
    Inherits EventArgs
public ref class DataReceivedEventArgs : public EventArgs
public ref class DataReceivedEventArgs : public EventArgs
The DataReceivedEventArgs type exposes the following members.
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Data |
Public property | EventType |
Top
See Also
Reference
Dln.SpiSlave Namespace


DataReceivedEventArgs Methods

DataReceivedEventArgs Methods dln.net.dll

The DataReceivedEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DataReceivedEventArgs Class
Dln.SpiSlave Namespace


DataReceivedEventArgs Properties

DataReceivedEventArgs Properties dln.net.dll

The DataReceivedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Data |
Public property | EventType |
Top
See Also

Reference

DataReceivedEventArgs Class
Dln.SpiSlave Namespace


DataReceivedEventArgs.Data Property

DataReceivedEventArgs Data Property dln.net.dll

[Missing <summary> documentation for "P:Dln.SpiSlave.DataReceivedEventArgs.Data"]

Namespace: Dln.SpiSlave
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public ReadOnlyCollection<byte> Data { get; }
public ReadOnlyCollection<byte> Data { get; }
Public ReadOnly Property Data As ReadOnlyCollection(Of Byte)
    Get
Public ReadOnly Property Data As ReadOnlyCollection(Of Byte)
    Get
public:
property ReadOnlyCollection<unsigned char>^ Data {
    ReadOnlyCollection<unsigned char>^ get ();
}
public:
property ReadOnlyCollection<unsigned char>^ Data {
    ReadOnlyCollection<unsigned char>^ get ();
}
Property Value
Type: ReadOnlyCollection  Byte
See Also
Reference
DataReceivedEventArgs Class
Dln.SpiSlave Namespace


DataReceivedEventArgs.EventType Property

DataReceivedEventArgs EventType Property dln.net.dll

[Missing <summary> documentation for "P:Dln.SpiSlave.DataReceivedEventArgs.EventType"]

Namespace: Dln.SpiSlave
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public EventType EventType { get; }
public EventType EventType { get; }
Public ReadOnly Property EventType As EventType
    Get
Public ReadOnly Property EventType As EventType
    Get
public:
property EventType EventType {
    EventType get ();
}
public:
property EventType EventType {
    EventType get ();
}
Property Value
Type: EventType
See Also
Reference
DataReceivedEventArgs Class
Dln.SpiSlave Namespace


EventType Enumeration

EventType Enumeration dln.net.dll
Represents available event types.

Namespace: Dln.SpiSlave
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public enum EventType
public enum EventType
Public Enumeration EventType
Public Enumeration EventType
public enum class EventType
public enum class EventType
Members
Member name | Value | Description
None | 0 | No events
SSRise | 1 | SS Rise event
BufferFull | 2 | Buffer full event
See Also
Reference
Dln.SpiSlave Namespace


Module Class

Module Class dln.net.dll

[Missing <summary> documentation for "T:Dln.SpiSlave.Module"]

Inheritance Hierarchy
System Object
Dln.SpiSlave Module

Namespace: Dln.SpiSlave
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public class Module
public class Module
Public Class Module
Public Class Module
public ref class Module
public ref class Module
The Module type exposes the following members.
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Ports |
Top
See Also
Reference
Dln.SpiSlave Namespace


Module Methods

Module Methods dln.net.dll

The Module type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Module Class
Dln.SpiSlave Namespace


Module Properties

Module Properties dln.net.dll

The Module type exposes the following members.

Properties
 | Name | Description
Public property | Ports |
Top
See Also

Reference

Module Class
Dln.SpiSlave Namespace


Module.Ports Property

Module Ports Property dln.net.dll

[Missing <summary> documentation for "P:Dln.SpiSlave.Module.Ports"]

Namespace: Dln.SpiSlave
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public Ports Ports { get; }
public Ports Ports { get; }
Public ReadOnly Property Ports As Ports
    Get
Public ReadOnly Property Ports As Ports
    Get
public:
property Ports^ Ports {
    Ports^ get ();
}
public:
property Ports^ Ports {
    Ports^ get ();
}
Property Value
Type: Ports
See Also
Reference
Module Class
Dln.SpiSlave Namespace


Port Class

Port Class dln.net.dll
Port class describes SPI slave port.
Inheritance Hierarchy
System Object
Dln.SpiSlave Port

Namespace: Dln.SpiSlave
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public class Port
public class Port
Public Class Port
Public Class Port
public ref class Port
public ref class Port
The Port type exposes the following members.
Methods
 | Name | Description
Public method | EnqueueReply( Byte ) | Adds a buffer to queue. This is equal to the LoadReply() method when queue is empty (after enabling).
Public method | EnqueueReply( Byte , Int32, Int32) | Adds a buffer to queue. This is equal to the LoadReply() method when queue is empty (after enabling).
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Public method | LoadReply( Byte ) | LoadReply method loads data to be transferred to an SPI-master device.
Public method | LoadReply( Byte , Int32, Int32) | LoadReply method loads data to be transferred to an SPI-master device.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Cpha | Allows to set or get clock phase value.
Public property | CphaValues |
Public property | Cpol | Allows to set and get clock polarity value.
Public property | CpolValues |
Public property | Enabled | Activates or disables corresponding SPI slave port at your DLN-series adapter.
Public property | EventBufferSize | Set or get event buffer size. Its value can vary from 1 to 256 bytes.
Public property | EventEnabled | Allows to enable or disable SPI slave module events.
Public property | FrameSize | Allows to set and get the size of a single SPI data frame.
Public property | FrameSizeValues |
Public property | Mode |
Public property | ReplyMode | Set or get SPI slave reply mode value. Reply mode with count based mode allows to send data regardless of how many (or few) words are framed by the SS line. SS based mode begins new data transfer/reply regardless of the data length.
Public property | ReplyModeValues | Retrieves all supported spi slave modes.
Public property | ReplyShortageAction | Set or get the reply shortage action value.
Public property | ReplyShortageActionValues | Retrieves supported shortage action values.
Public property | Restrictions |
Public property | SSIdleTimeout | SSIdleTimeout allows to set or get sets SS idle timeout.
Public property | SSRiseEventEnabled | Activates or deactivates event on SS rising edge.
Top
Events
 | Name | Description
Public event | DataReceived |
Public event | DataReceivedThreadSafe |
Top
See Also
Reference
Dln.SpiSlave Namespace


Port Methods

Port Methods dln.net.dll

The Port type exposes the following members.

Methods
 | Name | Description
Public method | EnqueueReply( Byte ) | Adds a buffer to queue. This is equal to the LoadReply() method when queue is empty (after enabling).
Public method | EnqueueReply( Byte , Int32, Int32) | Adds a buffer to queue. This is equal to the LoadReply() method when queue is empty (after enabling).
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Public method | LoadReply( Byte ) | LoadReply method loads data to be transferred to an SPI-master device.
Public method | LoadReply( Byte , Int32, Int32) | LoadReply method loads data to be transferred to an SPI-master device.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Port Class
Dln.SpiSlave Namespace


Port.EnqueueReply Method

Port EnqueueReply Method dln.net.dll
Overload List
 | Name | Description
Public method | EnqueueReply( Byte ) | Adds a buffer to queue. This is equal to the LoadReply() method when queue is empty (after enabling).
Public method | EnqueueReply( Byte , Int32, Int32) | Adds a buffer to queue. This is equal to the LoadReply() method when queue is empty (after enabling).
Top
See Also

Reference

Port Class
Dln.SpiSlave Namespace


Port.EnqueueReply Method (Byte[])

Port EnqueueReply Method ( Byte ) dln.net.dll
Adds a buffer to queue. This is equal to the LoadReply() method when queue is empty (after enabling).

Namespace: Dln.SpiSlave
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public void EnqueueReply(
    byte[] data
)
public void EnqueueReply(
    byte[] data
)
Public Sub EnqueueReply (
    data As Byte()
)
Public Sub EnqueueReply (
    data As Byte()
)
public:
void EnqueueReply(
    array<unsigned char>^ data
)
public:
void EnqueueReply(
    array<unsigned char>^ data
)
Parameters
data
Type:  System Byte
An array of unsigned 8-bit integers (max 256-elements array).
See Also
Reference
Port Class
EnqueueReply Overload
Dln.SpiSlave Namespace


Port.EnqueueReply Method (Byte[], Int32, Int32)

Port EnqueueReply Method ( Byte , Int32, Int32) dln.net.dll
Adds a buffer to queue. This is equal to the LoadReply() method when queue is empty (after enabling).

Namespace: Dln.SpiSlave
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public void EnqueueReply(
    byte[] data,
    int dataOffset,
    int dataSize
)
public void EnqueueReply(
    byte[] data,
    int dataOffset,
    int dataSize
)
Public Sub EnqueueReply (
    data As Byte(),
    dataOffset As Integer,
    dataSize As Integer
)
Public Sub EnqueueReply (
    data As Byte(),
    dataOffset As Integer,
    dataSize As Integer
)
public:
void EnqueueReply(
    array<unsigned char>^ data,
    int dataOffset,
    int dataSize
)
public:
void EnqueueReply(
    array<unsigned char>^ data,
    int dataOffset,
    int dataSize
)
Parameters
data
Type:  System Byte
The buffer must contain the data to be sent to an SPI bus master.
dataOffset
Type: System Int32
Data offset.
dataSize
Type: System Int32
A size of the message buffer. This parameter is specified in bytes. The maximum value is 256 bytes.
See Also
Reference
Port Class
EnqueueReply Overload
Dln.SpiSlave Namespace


Port.LoadReply Method

Port LoadReply Method dln.net.dll
Overload List
 | Name | Description
Public method | LoadReply( Byte ) | LoadReply method loads data to be transferred to an SPI-master device.
Public method | LoadReply( Byte , Int32, Int32) | LoadReply method loads data to be transferred to an SPI-master device.
Top
See Also

Reference

Port Class
Dln.SpiSlave Namespace


Port.LoadReply Method (Byte[])

Port LoadReply Method ( Byte ) dln.net.dll
LoadReply method loads data to be transferred to an SPI-master device.

Namespace: Dln.SpiSlave
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public void LoadReply(
    byte[] data
)
public void LoadReply(
    byte[] data
)
Public Sub LoadReply (
    data As Byte()
)
Public Sub LoadReply (
    data As Byte()
)
public:
void LoadReply(
    array<unsigned char>^ data
)
public:
void LoadReply(
    array<unsigned char>^ data
)
Parameters
data
Type:  System Byte
An array of unsigned 8-bit integers (max 256-elements array).
See Also
Reference
Port Class
LoadReply Overload
Dln.SpiSlave Namespace


Port.LoadReply Method (Byte[], Int32, Int32)

Port LoadReply Method ( Byte , Int32, Int32) dln.net.dll
LoadReply method loads data to be transferred to an SPI-master device.

Namespace: Dln.SpiSlave
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public void LoadReply(
    byte[] data,
    int dataOffset,
    int dataSize
)
public void LoadReply(
    byte[] data,
    int dataOffset,
    int dataSize
)
Public Sub LoadReply (
    data As Byte(),
    dataOffset As Integer,
    dataSize As Integer
)
Public Sub LoadReply (
    data As Byte(),
    dataOffset As Integer,
    dataSize As Integer
)
public:
void LoadReply(
    array<unsigned char>^ data,
    int dataOffset,
    int dataSize
)
public:
void LoadReply(
    array<unsigned char>^ data,
    int dataOffset,
    int dataSize
)
Parameters
data
Type:  System Byte
An array of unsigned 8-bit integers (max 256-elements array).
dataOffset
Type: System Int32
Data offset
dataSize
Type: System Int32
A size of the message buffer. This parameter is specified in bytes. The maximum value is 256 bytes.
See Also
Reference
Port Class
LoadReply Overload
Dln.SpiSlave Namespace


Port Properties

Port Properties dln.net.dll

The Port type exposes the following members.

Properties
 | Name | Description
Public property | Cpha | Allows to set or get clock phase value.
Public property | CphaValues |
Public property | Cpol | Allows to set and get clock polarity value.
Public property | CpolValues |
Public property | Enabled | Activates or disables corresponding SPI slave port at your DLN-series adapter.
Public property | EventBufferSize | Set or get event buffer size. Its value can vary from 1 to 256 bytes.
Public property | EventEnabled | Allows to enable or disable SPI slave module events.
Public property | FrameSize | Allows to set and get the size of a single SPI data frame.
Public property | FrameSizeValues |
Public property | Mode |
Public property | ReplyMode | Set or get SPI slave reply mode value. Reply mode with count based mode allows to send data regardless of how many (or few) words are framed by the SS line. SS based mode begins new data transfer/reply regardless of the data length.
Public property | ReplyModeValues | Retrieves all supported spi slave modes.
Public property | ReplyShortageAction | Set or get the reply shortage action value.
Public property | ReplyShortageActionValues | Retrieves supported shortage action values.
Public property | Restrictions |
Public property | SSIdleTimeout | SSIdleTimeout allows to set or get sets SS idle timeout.
Public property | SSRiseEventEnabled | Activates or deactivates event on SS rising edge.
Top
See Also

Reference

Port Class
Dln.SpiSlave Namespace


Port.Cpha Property

Port Cpha Property dln.net.dll
Allows to set or get clock phase value.

Namespace: Dln.SpiSlave
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public int Cpha { get; set; }
public int Cpha { get; set; }
Public Property Cpha As Integer
    Get
    Set
Public Property Cpha As Integer
    Get
    Set
public:
property int Cpha {
    int get ();
    void set (int value);
}
public:
property int Cpha {
    int get ();
    void set (int value);
}
Property Value
Type: Int32
See Also
Reference
Port Class
Dln.SpiSlave Namespace


Port.CphaValues Property

Port CphaValues Property dln.net.dll

[Missing <summary> documentation for "P:Dln.SpiSlave.Port.CphaValues"]

Namespace: Dln.SpiSlave
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public ReadOnlyCollection<int> CphaValues { get; }
public ReadOnlyCollection<int> CphaValues { get; }
Public ReadOnly Property CphaValues As ReadOnlyCollection(Of Integer)
    Get
Public ReadOnly Property CphaValues As ReadOnlyCollection(Of Integer)
    Get
public:
property ReadOnlyCollection<int>^ CphaValues {
    ReadOnlyCollection<int>^ get ();
}
public:
property ReadOnlyCollection<int>^ CphaValues {
    ReadOnlyCollection<int>^ get ();
}
Property Value
Type: ReadOnlyCollection  Int32
See Also
Reference
Port Class
Dln.SpiSlave Namespace


Port.Cpol Property

Port Cpol Property dln.net.dll
Allows to set and get clock polarity value.

Namespace: Dln.SpiSlave
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public int Cpol { get; set; }
public int Cpol { get; set; }
Public Property Cpol As Integer
    Get
    Set
Public Property Cpol As Integer
    Get
    Set
public:
property int Cpol {
    int get ();
    void set (int value);
}
public:
property int Cpol {
    int get ();
    void set (int value);
}
Property Value
Type: Int32
See Also
Reference
Port Class
Dln.SpiSlave Namespace


Port.CpolValues Property

Port CpolValues Property dln.net.dll

[Missing <summary> documentation for "P:Dln.SpiSlave.Port.CpolValues"]

Namespace: Dln.SpiSlave
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public ReadOnlyCollection<int> CpolValues { get; }
public ReadOnlyCollection<int> CpolValues { get; }
Public ReadOnly Property CpolValues As ReadOnlyCollection(Of Integer)
    Get
Public ReadOnly Property CpolValues As ReadOnlyCollection(Of Integer)
    Get
public:
property ReadOnlyCollection<int>^ CpolValues {
    ReadOnlyCollection<int>^ get ();
}
public:
property ReadOnlyCollection<int>^ CpolValues {
    ReadOnlyCollection<int>^ get ();
}
Property Value
Type: ReadOnlyCollection  Int32
See Also
Reference
Port Class
Dln.SpiSlave Namespace


Port.Enabled Property

Port Enabled Property dln.net.dll
Activates or disables corresponding SPI slave port at your DLN-series adapter.

Namespace: Dln.SpiSlave
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public bool Enabled { get; set; }
public bool Enabled { get; set; }
Public Property Enabled As Boolean
    Get
    Set
Public Property Enabled As Boolean
    Get
    Set
public:
property bool Enabled {
    bool get ();
    void set (bool value);
}
public:
property bool Enabled {
    bool get ();
    void set (bool value);
}
Property Value
Type: Boolean
See Also
Reference
Port Class
Dln.SpiSlave Namespace


Port.EventBufferSize Property

Port EventBufferSize Property dln.net.dll
Set or get event buffer size. Its value can vary from 1 to 256 bytes.

Namespace: Dln.SpiSlave
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public int EventBufferSize { get; set; }
public int EventBufferSize { get; set; }
Public Property EventBufferSize As Integer
    Get
    Set
Public Property EventBufferSize As Integer
    Get
    Set
public:
property int EventBufferSize {
    int get ();
    void set (int value);
}
public:
property int EventBufferSize {
    int get ();
    void set (int value);
}
Property Value
Type: Int32
See Also
Reference
Port Class
Dln.SpiSlave Namespace


Port.EventEnabled Property

Port EventEnabled Property dln.net.dll
Allows to enable or disable SPI slave module events.

Namespace: Dln.SpiSlave
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public bool EventEnabled { get; set; }
public bool EventEnabled { get; set; }
Public Property EventEnabled As Boolean
    Get
    Set
Public Property EventEnabled As Boolean
    Get
    Set
public:
property bool EventEnabled {
    bool get ();
    void set (bool value);
}
public:
property bool EventEnabled {
    bool get ();
    void set (bool value);
}
Property Value
Type: Boolean
See Also
Reference
Port Class
Dln.SpiSlave Namespace


Port.FrameSize Property

Port FrameSize Property dln.net.dll
Allows to set and get the size of a single SPI data frame.

Namespace: Dln.SpiSlave
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public int FrameSize { get; set; }
public int FrameSize { get; set; }
Public Property FrameSize As Integer
    Get
    Set
Public Property FrameSize As Integer
    Get
    Set
public:
property int FrameSize {
    int get ();
    void set (int value);
}
public:
property int FrameSize {
    int get ();
    void set (int value);
}
Property Value
Type: Int32
See Also
Reference
Port Class
Dln.SpiSlave Namespace


Port.FrameSizeValues Property

Port FrameSizeValues Property dln.net.dll

[Missing <summary> documentation for "P:Dln.SpiSlave.Port.FrameSizeValues"]

Namespace: Dln.SpiSlave
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public ReadOnlyCollection<int> FrameSizeValues { get; }
public ReadOnlyCollection<int> FrameSizeValues { get; }
Public ReadOnly Property FrameSizeValues As ReadOnlyCollection(Of Integer)
    Get
Public ReadOnly Property FrameSizeValues As ReadOnlyCollection(Of Integer)
    Get
public:
property ReadOnlyCollection<int>^ FrameSizeValues {
    ReadOnlyCollection<int>^ get ();
}
public:
property ReadOnlyCollection<int>^ FrameSizeValues {
    ReadOnlyCollection<int>^ get ();
}
Property Value
Type: ReadOnlyCollection  Int32
See Also
Reference
Port Class
Dln.SpiSlave Namespace


Port.Mode Property

Port Mode Property dln.net.dll

[Missing <summary> documentation for "P:Dln.SpiSlave.Port.Mode"]

Namespace: Dln.SpiSlave
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public int Mode { get; set; }
public int Mode { get; set; }
Public Property Mode As Integer
    Get
    Set
Public Property Mode As Integer
    Get
    Set
public:
property int Mode {
    int get ();
    void set (int value);
}
public:
property int Mode {
    int get ();
    void set (int value);
}
Property Value
Type: Int32
See Also
Reference
Port Class
Dln.SpiSlave Namespace


Port.ReplyMode Property

Port ReplyMode Property dln.net.dll
Set or get SPI slave reply mode value. Reply mode with count based mode allows to send data regardless of how many (or few) words are framed by the SS line. SS based mode begins new data transfer/reply regardless of the data length.

Namespace: Dln.SpiSlave
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public ReplyMode ReplyMode { get; set; }
public ReplyMode ReplyMode { get; set; }
Public Property ReplyMode As ReplyMode
    Get
    Set
Public Property ReplyMode As ReplyMode
    Get
    Set
public:
property ReplyMode ReplyMode {
    ReplyMode get ();
    void set (ReplyMode value);
}
public:
property ReplyMode ReplyMode {
    ReplyMode get ();
    void set (ReplyMode value);
}
Property Value
Type: ReplyMode
See Also
Reference
Port Class
Dln.SpiSlave Namespace


Port.ReplyModeValues Property

Port ReplyModeValues Property dln.net.dll
Retrieves all supported spi slave modes.

Namespace: Dln.SpiSlave
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public ReadOnlyCollection<ReplyMode> ReplyModeValues { get; }
public ReadOnlyCollection<ReplyMode> ReplyModeValues { get; }
Public ReadOnly Property ReplyModeValues As ReadOnlyCollection(Of ReplyMode)
    Get
Public ReadOnly Property ReplyModeValues As ReadOnlyCollection(Of ReplyMode)
    Get
public:
property ReadOnlyCollection<ReplyMode>^ ReplyModeValues {
    ReadOnlyCollection<ReplyMode>^ get ();
}
public:
property ReadOnlyCollection<ReplyMode>^ ReplyModeValues {
    ReadOnlyCollection<ReplyMode>^ get ();
}
Property Value
Type: ReadOnlyCollection  ReplyMode
See Also
Reference
Port Class
Dln.SpiSlave Namespace


Port.ReplyShortageAction Property

Port ReplyShortageAction Property dln.net.dll
Set or get the reply shortage action value.

Namespace: Dln.SpiSlave
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public ReplyShortageAction ReplyShortageAction { get; set; }
public ReplyShortageAction ReplyShortageAction { get; set; }
Public Property ReplyShortageAction As ReplyShortageAction
    Get
    Set
Public Property ReplyShortageAction As ReplyShortageAction
    Get
    Set
public:
property ReplyShortageAction ReplyShortageAction {
    ReplyShortageAction get ();
    void set (ReplyShortageAction value);
}
public:
property ReplyShortageAction ReplyShortageAction {
    ReplyShortageAction get ();
    void set (ReplyShortageAction value);
}
Property Value
Type: ReplyShortageAction
See Also
Reference
Port Class
Dln.SpiSlave Namespace


Port.ReplyShortageActionValues Property

Port ReplyShortageActionValues Property dln.net.dll
Retrieves supported shortage action values.

Namespace: Dln.SpiSlave
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public ReadOnlyCollection<ReplyShortageAction> ReplyShortageActionValues { get; }
public ReadOnlyCollection<ReplyShortageAction> ReplyShortageActionValues { get; }
Public ReadOnly Property ReplyShortageActionValues As ReadOnlyCollection(Of ReplyShortageAction)
    Get
Public ReadOnly Property ReplyShortageActionValues As ReadOnlyCollection(Of ReplyShortageAction)
    Get
public:
property ReadOnlyCollection<ReplyShortageAction>^ ReplyShortageActionValues {
    ReadOnlyCollection<ReplyShortageAction>^ get ();
}
public:
property ReadOnlyCollection<ReplyShortageAction>^ ReplyShortageActionValues {
    ReadOnlyCollection<ReplyShortageAction>^ get ();
}
Property Value
Type: ReadOnlyCollection  ReplyShortageAction
See Also
Reference
Port Class
Dln.SpiSlave Namespace


Port.Restrictions Property

Port Restrictions Property dln.net.dll

[Missing <summary> documentation for "P:Dln.SpiSlave.Port.Restrictions"]

Namespace: Dln.SpiSlave
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public PortRestrictions Restrictions { get; }
public PortRestrictions Restrictions { get; }
Public ReadOnly Property Restrictions As PortRestrictions
    Get
Public ReadOnly Property Restrictions As PortRestrictions
    Get
public:
property PortRestrictions^ Restrictions {
    PortRestrictions^ get ();
}
public:
property PortRestrictions^ Restrictions {
    PortRestrictions^ get ();
}
Property Value
Type: PortRestrictions
See Also
Reference
Port Class
Dln.SpiSlave Namespace


Port.SSIdleTimeout Property

Port SSIdleTimeout Property dln.net.dll
SSIdleTimeout allows to set or get sets SS idle timeout.

Namespace: Dln.SpiSlave
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public uint SSIdleTimeout { get; set; }
public uint SSIdleTimeout { get; set; }
Public Property SSIdleTimeout As UInteger
    Get
    Set
Public Property SSIdleTimeout As UInteger
    Get
    Set
public:
property unsigned int SSIdleTimeout {
    unsigned int get ();
    void set (unsigned int value);
}
public:
property unsigned int SSIdleTimeout {
    unsigned int get ();
    void set (unsigned int value);
}
Property Value
Type: UInt32
See Also
Reference
Port Class
Dln.SpiSlave Namespace


Port.SSRiseEventEnabled Property

Port SSRiseEventEnabled Property dln.net.dll
Activates or deactivates event on SS rising edge.

Namespace: Dln.SpiSlave
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public bool SSRiseEventEnabled { get; set; }
public bool SSRiseEventEnabled { get; set; }
Public Property SSRiseEventEnabled As Boolean
    Get
    Set
Public Property SSRiseEventEnabled As Boolean
    Get
    Set
public:
property bool SSRiseEventEnabled {
    bool get ();
    void set (bool value);
}
public:
property bool SSRiseEventEnabled {
    bool get ();
    void set (bool value);
}
Property Value
Type: Boolean
See Also
Reference
Port Class
Dln.SpiSlave Namespace


Port Events

Port Events dln.net.dll

The Port type exposes the following members.

Events
 | Name | Description
Public event | DataReceived |
Public event | DataReceivedThreadSafe |
Top
See Also

Reference

Port Class
Dln.SpiSlave Namespace


Port.DataReceived Event

Port DataReceived Event dln.net.dll

[Missing <summary> documentation for "E:Dln.SpiSlave.Port.DataReceived"]

Namespace: Dln.SpiSlave
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public event EventHandler<DataReceivedEventArgs> DataReceived
public event EventHandler<DataReceivedEventArgs> DataReceived
Public Event DataReceived As EventHandler(Of DataReceivedEventArgs)
Public Event DataReceived As EventHandler(Of DataReceivedEventArgs)
public:
 event EventHandler<DataReceivedEventArgs^>^ DataReceived {
    void add (EventHandler<DataReceivedEventArgs^>^ value);
    void remove (EventHandler<DataReceivedEventArgs^>^ value);
}
public:
 event EventHandler<DataReceivedEventArgs^>^ DataReceived {
    void add (EventHandler<DataReceivedEventArgs^>^ value);
    void remove (EventHandler<DataReceivedEventArgs^>^ value);
}
Value
Type: System EventHandler  DataReceivedEventArgs
See Also
Reference
Port Class
Dln.SpiSlave Namespace


Port.DataReceivedThreadSafe Event

Port DataReceivedThreadSafe Event dln.net.dll

[Missing <summary> documentation for "E:Dln.SpiSlave.Port.DataReceivedThreadSafe"]

Namespace: Dln.SpiSlave
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public event EventHandler<DataReceivedEventArgs> DataReceivedThreadSafe
public event EventHandler<DataReceivedEventArgs> DataReceivedThreadSafe
Public Event DataReceivedThreadSafe As EventHandler(Of DataReceivedEventArgs)
Public Event DataReceivedThreadSafe As EventHandler(Of DataReceivedEventArgs)
public:
 event EventHandler<DataReceivedEventArgs^>^ DataReceivedThreadSafe {
    void add (EventHandler<DataReceivedEventArgs^>^ value);
    void remove (EventHandler<DataReceivedEventArgs^>^ value);
}
public:
 event EventHandler<DataReceivedEventArgs^>^ DataReceivedThreadSafe {
    void add (EventHandler<DataReceivedEventArgs^>^ value);
    void remove (EventHandler<DataReceivedEventArgs^>^ value);
}
Value
Type: System EventHandler  DataReceivedEventArgs
See Also
Reference
Port Class
Dln.SpiSlave Namespace


PortRestrictions Class

PortRestrictions Class dln.net.dll
SPI slave port restrictions
Inheritance Hierarchy
System Object
Dln.SpiSlave PortRestrictions

Namespace: Dln.SpiSlave
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public class PortRestrictions
public class PortRestrictions
Public Class PortRestrictions
Public Class PortRestrictions
public ref class PortRestrictions
public ref class PortRestrictions
The PortRestrictions type exposes the following members.
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Cpha | CPHA restriction
Public property | Cpol | CPOL restriction
Public property | Enabled | SPI slave port enabled restriction
Public property | EnqueueReply | Enqueue reply restriction
Public property | EventBufferSize | Event buffer size restriction
Public property | EventEnabled | Events enabled restriction
Public property | FrameSize | Frame size restriction
Public property | LoadReply | Load reply restriction
Public property | Mode | SPI slave mode restriction
Public property | ReplyMode | Reply mode restriction
Public property | ReplyShortageAction | Reply shortage action restriction
Public property | SSIdleTimeout | SS idle timeout restriction
Public property | SSRiseEventEnabled | SS rise event enabled restriction
Top
See Also
Reference
Dln.SpiSlave Namespace


PortRestrictions Methods

PortRestrictions Methods dln.net.dll

The PortRestrictions type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PortRestrictions Class
Dln.SpiSlave Namespace


PortRestrictions Properties

PortRestrictions Properties dln.net.dll

The PortRestrictions type exposes the following members.

Properties
 | Name | Description
Public property | Cpha | CPHA restriction
Public property | Cpol | CPOL restriction
Public property | Enabled | SPI slave port enabled restriction
Public property | EnqueueReply | Enqueue reply restriction
Public property | EventBufferSize | Event buffer size restriction
Public property | EventEnabled | Events enabled restriction
Public property | FrameSize | Frame size restriction
Public property | LoadReply | Load reply restriction
Public property | Mode | SPI slave mode restriction
Public property | ReplyMode | Reply mode restriction
Public property | ReplyShortageAction | Reply shortage action restriction
Public property | SSIdleTimeout | SS idle timeout restriction
Public property | SSRiseEventEnabled | SS rise event enabled restriction
Top
See Also

Reference

PortRestrictions Class
Dln.SpiSlave Namespace


PortRestrictions.Cpha Property

PortRestrictions Cpha Property dln.net.dll
CPHA restriction

Namespace: Dln.SpiSlave
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public Restriction Cpha { get; }
public Restriction Cpha { get; }
Public ReadOnly Property Cpha As Restriction
    Get
Public ReadOnly Property Cpha As Restriction
    Get
public:
property Restriction Cpha {
    Restriction get ();
}
public:
property Restriction Cpha {
    Restriction get ();
}
Property Value
Type: Restriction
See Also
Reference
PortRestrictions Class
Dln.SpiSlave Namespace


PortRestrictions.Cpol Property

PortRestrictions Cpol Property dln.net.dll
CPOL restriction

Namespace: Dln.SpiSlave
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public Restriction Cpol { get; }
public Restriction Cpol { get; }
Public ReadOnly Property Cpol As Restriction
    Get
Public ReadOnly Property Cpol As Restriction
    Get
public:
property Restriction Cpol {
    Restriction get ();
}
public:
property Restriction Cpol {
    Restriction get ();
}
Property Value
Type: Restriction
See Also
Reference
PortRestrictions Class
Dln.SpiSlave Namespace


PortRestrictions.Enabled Property

PortRestrictions Enabled Property dln.net.dll
SPI slave port enabled restriction

Namespace: Dln.SpiSlave
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public Restriction Enabled { get; }
public Restriction Enabled { get; }
Public ReadOnly Property Enabled As Restriction
    Get
Public ReadOnly Property Enabled As Restriction
    Get
public:
property Restriction Enabled {
    Restriction get ();
}
public:
property Restriction Enabled {
    Restriction get ();
}
Property Value
Type: Restriction
See Also
Reference
PortRestrictions Class
Dln.SpiSlave Namespace


PortRestrictions.EnqueueReply Property

PortRestrictions EnqueueReply Property dln.net.dll
Enqueue reply restriction

Namespace: Dln.SpiSlave
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public Restriction EnqueueReply { get; }
public Restriction EnqueueReply { get; }
Public ReadOnly Property EnqueueReply As Restriction
    Get
Public ReadOnly Property EnqueueReply As Restriction
    Get
public:
property Restriction EnqueueReply {
    Restriction get ();
}
public:
property Restriction EnqueueReply {
    Restriction get ();
}
Property Value
Type: Restriction
See Also
Reference
PortRestrictions Class
Dln.SpiSlave Namespace


PortRestrictions.EventBufferSize Property

PortRestrictions EventBufferSize Property dln.net.dll
Event buffer size restriction

Namespace: Dln.SpiSlave
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public Restriction EventBufferSize { get; }
public Restriction EventBufferSize { get; }
Public ReadOnly Property EventBufferSize As Restriction
    Get
Public ReadOnly Property EventBufferSize As Restriction
    Get
public:
property Restriction EventBufferSize {
    Restriction get ();
}
public:
property Restriction EventBufferSize {
    Restriction get ();
}
Property Value
Type: Restriction
See Also
Reference
PortRestrictions Class
Dln.SpiSlave Namespace


PortRestrictions.EventEnabled Property

PortRestrictions EventEnabled Property dln.net.dll
Events enabled restriction

Namespace: Dln.SpiSlave
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public Restriction EventEnabled { get; }
public Restriction EventEnabled { get; }
Public ReadOnly Property EventEnabled As Restriction
    Get
Public ReadOnly Property EventEnabled As Restriction
    Get
public:
property Restriction EventEnabled {
    Restriction get ();
}
public:
property Restriction EventEnabled {
    Restriction get ();
}
Property Value
Type: Restriction
See Also
Reference
PortRestrictions Class
Dln.SpiSlave Namespace


PortRestrictions.FrameSize Property

PortRestrictions FrameSize Property dln.net.dll
Frame size restriction

Namespace: Dln.SpiSlave
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public Restriction FrameSize { get; }
public Restriction FrameSize { get; }
Public ReadOnly Property FrameSize As Restriction
    Get
Public ReadOnly Property FrameSize As Restriction
    Get
public:
property Restriction FrameSize {
    Restriction get ();
}
public:
property Restriction FrameSize {
    Restriction get ();
}
Property Value
Type: Restriction
See Also
Reference
PortRestrictions Class
Dln.SpiSlave Namespace


PortRestrictions.LoadReply Property

PortRestrictions LoadReply Property dln.net.dll
Load reply restriction

Namespace: Dln.SpiSlave
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public Restriction LoadReply { get; }
public Restriction LoadReply { get; }
Public ReadOnly Property LoadReply As Restriction
    Get
Public ReadOnly Property LoadReply As Restriction
    Get
public:
property Restriction LoadReply {
    Restriction get ();
}
public:
property Restriction LoadReply {
    Restriction get ();
}
Property Value
Type: Restriction
See Also
Reference
PortRestrictions Class
Dln.SpiSlave Namespace


PortRestrictions.Mode Property

PortRestrictions Mode Property dln.net.dll
SPI slave mode restriction

Namespace: Dln.SpiSlave
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public Restriction Mode { get; }
public Restriction Mode { get; }
Public ReadOnly Property Mode As Restriction
    Get
Public ReadOnly Property Mode As Restriction
    Get
public:
property Restriction Mode {
    Restriction get ();
}
public:
property Restriction Mode {
    Restriction get ();
}
Property Value
Type: Restriction
See Also
Reference
PortRestrictions Class
Dln.SpiSlave Namespace


PortRestrictions.ReplyMode Property

PortRestrictions ReplyMode Property dln.net.dll
Reply mode restriction

Namespace: Dln.SpiSlave
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public Restriction ReplyMode { get; }
public Restriction ReplyMode { get; }
Public ReadOnly Property ReplyMode As Restriction
    Get
Public ReadOnly Property ReplyMode As Restriction
    Get
public:
property Restriction ReplyMode {
    Restriction get ();
}
public:
property Restriction ReplyMode {
    Restriction get ();
}
Property Value
Type: Restriction
See Also
Reference
PortRestrictions Class
Dln.SpiSlave Namespace


PortRestrictions.ReplyShortageAction Property

PortRestrictions ReplyShortageAction Property dln.net.dll
Reply shortage action restriction

Namespace: Dln.SpiSlave
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public Restriction ReplyShortageAction { get; }
public Restriction ReplyShortageAction { get; }
Public ReadOnly Property ReplyShortageAction As Restriction
    Get
Public ReadOnly Property ReplyShortageAction As Restriction
    Get
public:
property Restriction ReplyShortageAction {
    Restriction get ();
}
public:
property Restriction ReplyShortageAction {
    Restriction get ();
}
Property Value
Type: Restriction
See Also
Reference
PortRestrictions Class
Dln.SpiSlave Namespace


PortRestrictions.SSIdleTimeout Property

PortRestrictions SSIdleTimeout Property dln.net.dll
SS idle timeout restriction

Namespace: Dln.SpiSlave
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public Restriction SSIdleTimeout { get; }
public Restriction SSIdleTimeout { get; }
Public ReadOnly Property SSIdleTimeout As Restriction
    Get
Public ReadOnly Property SSIdleTimeout As Restriction
    Get
public:
property Restriction SSIdleTimeout {
    Restriction get ();
}
public:
property Restriction SSIdleTimeout {
    Restriction get ();
}
Property Value
Type: Restriction
See Also
Reference
PortRestrictions Class
Dln.SpiSlave Namespace


PortRestrictions.SSRiseEventEnabled Property

PortRestrictions SSRiseEventEnabled Property dln.net.dll
SS rise event enabled restriction

Namespace: Dln.SpiSlave
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public Restriction SSRiseEventEnabled { get; }
public Restriction SSRiseEventEnabled { get; }
Public ReadOnly Property SSRiseEventEnabled As Restriction
    Get
Public ReadOnly Property SSRiseEventEnabled As Restriction
    Get
public:
property Restriction SSRiseEventEnabled {
    Restriction get ();
}
public:
property Restriction SSRiseEventEnabled {
    Restriction get ();
}
Property Value
Type: Restriction
See Also
Reference
PortRestrictions Class
Dln.SpiSlave Namespace


Ports Class

Ports Class dln.net.dll

[Missing <summary> documentation for "T:Dln.SpiSlave.Ports"]

Inheritance Hierarchy
System Object
System.Collections.ObjectModel ReadOnlyCollection Port
Dln.SpiSlave Ports

Namespace: Dln.SpiSlave
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public class Ports : ReadOnlyCollection<Port>
public class Ports : ReadOnlyCollection<Port>
Public Class Ports
    Inherits ReadOnlyCollection(Of Port)
Public Class Ports
    Inherits ReadOnlyCollection(Of Port)
public ref class Ports : public ReadOnlyCollection<Port^>
public ref class Ports : public ReadOnlyCollection<Port^>
The Ports type exposes the following members.
Methods
 | Name | Description
Public method | Contains | Determines whether an element is in the ReadOnlyCollection T . (Inherited from ReadOnlyCollection Port .)
Public method | CopyTo | Copies the entire ReadOnlyCollection T to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from ReadOnlyCollection Port .)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the ReadOnlyCollection T . (Inherited from ReadOnlyCollection Port .)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Public method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ReadOnlyCollection T . (Inherited from ReadOnlyCollection Port .)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the ReadOnlyCollection T instance. (Inherited from ReadOnlyCollection Port .)
Public property | Item |
Protected property | Items | Returns the IList T that the ReadOnlyCollection T wraps. (Inherited from ReadOnlyCollection Port .)
Top
See Also
Reference
Dln.SpiSlave Namespace


Ports Methods

Ports Methods dln.net.dll

The Ports type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Determines whether an element is in the ReadOnlyCollection T . (Inherited from ReadOnlyCollection Port .)
Public method | CopyTo | Copies the entire ReadOnlyCollection T to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from ReadOnlyCollection Port .)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the ReadOnlyCollection T . (Inherited from ReadOnlyCollection Port .)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Public method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ReadOnlyCollection T . (Inherited from ReadOnlyCollection Port .)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Ports Class
Dln.SpiSlave Namespace


Ports Properties

Ports Properties dln.net.dll

The Ports type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the ReadOnlyCollection T instance. (Inherited from ReadOnlyCollection Port .)
Public property | Item |
Protected property | Items | Returns the IList T that the ReadOnlyCollection T wraps. (Inherited from ReadOnlyCollection Port .)
Top
See Also

Reference

Ports Class
Dln.SpiSlave Namespace


Ports.Item Property

Ports Item Property dln.net.dll

[Missing <summary> documentation for "P:Dln.SpiSlave.Ports.Item(System.Int32)"]

Namespace: Dln.SpiSlave
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public Port this[
    int index
] { get; }
public Port this[
    int index
] { get; }
Public ReadOnly Default Property Item (
    index As Integer
) As Port
    Get
Public ReadOnly Default Property Item (
    index As Integer
) As Port
    Get
public:
property Port^ default[int index] {
    Port^ get (int index);
}
public:
property Port^ default[int index] {
    Port^ get (int index);
}
Parameters
index
Type: System Int32
Property Value
Type: Port
See Also
Reference
Ports Class
Dln.SpiSlave Namespace


ReplyMode Enumeration

ReplyMode Enumeration dln.net.dll
Represents available reply modes.

Namespace: Dln.SpiSlave
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public enum ReplyMode
public enum ReplyMode
Public Enumeration ReplyMode
Public Enumeration ReplyMode
public enum class ReplyMode
public enum class ReplyMode
Members
Member name | Value | Description
Off | 0 | Reply mode off.
SSBased | 1 | SS based reply mode
CountBased | 2 | Count based reply mode
See Also
Reference
Dln.SpiSlave Namespace


ReplyShortageAction Enumeration

ReplyShortageAction Enumeration dln.net.dll
Represents available reply shortage values.

Namespace: Dln.SpiSlave
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public enum ReplyShortageAction
public enum ReplyShortageAction
Public Enumeration ReplyShortageAction
Public Enumeration ReplyShortageAction
public enum class ReplyShortageAction
public enum class ReplyShortageAction
Members
Member name | Value | Description
SendZeros | 0 |
Reuse | 1 |
See Also
Reference
Dln.SpiSlave Namespace


Dln.Uart Namespace

Dln.Uart Namespace dln.net.dll
The Dln.Uart namespace contains types that allow UART module usage of DLN-series adapters.
Classes
 | Class | Description
Public class | DataReceivedEventArgs | DataReceivedEventsArgs class
Public class | Module | Module class describes methods and properties for Uart module.
Public class | Port | Port class describes methods and properties for UART module ports
Public class | PortRestrictions | PortRestrictions class describes Uart port restrictions
Public class | Ports | Ports class
Enumerations
 | Enumeration | Description
Public enumeration | Parity | Parity enumeration describes all possible parity values.
Public enumeration | Stopbits | Stopbits enumeration describes all possible stopbits values.


DataReceivedEventArgs Class

DataReceivedEventArgs Class dln.net.dll
DataReceivedEventsArgs class
Inheritance Hierarchy
System Object
System EventArgs
Dln.Uart DataReceivedEventArgs

Namespace: Dln.Uart
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public class DataReceivedEventArgs : EventArgs
public class DataReceivedEventArgs : EventArgs
Public Class DataReceivedEventArgs
    Inherits EventArgs
Public Class DataReceivedEventArgs
    Inherits EventArgs
public ref class DataReceivedEventArgs : public EventArgs
public ref class DataReceivedEventArgs : public EventArgs
The DataReceivedEventArgs type exposes the following members.
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Data | Additional event data
Public property | Port | Uart port
Top
See Also
Reference
Dln.Uart Namespace


DataReceivedEventArgs Methods

DataReceivedEventArgs Methods dln.net.dll

The DataReceivedEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DataReceivedEventArgs Class
Dln.Uart Namespace


DataReceivedEventArgs Properties

DataReceivedEventArgs Properties dln.net.dll

The DataReceivedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Data | Additional event data
Public property | Port | Uart port
Top
See Also

Reference

DataReceivedEventArgs Class
Dln.Uart Namespace


DataReceivedEventArgs.Data Property

DataReceivedEventArgs Data Property dln.net.dll
Additional event data

Namespace: Dln.Uart
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public ReadOnlyCollection<byte> Data { get; }
public ReadOnlyCollection<byte> Data { get; }
Public ReadOnly Property Data As ReadOnlyCollection(Of Byte)
    Get
Public ReadOnly Property Data As ReadOnlyCollection(Of Byte)
    Get
public:
property ReadOnlyCollection<unsigned char>^ Data {
    ReadOnlyCollection<unsigned char>^ get ();
}
public:
property ReadOnlyCollection<unsigned char>^ Data {
    ReadOnlyCollection<unsigned char>^ get ();
}
Property Value
Type: ReadOnlyCollection  Byte
See Also
Reference
DataReceivedEventArgs Class
Dln.Uart Namespace


DataReceivedEventArgs.Port Property

DataReceivedEventArgs Port Property dln.net.dll
Uart port

Namespace: Dln.Uart
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public int Port { get; }
public int Port { get; }
Public ReadOnly Property Port As Integer
    Get
Public ReadOnly Property Port As Integer
    Get
public:
property int Port {
    int get ();
}
public:
property int Port {
    int get ();
}
Property Value
Type: Int32
See Also
Reference
DataReceivedEventArgs Class
Dln.Uart Namespace


Module Class

Module Class dln.net.dll
Module class describes methods and properties for Uart module.
Inheritance Hierarchy
System Object
Dln.Uart Module

Namespace: Dln.Uart
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public class Module
public class Module
Public Class Module
Public Class Module
public ref class Module
public ref class Module
The Module type exposes the following members.
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Ports | Retrieves Uart module ports
Top
See Also
Reference
Dln.Uart Namespace


Module Methods

Module Methods dln.net.dll

The Module type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Module Class
Dln.Uart Namespace


Module Properties

Module Properties dln.net.dll

The Module type exposes the following members.

Properties
 | Name | Description
Public property | Ports | Retrieves Uart module ports
Top
See Also

Reference

Module Class
Dln.Uart Namespace


Module.Ports Property

Module Ports Property dln.net.dll
Retrieves Uart module ports

Namespace: Dln.Uart
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public Ports Ports { get; }
public Ports Ports { get; }
Public ReadOnly Property Ports As Ports
    Get
Public ReadOnly Property Ports As Ports
    Get
public:
property Ports^ Ports {
    Ports^ get ();
}
public:
property Ports^ Ports {
    Ports^ get ();
}
Property Value
Type: Ports
See Also
Reference
Module Class
Dln.Uart Namespace


Parity Enumeration

Parity Enumeration dln.net.dll
Parity enumeration describes all possible parity values.

Namespace: Dln.Uart
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public enum Parity
public enum Parity
Public Enumeration Parity
Public Enumeration Parity
public enum class Parity
public enum class Parity
Members
Member name | Value | Description
Even | 0 | Even parity
Odd | 1 | Odd parity
Space | 2 | Add Space
Mark | 3 | Add mark
None | 4 | Nothing
See Also
Reference
Dln.Uart Namespace


Port Class

Port Class dln.net.dll
Port class describes methods and properties for UART module ports
Inheritance Hierarchy
System Object
Dln.Uart Port

Namespace: Dln.Uart
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public class Port
public class Port
Public Class Port
Public Class Port
public ref class Port
public ref class Port
The Port type exposes the following members.
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Read( Byte ) | Receives data via UART interface.
Public method | Read( Byte , Int32, Int32) | Receives data via UART interface.
Public method | ReadByte | Read one byte via UART interface
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Write( Byte ) | Sends data via UART interface.
Public method | Write( Byte , Int32, Int32) | Sends data via UART interface.
Public method | WriteByte | Sends single byte value via UART interface.
Top
Properties
 | Name | Description
Public property | Baudrate | Sets or gets the baud rate, which represents the number of bits that are actually being sent.
Public property | CharacterLength | Selects the data character length of 5, 6, 7, 8 and 9 bits per character. Leave property blank to get current value.
Public property | Enabled | Enables or disables the UART port.
Public property | EventEnabled | Enables or disables UART event for current UART port. Leave property blank to get current value.
Public property | EventPeriod | Configures the event period for current UART port. Leave property blank to get current value.
Public property | EventSize | Configures the event size. Leave property blank to get current value.
Public property | MaxBaudrate | Retrieves the maximum possible baud rate value.
Public property | MinBaudrate | Retrieves the minimum possible baud rate value.
Public property | Parity | Select even, odd, mark (when the parity bit is always 1), space (the bit is always 0) or none parity. Leave property blank to get current value.
Public property | ReadTimeout | Gets or sets the number of milliseconds before a time-out occurs when a read operation does not finish.
Public property | Restrictions | Retrieves predefined restrictions
Public property | Stopbits | Select the number of stop bits to be sent with each character. Leave property blank to get current value.
Public property | SupportedCharacterLengths | Returns all supported character length types.
Public property | SupportedParities | Returns all supported parities values.
Public property | SupportedStopbits | Returns all supported stop bits values.
Top
Events
 | Name | Description
Public event | DataReceived | DataReceived event handler
Public event | DataReceivedThreadSafe | DataReceivedThreadSafe event handler
Top
See Also
Reference
Dln.Uart Namespace


Port Methods

Port Methods dln.net.dll

The Port type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Read( Byte ) | Receives data via UART interface.
Public method | Read( Byte , Int32, Int32) | Receives data via UART interface.
Public method | ReadByte | Read one byte via UART interface
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Write( Byte ) | Sends data via UART interface.
Public method | Write( Byte , Int32, Int32) | Sends data via UART interface.
Public method | WriteByte | Sends single byte value via UART interface.
Top
See Also

Reference

Port Class
Dln.Uart Namespace


Port.Read Method

Port Read Method dln.net.dll
Overload List
 | Name | Description
Public method | Read( Byte ) | Receives data via UART interface.
Public method | Read( Byte , Int32, Int32) | Receives data via UART interface.
Top
See Also

Reference

Port Class
Dln.Uart Namespace


Port.Read Method (Byte[])

Port Read Method ( Byte ) dln.net.dll
Receives data via UART interface.

Namespace: Dln.Uart
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public int Read(
    byte[] buffer
)
public int Read(
    byte[] buffer
)
Public Function Read (
    buffer As Byte()
) As Integer
Public Function Read (
    buffer As Byte()
) As Integer
public:
int Read(
    array<unsigned char>^ buffer
)
public:
int Read(
    array<unsigned char>^ buffer
)
Parameters
buffer
Type:  System Byte
This array will be filled with received data during the function execution.
Return Value
Type: Int32
[Missing <returns> documentation for "M:Dln.Uart.Port.Read(System.Byte[])"]
See Also
Reference
Port Class
Read Overload
Dln.Uart Namespace


Port.Read Method (Byte[], Int32, Int32)

Port Read Method ( Byte , Int32, Int32) dln.net.dll
Receives data via UART interface.

Namespace: Dln.Uart
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public int Read(
    byte[] buffer,
    int offset,
    int count
)
public int Read(
    byte[] buffer,
    int offset,
    int count
)
Public Function Read (
    buffer As Byte(),
    offset As Integer,
    count As Integer
) As Integer
Public Function Read (
    buffer As Byte(),
    offset As Integer,
    count As Integer
) As Integer
public:
int Read(
    array<unsigned char>^ buffer,
    int offset,
    int count
)
public:
int Read(
    array<unsigned char>^ buffer,
    int offset,
    int count
)
Parameters
buffer
Type:  System Byte
This array will be filled with received data during the function execution.
offset
Type: System Int32
Data offset
count
Type: System Int32
[Missing <param name="count"/> documentation for "M:Dln.Uart.Port.Read(System.Byte[],System.Int32,System.Int32)"]
Return Value
Type: Int32
[Missing <returns> documentation for "M:Dln.Uart.Port.Read(System.Byte[],System.Int32,System.Int32)"]
See Also
Reference
Port Class
Read Overload
Dln.Uart Namespace


Port.ReadByte Method

Port ReadByte Method dln.net.dll
Read one byte via UART interface

Namespace: Dln.Uart
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public int ReadByte()
public int ReadByte()
Public Function ReadByte As Integer
Public Function ReadByte As Integer
public:
int ReadByte()
public:
int ReadByte()
Return Value
Type: Int32
Returns buffer
See Also
Reference
Port Class
Dln.Uart Namespace


Port.Write Method

Port Write Method dln.net.dll
Overload List
 | Name | Description
Public method | Write( Byte ) | Sends data via UART interface.
Public method | Write( Byte , Int32, Int32) | Sends data via UART interface.
Top
See Also

Reference

Port Class
Dln.Uart Namespace


Port.Write Method (Byte[])

Port Write Method ( Byte ) dln.net.dll
Sends data via UART interface.

Namespace: Dln.Uart
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public int Write(
    byte[] buffer
)
public int Write(
    byte[] buffer
)
Public Function Write (
    buffer As Byte()
) As Integer
Public Function Write (
    buffer As Byte()
) As Integer
public:
int Write(
    array<unsigned char>^ buffer
)
public:
int Write(
    array<unsigned char>^ buffer
)
Parameters
buffer
Type:  System Byte
This array must be filled with data to be sent during the function execution.
Return Value
Type: Int32
[Missing <returns> documentation for "M:Dln.Uart.Port.Write(System.Byte[])"]
See Also
Reference
Port Class
Write Overload
Dln.Uart Namespace


Port.Write Method (Byte[], Int32, Int32)

Port Write Method ( Byte , Int32, Int32) dln.net.dll
Sends data via UART interface.

Namespace: Dln.Uart
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public int Write(
    byte[] buffer,
    int offset,
    int count
)
public int Write(
    byte[] buffer,
    int offset,
    int count
)
Public Function Write (
    buffer As Byte(),
    offset As Integer,
    count As Integer
) As Integer
Public Function Write (
    buffer As Byte(),
    offset As Integer,
    count As Integer
) As Integer
public:
int Write(
    array<unsigned char>^ buffer,
    int offset,
    int count
)
public:
int Write(
    array<unsigned char>^ buffer,
    int offset,
    int count
)
Parameters
buffer
Type:  System Byte
This array must be filled with data to be sent during the function execution.
offset
Type: System Int32
Data offset.
count
Type: System Int32
[Missing <param name="count"/> documentation for "M:Dln.Uart.Port.Write(System.Byte[],System.Int32,System.Int32)"]
Return Value
Type: Int32
[Missing <returns> documentation for "M:Dln.Uart.Port.Write(System.Byte[],System.Int32,System.Int32)"]
See Also
Reference
Port Class
Write Overload
Dln.Uart Namespace


Port.WriteByte Method

Port WriteByte Method dln.net.dll
Sends single byte value via UART interface.

Namespace: Dln.Uart
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public void WriteByte(
    int value
)
public void WriteByte(
    int value
)
Public Sub WriteByte (
    value As Integer
)
Public Sub WriteByte (
    value As Integer
)
public:
void WriteByte(
    int value
)
public:
void WriteByte(
    int value
)
Parameters
value
Type: System Int32
Value to be sent.
See Also
Reference
Port Class
Dln.Uart Namespace


Port Properties

Port Properties dln.net.dll

The Port type exposes the following members.

Properties
 | Name | Description
Public property | Baudrate | Sets or gets the baud rate, which represents the number of bits that are actually being sent.
Public property | CharacterLength | Selects the data character length of 5, 6, 7, 8 and 9 bits per character. Leave property blank to get current value.
Public property | Enabled | Enables or disables the UART port.
Public property | EventEnabled | Enables or disables UART event for current UART port. Leave property blank to get current value.
Public property | EventPeriod | Configures the event period for current UART port. Leave property blank to get current value.
Public property | EventSize | Configures the event size. Leave property blank to get current value.
Public property | MaxBaudrate | Retrieves the maximum possible baud rate value.
Public property | MinBaudrate | Retrieves the minimum possible baud rate value.
Public property | Parity | Select even, odd, mark (when the parity bit is always 1), space (the bit is always 0) or none parity. Leave property blank to get current value.
Public property | ReadTimeout | Gets or sets the number of milliseconds before a time-out occurs when a read operation does not finish.
Public property | Restrictions | Retrieves predefined restrictions
Public property | Stopbits | Select the number of stop bits to be sent with each character. Leave property blank to get current value.
Public property | SupportedCharacterLengths | Returns all supported character length types.
Public property | SupportedParities | Returns all supported parities values.
Public property | SupportedStopbits | Returns all supported stop bits values.
Top
See Also

Reference

Port Class
Dln.Uart Namespace


Port.Baudrate Property

Port Baudrate Property dln.net.dll
Sets or gets the baud rate, which represents the number of bits that are actually being sent.

Namespace: Dln.Uart
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public int Baudrate { get; set; }
public int Baudrate { get; set; }
Public Property Baudrate As Integer
    Get
    Set
Public Property Baudrate As Integer
    Get
    Set
public:
property int Baudrate {
    int get ();
    void set (int value);
}
public:
property int Baudrate {
    int get ();
    void set (int value);
}
Property Value
Type: Int32
See Also
Reference
Port Class
Dln.Uart Namespace


Port.CharacterLength Property

Port CharacterLength Property dln.net.dll
Selects the data character length of 5, 6, 7, 8 and 9 bits per character. Leave property blank to get current value.

Namespace: Dln.Uart
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public int CharacterLength { get; set; }
public int CharacterLength { get; set; }
Public Property CharacterLength As Integer
    Get
    Set
Public Property CharacterLength As Integer
    Get
    Set
public:
property int CharacterLength {
    int get ();
    void set (int value);
}
public:
property int CharacterLength {
    int get ();
    void set (int value);
}
Property Value
Type: Int32
See Also
Reference
Port Class
Dln.Uart Namespace


Port.Enabled Property

Port Enabled Property dln.net.dll
Enables or disables the UART port.

Namespace: Dln.Uart
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public bool Enabled { get; set; }
public bool Enabled { get; set; }
Public Property Enabled As Boolean
    Get
    Set
Public Property Enabled As Boolean
    Get
    Set
public:
property bool Enabled {
    bool get ();
    void set (bool value);
}
public:
property bool Enabled {
    bool get ();
    void set (bool value);
}
Property Value
Type: Boolean
See Also
Reference
Port Class
Dln.Uart Namespace


Port.EventEnabled Property

Port EventEnabled Property dln.net.dll
Enables or disables UART event for current UART port. Leave property blank to get current value.

Namespace: Dln.Uart
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public bool EventEnabled { get; set; }
public bool EventEnabled { get; set; }
Public Property EventEnabled As Boolean
    Get
    Set
Public Property EventEnabled As Boolean
    Get
    Set
public:
property bool EventEnabled {
    bool get ();
    void set (bool value);
}
public:
property bool EventEnabled {
    bool get ();
    void set (bool value);
}
Property Value
Type: Boolean
See Also
Reference
Port Class
Dln.Uart Namespace


Port.EventPeriod Property

Port EventPeriod Property dln.net.dll
Configures the event period for current UART port. Leave property blank to get current value.

Namespace: Dln.Uart
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public int EventPeriod { get; set; }
public int EventPeriod { get; set; }
Public Property EventPeriod As Integer
    Get
    Set
Public Property EventPeriod As Integer
    Get
    Set
public:
property int EventPeriod {
    int get ();
    void set (int value);
}
public:
property int EventPeriod {
    int get ();
    void set (int value);
}
Property Value
Type: Int32
See Also
Reference
Port Class
Dln.Uart Namespace


Port.EventSize Property

Port EventSize Property dln.net.dll
Configures the event size. Leave property blank to get current value.

Namespace: Dln.Uart
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public int EventSize { get; set; }
public int EventSize { get; set; }
Public Property EventSize As Integer
    Get
    Set
Public Property EventSize As Integer
    Get
    Set
public:
property int EventSize {
    int get ();
    void set (int value);
}
public:
property int EventSize {
    int get ();
    void set (int value);
}
Property Value
Type: Int32
See Also
Reference
Port Class
Dln.Uart Namespace


Port.MaxBaudrate Property

Port MaxBaudrate Property dln.net.dll
Retrieves the maximum possible baud rate value.

Namespace: Dln.Uart
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public int MaxBaudrate { get; }
public int MaxBaudrate { get; }
Public ReadOnly Property MaxBaudrate As Integer
    Get
Public ReadOnly Property MaxBaudrate As Integer
    Get
public:
property int MaxBaudrate {
    int get ();
}
public:
property int MaxBaudrate {
    int get ();
}
Property Value
Type: Int32
See Also
Reference
Port Class
Dln.Uart Namespace


Port.MinBaudrate Property

Port MinBaudrate Property dln.net.dll
Retrieves the minimum possible baud rate value.

Namespace: Dln.Uart
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public int MinBaudrate { get; }
public int MinBaudrate { get; }
Public ReadOnly Property MinBaudrate As Integer
    Get
Public ReadOnly Property MinBaudrate As Integer
    Get
public:
property int MinBaudrate {
    int get ();
}
public:
property int MinBaudrate {
    int get ();
}
Property Value
Type: Int32
See Also
Reference
Port Class
Dln.Uart Namespace


Port.Parity Property

Port Parity Property dln.net.dll
Select even, odd, mark (when the parity bit is always 1), space (the bit is always 0) or none parity. Leave property blank to get current value.

Namespace: Dln.Uart
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public Parity Parity { get; set; }
public Parity Parity { get; set; }
Public Property Parity As Parity
    Get
    Set
Public Property Parity As Parity
    Get
    Set
public:
property Parity Parity {
    Parity get ();
    void set (Parity value);
}
public:
property Parity Parity {
    Parity get ();
    void set (Parity value);
}
Property Value
Type: Parity
See Also
Reference
Port Class
Dln.Uart Namespace


Port.ReadTimeout Property

Port ReadTimeout Property dln.net.dll
Gets or sets the number of milliseconds before a time-out occurs when a read operation does not finish.

Namespace: Dln.Uart
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public int ReadTimeout { get; set; }
public int ReadTimeout { get; set; }
Public Property ReadTimeout As Integer
    Get
    Set
Public Property ReadTimeout As Integer
    Get
    Set
public:
property int ReadTimeout {
    int get ();
    void set (int value);
}
public:
property int ReadTimeout {
    int get ();
    void set (int value);
}
Property Value
Type: Int32
See Also
Reference
Port Class
Dln.Uart Namespace


Port.Restrictions Property

Port Restrictions Property dln.net.dll
Retrieves predefined restrictions

Namespace: Dln.Uart
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public PortRestrictions Restrictions { get; }
public PortRestrictions Restrictions { get; }
Public ReadOnly Property Restrictions As PortRestrictions
    Get
Public ReadOnly Property Restrictions As PortRestrictions
    Get
public:
property PortRestrictions^ Restrictions {
    PortRestrictions^ get ();
}
public:
property PortRestrictions^ Restrictions {
    PortRestrictions^ get ();
}
Property Value
Type: PortRestrictions
See Also
Reference
Port Class
Dln.Uart Namespace


Port.Stopbits Property

Port Stopbits Property dln.net.dll
Select the number of stop bits to be sent with each character. Leave property blank to get current value.

Namespace: Dln.Uart
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public Stopbits Stopbits { get; set; }
public Stopbits Stopbits { get; set; }
Public Property Stopbits As Stopbits
    Get
    Set
Public Property Stopbits As Stopbits
    Get
    Set
public:
property Stopbits Stopbits {
    Stopbits get ();
    void set (Stopbits value);
}
public:
property Stopbits Stopbits {
    Stopbits get ();
    void set (Stopbits value);
}
Property Value
Type: Stopbits
See Also
Reference
Port Class
Dln.Uart Namespace


Port.SupportedCharacterLengths Property

Port SupportedCharacterLengths Property dln.net.dll
Returns all supported character length types.

Namespace: Dln.Uart
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public ReadOnlyCollection<int> SupportedCharacterLengths { get; }
public ReadOnlyCollection<int> SupportedCharacterLengths { get; }
Public ReadOnly Property SupportedCharacterLengths As ReadOnlyCollection(Of Integer)
    Get
Public ReadOnly Property SupportedCharacterLengths As ReadOnlyCollection(Of Integer)
    Get
public:
property ReadOnlyCollection<int>^ SupportedCharacterLengths {
    ReadOnlyCollection<int>^ get ();
}
public:
property ReadOnlyCollection<int>^ SupportedCharacterLengths {
    ReadOnlyCollection<int>^ get ();
}
Property Value
Type: ReadOnlyCollection  Int32
See Also
Reference
Port Class
Dln.Uart Namespace


Port.SupportedParities Property

Port SupportedParities Property dln.net.dll
Returns all supported parities values.

Namespace: Dln.Uart
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public ReadOnlyCollection<Parity> SupportedParities { get; }
public ReadOnlyCollection<Parity> SupportedParities { get; }
Public ReadOnly Property SupportedParities As ReadOnlyCollection(Of Parity)
    Get
Public ReadOnly Property SupportedParities As ReadOnlyCollection(Of Parity)
    Get
public:
property ReadOnlyCollection<Parity>^ SupportedParities {
    ReadOnlyCollection<Parity>^ get ();
}
public:
property ReadOnlyCollection<Parity>^ SupportedParities {
    ReadOnlyCollection<Parity>^ get ();
}
Property Value
Type: ReadOnlyCollection  Parity
See Also
Reference
Port Class
Dln.Uart Namespace


Port.SupportedStopbits Property

Port SupportedStopbits Property dln.net.dll
Returns all supported stop bits values.

Namespace: Dln.Uart
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public ReadOnlyCollection<Stopbits> SupportedStopbits { get; }
public ReadOnlyCollection<Stopbits> SupportedStopbits { get; }
Public ReadOnly Property SupportedStopbits As ReadOnlyCollection(Of Stopbits)
    Get
Public ReadOnly Property SupportedStopbits As ReadOnlyCollection(Of Stopbits)
    Get
public:
property ReadOnlyCollection<Stopbits>^ SupportedStopbits {
    ReadOnlyCollection<Stopbits>^ get ();
}
public:
property ReadOnlyCollection<Stopbits>^ SupportedStopbits {
    ReadOnlyCollection<Stopbits>^ get ();
}
Property Value
Type: ReadOnlyCollection  Stopbits
See Also
Reference
Port Class
Dln.Uart Namespace


Port Events

Port Events dln.net.dll

The Port type exposes the following members.

Events
 | Name | Description
Public event | DataReceived | DataReceived event handler
Public event | DataReceivedThreadSafe | DataReceivedThreadSafe event handler
Top
See Also

Reference

Port Class
Dln.Uart Namespace


Port.DataReceived Event

Port DataReceived Event dln.net.dll
DataReceived event handler

Namespace: Dln.Uart
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public event EventHandler<DataReceivedEventArgs> DataReceived
public event EventHandler<DataReceivedEventArgs> DataReceived
Public Event DataReceived As EventHandler(Of DataReceivedEventArgs)
Public Event DataReceived As EventHandler(Of DataReceivedEventArgs)
public:
 event EventHandler<DataReceivedEventArgs^>^ DataReceived {
    void add (EventHandler<DataReceivedEventArgs^>^ value);
    void remove (EventHandler<DataReceivedEventArgs^>^ value);
}
public:
 event EventHandler<DataReceivedEventArgs^>^ DataReceived {
    void add (EventHandler<DataReceivedEventArgs^>^ value);
    void remove (EventHandler<DataReceivedEventArgs^>^ value);
}
Value
Type: System EventHandler  DataReceivedEventArgs
See Also
Reference
Port Class
Dln.Uart Namespace


Port.DataReceivedThreadSafe Event

Port DataReceivedThreadSafe Event dln.net.dll
DataReceivedThreadSafe event handler

Namespace: Dln.Uart
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public event EventHandler<DataReceivedEventArgs> DataReceivedThreadSafe
public event EventHandler<DataReceivedEventArgs> DataReceivedThreadSafe
Public Event DataReceivedThreadSafe As EventHandler(Of DataReceivedEventArgs)
Public Event DataReceivedThreadSafe As EventHandler(Of DataReceivedEventArgs)
public:
 event EventHandler<DataReceivedEventArgs^>^ DataReceivedThreadSafe {
    void add (EventHandler<DataReceivedEventArgs^>^ value);
    void remove (EventHandler<DataReceivedEventArgs^>^ value);
}
public:
 event EventHandler<DataReceivedEventArgs^>^ DataReceivedThreadSafe {
    void add (EventHandler<DataReceivedEventArgs^>^ value);
    void remove (EventHandler<DataReceivedEventArgs^>^ value);
}
Value
Type: System EventHandler  DataReceivedEventArgs
See Also
Reference
Port Class
Dln.Uart Namespace


PortRestrictions Class

PortRestrictions Class dln.net.dll
PortRestrictions class describes Uart port restrictions
Inheritance Hierarchy
System Object
Dln.Uart PortRestrictions

Namespace: Dln.Uart
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public class PortRestrictions
public class PortRestrictions
Public Class PortRestrictions
Public Class PortRestrictions
public ref class PortRestrictions
public ref class PortRestrictions
The PortRestrictions type exposes the following members.
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Baudrate | Baudrate restriction
Public property | CharacterLength | Character length restriction
Public property | Enabled | Enabled restriction
Public property | EventEnabled | Event status restriction
Public property | EventPeriod | Event period restriction
Public property | EventSize | Event size restriction
Public property | MaxBaudrate | Maximum baudrate restriction
Public property | MinBaudrate | Minimum baudrate restriction
Public property | Parity | Parity restriction
Public property | Read | Read restriction
Public property | Stopbits | Stopbits restriction
Public property | SupportedCharacterLengths | Supported character lengths restriction
Public property | SupportedParities | Supported parities restriction
Public property | SupportedStopbits | Supported stopbits restriction
Public property | Write | Write restriction
Top
See Also
Reference
Dln.Uart Namespace


PortRestrictions Methods

PortRestrictions Methods dln.net.dll

The PortRestrictions type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PortRestrictions Class
Dln.Uart Namespace


PortRestrictions Properties

PortRestrictions Properties dln.net.dll

The PortRestrictions type exposes the following members.

Properties
 | Name | Description
Public property | Baudrate | Baudrate restriction
Public property | CharacterLength | Character length restriction
Public property | Enabled | Enabled restriction
Public property | EventEnabled | Event status restriction
Public property | EventPeriod | Event period restriction
Public property | EventSize | Event size restriction
Public property | MaxBaudrate | Maximum baudrate restriction
Public property | MinBaudrate | Minimum baudrate restriction
Public property | Parity | Parity restriction
Public property | Read | Read restriction
Public property | Stopbits | Stopbits restriction
Public property | SupportedCharacterLengths | Supported character lengths restriction
Public property | SupportedParities | Supported parities restriction
Public property | SupportedStopbits | Supported stopbits restriction
Public property | Write | Write restriction
Top
See Also

Reference

PortRestrictions Class
Dln.Uart Namespace


PortRestrictions.Baudrate Property

PortRestrictions Baudrate Property dln.net.dll
Baudrate restriction

Namespace: Dln.Uart
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public Restriction Baudrate { get; }
public Restriction Baudrate { get; }
Public ReadOnly Property Baudrate As Restriction
    Get
Public ReadOnly Property Baudrate As Restriction
    Get
public:
property Restriction Baudrate {
    Restriction get ();
}
public:
property Restriction Baudrate {
    Restriction get ();
}
Property Value
Type: Restriction
See Also
Reference
PortRestrictions Class
Dln.Uart Namespace


PortRestrictions.CharacterLength Property

PortRestrictions CharacterLength Property dln.net.dll
Character length restriction

Namespace: Dln.Uart
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public Restriction CharacterLength { get; }
public Restriction CharacterLength { get; }
Public ReadOnly Property CharacterLength As Restriction
    Get
Public ReadOnly Property CharacterLength As Restriction
    Get
public:
property Restriction CharacterLength {
    Restriction get ();
}
public:
property Restriction CharacterLength {
    Restriction get ();
}
Property Value
Type: Restriction
See Also
Reference
PortRestrictions Class
Dln.Uart Namespace


PortRestrictions.Enabled Property

PortRestrictions Enabled Property dln.net.dll
Enabled restriction

Namespace: Dln.Uart
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public Restriction Enabled { get; }
public Restriction Enabled { get; }
Public ReadOnly Property Enabled As Restriction
    Get
Public ReadOnly Property Enabled As Restriction
    Get
public:
property Restriction Enabled {
    Restriction get ();
}
public:
property Restriction Enabled {
    Restriction get ();
}
Property Value
Type: Restriction
See Also
Reference
PortRestrictions Class
Dln.Uart Namespace


PortRestrictions.EventEnabled Property

PortRestrictions EventEnabled Property dln.net.dll
Event status restriction

Namespace: Dln.Uart
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public Restriction EventEnabled { get; }
public Restriction EventEnabled { get; }
Public ReadOnly Property EventEnabled As Restriction
    Get
Public ReadOnly Property EventEnabled As Restriction
    Get
public:
property Restriction EventEnabled {
    Restriction get ();
}
public:
property Restriction EventEnabled {
    Restriction get ();
}
Property Value
Type: Restriction
See Also
Reference
PortRestrictions Class
Dln.Uart Namespace


PortRestrictions.EventPeriod Property

PortRestrictions EventPeriod Property dln.net.dll
Event period restriction

Namespace: Dln.Uart
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public Restriction EventPeriod { get; }
public Restriction EventPeriod { get; }
Public ReadOnly Property EventPeriod As Restriction
    Get
Public ReadOnly Property EventPeriod As Restriction
    Get
public:
property Restriction EventPeriod {
    Restriction get ();
}
public:
property Restriction EventPeriod {
    Restriction get ();
}
Property Value
Type: Restriction
See Also
Reference
PortRestrictions Class
Dln.Uart Namespace


PortRestrictions.EventSize Property

PortRestrictions EventSize Property dln.net.dll
Event size restriction

Namespace: Dln.Uart
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public Restriction EventSize { get; }
public Restriction EventSize { get; }
Public ReadOnly Property EventSize As Restriction
    Get
Public ReadOnly Property EventSize As Restriction
    Get
public:
property Restriction EventSize {
    Restriction get ();
}
public:
property Restriction EventSize {
    Restriction get ();
}
Property Value
Type: Restriction
See Also
Reference
PortRestrictions Class
Dln.Uart Namespace


PortRestrictions.MaxBaudrate Property

PortRestrictions MaxBaudrate Property dln.net.dll
Maximum baudrate restriction

Namespace: Dln.Uart
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public Restriction MaxBaudrate { get; }
public Restriction MaxBaudrate { get; }
Public ReadOnly Property MaxBaudrate As Restriction
    Get
Public ReadOnly Property MaxBaudrate As Restriction
    Get
public:
property Restriction MaxBaudrate {
    Restriction get ();
}
public:
property Restriction MaxBaudrate {
    Restriction get ();
}
Property Value
Type: Restriction
See Also
Reference
PortRestrictions Class
Dln.Uart Namespace


PortRestrictions.MinBaudrate Property

PortRestrictions MinBaudrate Property dln.net.dll
Minimum baudrate restriction

Namespace: Dln.Uart
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public Restriction MinBaudrate { get; }
public Restriction MinBaudrate { get; }
Public ReadOnly Property MinBaudrate As Restriction
    Get
Public ReadOnly Property MinBaudrate As Restriction
    Get
public:
property Restriction MinBaudrate {
    Restriction get ();
}
public:
property Restriction MinBaudrate {
    Restriction get ();
}
Property Value
Type: Restriction
See Also
Reference
PortRestrictions Class
Dln.Uart Namespace


PortRestrictions.Parity Property

PortRestrictions Parity Property dln.net.dll
Parity restriction

Namespace: Dln.Uart
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public Restriction Parity { get; }
public Restriction Parity { get; }
Public ReadOnly Property Parity As Restriction
    Get
Public ReadOnly Property Parity As Restriction
    Get
public:
property Restriction Parity {
    Restriction get ();
}
public:
property Restriction Parity {
    Restriction get ();
}
Property Value
Type: Restriction
See Also
Reference
PortRestrictions Class
Dln.Uart Namespace


PortRestrictions.Read Property

PortRestrictions Read Property dln.net.dll
Read restriction

Namespace: Dln.Uart
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public Restriction Read { get; }
public Restriction Read { get; }
Public ReadOnly Property Read As Restriction
    Get
Public ReadOnly Property Read As Restriction
    Get
public:
property Restriction Read {
    Restriction get ();
}
public:
property Restriction Read {
    Restriction get ();
}
Property Value
Type: Restriction
See Also
Reference
PortRestrictions Class
Dln.Uart Namespace


PortRestrictions.Stopbits Property

PortRestrictions Stopbits Property dln.net.dll
Stopbits restriction

Namespace: Dln.Uart
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public Restriction Stopbits { get; }
public Restriction Stopbits { get; }
Public ReadOnly Property Stopbits As Restriction
    Get
Public ReadOnly Property Stopbits As Restriction
    Get
public:
property Restriction Stopbits {
    Restriction get ();
}
public:
property Restriction Stopbits {
    Restriction get ();
}
Property Value
Type: Restriction
See Also
Reference
PortRestrictions Class
Dln.Uart Namespace


PortRestrictions.SupportedCharacterLengths Property

PortRestrictions SupportedCharacterLengths Property dln.net.dll
Supported character lengths restriction

Namespace: Dln.Uart
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public Restriction SupportedCharacterLengths { get; }
public Restriction SupportedCharacterLengths { get; }
Public ReadOnly Property SupportedCharacterLengths As Restriction
    Get
Public ReadOnly Property SupportedCharacterLengths As Restriction
    Get
public:
property Restriction SupportedCharacterLengths {
    Restriction get ();
}
public:
property Restriction SupportedCharacterLengths {
    Restriction get ();
}
Property Value
Type: Restriction
See Also
Reference
PortRestrictions Class
Dln.Uart Namespace


PortRestrictions.SupportedParities Property

PortRestrictions SupportedParities Property dln.net.dll
Supported parities restriction

Namespace: Dln.Uart
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public Restriction SupportedParities { get; }
public Restriction SupportedParities { get; }
Public ReadOnly Property SupportedParities As Restriction
    Get
Public ReadOnly Property SupportedParities As Restriction
    Get
public:
property Restriction SupportedParities {
    Restriction get ();
}
public:
property Restriction SupportedParities {
    Restriction get ();
}
Property Value
Type: Restriction
See Also
Reference
PortRestrictions Class
Dln.Uart Namespace


PortRestrictions.SupportedStopbits Property

PortRestrictions SupportedStopbits Property dln.net.dll
Supported stopbits restriction

Namespace: Dln.Uart
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public Restriction SupportedStopbits { get; }
public Restriction SupportedStopbits { get; }
Public ReadOnly Property SupportedStopbits As Restriction
    Get
Public ReadOnly Property SupportedStopbits As Restriction
    Get
public:
property Restriction SupportedStopbits {
    Restriction get ();
}
public:
property Restriction SupportedStopbits {
    Restriction get ();
}
Property Value
Type: Restriction
See Also
Reference
PortRestrictions Class
Dln.Uart Namespace


PortRestrictions.Write Property

PortRestrictions Write Property dln.net.dll
Write restriction

Namespace: Dln.Uart
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public Restriction Write { get; }
public Restriction Write { get; }
Public ReadOnly Property Write As Restriction
    Get
Public ReadOnly Property Write As Restriction
    Get
public:
property Restriction Write {
    Restriction get ();
}
public:
property Restriction Write {
    Restriction get ();
}
Property Value
Type: Restriction
See Also
Reference
PortRestrictions Class
Dln.Uart Namespace


Ports Class

Ports Class dln.net.dll
Ports class
Inheritance Hierarchy
System Object
System.Collections.ObjectModel ReadOnlyCollection Port
Dln.Uart Ports

Namespace: Dln.Uart
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public class Ports : ReadOnlyCollection<Port>
public class Ports : ReadOnlyCollection<Port>
Public Class Ports
    Inherits ReadOnlyCollection(Of Port)
Public Class Ports
    Inherits ReadOnlyCollection(Of Port)
public ref class Ports : public ReadOnlyCollection<Port^>
public ref class Ports : public ReadOnlyCollection<Port^>
The Ports type exposes the following members.
Methods
 | Name | Description
Public method | Contains | Determines whether an element is in the ReadOnlyCollection T . (Inherited from ReadOnlyCollection Port .)
Public method | CopyTo | Copies the entire ReadOnlyCollection T to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from ReadOnlyCollection Port .)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the ReadOnlyCollection T . (Inherited from ReadOnlyCollection Port .)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Public method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ReadOnlyCollection T . (Inherited from ReadOnlyCollection Port .)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the ReadOnlyCollection T instance. (Inherited from ReadOnlyCollection Port .)
Public property | Item |
Protected property | Items | Returns the IList T that the ReadOnlyCollection T wraps. (Inherited from ReadOnlyCollection Port .)
Top
See Also
Reference
Dln.Uart Namespace


Ports Methods

Ports Methods dln.net.dll

The Ports type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Determines whether an element is in the ReadOnlyCollection T . (Inherited from ReadOnlyCollection Port .)
Public method | CopyTo | Copies the entire ReadOnlyCollection T to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from ReadOnlyCollection Port .)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the ReadOnlyCollection T . (Inherited from ReadOnlyCollection Port .)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Public method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ReadOnlyCollection T . (Inherited from ReadOnlyCollection Port .)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Ports Class
Dln.Uart Namespace


Ports Properties

Ports Properties dln.net.dll

The Ports type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the ReadOnlyCollection T instance. (Inherited from ReadOnlyCollection Port .)
Public property | Item |
Protected property | Items | Returns the IList T that the ReadOnlyCollection T wraps. (Inherited from ReadOnlyCollection Port .)
Top
See Also

Reference

Ports Class
Dln.Uart Namespace


Ports.Item Property

Ports Item Property dln.net.dll

[Missing <summary> documentation for "P:Dln.Uart.Ports.Item(System.Int32)"]

Namespace: Dln.Uart
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public Port this[
    int index
] { get; }
public Port this[
    int index
] { get; }
Public ReadOnly Default Property Item (
    index As Integer
) As Port
    Get
Public ReadOnly Default Property Item (
    index As Integer
) As Port
    Get
public:
property Port^ default[int index] {
    Port^ get (int index);
}
public:
property Port^ default[int index] {
    Port^ get (int index);
}
Parameters
index
Type: System Int32
Rort index
Return Value
Type: Port
Port object by index
See Also
Reference
Ports Class
Dln.Uart Namespace


Stopbits Enumeration

Stopbits Enumeration dln.net.dll
Stopbits enumeration describes all possible stopbits values.

Namespace: Dln.Uart
Assembly: dln.net (in dln.net.dll) Version: 2.1.0.3 (2.1.0.3)
Syntax
C#
VB
C++
F#
Copy to Clipboard Print
public enum Stopbits
public enum Stopbits
Public Enumeration Stopbits
Public Enumeration Stopbits
public enum class Stopbits
public enum class Stopbits
Members
Member name | Value | Description
One | 0 | Zero value
OnePointFive | 1 | 1 value
Two | 2 | 2 value
See Also
Reference
Dln.Uart Namespace